aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2017-03-15 14:45:30 +0000
committerMathieu Arnold <mat@FreeBSD.org>2017-03-15 14:45:30 +0000
commita28f0f7f7f7687e6ab6ebc4b3313f96232c00aa0 (patch)
treebaf6ab0b133f634d778359bdbf4c920166db5b76 /security
parentc285e43283c14c5abf4dc12cfdf0793f4ca0d130 (diff)
Notes
Diffstat (limited to 'security')
-rw-r--r--security/apache-xml-security-c/Makefile4
-rw-r--r--security/botan110/Makefile2
-rw-r--r--security/chntpw/Makefile3
-rw-r--r--security/cyrus-sasl2/Makefile.common4
-rw-r--r--security/eschalot/Makefile3
-rw-r--r--security/esteidfirefoxplugin/Makefile3
-rw-r--r--security/fwbuilder/Makefile3
-rw-r--r--security/gstreamer1-plugins-dtls/Makefile2
-rw-r--r--security/hpenc/Makefile3
-rw-r--r--security/hs-HsOpenSSL/Makefile2
-rw-r--r--security/ike/Makefile3
-rw-r--r--security/ipsec-tools/Makefile3
-rw-r--r--security/isakmpd/Makefile4
-rw-r--r--security/keynote/Makefile4
-rw-r--r--security/lasso/Makefile3
-rw-r--r--security/libfprint/Makefile3
-rw-r--r--security/opensc/Makefile3
-rw-r--r--security/openssh-portable/Makefile3
-rw-r--r--security/osiris/Makefile2
-rw-r--r--security/osslsigncode/Makefile3
-rw-r--r--security/p5-Crypt-OpenSSL-AES/Makefile3
-rw-r--r--security/p5-Crypt-OpenSSL-RSA/Makefile3
-rw-r--r--security/p5-Crypt-OpenSSL-Random/Makefile3
-rw-r--r--security/p5-Filter-Crypto/Makefile3
-rw-r--r--security/p5-OpenCA-OpenSSL/Makefile3
-rw-r--r--security/pam_p11/Makefile3
-rw-r--r--security/pidentd/Makefile2
-rw-r--r--security/pixiewps/Makefile6
-rw-r--r--security/pkcs11-dump/Makefile3
-rw-r--r--security/pkcs11-helper/Makefile3
-rw-r--r--security/py-pow/Makefile3
-rw-r--r--security/racoon2/Makefile3
-rw-r--r--security/scrypt/Makefile3
-rw-r--r--security/sectok/Makefile2
-rw-r--r--security/skipfish/Makefile3
-rw-r--r--security/slush/Makefile2
-rw-r--r--security/sslwrap/Makefile2
-rw-r--r--security/sst/Makefile3
-rw-r--r--security/stud/Makefile3
-rw-r--r--security/tinyca/Makefile3
-rw-r--r--security/yapet/Makefile3
-rw-r--r--security/yubico-piv-tool/Makefile3
-rw-r--r--security/zebedee/Makefile3
-rw-r--r--security/zxid/Makefile3
44 files changed, 47 insertions, 84 deletions
diff --git a/security/apache-xml-security-c/Makefile b/security/apache-xml-security-c/Makefile
index 979920505b20..a9635e7969df 100644
--- a/security/apache-xml-security-c/Makefile
+++ b/security/apache-xml-security-c/Makefile
@@ -12,13 +12,11 @@ COMMENT= Apache XML security libraries - C++ version
LICENSE= APACHE20
-USE_OPENSSL= yes
-
LIB_DEPENDS+= libxerces-c.so.3:textproc/xerces-c3
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-xerces=${LOCALBASE}
-USES= gmake libtool tar:bzip2
+USES= gmake libtool tar:bzip2 ssl
USE_LDCONFIG= yes
CONFIGURE_ARGS+=--with-openssl=${OPENSSLBASE}
diff --git a/security/botan110/Makefile b/security/botan110/Makefile
index 050d31529a23..e15762fe7bfe 100644
--- a/security/botan110/Makefile
+++ b/security/botan110/Makefile
@@ -36,7 +36,7 @@ BROKEN_aarch64= Fails to configure: unknown or unidentifiable processor arm64
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MSSL}
-USE_OPENSSL= yes
+USES+= ssl
CONFIGURE_ARGS+=--with-openssl
.endif
diff --git a/security/chntpw/Makefile b/security/chntpw/Makefile
index a8cf72f131dc..3bf9d4ab0116 100644
--- a/security/chntpw/Makefile
+++ b/security/chntpw/Makefile
@@ -15,8 +15,7 @@ LICENSE= GPLv2
OPTIONS_DEFINE= DOCS
-USE_OPENSSL= yes
-USES= gmake zip
+USES= gmake zip ssl
BIN_FILES= chntpw cpnt reged
PLIST_FILES= ${BIN_FILES:C|^|bin/|}
diff --git a/security/cyrus-sasl2/Makefile.common b/security/cyrus-sasl2/Makefile.common
index 0b589b4f3626..6baa204afdf2 100644
--- a/security/cyrus-sasl2/Makefile.common
+++ b/security/cyrus-sasl2/Makefile.common
@@ -12,7 +12,7 @@ LICENSE= BSD4CLAUSE
LICENSE_FILE= ${WRKSRC}/COPYING
USE_LDCONFIG= yes
-USE_OPENSSL= yes
+USES= ssl
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--sysconfdir=${PREFIX}/etc \
@@ -62,7 +62,7 @@ CYRUS_BUILD_TARGET?= ${PORTNAME}
INSTALL_WRKSRC= ${WRKSRC}/plugins
LIB_DEPENDS= libsasl2.so:security/cyrus-sasl2
-USES= libtool:build
+USES+= libtool:build
PLIST_FILES+= lib/sasl2/lib${CYRUS_BUILD_TARGET}.a \
lib/sasl2/lib${CYRUS_BUILD_TARGET}.so \
diff --git a/security/eschalot/Makefile b/security/eschalot/Makefile
index 973455771911..22b02d833484 100644
--- a/security/eschalot/Makefile
+++ b/security/eschalot/Makefile
@@ -15,8 +15,7 @@ USE_GITHUB= yes
GH_ACCOUNT= ReclaimYourPrivacy
GH_TAGNAME= e9e085e
-USES= gmake
-USE_OPENSSL= yes
+USES= gmake ssl
MAKE_ENV= INSTALL="${INSTALL_PROGRAM}"
MAKE_ARGS= PREFIX="${STAGEDIR}${PREFIX}"
TEST_TARGET= test
diff --git a/security/esteidfirefoxplugin/Makefile b/security/esteidfirefoxplugin/Makefile
index 2fec881bd714..8d1aa9b068a2 100644
--- a/security/esteidfirefoxplugin/Makefile
+++ b/security/esteidfirefoxplugin/Makefile
@@ -13,9 +13,8 @@ LICENSE= LGPL21
RUN_DEPENDS= opensc-tool:security/opensc \
pcscd:devel/pcsc-lite
-USE_OPENSSL= yes
USE_GNOME= gtk20
-USES= webplugin:gecko pkgconfig
+USES= webplugin:gecko pkgconfig ssl
WEBPLUGIN_DIR= ${PREFIX}/lib
WEBPLUGIN_FILES= npesteid-firefox-plugin.so
diff --git a/security/fwbuilder/Makefile b/security/fwbuilder/Makefile
index fab7b57d60cd..5b5010ba8e4c 100644
--- a/security/fwbuilder/Makefile
+++ b/security/fwbuilder/Makefile
@@ -47,8 +47,7 @@ USE_QT4= corelib \
QTDIR?= ${PREFIX}
-USE_OPENSSL= yes
-USES= autoreconf:build gmake libtool
+USES= autoreconf:build gmake libtool ssl
GNU_CONFIGURE= yes
CONFIGURE_ENV= QMAKESPEC=${LOCALBASE}/share/qt/mkspecs/freebsd-g++ \
INSTALL_ROOT=${STAGEDIR}
diff --git a/security/gstreamer1-plugins-dtls/Makefile b/security/gstreamer1-plugins-dtls/Makefile
index f13fc26ac56b..9ac6eac0982b 100644
--- a/security/gstreamer1-plugins-dtls/Makefile
+++ b/security/gstreamer1-plugins-dtls/Makefile
@@ -9,7 +9,7 @@ GST_PLUGIN= dtls
DIST= bad
# we don't have a way to specify this in ${MASTERDIR}/Makefile.common
-USE_OPENSSL= yes
+USES= ssl
CONFIGURE_ENV= DTLS_CFLAGS="-I${OPENSSLINC}" \
DTLS_LIBS="-L${OPENSSLLIB} -lcrypto -lssl"
diff --git a/security/hpenc/Makefile b/security/hpenc/Makefile
index e89c0e4027ce..182129c396e6 100644
--- a/security/hpenc/Makefile
+++ b/security/hpenc/Makefile
@@ -16,8 +16,7 @@ BROKEN_powerpc64= Does not build
NOT_FOR_ARCHS= aarch64 sparc64
NOT_FOR_ARCHS_REASON= not yet ported to this architecture
-USES= tar:xz compiler:c++11-lib gmake
-USE_OPENSSL= yes
+USES= tar:xz compiler:c++11-lib gmake ssl
PLIST_FILES= bin/hpenc man/man1/hpenc.1.gz
MAKE_ARGS+= "ARCH=${ARCH:S/amd64/x86/:S/i386/x86/}"
diff --git a/security/hs-HsOpenSSL/Makefile b/security/hs-HsOpenSSL/Makefile
index 5548a23f93dc..e144d0a16f5d 100644
--- a/security/hs-HsOpenSSL/Makefile
+++ b/security/hs-HsOpenSSL/Makefile
@@ -9,7 +9,7 @@ COMMENT= Partial OpenSSL binding for Haskell
USE_CABAL= network>=2.1 old-locale>=1.0
-USE_OPENSSL= yes
+USES= ssl
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/security/ike/Makefile b/security/ike/Makefile
index c75cc9bd5d0c..b334dfbc094a 100644
--- a/security/ike/Makefile
+++ b/security/ike/Makefile
@@ -14,8 +14,7 @@ COMMENT= Shrew Soft IKE daemon and client tools
ONLY_FOR_ARCHS= i386 amd64
USE_RC_SUBR= iked
-USES= bison cmake libedit localbase:ldflags tar:tbz2
-USE_OPENSSL= yes
+USES= bison cmake libedit localbase:ldflags tar:tbz2 ssl
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
diff --git a/security/ipsec-tools/Makefile b/security/ipsec-tools/Makefile
index 8d59a62db2f1..7771b5116906 100644
--- a/security/ipsec-tools/Makefile
+++ b/security/ipsec-tools/Makefile
@@ -18,11 +18,10 @@ COMMENT= KAME racoon IKE daemon, ipsec-tools version
CONFLICTS= racoon-[0-9]*
USE_RC_SUBR= racoon
-USE_OPENSSL= yes
INSTALL_TARGET= install-strip
-USES= libtool tar:bzip2
+USES= libtool tar:bzip2 ssl
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
CONFIGURE_ARGS= --enable-shared --sysconfdir=${PREFIX}/etc/racoon \
diff --git a/security/isakmpd/Makefile b/security/isakmpd/Makefile
index 0b372b79091f..bba4868b2626 100644
--- a/security/isakmpd/Makefile
+++ b/security/isakmpd/Makefile
@@ -20,12 +20,10 @@ BROKEN= requires IPsec support
BUILD_DEPENDS+= keynote:security/keynote
.endif
-USES= uidfix
+USES= uidfix ssl
USE_RC_SUBR= isakmpd
MAKE_ENV+= BINDIR=${PREFIX}/sbin MANDIR=${PREFIX}/man/man
-USE_OPENSSL= yes
-
MAKE_JOBS_UNSAFE= yes
.include <bsd.port.pre.mk>
diff --git a/security/keynote/Makefile b/security/keynote/Makefile
index 7f9083572a6b..eed7ac9ccb99 100644
--- a/security/keynote/Makefile
+++ b/security/keynote/Makefile
@@ -13,8 +13,8 @@ COMMENT= Trust-Management System
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= gmake # required to support parallel (-jX) builds
-USE_OPENSSL= yes
+# gmake required to support parallel (-jX) builds
+USES= gmake ssl
GNU_CONFIGURE= yes
CONFIGURE_ENV= SSLEAY="${OPENSSLBASE}/bin" OPENSSLLIB="${OPENSSLLIB}" \
OPENSSLINC="${OPENSSLINC}"
diff --git a/security/lasso/Makefile b/security/lasso/Makefile
index 97cb0793260c..c4ecd438fa99 100644
--- a/security/lasso/Makefile
+++ b/security/lasso/Makefile
@@ -15,13 +15,12 @@ LICENSE= GPLv2
BUILD_DEPENDS= xmlsec1:security/xmlsec1
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USES= cpe libtool pathfix pkgconfig
+USES= cpe libtool pathfix pkgconfig ssl
CPE_VENDOR= entrouvert
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-java --with-zlib
USE_GNOME= glib20 libxml2
USE_LDCONFIG= yes
-USE_OPENSSL= yes
INSTALL_TARGET= install-strip
OPTIONS_DEFINE= PERL PHP PYTHON DOCS
diff --git a/security/libfprint/Makefile b/security/libfprint/Makefile
index d20e3f7b81a3..acd993ddba3f 100644
--- a/security/libfprint/Makefile
+++ b/security/libfprint/Makefile
@@ -14,9 +14,8 @@ LIB_DEPENDS= libMagickCore-6.so:graphics/ImageMagick \
libnss3.so:security/nss
GNU_CONFIGURE= yes
-USES= libtool pathfix pkgconfig tar:xz
+USES= libtool pathfix pkgconfig tar:xz ssl
USE_LDCONFIG= yes
-USE_OPENSSL= yes
USE_GNOME= glib20
INSTALL_TARGET= install-strip
diff --git a/security/opensc/Makefile b/security/opensc/Makefile
index f5e7b74ee950..a6b9c622eb64 100644
--- a/security/opensc/Makefile
+++ b/security/opensc/Makefile
@@ -21,8 +21,7 @@ OPENCT_DESC= Use OpenCT backend
CTAPI_DESC= Use CT-API backend
SM_DESC= Enable secure messaging support
-USES= libtool pkgconfig gmake
-USE_OPENSSL= yes
+USES= libtool pkgconfig gmake ssl
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
diff --git a/security/openssh-portable/Makefile b/security/openssh-portable/Makefile
index 34f41f2a01a8..d7ca5ef9b3d3 100644
--- a/security/openssh-portable/Makefile
+++ b/security/openssh-portable/Makefile
@@ -17,9 +17,8 @@ COMMENT= The portable version of OpenBSD's OpenSSH
CONFLICTS?= openssh-3.* ssh-1.* ssh2-3.* openssh-portable-devel-*
-USES= alias ncurses
+USES= alias ncurses ssl
USE_AUTOTOOLS= autoconf autoheader
-USE_OPENSSL= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= ac_cv_func_strnvis=no
CONFIGURE_ARGS= --prefix=${PREFIX} --with-md5-passwords \
diff --git a/security/osiris/Makefile b/security/osiris/Makefile
index bc44e4c49a7c..6154a9dc5f19 100644
--- a/security/osiris/Makefile
+++ b/security/osiris/Makefile
@@ -11,7 +11,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Shmoo client/server host integrity checker
GNU_CONFIGURE= yes
-USE_OPENSSL= yes
+USES= ssl
OPTIONS_DEFINE= OSIRISMD OSIRISD PRINTDB CLI
OPTIONS_DEFAULT= OSIRISD
diff --git a/security/osslsigncode/Makefile b/security/osslsigncode/Makefile
index 970f132e6add..d7d161e65a2d 100644
--- a/security/osslsigncode/Makefile
+++ b/security/osslsigncode/Makefile
@@ -12,9 +12,8 @@ COMMENT= OpenSSL-based signcode utility
PLIST_FILES= bin/osslsigncode
-USES= pkgconfig
+USES= pkgconfig ssl
GNU_CONFIGURE= yes
-USE_OPENSSL= yes
OPTIONS_DEFINE= CURL GSF
OPTIONS_DEFAULT= CURL GSF
diff --git a/security/p5-Crypt-OpenSSL-AES/Makefile b/security/p5-Crypt-OpenSSL-AES/Makefile
index 67c6f7942ba3..e92ab745af5b 100644
--- a/security/p5-Crypt-OpenSSL-AES/Makefile
+++ b/security/p5-Crypt-OpenSSL-AES/Makefile
@@ -11,9 +11,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= jdferrell3@yahoo.com
COMMENT= Perl wrapper around OpenSSL's AES library
-USES= perl5
+USES= perl5 ssl
USE_PERL5= configure
-USE_OPENSSL= yes
MAKE_ARGS+= PASTHRU_INC=-I${OPENSSLINC}
.include <bsd.port.mk>
diff --git a/security/p5-Crypt-OpenSSL-RSA/Makefile b/security/p5-Crypt-OpenSSL-RSA/Makefile
index 687eab52fc9d..4599bce26277 100644
--- a/security/p5-Crypt-OpenSSL-RSA/Makefile
+++ b/security/p5-Crypt-OpenSSL-RSA/Makefile
@@ -15,9 +15,8 @@ BUILD_DEPENDS= p5-Crypt-OpenSSL-Bignum>=0:security/p5-Crypt-OpenSSL-Bignum \
p5-Crypt-OpenSSL-Random>=0:security/p5-Crypt-OpenSSL-Random
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USES= perl5
+USES= perl5 ssl
USE_PERL5= configure
-USE_OPENSSL= yes
MAKE_ARGS= PASTHRU_INC=-I${OPENSSLINC}
regression-test: build
diff --git a/security/p5-Crypt-OpenSSL-Random/Makefile b/security/p5-Crypt-OpenSSL-Random/Makefile
index 43bc75eb7138..01bd1ade10c7 100644
--- a/security/p5-Crypt-OpenSSL-Random/Makefile
+++ b/security/p5-Crypt-OpenSSL-Random/Makefile
@@ -15,8 +15,7 @@ LICENSE= ART10 GPLv1
LICENSE_COMB= dual
MAKE_ARGS= PASTHRU_INC=-I${OPENSSLINC}
-USES= perl5
-USE_OPENSSL= yes
+USES= perl5 ssl
USE_PERL5= configure
post-install:
diff --git a/security/p5-Filter-Crypto/Makefile b/security/p5-Filter-Crypto/Makefile
index ea1e55b0cae0..b96c522babca 100644
--- a/security/p5-Filter-Crypto/Makefile
+++ b/security/p5-Filter-Crypto/Makefile
@@ -16,9 +16,8 @@ LICENSE_COMB= dual
BUILD_DEPENDS= p5-PAR-Packer>=0:devel/p5-PAR-Packer
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USES= perl5
+USES= perl5 ssl
USE_PERL5= configure
-USE_OPENSSL= yes
CONFIGURE_ARGS= --prefix-dir=${OPENSSLBASE} --defaults
.include <bsd.port.mk>
diff --git a/security/p5-OpenCA-OpenSSL/Makefile b/security/p5-OpenCA-OpenSSL/Makefile
index 71c1ee21d16f..42e6805d6f2c 100644
--- a/security/p5-OpenCA-OpenSSL/Makefile
+++ b/security/p5-OpenCA-OpenSSL/Makefile
@@ -17,9 +17,8 @@ BUILD_DEPENDS= p5-Locale-libintl>=0:devel/p5-Locale-libintl \
p5-X500-DN>=0:net/p5-X500-DN
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USES= perl5
+USES= perl5 ssl
USE_PERL5= configure
-USE_OPENSSL= yes
MAKE_ARGS+= PASTHRU_INC=-I${OPENSSLINC}
.include <bsd.port.mk>
diff --git a/security/pam_p11/Makefile b/security/pam_p11/Makefile
index 3595b885bbbf..f48ea218f706 100644
--- a/security/pam_p11/Makefile
+++ b/security/pam_p11/Makefile
@@ -16,9 +16,8 @@ LIB_DEPENDS= libp11.so:security/libp11
OPTIONS_DEFINE= DOCS
-USE_OPENSSL= yes
GNU_CONFIGURE= yes
-USES= libtool pkgconfig
+USES= libtool pkgconfig ssl
CONFIGURE_ENV= OPENSSL_CFLAGS="-I${OPENSSLINC}" \
OPENSSL_LIBS="-L${OPENSSLLIB} -lssl"
diff --git a/security/pidentd/Makefile b/security/pidentd/Makefile
index 80667891af20..603d850969b3 100644
--- a/security/pidentd/Makefile
+++ b/security/pidentd/Makefile
@@ -19,7 +19,7 @@ COMMENT= RFC1413 identification server
CONFLICTS_INSTALL= fakeident-[0-9]*
GNU_CONFIGURE= yes
-USE_OPENSSL= yes
+USES= ssl
PLIST_FILES= sbin/ibench sbin/identd sbin/idecrypt sbin/ikeygen \
man/man8/identd.8.gz man/man8/idecrypt.8.gz
diff --git a/security/pixiewps/Makefile b/security/pixiewps/Makefile
index 74b4d52aab5e..36becde466f5 100644
--- a/security/pixiewps/Makefile
+++ b/security/pixiewps/Makefile
@@ -11,10 +11,8 @@ COMMENT= Offline WPS bruteforce utility
LICENSE= GPLv3
-USE_OPENSSL= yes
-
-USES= gmake
-WRKSRC_SUBDIR= src/
+USES= gmake ssl
+WRKSRC_SUBDIR= src
USE_GITHUB= yes
GH_ACCOUNT= wiire
diff --git a/security/pkcs11-dump/Makefile b/security/pkcs11-dump/Makefile
index f970a950fd94..e06522f2fbb9 100644
--- a/security/pkcs11-dump/Makefile
+++ b/security/pkcs11-dump/Makefile
@@ -15,8 +15,7 @@ BROKEN= Unfetchable (google code has gone away)
DEPRECATED= Unfetchable for more than six months (google code has gone away)
EXPIRATION_DATE= 2017-04-30
-USES= tar:bzip2
-USE_OPENSSL= yes
+USES= tar:bzip2 ssl
GNU_CONFIGURE= yes
CONFIGURE_ENV= OPENSSL_CFLAGS="-I${OPENSSLINC}" \
diff --git a/security/pkcs11-helper/Makefile b/security/pkcs11-helper/Makefile
index f8a960952aa0..bc7dbe8ba735 100644
--- a/security/pkcs11-helper/Makefile
+++ b/security/pkcs11-helper/Makefile
@@ -16,9 +16,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LICENSE_FILE_BSD3CLAUSE=${WRKSRC}/COPYING.BSD
LICENSE_FILE_GPLv2= ${WRKSRC}/COPYING.GPL
-USE_OPENSSL= yes
GNU_CONFIGURE= yes
-USES= libtool:keepla pathfix pkgconfig tar:bzip2
+USES= libtool:keepla pathfix pkgconfig tar:bzip2 ssl
USE_LDCONFIG= yes
CONFIGURE_ENV= OPENSSL_CFLAGS="-I${OPENSSLINC}" \
diff --git a/security/py-pow/Makefile b/security/py-pow/Makefile
index ad1bc69f1dee..5f7ea2c6d9e9 100644
--- a/security/py-pow/Makefile
+++ b/security/py-pow/Makefile
@@ -14,10 +14,9 @@ COMMENT= Python OpenSSL Wrappers
LICENSE= BSD3CLAUSE
-USES= python
+USES= python ssl
USE_PYTHON= distutils
PYDISTUTILS_PKGNAME= POW
-USE_OPENSSL= yes
PORTDOCS= POW.pdf
diff --git a/security/racoon2/Makefile b/security/racoon2/Makefile
index 6a6247b61ddd..4127d6bd1b79 100644
--- a/security/racoon2/Makefile
+++ b/security/racoon2/Makefile
@@ -10,8 +10,7 @@ MASTER_SITES= ftp://ftp.racoon2.wide.ad.jp/pub/racoon2/
MAINTAINER= cy@FreeBSD.org
COMMENT= Racoon2 IPsec daemon
-USES= perl5 tar:tgz
-USE_OPENSSL= YES
+USES= perl5 tar:tgz ssl
CONFIGURE_ARGS+= --disable-kinkd
PLIST_SUB+= KINK="@comment "
diff --git a/security/scrypt/Makefile b/security/scrypt/Makefile
index 9b6797d48461..d093c31c7712 100644
--- a/security/scrypt/Makefile
+++ b/security/scrypt/Makefile
@@ -14,8 +14,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= CFLAGS="-I${OPENSSLINC} ${CFLAGS}" \
LDFLAGS="-L${OPENSSLLIB} ${LDFLAGS}"
-USES= gmake tar:tgz
-USE_OPENSSL= YES
+USES= gmake tar:tgz ssl
PLIST_FILES= bin/scrypt \
man/man1/scrypt.1.gz
diff --git a/security/sectok/Makefile b/security/sectok/Makefile
index 47430307a6c5..9c5a0f7ed8b8 100644
--- a/security/sectok/Makefile
+++ b/security/sectok/Makefile
@@ -13,7 +13,7 @@ COMMENT= ISO 7816 Smartcard Utility
LIB_DEPENDS= libsectok.so:security/libsectok
-USE_OPENSSL= yes
+USES= ssl
USE_LDCONFIG= yes
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}"
diff --git a/security/skipfish/Makefile b/security/skipfish/Makefile
index cfd83e2b02cb..65e91d0549a9 100644
--- a/security/skipfish/Makefile
+++ b/security/skipfish/Makefile
@@ -20,8 +20,7 @@ EXPIRATION_DATE= 2017-04-30
LIB_DEPENDS= libidn.so:dns/libidn \
libpcre.so:devel/pcre
-USES= gmake tar:tgz
-USE_OPENSSL= yes
+USES= gmake tar:tgz ssl
SUB_FILES= pkg-message
OPTIONS_DEFINE= DOCS
diff --git a/security/slush/Makefile b/security/slush/Makefile
index e348e0af678a..b5a1a3d8bcd7 100644
--- a/security/slush/Makefile
+++ b/security/slush/Makefile
@@ -14,7 +14,7 @@ LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYRIGHT.GPL
GNU_CONFIGURE= yes
-USE_OPENSSL= yes
+USES= ssl
OPTIONS_DEFINE= DOCS
diff --git a/security/sslwrap/Makefile b/security/sslwrap/Makefile
index dbcad28223db..a60d3784d6dd 100644
--- a/security/sslwrap/Makefile
+++ b/security/sslwrap/Makefile
@@ -18,7 +18,7 @@ LICENSE= BSD4CLAUSE
WRKSRC= ${WRKDIR}/${PORTNAME}${PORTVERSION:S/.//g}
-USE_OPENSSL= yes
+USES= ssl
PORTDOCS= README docs.html
PLIST_FILES= bin/sslwrap
diff --git a/security/sst/Makefile b/security/sst/Makefile
index 70471e7d33e5..db0f4e4b14e1 100644
--- a/security/sst/Makefile
+++ b/security/sst/Makefile
@@ -16,8 +16,7 @@ RUN_DEPENDS= netcat:net/netcat
.endif
MAKEFILE= ${FILESDIR}/Makefile
-USES= uidfix
-USE_OPENSSL= YES
+USES= uidfix ssl
PLIST_FILES= sbin/sst \
man/man1/sst.1.gz
diff --git a/security/stud/Makefile b/security/stud/Makefile
index 5d4dd50310e3..5bb165e27b5d 100644
--- a/security/stud/Makefile
+++ b/security/stud/Makefile
@@ -13,9 +13,8 @@ LICENSE= BSD2CLAUSE
LIB_DEPENDS= libev.so:devel/libev
-USES= gmake
+USES= gmake ssl
USE_GITHUB= yes
-USE_OPENSSL= yes
GH_ACCOUNT= wasted
diff --git a/security/tinyca/Makefile b/security/tinyca/Makefile
index 333719718e24..1fa1db702f18 100644
--- a/security/tinyca/Makefile
+++ b/security/tinyca/Makefile
@@ -16,8 +16,7 @@ RUN_DEPENDS= p5-Gtk2>=0:x11-toolkits/p5-Gtk2 \
zip:archivers/zip \
p5-MIME-Base64>=0:converters/p5-MIME-Base64
-USES= perl5 tar:xz shebangfix
-USE_OPENSSL= yes
+USES= perl5 tar:xz shebangfix ssl
SHEBANG_FILES= tinyca2
NO_BUILD= yes
NO_ARCH= yes
diff --git a/security/yapet/Makefile b/security/yapet/Makefile
index 19990c8d8608..319e50c2ecc4 100644
--- a/security/yapet/Makefile
+++ b/security/yapet/Makefile
@@ -11,8 +11,7 @@ COMMENT= Curses based password manager
LICENSE= GPLv3
-USES= gmake ncurses
-USE_OPENSSL= yes
+USES= gmake ncurses ssl
GNU_CONFIGURE= yes
OPTIONS_DEFINE= CONVERTERS DOCS NLS
diff --git a/security/yubico-piv-tool/Makefile b/security/yubico-piv-tool/Makefile
index e730deb7248f..6eb4ae527e5c 100644
--- a/security/yubico-piv-tool/Makefile
+++ b/security/yubico-piv-tool/Makefile
@@ -14,9 +14,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libpcsclite.so:devel/pcsc-lite
-USES= libtool pathfix pkgconfig
+USES= libtool pathfix pkgconfig ssl
USE_LDCONFIG= yes
-USE_OPENSSL= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= OPENSSL_CFLAGS="${OPENSSL_CFLAGS}" \
OPENSSL_LIBS="-L${OPENSSLLIB} -lcrypto"
diff --git a/security/zebedee/Makefile b/security/zebedee/Makefile
index 46c07f24ccb5..870de551dbd4 100644
--- a/security/zebedee/Makefile
+++ b/security/zebedee/Makefile
@@ -12,8 +12,7 @@ COMMENT= Encrypted, secure compressed TCP tunnel
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/GPL2.txt
-USES= perl5
-USE_OPENSSL= yes
+USES= perl5 ssl
USE_PERL5= build
PORTEXAMPLES= vncviewer.zbd vncserver.zbd server.key server.id client1.key \
diff --git a/security/zxid/Makefile b/security/zxid/Makefile
index 853a2710c6b8..bab0b64e8757 100644
--- a/security/zxid/Makefile
+++ b/security/zxid/Makefile
@@ -16,8 +16,7 @@ LICENSE_PERMS= # none
LIB_DEPENDS= libcurl.so:ftp/curl
-USES= gmake localbase tar:tgz
-USE_OPENSSL= yes
+USES= gmake localbase tar:tgz ssl
USE_CSTD= gnu89
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}" \
LD="${CC}" LDFLAGS="${LDFLAGS}" \