aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorSimon Barner <barner@FreeBSD.org>2008-04-15 21:15:09 +0000
committerSimon Barner <barner@FreeBSD.org>2008-04-15 21:15:09 +0000
commitaca903d33450930e5f974fe0aaafd538ee198e16 (patch)
tree430aeec59d010c784a42a31108bb181ff74b9805 /security
parent0d3f3d0c946e6bce28bc3fe068f50a453f649793 (diff)
downloadports-aca903d33450930e5f974fe0aaafd538ee198e16.tar.gz
ports-aca903d33450930e5f974fe0aaafd538ee198e16.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/pam_fprint/Makefile40
-rw-r--r--security/pam_fprint/distinfo3
-rw-r--r--security/pam_fprint/files/patch-src_Makefile.in20
-rw-r--r--security/pam_fprint/files/patch-src_pam_fprint.c11
-rw-r--r--security/pam_fprint/files/pkg-message.in32
-rw-r--r--security/pam_fprint/pkg-descr5
7 files changed, 112 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 49dbd71a3cc9..23b0755012bb 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -521,6 +521,7 @@
SUBDIR += pam_alreadyloggedin
SUBDIR += pam_authsrv
SUBDIR += pam_bsdbioapi
+ SUBDIR += pam_fprint
SUBDIR += pam_krb5
SUBDIR += pam_ldap
SUBDIR += pam_mkhomedir
diff --git a/security/pam_fprint/Makefile b/security/pam_fprint/Makefile
new file mode 100644
index 000000000000..a6dad668f920
--- /dev/null
+++ b/security/pam_fprint/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: pam_fprint
+# Date created: April 12 2008
+# Whom: barner
+#
+# $FreeBSD$
+#
+
+PORTNAME= pam_fprint
+PORTVERSION= 0.2
+CATEGORIES= security
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= fprint
+
+MAINTAINER= barner@FreeBSD.org
+COMMENT= PAM module offering finger print authentication using libfprint
+
+LIB_DEPENDS= fprint:${PORTSDIR}/security/libfprint
+
+CONFIGURE_ENV+= FPRINT_CFLAGS=-I${LOCALBASE}/include
+GNU_CONFIGURE= yes
+
+USE_BZIP2= yes
+USE_GNOME= pkgconfig
+
+PLIST_FILES+= bin/pam_fprint_enroll \
+ lib/pam_fprint.so
+
+SUB_FILES= pkg-message
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+post-install:
+ @${ECHO}
+ @${ECHO} =========================================================================
+ @${ECHO}
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO}
+ @${ECHO} =========================================================================
+ @${ECHO}
+
+.include <bsd.port.mk>
diff --git a/security/pam_fprint/distinfo b/security/pam_fprint/distinfo
new file mode 100644
index 000000000000..ab8b1dfb1ab0
--- /dev/null
+++ b/security/pam_fprint/distinfo
@@ -0,0 +1,3 @@
+MD5 (pam_fprint-0.2.tar.bz2) = abfb041ed856aaac5c5c416973451226
+SHA256 (pam_fprint-0.2.tar.bz2) = 57cba8a951d4127e5be4c3b2ced0c1c6fac0201a08c833f1644f0ea2e3fa8a72
+SIZE (pam_fprint-0.2.tar.bz2) = 72781
diff --git a/security/pam_fprint/files/patch-src_Makefile.in b/security/pam_fprint/files/patch-src_Makefile.in
new file mode 100644
index 000000000000..54e5dd1891a1
--- /dev/null
+++ b/security/pam_fprint/files/patch-src_Makefile.in
@@ -0,0 +1,20 @@
+--- src/Makefile.in.orig 2007-11-19 20:15:11.000000000 +0100
++++ src/Makefile.in 2008-04-12 18:44:55.000000000 +0200
+@@ -30,7 +30,7 @@
+ NORMAL_UNINSTALL = :
+ PRE_UNINSTALL = :
+ POST_UNINSTALL = :
+-noinst_PROGRAMS = pamtest$(EXEEXT)
++noinst_PROGRAMS =
+ bin_PROGRAMS = pam_fprint_enroll$(EXEEXT)
+ pammod_PROGRAMS = pam_fprint.so$(EXEEXT)
+ subdir = src
+@@ -163,7 +163,7 @@
+ target_alias = @target_alias@
+ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
+-pammoddir = /lib/security
++pammoddir = ${PREFIX}/lib
+ pam_fprint_so_SOURCES = pam_fprint.c
+ pam_fprint_so_CFLAGS = -fPIC $(FPRINT_CFLAGS)
+ pam_fprint_so_LDFLAGS = -shared
diff --git a/security/pam_fprint/files/patch-src_pam_fprint.c b/security/pam_fprint/files/patch-src_pam_fprint.c
new file mode 100644
index 000000000000..8601cae85659
--- /dev/null
+++ b/security/pam_fprint/files/patch-src_pam_fprint.c
@@ -0,0 +1,11 @@
+--- src/pam_fprint.c.orig 2008-04-12 18:33:50.000000000 +0200
++++ src/pam_fprint.c 2008-04-12 18:34:31.000000000 +0200
+@@ -23,7 +23,7 @@
+ #include <pwd.h>
+ #include <string.h>
+
+-#include <fprint.h>
++#include "libfprint/fprint.h"
+
+ #define PAM_SM_AUTH
+ #include <security/pam_modules.h>
diff --git a/security/pam_fprint/files/pkg-message.in b/security/pam_fprint/files/pkg-message.in
new file mode 100644
index 000000000000..13f8e0144419
--- /dev/null
+++ b/security/pam_fprint/files/pkg-message.in
@@ -0,0 +1,32 @@
+In order to enroll new finger prints, you must have r/w access to the
+usb device node(s) of your finger print reader (e.g. /dev/ugen*)
+(tested with UPEK finger print reader as found in Lenovo T61).
+
+It is recommended to use devfs.rules(5) and a dedicated group to manage
+access to your finger print reader.
+
+Example configuration:
+- /etc/rc.conf:
+devfs_system_ruleset="localrules"
+
+- /etc/devfs.rules:
+[localrules=10]
+add path 'ugen0*' mode 0660 group operator
+
+# /etc/rc.d/devfs restart
+
+Read `pam_fprint_enroll --help' to learn about enrolling fingers.
+
+The security/fprint_demo port contains the graphical `fprint_demo'
+application that allows you to manage your finger prints in a comfortable
+way.
+
+After enrolling fingerprints for your user(s), you can enable finger
+print authentication by adding the following line to the corresponding
+PAM configuration file(s) (see the PAM documentation and the pam_fprint
+web site for more information).
+
+auth sufficient %%PREFIX%%/lib/pam_fprint.so
+
+/etc/pam.d/system is used for system-wide defaults,
+/etc/pam.d/{gdm, kde} are used by the GDM/KDM login managers.
diff --git a/security/pam_fprint/pkg-descr b/security/pam_fprint/pkg-descr
new file mode 100644
index 000000000000..e076a8e16a59
--- /dev/null
+++ b/security/pam_fprint/pkg-descr
@@ -0,0 +1,5 @@
+pam_fprint is a simple PAM module which uses libfprint's fingerprint
+processing and verification functionality for authentication. In other words,
+instead of seeing a password prompt, you're asked to scan your fingerprint.
+
+WWW: http://www.reactivated.net/fprint/wiki/Pam_fprint