aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-10-26 16:00:45 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-10-26 16:00:45 +0000
commit0a62153e7a5ec4d8c3daf4af0974fdb238d05f20 (patch)
tree6d852d86535632eb6230f201539acf5ce9e8dd86 /security
parenteb3a517e234ba4a78c19519b4cb2b04e84fdfc57 (diff)
downloadports-0a62153e7a5ec4d8c3daf4af0974fdb238d05f20.tar.gz
ports-0a62153e7a5ec4d8c3daf4af0974fdb238d05f20.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/rubygem-sshkit/Makefile22
-rw-r--r--security/rubygem-sshkit/distinfo2
-rw-r--r--security/rubygem-sshkit/pkg-descr5
4 files changed, 30 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index b85be1017066..2bdb3ef44c70 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -874,6 +874,7 @@
SUBDIR += rubygem-roauth
SUBDIR += rubygem-ruby-hmac
SUBDIR += rubygem-six
+ SUBDIR += rubygem-sshkit
SUBDIR += rubygem-twitter_oauth
SUBDIR += safesh
SUBDIR += saint
diff --git a/security/rubygem-sshkit/Makefile b/security/rubygem-sshkit/Makefile
new file mode 100644
index 000000000000..10a963ca2e0a
--- /dev/null
+++ b/security/rubygem-sshkit/Makefile
@@ -0,0 +1,22 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= sshkit
+PORTVERSION= 1.1.0
+CATEGORIES= security rubygems
+MASTER_SITES= RG
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Toolkit for remotely running commands on groups of servers
+
+LICENSE= GPLv3
+
+RUN_DEPENDS= rubygem-net-scp>=0:${PORTSDIR}/security/rubygem-net-scp \
+ rubygem-net-ssh>=0:${PORTSDIR}/security/rubygem-net-ssh \
+ rubygem-term-ansicolor>=0:${PORTSDIR}/devel/rubygem-term-ansicolor
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/security/rubygem-sshkit/distinfo b/security/rubygem-sshkit/distinfo
new file mode 100644
index 000000000000..52748ca44dc1
--- /dev/null
+++ b/security/rubygem-sshkit/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/sshkit-1.1.0.gem) = 2455e0b536f4aba60895e82ba3030639cea77f6533ef287b0ddc57823eecbc16
+SIZE (rubygem/sshkit-1.1.0.gem) = 131072
diff --git a/security/rubygem-sshkit/pkg-descr b/security/rubygem-sshkit/pkg-descr
new file mode 100644
index 000000000000..c9d03c7b15d8
--- /dev/null
+++ b/security/rubygem-sshkit/pkg-descr
@@ -0,0 +1,5 @@
+SSHKit is a comprehensive toolkit for remotely running commands in a structured
+manner on groups of servers.
+
+WWW: https://github.com/leehambley/sshkit
+RG: https://rubygems.org/gems/sshkit