aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2020-05-22 15:49:18 +0000
committerCy Schubert <cy@FreeBSD.org>2020-05-22 15:49:18 +0000
commit72b35d22697f65ab00b963637f670fe37c2460d7 (patch)
tree1b470e0e46bd0b9b7e5cbc0b77e341beb5d7d520 /security
parentaeef0566d71de6bea40f264d3ea676a07d674f4b (diff)
downloadports-72b35d22697f65ab00b963637f670fe37c2460d7.tar.gz
ports-72b35d22697f65ab00b963637f670fe37c2460d7.zip
MFH: r535967
Chase src r361272: Silence the once per second CTRL-EVENT-SCAN-FAILED errors when the WiFi radio is disabled through the communication device toggle key (also known as the RF raidio kill button). Only the CTRL-EVENT-DISCONNECTED will be issued. Submitted by: avg Reported by: avg Approved by: portmgr (joneum)
Notes
Notes: svn path=/branches/2020Q2/; revision=536208
Diffstat (limited to 'security')
-rw-r--r--security/wpa_supplicant/Makefile2
-rw-r--r--security/wpa_supplicant/files/patch-src_drivers_driver__bsd.c24
2 files changed, 25 insertions, 1 deletions
diff --git a/security/wpa_supplicant/Makefile b/security/wpa_supplicant/Makefile
index 33a258b40ef3..611461f9da6a 100644
--- a/security/wpa_supplicant/Makefile
+++ b/security/wpa_supplicant/Makefile
@@ -2,7 +2,7 @@
PORTNAME= wpa_supplicant
PORTVERSION= 2.9
-PORTREVISION= 3
+PORTREVISION= 5
CATEGORIES= security net
MASTER_SITES= https://w1.fi/releases/
diff --git a/security/wpa_supplicant/files/patch-src_drivers_driver__bsd.c b/security/wpa_supplicant/files/patch-src_drivers_driver__bsd.c
new file mode 100644
index 000000000000..20de452175c7
--- /dev/null
+++ b/security/wpa_supplicant/files/patch-src_drivers_driver__bsd.c
@@ -0,0 +1,24 @@
+--- src/drivers/driver_bsd.c.orig 2019-08-07 06:25:25.000000000 -0700
++++ src/drivers/driver_bsd.c 2020-05-19 18:17:48.607660000 -0700
+@@ -1336,14 +1336,18 @@
+ drv = bsd_get_drvindex(global, ifm->ifm_index);
+ if (drv == NULL)
+ return;
+- if ((ifm->ifm_flags & IFF_UP) == 0 &&
+- (drv->flags & IFF_UP) != 0) {
++ if (((ifm->ifm_flags & IFF_UP) == 0 ||
++ (ifm->ifm_flags & IFF_RUNNING) == 0) &&
++ (drv->flags & IFF_UP) != 0 &&
++ (drv->flags & IFF_RUNNING) != 0) {
+ wpa_printf(MSG_DEBUG, "RTM_IFINFO: Interface '%s' DOWN",
+ drv->ifname);
+ wpa_supplicant_event(drv->ctx, EVENT_INTERFACE_DISABLED,
+ NULL);
+ } else if ((ifm->ifm_flags & IFF_UP) != 0 &&
+- (drv->flags & IFF_UP) == 0) {
++ (ifm->ifm_flags & IFF_RUNNING) != 0 &&
++ ((drv->flags & IFF_UP) == 0 ||
++ (drv->flags & IFF_RUNNING) == 0)) {
+ wpa_printf(MSG_DEBUG, "RTM_IFINFO: Interface '%s' UP",
+ drv->ifname);
+ wpa_supplicant_event(drv->ctx, EVENT_INTERFACE_ENABLED,