aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-05-06 09:39:25 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-05-06 09:39:25 +0000
commit86c6fbb45f6da8c66ff7d56e59d3a231e375ca95 (patch)
treeb28f98dfecd6328c2f721168c661dd06de72dd2e /security
parentc40e54425136c321d8be8532cafe919757c8b7ac (diff)
Finish converting security from WITHOUT_NLS to PORT_OPTIONS:MNLS
Notes
Notes: svn path=/head/; revision=317496
Diffstat (limited to 'security')
-rw-r--r--security/gnutls-devel/Makefile12
-rw-r--r--security/pam_krb5-rh/Makefile18
-rw-r--r--security/pidgin-encryption/Makefile10
3 files changed, 17 insertions, 23 deletions
diff --git a/security/gnutls-devel/Makefile b/security/gnutls-devel/Makefile
index 57a5577a8080..0eb89c8b41eb 100644
--- a/security/gnutls-devel/Makefile
+++ b/security/gnutls-devel/Makefile
@@ -50,15 +50,15 @@ PLIST_SUB+= CXX="@comment "
PLIST_SUB+= CXX=""
.endif
-.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS="@comment "
-.else
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
PORTDOCS= AUTHORS NEWS README THANKS
.endif
EXAMPLES= doc/examples/*.c
@@ -72,7 +72,7 @@ pre-configure:
post-install:
@${MKDIR} ${EXAMPLESDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${EXAMPLES} ${EXAMPLESDIR}
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for i in ${PORTDOCS}
@${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
diff --git a/security/pam_krb5-rh/Makefile b/security/pam_krb5-rh/Makefile
index 98a7e10ece66..2c3b5e720c16 100644
--- a/security/pam_krb5-rh/Makefile
+++ b/security/pam_krb5-rh/Makefile
@@ -26,19 +26,15 @@ LDFLAGS+= -L${LOCALBASE}/lib
MAN5= pam_krb5.5
MAN8= pam_krb5.8 pam_krb5_cchelper.8
-.if defined(WITHOUT_NLS)
-PLIST_SUB+= NLS="@comment "
-CONFIGURE_ARGS+=--disable-nls
-.else
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
PLIST_SUB+= NLS=""
LDFLAGS+= -lintl
USES+= gettext
-.endif
-
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 800000
-BROKEN= does not build on FreeBSD 7.x
+.else
+PLIST_SUB+= NLS="@comment "
+CONFIGURE_ARGS+=--disable-nls
.endif
post-patch:
@@ -50,4 +46,4 @@ post-patch:
@${REINPLACE_CMD} -e 's|PAM_AUTHTOK_RECOVER_ERR|PAM_AUTHTOK_RECOVERY_ERR|g' \
${WRKSRC}/src/password.c
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/pidgin-encryption/Makefile b/security/pidgin-encryption/Makefile
index 543077c62687..367404f93a63 100644
--- a/security/pidgin-encryption/Makefile
+++ b/security/pidgin-encryption/Makefile
@@ -1,9 +1,5 @@
-# New ports collection Makefile for: pidgin-encryption
-# Date created: 2004-05-01
-# Whom: ports@c0decafe.net
-#
+# Created by: ports@c0decafe.net
# $FreeBSD$
-#
PORTNAME= pidgin
PORTVERSION= 3.1
@@ -32,7 +28,9 @@ CONFIGURE_ARGS= --with-nspr-includes=${LOCALBASE}/include/nspr \
--with-nss-includes=${LOCALBASE}/include/nss/nss \
--with-nss-libs=${LOCALBASE}/lib/nss
-.if !defined(WITHOUT_NLS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
CONFIGURE_ARGS+= --with-libintl-prefix=${LOCALBASE}
PLIST_SUB+= NLS=""