aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-11-09 16:38:32 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-11-09 16:38:32 +0000
commit8abc7ca47a1548a0e6e271898b555fd541529307 (patch)
tree52b5ebd063576f66d9510f5fa186b23127ba71fd /security
parenta3b1dbe9f1f3dba2d49e8bcfda4bfdc94da90f46 (diff)
downloadports-8abc7ca47a1548a0e6e271898b555fd541529307.tar.gz
ports-8abc7ca47a1548a0e6e271898b555fd541529307.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/makepasswd/Makefile20
-rw-r--r--security/makepasswd/distinfo1
-rw-r--r--security/makepasswd/pkg-plist6
3 files changed, 22 insertions, 5 deletions
diff --git a/security/makepasswd/Makefile b/security/makepasswd/Makefile
index 2e69dd8962f0..95f887ed9136 100644
--- a/security/makepasswd/Makefile
+++ b/security/makepasswd/Makefile
@@ -7,21 +7,37 @@
PORTNAME= makepasswd
PORTVERSION= 1.10
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_DEBIAN}
-MASTER_SITE_SUBDIR= dists/potato/main/source/admin/
+MASTER_SITE_SUBDIR= pool/main/m/makepasswd
DISTNAME= ${PORTNAME}_${PORTVERSION}.orig
+PATCHFILES= ${PORTNAME}_${PORTVERSION}-2.diff.gz
+PATCH_SITES= ${MASTER_SITES}
+PATCH_SITE_SUBDIR= ${MASTER_SITE_SUBDIR}
+PATCH_DIST_STRIP= -p1
+
MAINTAINER= toni.viemero@iki.fi
COMMENT= Random password generator
NO_BUILD= yes
USE_PERL5_RUN= yes
+USE_REINPLACE= yes
+
+RUN_DEPENDS+= ${SITE_PERL}/Crypt/PasswdMD5.pm:${PORTSDIR}/security/p5-Crypt-PasswdMD5
+
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
MAN1= makepasswd.1
DOCS= CHANGES README
+.include <bsd.port.pre.mk>
+
+pre-patch:
+ ${REINPLACE_CMD} -e "s/\/dev\/random/\/dev\/urandom/" ${WRKSRC}/makepasswd
+ ${REINPLACE_CMD} -e "s/\/dev\/random/\/dev\/urandom/" ${WRKSRC}/makepasswd.1
+
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/makepasswd ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/${MAN1} ${PREFIX}/man/man1
@@ -32,4 +48,4 @@ do-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/security/makepasswd/distinfo b/security/makepasswd/distinfo
index cb34811b8248..26826bd39af7 100644
--- a/security/makepasswd/distinfo
+++ b/security/makepasswd/distinfo
@@ -1 +1,2 @@
MD5 (makepasswd_1.10.orig.tar.gz) = 55842bb4c064ebcdedffb4afd5f0945a
+MD5 (makepasswd_1.10-2.diff.gz) = 3525498bf730e11c3aa14721556110fb
diff --git a/security/makepasswd/pkg-plist b/security/makepasswd/pkg-plist
index f4087be20385..4f66536b1d9f 100644
--- a/security/makepasswd/pkg-plist
+++ b/security/makepasswd/pkg-plist
@@ -1,4 +1,4 @@
bin/makepasswd
-share/doc/makepasswd/CHANGES
-share/doc/makepasswd/README
-@dirrm share/doc/makepasswd
+%%PORTDOCS%%%%DOCSDIR%%/CHANGES
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%