aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2012-12-30 21:05:07 +0000
committerPawel Pekala <pawel@FreeBSD.org>2012-12-30 21:05:07 +0000
commitadcc03d0ccddd8eacb24179a8f923f16e0460cdf (patch)
tree7e9217247f44f18ba0e7ecd2ac317d0e557d1840 /security
parent463849d869a350d4196b51da856ca6a9ecef8423 (diff)
Notes
Diffstat (limited to 'security')
-rw-r--r--security/wipe/Makefile22
-rw-r--r--security/wipe/distinfo4
-rw-r--r--security/wipe/files/patch-Makefile.in3
-rw-r--r--security/wipe/files/patch-blkdev.c4
-rw-r--r--security/wipe/pkg-descr3
-rw-r--r--security/wipe/pkg-plist1
6 files changed, 18 insertions, 19 deletions
diff --git a/security/wipe/Makefile b/security/wipe/Makefile
index fee6d1a3bc1b..40e97da7d4cc 100644
--- a/security/wipe/Makefile
+++ b/security/wipe/Makefile
@@ -1,32 +1,32 @@
-# New ports collection makefile for: wipe
-# Date created: 04 February 2005
-# Whom: Edson Brandi <ebrandi@fugspbr.org>
-#
+# Created by: Edson Brandi <ebrandi@fugspbr.org>
# $FreeBSD$
-#
PORTNAME= wipe
-PORTVERSION= 2.3.0
-PORTREVISION= 2
+PORTVERSION= 2.3.1
CATEGORIES= security
MASTER_SITES= SF
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= linpc@cs.nctu.edu.tw
COMMENT= File and block device wiping utility
+LICENSE= GPLv2
+
USE_BZIP2= yes
GNU_CONFIGURE= yes
+PLIST_FILES= bin/wipe
+
MAN1= wipe.1
PORTDOCS= CHANGES INSTALL LICENSE README TESTING TODO copyright
post-patch:
@${REINPLACE_CMD} -e 's|@CFLAGS@|${CFLAGS}|' ${WRKSRC}/Makefile.in
+.include <bsd.port.options.mk>
+
post-install:
- ${INSTALL_MAN} ${WRKSRC}/wipe.1 ${PREFIX}/man/man1
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/wipe
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${DOCSDIR}
for i in ${PORTDOCS}; do \
${INSTALL_DATA} ${WRKSRC}/$$i ${DOCSDIR}; \
done
diff --git a/security/wipe/distinfo b/security/wipe/distinfo
index f958bd0530a4..1b3ff3af9ae4 100644
--- a/security/wipe/distinfo
+++ b/security/wipe/distinfo
@@ -1,2 +1,2 @@
-SHA256 (wipe-2.3.0.tar.bz2) = 2ddc5a55c03286a55f8bfbe6b79d51052899c2e3ceaf78f0be96acdab13cf098
-SIZE (wipe-2.3.0.tar.bz2) = 72257
+SHA256 (wipe-2.3.1.tar.bz2) = 463916370f9b35bb34419c2c0ae3dc4c0a471db32e8595afa1d14c0337b61aa0
+SIZE (wipe-2.3.1.tar.bz2) = 72297
diff --git a/security/wipe/files/patch-Makefile.in b/security/wipe/files/patch-Makefile.in
index d3d802db0f47..0512b45988d3 100644
--- a/security/wipe/files/patch-Makefile.in
+++ b/security/wipe/files/patch-Makefile.in
@@ -1,6 +1,6 @@
--- Makefile.in.orig Sat Aug 30 18:18:03 2003
+++ Makefile.in Sat Mar 5 00:24:22 2005
-@@ -60,13 +60,6 @@
+@@ -60,13 +60,7 @@
$(INSTALL_BIN) -d $(bindir)
$(INSTALL_BIN) -s $(BIN_OUT) $(bindir)
$(INSTALL) -d $(mandir)/man1
@@ -11,6 +11,7 @@
- for file in $(DOCS); do \
- $(INSTALL) -o root -m 0644 $$file $(datadir)/doc/wipe/; \
- done
++ $(INSTALL) -o root -g wheel -m 0444 wipe.1 $(mandir)/man1/
install_home: $(BIN_OUT)
strip $(BIN_OUT)
diff --git a/security/wipe/files/patch-blkdev.c b/security/wipe/files/patch-blkdev.c
index cfb7ff3eea1b..bd01683d77b4 100644
--- a/security/wipe/files/patch-blkdev.c
+++ b/security/wipe/files/patch-blkdev.c
@@ -1,6 +1,6 @@
--- blkdev.c.orig Sun Aug 3 16:07:29 2003
+++ blkdev.c Sat Mar 5 00:23:40 2005
-@@ -128,6 +128,10 @@
+@@ -141,6 +141,10 @@
int code;
#ifdef BSD_BLKDEV
@@ -11,7 +11,7 @@
struct partinfo pinfo;
#endif
-@@ -160,7 +164,7 @@
+@@ -173,7 +177,7 @@
}
#ifdef BSD_BLKDEV
diff --git a/security/wipe/pkg-descr b/security/wipe/pkg-descr
index a599e19ab820..0e849ec4c94c 100644
--- a/security/wipe/pkg-descr
+++ b/security/wipe/pkg-descr
@@ -1,4 +1,3 @@
-Wipe is a file and block device wiping utility
+Wipe is a file and block device wiping utility.
-Author: Tom Vier <nester@users.sf.net>
WWW: http://wipe.sourceforge.net/
diff --git a/security/wipe/pkg-plist b/security/wipe/pkg-plist
deleted file mode 100644
index c0d90a8b6181..000000000000
--- a/security/wipe/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-bin/wipe