aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2007-08-15 18:48:12 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2007-08-15 18:48:12 +0000
commitc4fc19cf10b4f662944d708ebdeed84a011c72e5 (patch)
tree323a236e949c5d798e260b905d167b5f7fb5bc73 /security
parentdbecc08e70b31d5973827d18f20946a492b96112 (diff)
downloadports-c4fc19cf10b4f662944d708ebdeed84a011c72e5.tar.gz
ports-c4fc19cf10b4f662944d708ebdeed84a011c72e5.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-Net-Server-Mail-ESMTP-AUTH/Makefile26
-rw-r--r--security/p5-Net-Server-Mail-ESMTP-AUTH/distinfo3
-rw-r--r--security/p5-Net-Server-Mail-ESMTP-AUTH/pkg-descr8
-rw-r--r--security/p5-Net-Server-Mail-ESMTP-AUTH/pkg-plist11
5 files changed, 49 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 83eb39b0e257..92189e15d5af 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -478,6 +478,7 @@
SUBDIR += p5-Net-OpenID-JanRain
SUBDIR += p5-Net-OpenID-Server
SUBDIR += p5-Net-SSLeay
+ SUBDIR += p5-Net-Server-Mail-ESMTP-AUTH
SUBDIR += p5-Net-SinFP
SUBDIR += p5-Nmap-Parser
SUBDIR += p5-Nmap-Scanner
diff --git a/security/p5-Net-Server-Mail-ESMTP-AUTH/Makefile b/security/p5-Net-Server-Mail-ESMTP-AUTH/Makefile
new file mode 100644
index 000000000000..4c09b5ccf3e0
--- /dev/null
+++ b/security/p5-Net-Server-Mail-ESMTP-AUTH/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-Net-Server-Mail-ESMTP-AUTH
+# Date created: 20th July 2007
+# Whom: Zane C. Bowers <vvelox@vvelox.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-Server-Mail-ESMTP-AUTH
+PORTVERSION= 0.1
+CATEGORIES= security mail perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= vvelox@vvelox.net
+COMMENT= Plain and login auth methods for Net::Server::Mail::ESMTP
+
+BUILD_DEPENDS= ${SITE_PERL}/Net/Server/Mail/ESMTP.pm:${PORTSDIR}/mail/p5-Net-Server-Mail \
+ ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+USE_PERL5= yes
+PERL_CONFIGURE= yes
+
+MAN3= Net::Server::Mail::ESMTP::AUTH.3
+
+.include <bsd.port.mk>
diff --git a/security/p5-Net-Server-Mail-ESMTP-AUTH/distinfo b/security/p5-Net-Server-Mail-ESMTP-AUTH/distinfo
new file mode 100644
index 000000000000..0f3995ed3e37
--- /dev/null
+++ b/security/p5-Net-Server-Mail-ESMTP-AUTH/distinfo
@@ -0,0 +1,3 @@
+MD5 (Net-Server-Mail-ESMTP-AUTH-0.1.tar.gz) = 1471ec31a0287e0c3691669c92f947e7
+SHA256 (Net-Server-Mail-ESMTP-AUTH-0.1.tar.gz) = ff09008efce656e01b4730fd4bc6bcf075da3cef1569452d75794f85a5a305fd
+SIZE (Net-Server-Mail-ESMTP-AUTH-0.1.tar.gz) = 3014
diff --git a/security/p5-Net-Server-Mail-ESMTP-AUTH/pkg-descr b/security/p5-Net-Server-Mail-ESMTP-AUTH/pkg-descr
new file mode 100644
index 000000000000..2a96e55eb9bc
--- /dev/null
+++ b/security/p5-Net-Server-Mail-ESMTP-AUTH/pkg-descr
@@ -0,0 +1,8 @@
+Net::Server::Mail::ESMTP::AUTH is an extension to provide
+support for SMTP authentication with Net::Server::Mail::ESMTP
+module.
+
+Currently only LOGIN and PLAIN methods are supported.
+
+WWW: http://search.cpan.org/dist/Net-Server-Mail-ESMTP-AUTH/
+Author: Sylvain Cresto <scresto [_at_] gmail.com>
diff --git a/security/p5-Net-Server-Mail-ESMTP-AUTH/pkg-plist b/security/p5-Net-Server-Mail-ESMTP-AUTH/pkg-plist
new file mode 100644
index 000000000000..65bda0cf672c
--- /dev/null
+++ b/security/p5-Net-Server-Mail-ESMTP-AUTH/pkg-plist
@@ -0,0 +1,11 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Server/Mail/ESMTP/AUTH/.packlist
+%%SITE_PERL%%/Net/Server/Mail/ESMTP/AUTH.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Server/Mail/ESMTP/AUTH
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Server/Mail/ESMTP
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Server/Mail
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Server
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
+@dirrmtry %%SITE_PERL%%/Net/Server/Mail/ESMTP
+@dirrmtry %%SITE_PERL%%/Net/Server/Mail
+@dirrmtry %%SITE_PERL%%/Net/Server
+@dirrmtry %%SITE_PERL%%/Net