aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2006-11-14 07:52:02 +0000
committerMartin Wilke <miwi@FreeBSD.org>2006-11-14 07:52:02 +0000
commite34f313a92bd1de67fb3d677a4ad231d8214e49e (patch)
tree76d0866460ba41013973bc96a15174d69746df58 /security
parente83eaf521426d2835e2710f33de42474780c9964 (diff)
downloadports-e34f313a92bd1de67fb3d677a4ad231d8214e49e.tar.gz
ports-e34f313a92bd1de67fb3d677a4ad231d8214e49e.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/pear-Crypt_Blowfish/Makefile25
-rw-r--r--security/pear-Crypt_Blowfish/distinfo6
-rw-r--r--security/pear-Crypt_Blowfish/pkg-descr7
3 files changed, 28 insertions, 10 deletions
diff --git a/security/pear-Crypt_Blowfish/Makefile b/security/pear-Crypt_Blowfish/Makefile
index e089891b1256..37ae2bc0bb76 100644
--- a/security/pear-Crypt_Blowfish/Makefile
+++ b/security/pear-Crypt_Blowfish/Makefile
@@ -6,8 +6,9 @@
#
PORTNAME= Crypt_Blowfish
-PORTVERSION= 1.0.1
+PORTVERSION= 1.1.0.r1
CATEGORIES= security www pear
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/.r/RC/}
MAINTAINER= thomas@goodking.ca
COMMENT= PEAR class for blowfish encryption
@@ -16,8 +17,26 @@ BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
RUN_DEPENDS= ${BUILD_DEPENDS}
CATEGORY= Crypt
-FILES= Blowfish.php Blowfish/DefaultKey.php
-TESTS= blowfish.phpt vectors.txt
+FILES= Blowfish.php \
+ Blowfish/CBC.php \
+ Blowfish/DefaultKey.php \
+ Blowfish/ECB.php \
+ Blowfish/MCrypt.php \
+ Blowfish/PHP.php
+TESTS= blowfish.phpt \
+ blowfish_cbc.phpt \
+ vectors.txt \
+ vectors_cbc.txt
+
+.if defined(WITH_PHP_MCRYPT)
+USE_PHP=mcrypt
+.endif
+
+pre-fetch:
+ @${ECHO_CMD} ""
+ @${ECHO_CMD} "You may set envirtonment variable WITH_PHP_MCRYPT to include"
+ @${ECHO_CMD} "additional MCrypt PHP support"
+ @${ECHO_CMD} ""
post-patch:
.for file in ${FILES}
diff --git a/security/pear-Crypt_Blowfish/distinfo b/security/pear-Crypt_Blowfish/distinfo
index 66fa6aea404e..4fb5f7422c0c 100644
--- a/security/pear-Crypt_Blowfish/distinfo
+++ b/security/pear-Crypt_Blowfish/distinfo
@@ -1,3 +1,3 @@
-MD5 (PEAR/Crypt_Blowfish-1.0.1.tgz) = 93873efe07a267b2b415965994a0af98
-SHA256 (PEAR/Crypt_Blowfish-1.0.1.tgz) = e793daae146491a3dc8000ed732de7f4b9b50d76e91c935807487fdc3d169655
-SIZE (PEAR/Crypt_Blowfish-1.0.1.tgz) = 11954
+MD5 (PEAR/Crypt_Blowfish-1.1.0RC1.tgz) = e81ed11bbb24f4c8b278bd5af0de1884
+SHA256 (PEAR/Crypt_Blowfish-1.1.0RC1.tgz) = d467af9d3ba0b07fd694817930228e6b71060574a1e91c4f320cc6134da3824c
+SIZE (PEAR/Crypt_Blowfish-1.1.0RC1.tgz) = 18304
diff --git a/security/pear-Crypt_Blowfish/pkg-descr b/security/pear-Crypt_Blowfish/pkg-descr
index efac6514e273..05143e067b9a 100644
--- a/security/pear-Crypt_Blowfish/pkg-descr
+++ b/security/pear-Crypt_Blowfish/pkg-descr
@@ -1,6 +1,5 @@
-PEAR::Crypt_Blowfish allows you to prefore two-way blowfish on the fly using
-only PHP.
-
-This package does not require the Mcrypt PHP extension to work.
+PEAR::Crypt_Blowfish allows you to perform two-way blowfish encryption on
+the fly using only PHP. This package does not require the MCrypt
+PHP extension to work, although it can make use of it if available.
WWW: http://pear.php.net/package/Crypt_Blowfish/