aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2015-03-15 10:21:14 +0000
committerPawel Pekala <pawel@FreeBSD.org>2015-03-15 10:21:14 +0000
commit2254455d5e5591100b1df1a5f97f63aa64d51ca9 (patch)
tree700858ba98a1d6a0ce74616f1a6af073f7b35323 /security
parented632970ff854f03ec3e5b21b0130fb4cb60ccad (diff)
downloadports-2254455d5e5591100b1df1a5f97f63aa64d51ca9.tar.gz
ports-2254455d5e5591100b1df1a5f97f63aa64d51ca9.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/polarssl13/Makefile19
-rw-r--r--security/polarssl13/distinfo4
-rw-r--r--security/polarssl13/files/patch-include_polarssl_config.h9
-rw-r--r--security/polarssl13/files/patch-library-Makefile9
-rw-r--r--security/polarssl13/files/patch-library-asn1parse_c11
-rw-r--r--security/polarssl13/pkg-plist50
6 files changed, 52 insertions, 50 deletions
diff --git a/security/polarssl13/Makefile b/security/polarssl13/Makefile
index 15a81ac05a89..c087c28b63ad 100644
--- a/security/polarssl13/Makefile
+++ b/security/polarssl13/Makefile
@@ -1,12 +1,13 @@
# $FreeBSD$
PORTNAME= polarssl
-PORTVERSION= 1.3.9
-PORTREVISION= 1
+PORTVERSION= 1.3.10
DISTVERSIONSUFFIX= -gpl
+#PORTREVISION= 1
CATEGORIES= security devel
-MASTER_SITES= http://polarssl.org/download/
+MASTER_SITES= https://polarssl.org/download/
PKGNAMESUFFIX= 13
+DISTNAME= mbedtls-${DISTVERSIONPREFIX}${DISTVERSION}${DISTVERSIONSUFFIX}
MAINTAINER= chris@bsdjunk.com
COMMENT= Open Source embedded SSL/TLS cryptographic library
@@ -15,10 +16,10 @@ LICENSE= GPLv2
ALL_TARGET= no_test
-USES= cpe gmake tar:tgz
+USES= cpe gmake tar:tgz
USE_LDCONFIG= yes
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+WRKSRC= ${WRKDIR}/mbedtls-${PORTVERSION}
CONFLICTS= polarssl-[0-9]*
@@ -32,9 +33,11 @@ BINFILES= aescrypt2 benchmark dh_client dh_genprime dh_server hello \
do-install:
@cd ${WRKSRC}/include && ${COPYTREE_SHARE} ${PORTNAME} ${STAGEDIR}${PREFIX}/include "! -name *.orig"
${INSTALL_DATA} ${WRKSRC}/library/libpolarssl.a ${STAGEDIR}${PREFIX}/lib/
- ${INSTALL_DATA} ${WRKSRC}/library/libpolarssl.so ${STAGEDIR}${PREFIX}/lib/libpolarssl.so.7
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libpolarssl.so.7
- cd ${STAGEDIR}${PREFIX}/lib/ && ${LN} -sf libpolarssl.so.7 libpolarssl.so
+ ${INSTALL_DATA} ${WRKSRC}/library/libpolarssl.so ${STAGEDIR}${PREFIX}/lib/libpolarssl.so.8
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libpolarssl.so.8
+ (cd ${STAGEDIR}${PREFIX}/lib/ && ${LN} -sf libpolarssl.so.8 libpolarssl.so)
+ (cd ${STAGEDIR}${PREFIX}/lib/ && ${LN} -sf libpolarssl.so.8 libmbedtls.so.8)
+ (cd ${STAGEDIR}${PREFIX}/lib/ && ${LN} -sf libmbedtls.so.8 libmbedtls.so)
.for i in ${BINFILES}
${INSTALL_PROGRAM} ${WRKSRC}/programs/*/${i} ${STAGEDIR}${PREFIX}/bin/polarssl_${i}
.endfor
diff --git a/security/polarssl13/distinfo b/security/polarssl13/distinfo
index 3abc9d6362f2..7d1b12956a09 100644
--- a/security/polarssl13/distinfo
+++ b/security/polarssl13/distinfo
@@ -1,2 +1,2 @@
-SHA256 (polarssl-1.3.9-gpl.tgz) = d3605afc28ed4b7d1d9e3142d72e42855e4a23c07c951bbb0299556b02d36755
-SIZE (polarssl-1.3.9-gpl.tgz) = 1741396
+SHA256 (mbedtls-1.3.10-gpl.tgz) = 746fd88e0c6623691fc56c4eed52e40a57b2da0ac80f6dd8995094aa6adb407e
+SIZE (mbedtls-1.3.10-gpl.tgz) = 1709888
diff --git a/security/polarssl13/files/patch-include_polarssl_config.h b/security/polarssl13/files/patch-include_polarssl_config.h
new file mode 100644
index 000000000000..73d2b920205f
--- /dev/null
+++ b/security/polarssl13/files/patch-include_polarssl_config.h
@@ -0,0 +1,9 @@
+--- include/polarssl/config.h.bak 2014-04-11 22:33:59.000000000 +0900
++++ include/polarssl/config.h 2014-04-30 17:36:41.000000000 +0900
+@@ -2383,4 +2383,6 @@
+ #error "POLARSSL_X509_CSR_WRITE_C defined, but not all prerequisites"
+ #endif
+
++#define SHOW_PROTOTYPE_CHANGE_WARNINGS
++
+ #endif /* config.h */
diff --git a/security/polarssl13/files/patch-library-Makefile b/security/polarssl13/files/patch-library-Makefile
index 88c39895a047..786f97efcbed 100644
--- a/security/polarssl13/files/patch-library-Makefile
+++ b/security/polarssl13/files/patch-library-Makefile
@@ -1,5 +1,5 @@
---- library/Makefile.old 2014-11-28 16:02:22.000000000 +0000
-+++ library/Makefile 2014-11-28 16:03:01.000000000 +0000
+--- library/Makefile.orig 2015-02-11 01:00:42.000000000 +0900
++++ library/Makefile 2015-02-18 12:47:25.000000000 +0900
@@ -18,9 +18,7 @@
# CFLAGS += -D_BSD_EXTENSION
@@ -8,7 +8,7 @@
CFLAGS += -fPIC
-endif
- SONAME=libpolarssl.so.7
+ SONAME=libmbedtls.so.8
@@ -65,11 +63,7 @@
@@ -17,9 +17,8 @@
-ifndef SHARED
-all: static
-else
--all: shared
+ all: shared static
-endif
-+all: shared static
static: libpolarssl.a
diff --git a/security/polarssl13/files/patch-library-asn1parse_c b/security/polarssl13/files/patch-library-asn1parse_c
deleted file mode 100644
index 63964875e155..000000000000
--- a/security/polarssl13/files/patch-library-asn1parse_c
+++ /dev/null
@@ -1,11 +0,0 @@
---- library/asn1parse.c.orig 2015-01-20 10:12:00.469677333 +0000
-+++ library/asn1parse.c 2015-01-20 10:14:00.764667419 +0000
-@@ -278,6 +278,8 @@
- if( cur->next == NULL )
- return( POLARSSL_ERR_ASN1_MALLOC_FAILED );
-
-+ memset( cur->next, 0, sizeof( asn1_sequence ) );
-+
- cur = cur->next;
- }
- }
diff --git a/security/polarssl13/pkg-plist b/security/polarssl13/pkg-plist
index 31f8ba1db1dd..045bc7c4354c 100644
--- a/security/polarssl13/pkg-plist
+++ b/security/polarssl13/pkg-plist
@@ -17,30 +17,8 @@ bin/polarssl_ssl_client1
bin/polarssl_ssl_client2
bin/polarssl_ssl_server
bin/polarssl_ssl_test
-include/polarssl/aesni.h
-include/polarssl/ccm.h
-include/polarssl/check_config.h
-include/polarssl/compat-1.2.h
-include/polarssl/ecdh.h
-include/polarssl/ecdsa.h
-include/polarssl/ecp.h
-include/polarssl/hmac_drbg.h
-include/polarssl/memory.h
-include/polarssl/memory_buffer_alloc.h
-include/polarssl/oid.h
-include/polarssl/pk.h
-include/polarssl/pk_wrap.h
-include/polarssl/platform.h
-include/polarssl/ripemd160.h
-include/polarssl/sha256.h
-include/polarssl/sha512.h
-include/polarssl/ssl_ciphersuites.h
-include/polarssl/threading.h
-include/polarssl/x509_crl.h
-include/polarssl/x509_crt.h
-include/polarssl/x509_csr.h
-lib/libpolarssl.so.7
include/polarssl/aes.h
+include/polarssl/aesni.h
include/polarssl/arc4.h
include/polarssl/asn1.h
include/polarssl/asn1write.h
@@ -49,42 +27,66 @@ include/polarssl/bignum.h
include/polarssl/blowfish.h
include/polarssl/bn_mul.h
include/polarssl/camellia.h
+include/polarssl/ccm.h
include/polarssl/certs.h
+include/polarssl/check_config.h
include/polarssl/cipher.h
include/polarssl/cipher_wrap.h
+include/polarssl/compat-1.2.h
include/polarssl/config.h
include/polarssl/ctr_drbg.h
include/polarssl/debug.h
include/polarssl/des.h
include/polarssl/dhm.h
+include/polarssl/ecdh.h
+include/polarssl/ecdsa.h
+include/polarssl/ecp.h
include/polarssl/entropy.h
include/polarssl/entropy_poll.h
include/polarssl/error.h
include/polarssl/gcm.h
include/polarssl/havege.h
+include/polarssl/hmac_drbg.h
include/polarssl/md.h
include/polarssl/md2.h
include/polarssl/md4.h
include/polarssl/md5.h
include/polarssl/md_wrap.h
+include/polarssl/memory.h
+include/polarssl/memory_buffer_alloc.h
include/polarssl/net.h
+include/polarssl/oid.h
include/polarssl/openssl.h
include/polarssl/padlock.h
-include/polarssl/pem.h
include/polarssl/pbkdf2.h
+include/polarssl/pem.h
+include/polarssl/pk.h
+include/polarssl/pk_wrap.h
include/polarssl/pkcs11.h
include/polarssl/pkcs12.h
include/polarssl/pkcs5.h
+include/polarssl/platform.h
+include/polarssl/ripemd160.h
include/polarssl/rsa.h
include/polarssl/sha1.h
+include/polarssl/sha256.h
+include/polarssl/sha512.h
include/polarssl/ssl.h
include/polarssl/ssl_cache.h
+include/polarssl/ssl_ciphersuites.h
+include/polarssl/threading.h
include/polarssl/timing.h
include/polarssl/version.h
include/polarssl/x509.h
+include/polarssl/x509_crl.h
+include/polarssl/x509_crt.h
+include/polarssl/x509_csr.h
include/polarssl/xtea.h
lib/libpolarssl.a
lib/libpolarssl.so
+lib/libpolarssl.so.8
+lib/libmbedtls.so
+lib/libmbedtls.so.8
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
%%PORTDOCS%%%%DOCSDIR%%/README.rst
%%PORTDOCS%%%%DOCSDIR%%/LICENSE