aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorXin LI <delphij@FreeBSD.org>2013-05-22 22:51:57 +0000
committerXin LI <delphij@FreeBSD.org>2013-05-22 22:51:57 +0000
commit38fdae7228e6b133016903194a040a3942900d9e (patch)
tree51c434f39d2f53cd005831574a4f24262cf663f7 /security
parent4fa5971018975ef5283476fe4fb71973e00adee9 (diff)
downloadports-38fdae7228e6b133016903194a040a3942900d9e.tar.gz
ports-38fdae7228e6b133016903194a040a3942900d9e.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/cryptopp/Makefile3
-rw-r--r--security/cryptopp/distinfo4
-rw-r--r--security/cryptopp/files/patch-GNUmakefile25
-rw-r--r--security/cryptopp/files/patch-clang97
-rw-r--r--security/cryptopp/pkg-plist1
5 files changed, 10 insertions, 120 deletions
diff --git a/security/cryptopp/Makefile b/security/cryptopp/Makefile
index d40343d8df74..b6594a09046c 100644
--- a/security/cryptopp/Makefile
+++ b/security/cryptopp/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= cryptopp
-PORTVERSION= 5.6.1
-PORTREVISION= 3
+PORTVERSION= 5.6.2
CATEGORIES= security
MASTER_SITES= SF \
http://www.cryptopp.com/
diff --git a/security/cryptopp/distinfo b/security/cryptopp/distinfo
index 560a716d272f..d36d9202e804 100644
--- a/security/cryptopp/distinfo
+++ b/security/cryptopp/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cryptopp561.zip) = 98e74d8cb17a38033354519ac8ba9c5d98a6dc00bf5d1ec3c533c2e8ec86f268
-SIZE (cryptopp561.zip) = 1069703
+SHA256 (cryptopp562.zip) = 5cbfd2fcb4a6b3aab35902e2e0f3b59d9171fee12b3fc2b363e1801dfec53574
+SIZE (cryptopp562.zip) = 1137964
diff --git a/security/cryptopp/files/patch-GNUmakefile b/security/cryptopp/files/patch-GNUmakefile
index 61a065dc0425..1a8d60ec4520 100644
--- a/security/cryptopp/files/patch-GNUmakefile
+++ b/security/cryptopp/files/patch-GNUmakefile
@@ -1,30 +1,17 @@
---- ./GNUmakefile.orig 2010-08-09 14:22:42.000000000 -0700
-+++ ./GNUmakefile 2012-07-21 03:14:01.000000000 +0200
+--- GNUmakefile.orig 2013-02-20 15:30:52.000000000 -0800
++++ GNUmakefile 2013-05-22 15:43:40.000000000 -0700
@@ -1,4 +1,4 @@
-CXXFLAGS = -DNDEBUG -g -O2
+#CXXFLAGS = -DNDEBUG -g -O2
- #CXXFLAGS = -g
+ # -O3 fails to link on Cygwin GCC version 4.5.3
# -fPIC is supported. Please report any breakage of -fPIC as a bug.
# CXXFLAGS += -fPIC
-@@ -28,9 +28,9 @@
- INTEL_COMPILER = $(shell $(CXX) --version 2>&1 | $(EGREP) -c "\(ICC\)")
- ICC111_OR_LATER = $(shell $(CXX) --version 2>&1 | $(EGREP) -c "\(ICC\) ([2-9][0-9]|1[2-9]|11\.[1-9])")
- IS_SUN_CC = $(shell $(CXX) -V 2>&1 | $(EGREP) -c "CC: Sun")
--GAS210_OR_LATER = $(shell echo "" | $(AS) -v 2>&1 | $(EGREP) -c "GNU assembler version (2\.[1-9][0-9]|[3-9])")
--GAS217_OR_LATER = $(shell echo "" | $(AS) -v 2>&1 | $(EGREP) -c "GNU assembler version (2\.1[7-9]|2\.[2-9]|[3-9])")
--GAS219_OR_LATER = $(shell echo "" | $(AS) -v 2>&1 | $(EGREP) -c "GNU assembler version (2\.19|2\.[2-9]|[3-9])")
-+GAS210_OR_LATER = $(shell echo "" | $(CXX) -xc -c -Wa,-v -o/dev/null - 2>&1 | $(EGREP) -c "GNU assembler version (2\.[1-9][0-9]|[3-9])")
-+GAS217_OR_LATER = $(shell echo "" | $(CXX) -xc -c -Wa,-v -o/dev/null - 2>&1 | $(EGREP) -c "GNU assembler version (2\.1[7-9]|2\.[2-9]|[3-9])")
-+GAS219_OR_LATER = $(shell echo "" | $(CXX) -xc -c -Wa,-v -o/dev/null - 2>&1 | $(EGREP) -c "GNU assembler version (2\.19|2\.[2-9]|[3-9])")
- ISMINGW = $(shell $(CXX) --version 2>&1 | $(EGREP) -c "mingw")
-
- ifneq ($(GCC42_OR_LATER),0)
-@@ -151,7 +151,7 @@
- $(RANLIB) $@
+@@ -165,7 +165,7 @@
+ $(RANLIB) $@
libcryptopp.so: $(LIBOBJS)
- $(CXX) -shared -o $@ $(LIBOBJS)
+ $(CXX) -shared -o $@ $(CXXFLAGS) $(LDFLAGS) $(LIBOBJS)
cryptest.exe: libcryptopp.a $(TESTOBJS)
- $(CXX) -o $@ $(CXXFLAGS) $(TESTOBJS) -L. -lcryptopp $(LDFLAGS) $(LDLIBS)
+ $(CXX) -o $@ $(CXXFLAGS) $(TESTOBJS) ./libcryptopp.a $(LDFLAGS) $(LDLIBS)
diff --git a/security/cryptopp/files/patch-clang b/security/cryptopp/files/patch-clang
deleted file mode 100644
index 3616eab98d3a..000000000000
--- a/security/cryptopp/files/patch-clang
+++ /dev/null
@@ -1,97 +0,0 @@
---- ./algebra.cpp.orig 2010-08-06 18:44:32.000000000 -0700
-+++ ./algebra.cpp 2011-09-06 12:55:41.351288757 -0700
-@@ -58,7 +58,7 @@
- Element g[3]={b, a};
- unsigned int i0=0, i1=1, i2=2;
-
-- while (!Equal(g[i1], this->Identity()))
-+ while (!this->Equal(g[i1], this->Identity()))
- {
- g[i2] = Mod(g[i0], g[i1]);
- unsigned int t = i0; i0 = i1; i1 = i2; i2 = t;
---- ./eccrypto.cpp.orig 2010-08-06 18:44:28.000000000 -0700
-+++ ./eccrypto.cpp 2011-09-06 12:55:41.355150164 -0700
-@@ -435,7 +435,7 @@
- StringSource ssG(param.g, true, new HexDecoder);
- Element G;
- bool result = GetCurve().DecodePoint(G, ssG, (size_t)ssG.MaxRetrievable());
-- SetSubgroupGenerator(G);
-+ this->SetSubgroupGenerator(G);
- assert(result);
-
- StringSource ssN(param.n, true, new HexDecoder);
-@@ -591,7 +591,7 @@
- if (level >= 2 && pass)
- {
- const Integer &q = GetSubgroupOrder();
-- Element gq = gpc ? gpc->Exponentiate(this->GetGroupPrecomputation(), q) : ExponentiateElement(g, q);
-+ Element gq = gpc ? gpc->Exponentiate(this->GetGroupPrecomputation(), q) : this->ExponentiateElement(g, q);
- pass = pass && IsIdentity(gq);
- }
- return pass;
-@@ -629,7 +629,7 @@
- typename EC::Point P;
- if (!this->GetGroupParameters().GetCurve().DecodePoint(P, bt, size))
- BERDecodeError();
-- SetPublicElement(P);
-+ this->SetPublicElement(P);
- }
-
- template <class EC>
---- ./eccrypto.h.orig 2010-08-06 18:46:24.000000000 -0700
-+++ ./eccrypto.h 2011-09-06 12:55:41.355150164 -0700
-@@ -43,7 +43,7 @@
- void Initialize(const EllipticCurve &ec, const Point &G, const Integer &n, const Integer &k = Integer::Zero())
- {
- this->m_groupPrecomputation.SetCurve(ec);
-- SetSubgroupGenerator(G);
-+ this->SetSubgroupGenerator(G);
- m_n = n;
- m_k = k;
- }
-@@ -145,9 +145,9 @@
- typedef typename EC::Point Element;
-
- void Initialize(const DL_GroupParameters_EC<EC> &params, const Element &Q)
-- {this->AccessGroupParameters() = params; SetPublicElement(Q);}
-+ {this->AccessGroupParameters() = params; this->SetPublicElement(Q);}
- void Initialize(const EC &ec, const Element &G, const Integer &n, const Element &Q)
-- {this->AccessGroupParameters().Initialize(ec, G, n); SetPublicElement(Q);}
-+ {this->AccessGroupParameters().Initialize(ec, G, n); this->SetPublicElement(Q);}
-
- // X509PublicKey
- void BERDecodePublicKey(BufferedTransformation &bt, bool parametersPresent, size_t size);
-@@ -166,9 +166,9 @@
- void Initialize(const EC &ec, const Element &G, const Integer &n, const Integer &x)
- {this->AccessGroupParameters().Initialize(ec, G, n); this->SetPrivateExponent(x);}
- void Initialize(RandomNumberGenerator &rng, const DL_GroupParameters_EC<EC> &params)
-- {GenerateRandom(rng, params);}
-+ {this->GenerateRandom(rng, params);}
- void Initialize(RandomNumberGenerator &rng, const EC &ec, const Element &G, const Integer &n)
-- {GenerateRandom(rng, DL_GroupParameters_EC<EC>(ec, G, n));}
-+ {this->GenerateRandom(rng, DL_GroupParameters_EC<EC>(ec, G, n));}
-
- // PKCS8PrivateKey
- void BERDecodePrivateKey(BufferedTransformation &bt, bool parametersPresent, size_t size);
---- ./panama.cpp.orig 2010-08-09 14:22:42.000000000 -0700
-+++ ./panama.cpp 2011-09-06 12:55:41.356148062 -0700
-@@ -422,7 +422,7 @@
- {
- this->ThrowIfInvalidTruncatedSize(size);
-
-- PadLastBlock(this->BLOCKSIZE, 0x01);
-+ this->PadLastBlock(this->BLOCKSIZE, 0x01);
-
- HashEndianCorrectedBlock(this->m_data);
-
---- ./secblock.h.orig 2010-08-06 18:46:20.000000000 -0700
-+++ ./secblock.h 2011-09-06 12:55:41.357147916 -0700
-@@ -88,7 +88,7 @@
-
- pointer allocate(size_type n, const void * = NULL)
- {
-- CheckSize(n);
-+ this->CheckSize(n);
- if (n == 0)
- return NULL;
-
diff --git a/security/cryptopp/pkg-plist b/security/cryptopp/pkg-plist
index 09235ff8da32..dc0537f4b721 100644
--- a/security/cryptopp/pkg-plist
+++ b/security/cryptopp/pkg-plist
@@ -103,6 +103,7 @@ include/cryptopp/seed.h
include/cryptopp/serpent.h
include/cryptopp/serpentp.h
include/cryptopp/sha.h
+include/cryptopp/sha3.h
include/cryptopp/shacal2.h
include/cryptopp/shark.h
include/cryptopp/simple.h