aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2020-05-12 19:26:45 +0000
committerRene Ladan <rene@FreeBSD.org>2020-05-12 19:26:45 +0000
commit69044e296e5c212c85fb1d5f9c0670e5fc030019 (patch)
treef8aafb2052c6c0d4b23240dfaf3583a1206f3c34 /security
parent4513acba3f956a82426686af2b28b1cc3e2f917c (diff)
Notes
Diffstat (limited to 'security')
-rw-r--r--security/pwauth/Makefile7
-rw-r--r--security/pwauth/files/patch-checkfaillog.c11
-rw-r--r--security/pwauth/files/patch-config.h8
-rw-r--r--security/pwauth/files/patch-fail__check.c11
-rw-r--r--security/pwauth/files/patch-pwauth.h11
-rw-r--r--security/pwauth/files/patch-utmpx33
6 files changed, 35 insertions, 46 deletions
diff --git a/security/pwauth/Makefile b/security/pwauth/Makefile
index 627ab4fdd2b1..f6059eef4764 100644
--- a/security/pwauth/Makefile
+++ b/security/pwauth/Makefile
@@ -4,15 +4,12 @@
PORTNAME= pwauth
PORTVERSION= 2.3.11
CATEGORIES= security www
-MASTER_SITES= http://www.unixpapa.com/software/
+MASTER_SITES= http://www.unixpapa.com/software/ \
+ https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/pwauth/
MAINTAINER= eg@fbsd.lt
COMMENT= Unix Web Authenticator
-BROKEN= unfetchable
-DEPRECATED= Broken for more than 6 months
-EXPIRATION_DATE= 2020-05-05
-
LICENSE= BSD3CLAUSE
PLIST_FILES= "@(,,4555) bin/pwauth" \
diff --git a/security/pwauth/files/patch-checkfaillog.c b/security/pwauth/files/patch-checkfaillog.c
index 320a51faf92a..a04fd035ebf6 100644
--- a/security/pwauth/files/patch-checkfaillog.c
+++ b/security/pwauth/files/patch-checkfaillog.c
@@ -1,10 +1,13 @@
---- checkfaillog.c.orig 2012-02-11 13:22:09.000000000 +0200
-+++ checkfaillog.c 2012-02-11 13:22:42.000000000 +0200
-@@ -32,6 +32,7 @@
+--- checkfaillog.c.orig 2020-04-11 16:27:51 UTC
++++ checkfaillog.c
+@@ -32,8 +32,9 @@
*/
#include <stdio.h>
+#include <stdlib.h>
#include <sys/types.h>
- #include <utmp.h>
+-#include <utmp.h>
++#include <utmpx.h>
#include <pwd.h>
+
+ #include "config.h"
diff --git a/security/pwauth/files/patch-config.h b/security/pwauth/files/patch-config.h
index 5a56d6bd5a6b..0d29f5da912b 100644
--- a/security/pwauth/files/patch-config.h
+++ b/security/pwauth/files/patch-config.h
@@ -1,5 +1,5 @@
---- config.h.orig 2012-02-11 15:52:24.000000000 +0200
-+++ config.h 2012-02-11 15:52:06.000000000 +0200
+--- config.h.orig 2013-10-04 13:59:08 UTC
++++ config.h
@@ -123,7 +123,7 @@
/* #define SHADOW_NONE /**/
@@ -29,7 +29,7 @@
/* If NOLOGIN_FILE is defined to the full path name of a file, then the
-@@ -278,7 +278,7 @@
+@@ -279,7 +279,7 @@
* to change the uid list.
*/
@@ -38,7 +38,7 @@
/* If MIN_UNIX_UID is defined to an integer, logins with uid numbers less than
-@@ -290,7 +290,7 @@
+@@ -291,7 +291,7 @@
* given value will be accepted).
*/
diff --git a/security/pwauth/files/patch-fail__check.c b/security/pwauth/files/patch-fail__check.c
new file mode 100644
index 000000000000..6965a6145777
--- /dev/null
+++ b/security/pwauth/files/patch-fail__check.c
@@ -0,0 +1,11 @@
+--- fail_check.c.orig 2020-04-11 16:28:08 UTC
++++ fail_check.c
+@@ -35,7 +35,7 @@
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <fcntl.h>
+-#include <utmp.h>
++#include <utmpx.h>
+
+ #include "config.h"
+ #include "fail_log.h"
diff --git a/security/pwauth/files/patch-pwauth.h b/security/pwauth/files/patch-pwauth.h
new file mode 100644
index 000000000000..39242895b7e7
--- /dev/null
+++ b/security/pwauth/files/patch-pwauth.h
@@ -0,0 +1,11 @@
+--- pwauth.h.orig 2020-04-11 16:28:30 UTC
++++ pwauth.h
+@@ -73,7 +73,7 @@
+
+ #ifdef UNIX_LASTLOG
+ # define NEED_UID
+-# include <utmp.h>
++# include <utmpx.h>
+ # ifdef HAVE_LASTLOG_H
+ # include <lastlog.h>
+ # endif
diff --git a/security/pwauth/files/patch-utmpx b/security/pwauth/files/patch-utmpx
deleted file mode 100644
index eef7e8e9b3a5..000000000000
--- a/security/pwauth/files/patch-utmpx
+++ /dev/null
@@ -1,33 +0,0 @@
---- checkfaillog.c.orig 2012-02-11 13:18:31.000000000 +0200
-+++ checkfaillog.c 2012-02-11 13:18:50.000000000 +0200
-@@ -33,7 +33,7 @@
-
- #include <stdio.h>
- #include <sys/types.h>
--#include <utmp.h>
-+#include <utmpx.h>
- #include <pwd.h>
-
- #include "config.h"
---- fail_check.c.orig 2012-02-11 13:18:36.000000000 +0200
-+++ fail_check.c 2012-02-11 13:18:59.000000000 +0200
-@@ -35,7 +35,7 @@
- #include <sys/types.h>
- #include <sys/stat.h>
- #include <fcntl.h>
--#include <utmp.h>
-+#include <utmpx.h>
-
- #include "config.h"
- #include "fail_log.h"
---- pwauth.h.orig 2012-02-11 13:18:41.000000000 +0200
-+++ pwauth.h 2012-02-11 13:19:08.000000000 +0200
-@@ -71,7 +71,7 @@
-
- #ifdef UNIX_LASTLOG
- # define NEED_UID
--# include <utmp.h>
-+# include <utmpx.h>
- # ifdef HAVE_LASTLOG_H
- # include <lastlog.h>
- # endif