aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2012-06-19 01:38:09 +0000
committerWesley Shields <wxs@FreeBSD.org>2012-06-19 01:38:09 +0000
commit705825bd697394b595d37e7dbfc2fb57d79aab09 (patch)
tree867e5cddc73505579b81a6b9ce1996584ffba5aa /security
parent6953a3bf20f887e75fcf03dd9cca7d35ffabcff5 (diff)
downloadports-705825bd697394b595d37e7dbfc2fb57d79aab09.tar.gz
ports-705825bd697394b595d37e7dbfc2fb57d79aab09.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/sudo/Makefile47
1 files changed, 28 insertions, 19 deletions
diff --git a/security/sudo/Makefile b/security/sudo/Makefile
index 399afad64560..a876fe50b45f 100644
--- a/security/sudo/Makefile
+++ b/security/sudo/Makefile
@@ -29,19 +29,30 @@ CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc \
--with-long-otp-prompt \
--with-pam
-OPTIONS= LDAP "With LDAP support" off \
- INSULTS "With all insults" off \
- DISABLE_ROOT_SUDO "Disable root sudo" off \
- DISABLE_AUTH "Disable authentication" off \
- NOARGS_SHELL "Enable no arguments shell" off \
- AUDIT "Enable BSM audit support" on
+OPTIONS_DEFINE= LDAP INSULTS DISABLE_ROOT_SUDO DISABLE_AUTH NOARGS_SHELL \
+ AUDIT OPIE NLS
+OPTIONS_DEFAULT= AUDIT NLS
+
+INSULT_DESC= Enable insults on failures
+DISABLE_ROOT_SUDO_DESC= Do not allow root to run sudo
+DISABLE_AUTH_DESC= Do not require authentication by default
+NOARGS_SHELL_DESC= Run a shell if no arguments are given
+AUDIT_DESC= Enable BSM audit support
+OPIE_DESC= Enable one-time passwords
LOGFAC?= local2
CONFIGURE_ARGS+= --with-logfac=${LOGFAC}
+# This is intentionally not an option.
+# SUDO_SECURE_PATH is a PATH string that will override the user's PATH.
+# ex: make SUDO_SECURE_PATH="/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin"
+.if defined(SUDO_SECURE_PATH)
+CONFIGURE_ARGS+= --with-secure-path="${SUDO_SECURE_PATH}"
+.endif
+
.include <bsd.port.options.mk>
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
LDFLAGS+= -L${LOCALBASE}/lib -lintl
CFLAGS+= -I${LOCALBASE}/include
@@ -51,18 +62,12 @@ CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= NLS="@comment "
.endif
-# SUDO_SECURE_PATH is a PATH string that will override the user's PATH.
-# ex: make SUDO_SECURE_PATH="/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin"
-.if defined(SUDO_SECURE_PATH)
-CONFIGURE_ARGS+= --with-secure-path="${SUDO_SECURE_PATH}"
-.endif
-
-.if defined(WITH_INSULTS)
+.if ${PORT_OPTIONS:MINSULTS}
CONFIGURE_ARGS+= --with-insults
CONFIGURE_ARGS+= --with-all-insults
.endif
-.if defined(WITH_LDAP)
+.if ${PORT_OPTIONS:MLDAP}
USE_OPENLDAP= yes
CONFIGURE_ARGS+= --with-ldap=${PREFIX}
SUDO_LDAP_CONF?= ldap.conf
@@ -73,22 +78,26 @@ MAN5+= sudoers.ldap.5
PLIST_SUB+= LDAP="@comment "
.endif
-.if defined(WITH_DISABLE_ROOT_SUDO)
+.if ${PORT_OPTIONS:MDISABLE_ROOT_SUDO}
CONFIGURE_ARGS+=--disable-root-sudo
.endif
-.if defined(WITH_DISABLE_AUTH)
+.if ${PORT_OPTIONS:MDISABLE_AUTH}
CONFIGURE_ARGS+=--disable-authentication
.endif
-.if defined(WITH_NOARGS_SHELL)
+.if ${PORT_OPTIONS:MNOARGS_SHELL}
CONFIGURE_ARGS+=--enable-noargs-shell
.endif
-.if defined(WITH_AUDIT)
+.if ${PORT_OPTIONS:MAUDIT}
CONFIGURE_ARGS+=--with-bsm-audit
.endif
+.if ${PORT_OPTIONS:MOPIE}
+CONFIGURE_ARGS+=--with-opie
+.endif
+
MAN5+= sudoers.5
MAN8= sudo.8 visudo.8 sudoreplay.8 sudo_plugin.8
MLINKS= sudo.8 sudoedit.8