aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorBartek Rutkowski <robak@FreeBSD.org>2015-03-16 10:52:01 +0000
committerBartek Rutkowski <robak@FreeBSD.org>2015-03-16 10:52:01 +0000
commitb5bac9f80f2617e3ab023615a8add89f7c5c16ac (patch)
tree7db80273752eff92e309cc5af8ef3f869932ac19 /security
parent363f7960c70045fb3c8d9ba1d450665d426fc422 (diff)
downloadports-b5bac9f80f2617e3ab023615a8add89f7c5c16ac.tar.gz
ports-b5bac9f80f2617e3ab023615a8add89f7c5c16ac.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/p5-openxpki/Makefile5
-rw-r--r--security/p5-openxpki/distinfo4
-rw-r--r--security/p5-openxpki/pkg-plist7
3 files changed, 11 insertions, 5 deletions
diff --git a/security/p5-openxpki/Makefile b/security/p5-openxpki/Makefile
index bfba0ae6beaf..4a2f6819f3df 100644
--- a/security/p5-openxpki/Makefile
+++ b/security/p5-openxpki/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= openxpki
-PORTVERSION= 0.26.1.1
+PORTVERSION= 0.27.0.1
CATEGORIES= security perl5
PKGNAMEPREFIX= p5-
DIST_SUBDIR= ${PORTNAME}
@@ -73,7 +73,7 @@ CONFLICTS= \
USE_GITHUB= yes
GH_TAGNAME= ${GH_COMMIT}
-GH_COMMIT= 9bd1fea
+GH_COMMIT= 5a4c5eb
USE_OPENSSL= yes
USE_PERL5= configure
@@ -86,7 +86,6 @@ WRKSRC= ${WRKDIR}/${GH_ACCOUNT}-${GH_PROJECT}-${GH_COMMIT}/core/server
USERS= openxpki
GROUPS= openxpki
-NO_ARCH= yes
OPTIONS_DEFINE= GRAPHVIZ DOCS
diff --git a/security/p5-openxpki/distinfo b/security/p5-openxpki/distinfo
index c2972cd0bdd8..0875e42a2959 100644
--- a/security/p5-openxpki/distinfo
+++ b/security/p5-openxpki/distinfo
@@ -1,2 +1,2 @@
-SHA256 (openxpki/openxpki-0.26.1.1.tar.gz) = 4bc3cefeafa23e002f763278dd48a21d31ce583221c4e8072cbf46206804d583
-SIZE (openxpki/openxpki-0.26.1.1.tar.gz) = 2048267
+SHA256 (openxpki/openxpki-0.27.0.1.tar.gz) = f604615bec19ed4ecc56d6d14803e70aea7e15ebb04dd8ca9dba59bdd70d46bc
+SIZE (openxpki/openxpki-0.27.0.1.tar.gz) = 2094176
diff --git a/security/p5-openxpki/pkg-plist b/security/p5-openxpki/pkg-plist
index 68fd3cfb84d1..cd834a673c0f 100644
--- a/security/p5-openxpki/pkg-plist
+++ b/security/p5-openxpki/pkg-plist
@@ -20,6 +20,7 @@ bin/openxpkictl
%%SITE_ARCH%%/OpenXPKI/Client/UI/Profile.pm
%%SITE_ARCH%%/OpenXPKI/Client/UI/Result.pm
%%SITE_ARCH%%/OpenXPKI/Client/UI/Secret.pm
+%%SITE_ARCH%%/OpenXPKI/Client/UI/Source.pm
%%SITE_ARCH%%/OpenXPKI/Client/UI/Workflow.pm
%%SITE_ARCH%%/OpenXPKI/Config.pm
%%SITE_ARCH%%/OpenXPKI/Config/Backend.pm
@@ -344,6 +345,7 @@ bin/openxpkictl
%%PERL5_MAN3%%/OpenXPKI::Client::UI::Home.3.gz
%%PERL5_MAN3%%/OpenXPKI::Client::UI::Information.3.gz
%%PERL5_MAN3%%/OpenXPKI::Client::UI::Result.3.gz
+%%PERL5_MAN3%%/OpenXPKI::Client::UI::Source.3.gz
%%PERL5_MAN3%%/OpenXPKI::Client::UI::Workflow.3.gz
%%PERL5_MAN3%%/OpenXPKI::Config.3.gz
%%PERL5_MAN3%%/OpenXPKI::Config::Backend.3.gz
@@ -727,6 +729,7 @@ man/man1/openxpkictl.1.gz
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/config.d/realm/ca-one/workflow/def/change_metadata.yaml
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/config.d/realm/ca-one/workflow/def/crl_issuance.yaml
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/config.d/realm/ca-one/workflow/def/enrollment.yaml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/config.d/realm/ca-one/workflow/global/action/cancel.yaml
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/config.d/realm/ca-one/workflow/global/action/check_for_revocation.yaml
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/config.d/realm/ca-one/workflow/global/action/disconnect.yaml
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/config.d/realm/ca-one/workflow/global/action/nice_fetch_certificate.yaml
@@ -736,9 +739,13 @@ man/man1/openxpkictl.1.gz
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/config.d/realm/ca-one/workflow/global/action/noop.yaml
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/config.d/realm/ca-one/workflow/global/action/noop2.yaml
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/config.d/realm/ca-one/workflow/global/action/skip.yaml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/config.d/realm/ca-one/workflow/global/condition/is_batch_mode.yaml
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/config.d/realm/ca-one/workflow/global/field/cert_identifier.yaml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/config.d/realm/ca-one/workflow/global/field/cert_subject.yaml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/config.d/realm/ca-one/workflow/global/field/cert_subject_alt_name.yaml
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/config.d/realm/ca-one/workflow/global/field/comment.yaml
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/config.d/realm/ca-one/workflow/global/field/email.yaml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/config.d/realm/ca-one/workflow/global/field/flag_batch_mode.yaml
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/config.d/realm/ca-one/workflow/global/field/invalidity_time.yaml
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/config.d/realm/ca-one/workflow/global/field/notafter.yaml
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/config.d/realm/ca-one/workflow/global/field/notbefore.yaml