aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2010-04-23 15:53:34 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2010-04-23 15:53:34 +0000
commitd111d16900ba8617e77a050fb56ea2d7b8a8a356 (patch)
treeb053a3cb6449405fccc081154e3eeb84812519fe /security
parent9dc8b611a5b09b846c90e4986efd921178a7c50c (diff)
downloadports-d111d16900ba8617e77a050fb56ea2d7b8a8a356.tar.gz
ports-d111d16900ba8617e77a050fb56ea2d7b8a8a356.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/php52-filter/Makefile14
-rw-r--r--security/php52-filter/files/patch-config.m425
-rw-r--r--security/php52-hash/Makefile14
4 files changed, 54 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index eea17b753e84..74c5161ff19e 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -630,6 +630,7 @@
SUBDIR += php5-mcrypt
SUBDIR += php5-openssl
SUBDIR += php52-filter
+ SUBDIR += php52-hash
SUBDIR += phpdeadlock
SUBDIR += phpmyid
SUBDIR += phpsecinfo
diff --git a/security/php52-filter/Makefile b/security/php52-filter/Makefile
new file mode 100644
index 000000000000..42a02c2e1012
--- /dev/null
+++ b/security/php52-filter/Makefile
@@ -0,0 +1,14 @@
+# New ports collection makefile for: php52-filter
+# Date created: 17 Apr 2010
+# Whom: Alex Keda <admin@lissyara.su>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= security
+
+MASTERDIR= ${.CURDIR}/../../lang/php52
+
+PKGNAMESUFFIX= -filter
+
+.include "${MASTERDIR}/Makefile"
diff --git a/security/php52-filter/files/patch-config.m4 b/security/php52-filter/files/patch-config.m4
new file mode 100644
index 000000000000..91aebe515ded
--- /dev/null
+++ b/security/php52-filter/files/patch-config.m4
@@ -0,0 +1,25 @@
+--- config.m4.orig 2009-03-06 08:25:45.000000000 +0100
++++ config.m4 2009-03-06 08:28:10.000000000 +0100
+@@ -19,7 +19,7 @@
+ CPPFLAGS=$INCLUDES
+ AC_EGREP_CPP(yes,[
+ #include <main/php_config.h>
+-#if defined(HAVE_BUNDLED_PCRE) && !defined(COMPILE_DL_PCRE)
++#if defined(HAVE_BUNDLED_PCRE)
+ yes
+ #endif
+ ],[
+@@ -27,11 +27,12 @@
+ ],[
+ AC_EGREP_CPP(yes,[
+ #include <main/php_config.h>
+-#if defined(HAVE_PCRE) && !defined(COMPILE_DL_PCRE)
++#if defined(HAVE_PCRE)
+ yes
+ #endif
+ ],[
+ PHP_PCRE_REGEX=pecl
++ PHP_ADD_INCLUDE($PHP_PCRE_DIR/include)
+ ],[
+ PHP_PCRE_REGEX=no
+ ])
diff --git a/security/php52-hash/Makefile b/security/php52-hash/Makefile
new file mode 100644
index 000000000000..11f6a504d6b3
--- /dev/null
+++ b/security/php52-hash/Makefile
@@ -0,0 +1,14 @@
+# New ports collection makefile for: php52-hash
+# Date created: 17 Apr 2010
+# Whom: Alex Keda <admin@lissyara.su>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= security
+
+MASTERDIR= ${.CURDIR}/../../lang/php52
+
+PKGNAMESUFFIX= -hash
+
+.include "${MASTERDIR}/Makefile"