aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2020-08-09 01:58:36 +0000
committerCy Schubert <cy@FreeBSD.org>2020-08-09 01:58:36 +0000
commitfb1833c45f0efd9bd735c5f882c7e022735489b5 (patch)
tree03d09ad26dd38cc3cb1d021281d8fd101ad83342 /security
parent138464f2fa8eca6cdf5e36bfc8416797e4d1a7ea (diff)
downloadports-fb1833c45f0efd9bd735c5f882c7e022735489b5.tar.gz
ports-fb1833c45f0efd9bd735c5f882c7e022735489b5.zip
MFH: r544301
Update to the latest Christos Zoulas commit on github (202000801). Fixes 13-CURRENT build errors. Additional change required to fixup pkg-plist was to move rc.d files to their proper location. Approved by: portmgr (joneum)
Notes
Notes: svn path=/branches/2020Q3/; revision=544538
Diffstat (limited to 'security')
-rw-r--r--security/racoon2/Makefile52
-rw-r--r--security/racoon2/distinfo6
-rw-r--r--security/racoon2/files/patch-Makefile.am10
-rw-r--r--security/racoon2/files/patch-configure19
-rw-r--r--security/racoon2/files/patch-configure.ac34
-rw-r--r--security/racoon2/files/patch-kinkd-Makefile.in36
-rw-r--r--security/racoon2/files/patch-lib-cftoken.l11
-rw-r--r--security/racoon2/files/patch-pskgen-Makefile.in11
-rw-r--r--security/racoon2/files/patch-samples-rc.d-iked.in27
-rw-r--r--security/racoon2/files/patch-samples-rc.d-kinkd.in15
-rw-r--r--security/racoon2/files/patch-samples-rc.d-spmd.in14
-rw-r--r--security/racoon2/files/patch-samples_Makefile.am11
-rw-r--r--security/racoon2/files/patch-samples_Makefile.in33
-rw-r--r--security/racoon2/files/patch-samples_hook_Makefile.in45
-rw-r--r--security/racoon2/files/patch-samples_hook_child-down.d_Makefile.in17
-rw-r--r--security/racoon2/files/patch-samples_hook_child-up.d_Makefile.in19
-rw-r--r--security/racoon2/files/patch-samples_hook_ikesa-up.d_Makefile.in13
-rw-r--r--security/racoon2/files/patch-samples_init.d_Makefile.am8
-rw-r--r--security/racoon2/files/patch-samples_rc.d_Makefile.am9
-rw-r--r--security/racoon2/files/patch-samples_rc.d_Makefile.in19
-rw-r--r--security/racoon2/files/patch-spmd-Makefile.in89
-rw-r--r--security/racoon2/pkg-plist13
22 files changed, 88 insertions, 423 deletions
diff --git a/security/racoon2/Makefile b/security/racoon2/Makefile
index 8562c474a2cc..3cd20f6865d9 100644
--- a/security/racoon2/Makefile
+++ b/security/racoon2/Makefile
@@ -3,10 +3,9 @@
PORTNAME= racoon2
PORTVERSION= ${RACOON2_COMMIT_DATE}
-PORTREVISION= 1
CATEGORIES= security net
-HASH= 5c4af73
-RACOON2_COMMIT_DATE=20181215
+HASH= f96b7ab
+RACOON2_COMMIT_DATE=202000801
MAINTAINER= cy@FreeBSD.org
COMMENT= Racoon2 IPsec daemon
@@ -19,50 +18,20 @@ USE_GITHUB= yes
GH_ACCOUNT= zoulasc
GH_TAGNAME= ${HASH}
-USES= autoreconf:build perl5 tar:tgz ssl
+USES= autoreconf libtool:build perl5 tar:tgz ssl
CONFIGURE_ARGS+= --enable-natt \
- --prefix=${PREFIX}
+ --prefix=${STAGEDIR}/${PREFIX}
GNU_CONFIGURE= yes
-CONFIGURE_ENV= YACC=/usr/bin/yacc perl_bindir=${LOCALBASE}/bin/perl5
+CONFIGURE_ENV= YACC=/usr/bin/yacc perl_bindir=${LOCALBASE}/bin/perl5 \
+ STAGEDIR=${STAGEDIR} PREFIX=${PREFIX}
-# MAKE_ENV= DESTDIR=${DESTDIR}
+MAKE_ENV= STAGEDIR=${STAGEDIR} PREFIX=${PREFIX}
CFLAGS= -DHAVE_CONFIG_H
OPTIONS_DEFINE= DOCS
-OPTIONS_DEFAULT= DOCS NO_KRB
-OPTIONS_SINGLE= KERBEROS
-OPTIONS_SINGLE_KERBEROS= NO_KRB KRB5 HEIMDAL_PORT HEIMDAL_BASE
-NO_KRB_DESC= No Kerberos support
-KRB5_DESC= Build with Kerberos (security/krb5)
-HEIMDAL_PORT_DESC= Build with Heimdal in ports (security/heimdal)
-HEIMDAL_BASE_DESC= Build with Heimdal in base
-
-NO_KRB_CONFIGURE_ON= --disable-kinkd
-NO_KRB_MAKE_ENV= WITH_KINK=no
-NO_KRB_PLIST_SUB= KINK="@comment "
-NO_KRB_VARS= KINK=no
-
-KRB5_USES= gssapi:mit
-KRB5_CONFIGURE_ON= --enable-kinkd
-KRB5_MAKE_ENV= WITH_KINK=yes
-KRB5_PLIST_SUB= KINK=""
-KRB5_LIB_DEPENDS= libkrb5support.so:security/krb5
-KRB5_RUN_DEPENDS= kinit:security/krb5
-KRB5_VARS= KINK=yes
-
-HEIMDAL_PORT_USES= gssapi:heimdal
-HEIMDAL_PORT_CONFIGURE_ON= --enable-kinkd
-HEIMDAL_PORT_MAKE_ENV= WITH_KINK=yes
-HEIMDAL_PORT_PLIST_SUB= KINK=""
-HEIMDAL_PORT_VARS= KINK=yes
-
-HEIMDAL_BASE_USES= gssapi:base
-HEIMDAL_BASE_CONFIGURE_ON= --enable-kinkd
-HEIMDAL_BASE_MAKE_ENV= WITH_KINK=yes
-HEIMDAL_BASE_PLIST_SUB= KINK=""
-HEIMDAL_BASE_VARS= KINK=yes
+OPTIONS_DEFAULT= DOCS
.include <bsd.port.options.mk>
@@ -70,15 +39,12 @@ HEIMDAL_BASE_VARS= KINK=yes
PORTDOCS+= INSTALL USAGE config-usage.ja.txt config-usage.txt
PORTDOCS+= iked-memo.ja.txt libracoon.ja.txt specification.ja.txt
PORTDOCS+= spmif.txt style.txt system-message.ja.txt
-.if defined(KINK)
-PORTDOCS+= kinkd-data-struct.obj kinkd-impl.ja.txt
-PORTDOCS+= kinkd-install.ja.txt kinkd-state-txn.obj
-.endif
.endif
post-patch:
# @${REINPLACE_CMD} 's|/var/run/racoon2|$$(STAGEDIR)&|' \
${WRKSRC}/samples/Makefile.in
+ ${REINPLACE_CMD} 's|$$(sysconfdir)|${STAGEDIR}/${PREFIX}/etc|' ${WRKSRC}/samples/rc.d/Makefile.am
@${LN} -sf ${LOCALBASE}/share/automake-1.16/ylwrap ${WRKSRC}/lib
post-patch-DOCS-on:
diff --git a/security/racoon2/distinfo b/security/racoon2/distinfo
index 9abd99624c9e..2f2f31e159a1 100644
--- a/security/racoon2/distinfo
+++ b/security/racoon2/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1539958190
-SHA256 (zoulasc-racoon2-20181215-5c4af73_GH0.tar.gz) = 9cce3857e0c16e284d2b4141ff2e6a3acf11f8401536a258bd9a1bec484bedb3
-SIZE (zoulasc-racoon2-20181215-5c4af73_GH0.tar.gz) = 1365031
+TIMESTAMP = 1596656478
+SHA256 (zoulasc-racoon2-202000801-f96b7ab_GH0.tar.gz) = 4742aeeadbc40db4a6a7cd7440295514f38b3169b5854eeb1460641fdb41040f
+SIZE (zoulasc-racoon2-202000801-f96b7ab_GH0.tar.gz) = 885762
diff --git a/security/racoon2/files/patch-Makefile.am b/security/racoon2/files/patch-Makefile.am
new file mode 100644
index 000000000000..bdbf0dc883b3
--- /dev/null
+++ b/security/racoon2/files/patch-Makefile.am
@@ -0,0 +1,10 @@
+--- Makefile.am.orig 2020-03-18 13:57:19.000000000 -0700
++++ Makefile.am 2020-06-29 12:53:16.217963000 -0700
+@@ -2,6 +2,6 @@
+
+ ACLOCAL_AMFLAGS = -I m4
+
+-SUBDIRS = lib spmd kinkd iked pskgen samples
++SUBDIRS = lib spmd iked pskgen samples
+
+
diff --git a/security/racoon2/files/patch-configure b/security/racoon2/files/patch-configure
deleted file mode 100644
index cf0943fe3d4b..000000000000
--- a/security/racoon2/files/patch-configure
+++ /dev/null
@@ -1,19 +0,0 @@
---- configure.orig 2018-08-15 21:36:53.000000000 -0700
-+++ configure 2018-10-19 07:12:40.370712000 -0700
-@@ -3740,7 +3740,7 @@
- netbsd*1.[56]*|netbsd*[2-9].*)
- startup_scripts=rc.d
- ;;
-- freebsd[5-9].*)
-+ freebsd[5-9].*|freebsd[1-4][0-9].*)
- startup_scripts=rc.d
- ;;
- *)
-@@ -5132,6 +5132,7 @@
- # CONFIG_SUBDIRS section.
- #
- if test "$no_recursion" != yes; then
-+ac_given_INSTALL="$INSTALL"
-
- # Remove --cache-file, --srcdir, and --disable-option-checking arguments
- # so they do not pile up.
diff --git a/security/racoon2/files/patch-configure.ac b/security/racoon2/files/patch-configure.ac
new file mode 100644
index 000000000000..273e50220e13
--- /dev/null
+++ b/security/racoon2/files/patch-configure.ac
@@ -0,0 +1,34 @@
+--- configure.ac.orig 2020-03-18 13:57:19.000000000 -0700
++++ configure.ac 2020-06-29 12:55:22.015784000 -0700
+@@ -16,7 +16,7 @@
+ AC_PROG_MAKE_SET
+ RC_IF_INSTALL_OPTS
+
+-AC_CONFIG_SUBDIRS([lib spmd iked kinkd])
++AC_CONFIG_SUBDIRS([lib spmd iked])
+
+ dnl Set the debug option by default for now.
+ AC_MSG_CHECKING(if --enable-debug option is specified)
+@@ -57,7 +57,7 @@
+ netbsd*1.[[56]]*|netbsd*[[2-9]].*)
+ startup_scripts=rc.d
+ ;;
+- freebsd[[5-9]].*)
++ freebsd*)
+ startup_scripts=rc.d
+ ;;
+ *)
+@@ -90,13 +90,11 @@
+ samples/hook/Makefile
+ samples/Makefile
+ samples/rc.d/iked
+- samples/rc.d/kinkd
+ samples/rc.d/racoon2
+ samples/rc.d/spmd
+ samples/rc.d/Makefile
+ samples/racoon2.conf
+ samples/init.d/iked
+- samples/init.d/kinkd
+ samples/init.d/spmd
+ samples/init.d/Makefile
+ samples/vals.conf])
diff --git a/security/racoon2/files/patch-kinkd-Makefile.in b/security/racoon2/files/patch-kinkd-Makefile.in
deleted file mode 100644
index 51598a007316..000000000000
--- a/security/racoon2/files/patch-kinkd-Makefile.in
+++ /dev/null
@@ -1,36 +0,0 @@
---- kinkd/Makefile.in.orig 2018-08-15 21:36:53.000000000 -0700
-+++ kinkd/Makefile.in 2018-12-15 13:47:35.410335000 -0800
-@@ -109,7 +109,7 @@
- PROGRAMS = $(sbin_PROGRAMS)
- am_kinkd_OBJECTS = main.$(OBJEXT) kink_fmt.$(OBJEXT) \
- kink_crypto.$(OBJEXT) bbkk_common.$(OBJEXT) \
-- bbkk_heimdal.$(OBJEXT) session.$(OBJEXT) base.$(OBJEXT) \
-+ bbkk_$(KRB5_TYPE).$(OBJEXT) session.$(OBJEXT) base.$(OBJEXT) \
- dpd.$(OBJEXT) peer.$(OBJEXT) handle.$(OBJEXT) \
- algorithm.$(OBJEXT) crypto_openssl.$(OBJEXT) oakley.$(OBJEXT) \
- ipsec_doi.$(OBJEXT) isakmp.$(OBJEXT) isakmp_quick.$(OBJEXT) \
-@@ -333,7 +333,7 @@
- top_builddir = @top_builddir@
- top_srcdir = @top_srcdir@
- kinkd_SOURCES = main.c \
-- kink_fmt.c kink_crypto.c bbkk_common.c bbkk_heimdal.c \
-+ kink_fmt.c kink_crypto.c bbkk_common.c bbkk_$(KRB5_TYPE).c \
- session.c base.c dpd.c peer.c handle.c \
- algorithm.c crypto_openssl.c oakley.c \
- ipsec_doi.c isakmp.c isakmp_quick.c isakmp_inf.c proposal.c \
-@@ -457,6 +457,7 @@
- @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/base.Po@am__quote@
- @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/bbkk_common.Po@am__quote@
- @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/bbkk_heimdal.Po@am__quote@
-+@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/bbkk_mit.Po@am__quote@
- @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/crypto_openssl.Po@am__quote@
- @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/dpd.Po@am__quote@
- @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/etchosts.Po@am__quote@
-@@ -902,3 +903,7 @@
- # Tell versions [3.59,3.63) of GNU make to not export all variables.
- # Otherwise a system limit (for SysV at least) may be exceeded.
- .NOEXPORT:
-+
-+# override default .c.o rule in case it doesn't include CPPFLAGS (FreeBSD)
-+.c.o:
-+ $(CC) -c $(CFLAGS) $(CPPFLAGS) -o $@ $<
diff --git a/security/racoon2/files/patch-lib-cftoken.l b/security/racoon2/files/patch-lib-cftoken.l
deleted file mode 100644
index ff592024978e..000000000000
--- a/security/racoon2/files/patch-lib-cftoken.l
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/cftoken.l.orig 2018-08-15 21:36:53.000000000 -0700
-+++ lib/cftoken.l 2018-10-19 12:15:39.256861000 -0700
-@@ -81,7 +81,7 @@
- if (cf_debug) { \
- fprintf(CF_ERRDEV, "%s:%d:%d[%s] len=%zu\n", \
- rcf_istk[rcf_istkp].path, rcf_istk[rcf_istkp].lineno, \
-- yy_start, yytext, yyleng); \
-+ yy_start, yytext, (int)yyleng); \
- }
- #else
- #define DP
diff --git a/security/racoon2/files/patch-pskgen-Makefile.in b/security/racoon2/files/patch-pskgen-Makefile.in
deleted file mode 100644
index dee94d5a3d14..000000000000
--- a/security/racoon2/files/patch-pskgen-Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- pskgen/Makefile.in.orig 2018-08-15 21:36:53.000000000 -0700
-+++ pskgen/Makefile.in 2018-12-19 23:35:20.908316000 -0800
-@@ -530,8 +530,6 @@
-
-
- install-exec-hook:
-- $(INSTALL) -d $(sysconfdir)
-- sh ./autogen.spmd.pwd
-
- # Tell versions [3.59,3.63) of GNU make to not export all variables.
- # Otherwise a system limit (for SysV at least) may be exceeded.
diff --git a/security/racoon2/files/patch-samples-rc.d-iked.in b/security/racoon2/files/patch-samples-rc.d-iked.in
deleted file mode 100644
index 8bad1a3d634b..000000000000
--- a/security/racoon2/files/patch-samples-rc.d-iked.in
+++ /dev/null
@@ -1,27 +0,0 @@
---- samples/rc.d/iked.in.orig 2018-08-15 22:36:53.000000000 -0600
-+++ samples/rc.d/iked.in 2019-05-09 08:03:55.095621000 -0600
-@@ -10,14 +10,22 @@
-
- . /etc/rc.subr
-
-+: ${iked_enable="NO"}
-+
- name="iked"
--rcvar=$name
-+rcvar=iked_enable
- command="@sbindir@/${name}"
- extra_commands="reload"
--required_vars="spmd"
-+required_vars="spmd_enable"
- pidfile="/var/run/${name}.pid"
- required_files="@sysconfdir@/racoon2.conf"
-+start_precmd="iked_precmd"
- reload_cmd="iked_reload"
-+
-+iked_precmd()
-+{
-+ sysctl -qn net.inet.ipsec.def_policy >/dev/null || kldload ipsec || return 1
-+}
-
- iked_reload()
- {
diff --git a/security/racoon2/files/patch-samples-rc.d-kinkd.in b/security/racoon2/files/patch-samples-rc.d-kinkd.in
deleted file mode 100644
index 70ab9e4a278b..000000000000
--- a/security/racoon2/files/patch-samples-rc.d-kinkd.in
+++ /dev/null
@@ -1,15 +0,0 @@
---- samples/rc.d/kinkd.in.orig 2005-10-28 15:33:16.000000000 +0900
-+++ samples/rc.d/kinkd.in 2008-04-17 15:11:55.000000000 +0900
-@@ -14,10 +14,10 @@
- exec_prefix=@exec_prefix@
-
- name="kinkd"
--rcvar=$name
-+rcvar=kinkd_enable
- command="@sbindir@/${name}"
- extra_commands="reload"
--required_vars="spmd"
-+required_vars="spmd_enable"
- pidfile="/var/run/${name}.pid"
- required_files="@sysconfdir@/racoon2.conf"
-
diff --git a/security/racoon2/files/patch-samples-rc.d-spmd.in b/security/racoon2/files/patch-samples-rc.d-spmd.in
deleted file mode 100644
index a39c5672aaae..000000000000
--- a/security/racoon2/files/patch-samples-rc.d-spmd.in
+++ /dev/null
@@ -1,14 +0,0 @@
---- samples/rc.d/spmd.in.orig 2018-08-15 21:36:53.000000000 -0700
-+++ samples/rc.d/spmd.in 2018-10-19 12:35:43.735681000 -0700
-@@ -9,8 +9,10 @@
-
- . /etc/rc.subr
-
-+: ${spmd_enable="NO"}
-+
- name="spmd"
--rcvar=$name
-+rcvar=spmd_enable
- command="@sbindir@/${name}"
- extra_commands="reload"
- pidfile="/var/run/${name}.pid"
diff --git a/security/racoon2/files/patch-samples_Makefile.am b/security/racoon2/files/patch-samples_Makefile.am
new file mode 100644
index 000000000000..017e00d5cc82
--- /dev/null
+++ b/security/racoon2/files/patch-samples_Makefile.am
@@ -0,0 +1,11 @@
+--- samples/Makefile.am.orig 2020-03-18 13:57:19.000000000 -0700
++++ samples/Makefile.am 2020-06-29 13:05:24.670094000 -0700
+@@ -13,8 +13,6 @@
+ $(INSTALL) -m 600 transport_ike.conf $(DESTDIR)$(sysconfdir)/transport_ike.conf.sample
+ $(INSTALL) -m 600 tunnel_ike.conf $(DESTDIR)$(sysconfdir)/tunnel_ike.conf.sample
+ $(INSTALL) -m 600 tunnel_ike_natt.conf $(DESTDIR)$(sysconfdir)/tunnel_ike_natt.conf.sample
+- $(INSTALL) -m 600 transport_kink.conf $(DESTDIR)$(sysconfdir)/transport_kink.conf.sample
+- $(INSTALL) -m 600 tunnel_kink.conf $(DESTDIR)$(sysconfdir)/tunnel_kink.conf.sample
+ $(INSTALL) -m 600 local-test.conf $(DESTDIR)$(sysconfdir)/local-test.conf.sample
+ $(INSTALL) -d -m 700 $(DESTDIR)$(sysconfdir)/psk
+ $(INSTALL) -d -m 700 $(DESTDIR)$(sysconfdir)/cert
diff --git a/security/racoon2/files/patch-samples_Makefile.in b/security/racoon2/files/patch-samples_Makefile.in
deleted file mode 100644
index 18429dfb2d88..000000000000
--- a/security/racoon2/files/patch-samples_Makefile.in
+++ /dev/null
@@ -1,33 +0,0 @@
---- samples/Makefile.in.orig 2018-12-19 18:42:30.245769000 -0800
-+++ samples/Makefile.in 2018-12-19 18:49:43.857886000 -0800
-@@ -594,18 +594,18 @@
-
- install-exec-hook:
- $(INSTALL) -d -o 0 -g 0 -m 700 $(DESTDIR)/var/run/racoon2
-- $(INSTALL) -d $(sysconfdir)
-- $(INSTALL) -m 600 racoon2.conf $(sysconfdir)/racoon2.conf.sample
-- $(INSTALL) -m 600 vals.conf $(sysconfdir)/vals.conf.sample
-- $(INSTALL) -m 600 default.conf $(sysconfdir)/default.conf.sample
-- $(INSTALL) -m 600 transport_ike.conf $(sysconfdir)/transport_ike.conf.sample
-- $(INSTALL) -m 600 tunnel_ike.conf $(sysconfdir)/tunnel_ike.conf.sample
-- $(INSTALL) -m 600 tunnel_ike_natt.conf $(sysconfdir)/tunnel_ike_natt.conf.sample
-- $(INSTALL) -m 600 transport_kink.conf $(sysconfdir)/transport_kink.conf.sample
-- $(INSTALL) -m 600 tunnel_kink.conf $(sysconfdir)/tunnel_kink.conf.sample
-- $(INSTALL) -m 600 local-test.conf $(sysconfdir)/local-test.conf.sample
-- $(INSTALL) -d -m 700 $(sysconfdir)/psk
-- $(INSTALL) -d -m 700 $(sysconfdir)/cert
-+ $(INSTALL) -d $(DESTDIR)/$(sysconfdir)
-+ $(INSTALL) -m 600 racoon2.conf $(DESTDIR)/$(sysconfdir)/racoon2.conf.sample
-+ $(INSTALL) -m 600 vals.conf $(DESTDIR)/$(sysconfdir)/vals.conf.sample
-+ $(INSTALL) -m 600 default.conf $(DESTDIR)/$(sysconfdir)/default.conf.sample
-+ $(INSTALL) -m 600 transport_ike.conf $(DESTDIR)/$(sysconfdir)/transport_ike.conf.sample
-+ $(INSTALL) -m 600 tunnel_ike.conf $(DESTDIR)/$(sysconfdir)/tunnel_ike.conf.sample
-+ $(INSTALL) -m 600 tunnel_ike_natt.conf $(DESTDIR)/$(sysconfdir)/tunnel_ike_natt.conf.sample
-+ $(INSTALL) -m 600 transport_kink.conf $(DESTDIR)/$(sysconfdir)/transport_kink.conf.sample
-+ $(INSTALL) -m 600 tunnel_kink.conf $(DESTDIR)/$(sysconfdir)/tunnel_kink.conf.sample
-+ $(INSTALL) -m 600 local-test.conf $(DESTDIR)/$(sysconfdir)/local-test.conf.sample
-+ $(INSTALL) -d -m 700 $(DESTDIR)/$(sysconfdir)/psk
-+ $(INSTALL) -d -m 700 $(DESTDIR)/$(sysconfdir)/cert
-
- # Tell versions [3.59,3.63) of GNU make to not export all variables.
- # Otherwise a system limit (for SysV at least) may be exceeded.
diff --git a/security/racoon2/files/patch-samples_hook_Makefile.in b/security/racoon2/files/patch-samples_hook_Makefile.in
deleted file mode 100644
index 18ce98a3b836..000000000000
--- a/security/racoon2/files/patch-samples_hook_Makefile.in
+++ /dev/null
@@ -1,45 +0,0 @@
---- samples/hook/Makefile.in.orig 2018-08-15 21:36:53.000000000 -0700
-+++ samples/hook/Makefile.in 2018-12-19 20:28:41.411352000 -0800
-@@ -611,22 +611,26 @@
-
-
- install-exec-hook:
-- $(INSTALL) -d $(sysconfdir)/hook
-- $(INSTALL_DATA) functions $(sysconfdir)/hook
-- $(INSTALL) -d $(sysconfdir)/hook/ikesa-up.d
-- $(INSTALL_SCRIPT) ikesa-up $(sysconfdir)/hook
-- $(INSTALL) -d $(sysconfdir)/hook/ikesa-down.d
-- $(INSTALL_SCRIPT) ikesa-down $(sysconfdir)/hook
-- $(INSTALL) -d $(sysconfdir)/hook/ikesa-rekey.d
-- $(INSTALL_SCRIPT) ikesa-rekey $(sysconfdir)/hook
-- $(INSTALL) -d $(sysconfdir)/hook/child-up.d
-- $(INSTALL_SCRIPT) child-up $(sysconfdir)/hook
-- $(INSTALL) -d $(sysconfdir)/hook/child-down.d
-- $(INSTALL_SCRIPT) child-down $(sysconfdir)/hook
-- $(INSTALL) -d $(sysconfdir)/hook/child-rekey.d
-- $(INSTALL_SCRIPT) child-rekey $(sysconfdir)/hook
-- $(INSTALL) -d $(sysconfdir)/hook/migration.d
-- $(INSTALL_SCRIPT) migration $(sysconfdir)/hook
-+ $(INSTALL) -d $(DESTDIR)/$(sysconfdir)/hook
-+ $(INSTALL_DATA) functions $(DESTDIR)/$(sysconfdir)/hook
-+ $(INSTALL) -d $(DESTDIR)/$(sysconfdir)/hook/ikesa-up.d
-+ $(INSTALL_SCRIPT) ikesa-up $(DESTDIR)/$(sysconfdir)/hook
-+ $(INSTALL) -d $(DESTDIR)/$(sysconfdir)/hook/ikesa-down.d
-+ $(INSTALL_SCRIPT) ikesa-down $(DESTDIR)/$(sysconfdir)/hook
-+ $(INSTALL) -d $(DESTDIR)/$(sysconfdir)/hook/ikesa-rekey.d
-+ $(INSTALL_SCRIPT) ikesa-rekey $(DESTDIR)/$(sysconfdir)/hook
-+ $(INSTALL) -d $(DESTDIR)/$(sysconfdir)/hook/child-up.d
-+ $(INSTALL_SCRIPT) child-up $(DESTDIR)/$(sysconfdir)/hook
-+ $(INSTALL) -d $(DESTDIR)/$(sysconfdir)/hook/child-down.d
-+ $(INSTALL_SCRIPT) child-down $(DESTDIR)/$(sysconfdir)/hook
-+ $(INSTALL) -d $(DESTDIR)/$(sysconfdir)/hook/child-rekey.d
-+ $(INSTALL_SCRIPT) child-rekey $(DESTDIR)/$(sysconfdir)/hook
-+ $(INSTALL) -d $(DESTDIR)/$(sysconfdir)/hook/migration.d
-+ $(INSTALL_SCRIPT) migration $(DESTDIR)/$(sysconfdir)/hook
-+ $(INSTALL) -d $(DESTDIR)/$(sysconfdir)/hook/ph1-down.d
-+ $(INSTALL_SCRIPT) ph1-down $(DESTDIR)/$(sysconfdir)/hook
-+ $(INSTALL) -d $(DESTDIR)/$(sysconfdir)/hook/ph1-up.d
-+ $(INSTALL_SCRIPT) ph1-up $(DESTDIR)/$(sysconfdir)/hook
-
- # Tell versions [3.59,3.63) of GNU make to not export all variables.
- # Otherwise a system limit (for SysV at least) may be exceeded.
diff --git a/security/racoon2/files/patch-samples_hook_child-down.d_Makefile.in b/security/racoon2/files/patch-samples_hook_child-down.d_Makefile.in
deleted file mode 100644
index a956cd22d9f3..000000000000
--- a/security/racoon2/files/patch-samples_hook_child-down.d_Makefile.in
+++ /dev/null
@@ -1,17 +0,0 @@
---- samples/hook/child-down.d/Makefile.in.orig 2018-08-15 21:36:53.000000000 -0700
-+++ samples/hook/child-down.d/Makefile.in 2018-12-19 22:39:38.279682000 -0800
-@@ -405,10 +405,10 @@
-
-
- install-exec-hook:
-- $(INSTALL) -d $(sysconfdir)/hook/child-down.d
-- $(INSTALL_DATA) 01setkey $(sysconfdir)/hook/child-down.d
-- $(INSTALL_DATA) 02ifconfig-gif $(sysconfdir)/hook/child-down.d
-- $(INSTALL_DATA) 03arp $(sysconfdir)/hook/child-down.d
-+ $(INSTALL) -d $(DESTDIR)/$(sysconfdir)/hook/child-down.d
-+ $(INSTALL_DATA) 01setkey $(DESTDIR)/$(sysconfdir)/hook/child-down.d
-+ $(INSTALL_DATA) 02ifconfig-gif $(DESTDIR)/$(sysconfdir)/hook/child-down.d
-+ $(INSTALL_DATA) 03arp $(DESTDIR)/$(sysconfdir)/hook/child-down.d
-
- # Tell versions [3.59,3.63) of GNU make to not export all variables.
- # Otherwise a system limit (for SysV at least) may be exceeded.
diff --git a/security/racoon2/files/patch-samples_hook_child-up.d_Makefile.in b/security/racoon2/files/patch-samples_hook_child-up.d_Makefile.in
deleted file mode 100644
index 02b6c68f1484..000000000000
--- a/security/racoon2/files/patch-samples_hook_child-up.d_Makefile.in
+++ /dev/null
@@ -1,19 +0,0 @@
---- samples/hook/child-up.d/Makefile.in.orig 2018-08-15 21:36:53.000000000 -0700
-+++ samples/hook/child-up.d/Makefile.in 2018-12-19 19:18:25.771791000 -0800
-@@ -405,11 +405,11 @@
-
-
- install-exec-hook:
-- $(INSTALL) -d $(sysconfdir)/hook/child-up.d
-- $(INSTALL_DATA) 00childup_sample $(sysconfdir)/hook/child-up.d
-- $(INSTALL_DATA) 01setkey $(sysconfdir)/hook/child-up.d
-- $(INSTALL_DATA) 02ifconfig-gif $(sysconfdir)/hook/child-up.d
-- $(INSTALL_DATA) 03arp $(sysconfdir)/hook/child-up.d
-+ $(INSTALL) -d $(DESTDIR)/$(sysconfdir)/hook/child-up.d
-+ $(INSTALL_DATA) 00childup_sample $(DESTDIR)/$(sysconfdir)/hook/child-up.d
-+ $(INSTALL_DATA) 01setkey $(DESTDIR)/$(sysconfdir)/hook/child-up.d
-+ $(INSTALL_DATA) 02ifconfig-gif $(DESTDIR)/$(sysconfdir)/hook/child-up.d
-+ $(INSTALL_DATA) 03arp $(DESTDIR)/$(sysconfdir)/hook/child-up.d
-
- # Tell versions [3.59,3.63) of GNU make to not export all variables.
- # Otherwise a system limit (for SysV at least) may be exceeded.
diff --git a/security/racoon2/files/patch-samples_hook_ikesa-up.d_Makefile.in b/security/racoon2/files/patch-samples_hook_ikesa-up.d_Makefile.in
deleted file mode 100644
index b305357a5780..000000000000
--- a/security/racoon2/files/patch-samples_hook_ikesa-up.d_Makefile.in
+++ /dev/null
@@ -1,13 +0,0 @@
---- samples/hook/ikesa-up.d/Makefile.in.orig 2018-08-15 21:36:53.000000000 -0700
-+++ samples/hook/ikesa-up.d/Makefile.in 2018-12-19 20:22:29.223583000 -0800
-@@ -405,8 +405,8 @@
-
-
- install-exec-hook:
-- $(INSTALL) -d $(sysconfdir)/hook/ikesa-up.d
-- $(INSTALL_DATA) 00ikesaup_sample $(sysconfdir)/hook/ikesa-up.d
-+ $(INSTALL) -d $(DESTDIR)/$(sysconfdir)/hook/ikesa-up.d
-+ $(INSTALL_DATA) 00ikesaup_sample $(DESTDIR)/$(sysconfdir)/hook/ikesa-up.d
-
- # Tell versions [3.59,3.63) of GNU make to not export all variables.
- # Otherwise a system limit (for SysV at least) may be exceeded.
diff --git a/security/racoon2/files/patch-samples_init.d_Makefile.am b/security/racoon2/files/patch-samples_init.d_Makefile.am
new file mode 100644
index 000000000000..9a38e8c0f018
--- /dev/null
+++ b/security/racoon2/files/patch-samples_init.d_Makefile.am
@@ -0,0 +1,8 @@
+--- samples/init.d/Makefile.am.orig 2020-03-18 13:57:19.000000000 -0700
++++ samples/init.d/Makefile.am 2020-06-29 14:52:07.468234000 -0700
+@@ -5,5 +5,4 @@
+ install-exec-hook:
+ $(INSTALL) -d $(DESTDIR)$(sysconfdir)/init.d
+ $(INSTALL_SCRIPT) iked $(DESTDIR)$(sysconfdir)/init.d/iked
+- $(INSTALL_SCRIPT) kinkd $(DESTDIR)$(sysconfdir)/init.d/kinkd
+ $(INSTALL_SCRIPT) spmd $(DESTDIR)$(sysconfdir)/init.d/spmd
diff --git a/security/racoon2/files/patch-samples_rc.d_Makefile.am b/security/racoon2/files/patch-samples_rc.d_Makefile.am
new file mode 100644
index 000000000000..f58a0cc0ba9e
--- /dev/null
+++ b/security/racoon2/files/patch-samples_rc.d_Makefile.am
@@ -0,0 +1,9 @@
+--- samples/rc.d/Makefile.am.orig 2020-03-18 13:57:19.000000000 -0700
++++ samples/rc.d/Makefile.am 2020-06-29 14:50:50.509434000 -0700
+@@ -5,6 +5,5 @@
+ install-exec-hook:
+ $(INSTALL) -d $(sysconfdir)/rc.d
+ $(INSTALL_SCRIPT) iked $(sysconfdir)/rc.d/iked
+- $(INSTALL_SCRIPT) kinkd $(sysconfdir)/rc.d/kinkd
+ $(INSTALL_SCRIPT) spmd $(sysconfdir)/rc.d/spmd
+ $(INSTALL_SCRIPT) racoon2 $(sysconfdir)/rc.d/racoon2
diff --git a/security/racoon2/files/patch-samples_rc.d_Makefile.in b/security/racoon2/files/patch-samples_rc.d_Makefile.in
deleted file mode 100644
index 829946633df6..000000000000
--- a/security/racoon2/files/patch-samples_rc.d_Makefile.in
+++ /dev/null
@@ -1,19 +0,0 @@
---- samples/rc.d/Makefile.in.orig 2018-08-15 21:36:53.000000000 -0700
-+++ samples/rc.d/Makefile.in 2018-12-18 20:45:22.072125000 -0800
-@@ -414,11 +414,11 @@
-
-
- install-exec-hook:
-- $(INSTALL) -d $(sysconfdir)/rc.d
-- $(INSTALL_SCRIPT) iked $(sysconfdir)/rc.d/iked
-- $(INSTALL_SCRIPT) kinkd $(sysconfdir)/rc.d/kinkd
-- $(INSTALL_SCRIPT) spmd $(sysconfdir)/rc.d/spmd
-- $(INSTALL_SCRIPT) racoon2 $(sysconfdir)/rc.d/racoon2
-+ $(INSTALL) -d $(DESTDIR)/${PREFIX}/etc/rc.d
-+ $(INSTALL_SCRIPT) iked $(DESTDIR)/${PREFIX}/etc/rc.d/iked
-+ $(INSTALL_SCRIPT) kinkd $(DESTDIR)/${PREFIX}/etc/rc.d/kinkd
-+ $(INSTALL_SCRIPT) spmd $(DESTDIR)/${PREFIX}/etc/rc.d/spmd
-+ $(INSTALL_SCRIPT) racoon2 $(DESTDIR)/${PREFIX}/etc/rc.d/racoon2
-
- # Tell versions [3.59,3.63) of GNU make to not export all variables.
- # Otherwise a system limit (for SysV at least) may be exceeded.
diff --git a/security/racoon2/files/patch-spmd-Makefile.in b/security/racoon2/files/patch-spmd-Makefile.in
deleted file mode 100644
index 28eed3e9e1a4..000000000000
--- a/security/racoon2/files/patch-spmd-Makefile.in
+++ /dev/null
@@ -1,89 +0,0 @@
---- spmd/Makefile.in.orig 2018-08-15 21:36:53.000000000 -0700
-+++ spmd/Makefile.in 2018-12-19 13:07:42.520771000 -0800
-@@ -70,6 +70,9 @@
- test $$has_opt = yes
- am__make_dryrun = (target_option=n; $(am__make_running_with_option))
- am__make_keepgoing = (target_option=k; $(am__make_running_with_option))
-+am__base_list = \
-+ sed '$$!N;$$!N;$$!N;$$!N;$$!N;$$!N;$$!N;s/\n/ /g' | \
-+ sed '$$!N;$$!N;$$!N;$$!N;s/\n/ /g'
- pkgdatadir = $(datadir)/@PACKAGE@
- pkgincludedir = $(includedir)/@PACKAGE@
- pkglibdir = $(libdir)/@PACKAGE@
-@@ -140,6 +143,7 @@
- am__v_CCLD_ = $(am__v_CCLD_@AM_DEFAULT_V@)
- am__v_CCLD_0 = @echo " CCLD " $@;
- am__v_CCLD_1 =
-+man8dir = $(mandir)/man8
- SOURCES = $(spmd_SOURCES) spmdctl.c
- DIST_SOURCES = $(spmd_SOURCES) spmdctl.c
- am__can_run_installinfo = \
-@@ -284,7 +288,7 @@
- top_builddir = @top_builddir@
- top_srcdir = @top_srcdir@
- AM_CPPFLAGS = -DSYSCONFDIR=\"${sysconfdir}\"
--MAN_MANS = spmd.8 spmdctl.8
-+man_MANS = spmd.8 spmdctl.8
- spmd_SOURCES = main.c dns.c udp.c query.c task.c signal.c shell.c utils.c cache.c spmd_pfkey.c fqdn_query.c
- spmdctl_SOURCE = spmdctl.c
- all: config.h
-@@ -672,6 +676,41 @@
- install_sh_PROGRAM="$(INSTALL_STRIP_PROGRAM)" INSTALL_STRIP_FLAG=-s \
- "INSTALL_PROGRAM_ENV=STRIPPROG='$(STRIP)'" install; \
- fi
-+
-+install-man8: $(man_MANS)
-+ @$(NORMAL_INSTALL)
-+ @list1=''; \
-+ list2='$(man_MANS)'; \
-+ test -n "$(man8dir)" \
-+ && test -n "`echo $$list1$$list2`" \
-+ || exit 0; \
-+ echo " $(MKDIR_P) '$(DESTDIR)$(man8dir)'"; \
-+ $(MKDIR_P) "$(DESTDIR)$(man8dir)" || exit 1; \
-+ { for i in $$list1; do echo "$$i"; done; \
-+ if test -n "$$list2"; then \
-+ for i in $$list2; do echo "$$i"; done \
-+ | sed -n '/\.8[a-z]*$$/p'; \
-+ fi; \
-+ } | while read p; do \
-+ if test -f $$p; then d=; else d="$(srcdir)/"; fi; \
-+ echo "$$d$$p"; echo "$$p"; \
-+ done | \
-+ sed -e 'n;s,.*/,,;p;h;s,.*\.,,;s,^[^8][0-9a-z]*$$,8,;x' \
-+ -e 's,\.[0-9a-z]*$$,,;$(transform);G;s,\n,.,' | \
-+ sed 'N;N;s,\n, ,g' | { \
-+ list=; while read file base inst; do \
-+ if test "$$base" = "$$inst"; then list="$$list $$file"; else \
-+ echo " $(INSTALL_DATA) '$$file' '$(DESTDIR)$(man8dir)/$$inst'"; \
-+ $(INSTALL_DATA) "$$file" "$(DESTDIR)$(man8dir)/$$inst" || exit $$?; \
-+ fi; \
-+ done; \
-+ for i in $$list; do echo "$$i"; done | $(am__base_list) | \
-+ while read files; do \
-+ test -z "$$files" || { \
-+ echo " $(INSTALL_DATA) $$files '$(DESTDIR)$(man8dir)'"; \
-+ $(INSTALL_DATA) $$files "$(DESTDIR)$(man8dir)" || exit $$?; }; \
-+ done; }
-+
- mostlyclean-generic:
-
- clean-generic:
-@@ -706,7 +745,7 @@
-
- info-am:
-
--install-data-am:
-+install-data-am: install-man
-
- install-dvi: install-dvi-am
-
-@@ -722,7 +761,7 @@
-
- install-info-am:
-
--install-man:
-+install-man: install-man8
-
- install-pdf: install-pdf-am
-
diff --git a/security/racoon2/pkg-plist b/security/racoon2/pkg-plist
index 5307af7783b1..27fcc0c48aa1 100644
--- a/security/racoon2/pkg-plist
+++ b/security/racoon2/pkg-plist
@@ -1,5 +1,4 @@
sbin/iked
-%%KINK%%sbin/kinkd
sbin/spmd
sbin/spmdctl
sbin/pskgen
@@ -7,10 +6,8 @@ etc/racoon2/default.conf.sample
etc/racoon2/local-test.conf.sample
etc/racoon2/racoon2.conf.sample
etc/racoon2/transport_ike.conf.sample
-etc/racoon2/transport_kink.conf.sample
etc/racoon2/tunnel_ike.conf.sample
etc/racoon2/tunnel_ike_natt.conf.sample
-etc/racoon2/tunnel_kink.conf.sample
etc/racoon2/vals.conf.sample
etc/racoon2/hook/functions
etc/racoon2/hook/ikesa-up.d/00ikesaup_sample
@@ -28,12 +25,13 @@ etc/racoon2/hook/child-down.d/03arp
etc/racoon2/hook/child-down
etc/racoon2/hook/child-rekey
etc/racoon2/hook/migration
-etc/racoon2/hook/ph1-up
-etc/racoon2/hook/ph1-down
etc/rc.d/iked
etc/rc.d/racoon2
etc/rc.d/spmd
-%%KINK%%etc/rc.d/kinkd
+lib/libracoon.a
+lib/libracoon.so
+lib/libracoon.so.0
+lib/libracoon.so.0.0.0
%%PORTDOCS%%%%DOCSDIR%%/COPYRIGHT
%%PORTDOCS%%%%DOCSDIR%%/COPYRIGHT.jp
%%PORTDOCS%%%%DOCSDIR%%/README
@@ -41,10 +39,7 @@ man/man8/spmd.8.gz
man/man8/spmdctl.8.gz
man/man8/pskgen.8.gz
man/man8/iked.8.gz
-%%KINK%%man/man8/kinkd.8.gz
@dir etc/racoon2/psk
-@dir etc/racoon2/hook/ph1-up.d
-@dir etc/racoon2/hook/ph1-down.d
@dir etc/racoon2/hook/migration.d
@dir etc/racoon2/hook/ikesa-rekey.d
@dir etc/racoon2/hook/ikesa-down.d