aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2020-09-22 11:23:52 +0000
committerStefan Eßer <se@FreeBSD.org>2020-09-22 11:23:52 +0000
commit1782c583de41206df2798283470ef259f9b475eb (patch)
tree83a0685764404999a033d787832bfd27d5f0fc57 /security
parent7e1c61a2ad44d47ca7a870ed43c0aa923cbf58c8 (diff)
downloadports-1782c583de41206df2798283470ef259f9b475eb.tar.gz
ports-1782c583de41206df2798283470ef259f9b475eb.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/pwman/Makefile1
-rw-r--r--security/pwman/files/patch-src__pwman.h23
-rw-r--r--security/pwman/files/patch-src_actions.c16
3 files changed, 38 insertions, 2 deletions
diff --git a/security/pwman/Makefile b/security/pwman/Makefile
index 4f26a773760c..fa2a8f24d9fa 100644
--- a/security/pwman/Makefile
+++ b/security/pwman/Makefile
@@ -3,6 +3,7 @@
PORTNAME= pwman
DISTVERSION= 0.4.5
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
diff --git a/security/pwman/files/patch-src__pwman.h b/security/pwman/files/patch-src__pwman.h
index 1cc049ec743c..5a5919bc2926 100644
--- a/security/pwman/files/patch-src__pwman.h
+++ b/security/pwman/files/patch-src__pwman.h
@@ -1,5 +1,5 @@
---- ./src/pwman.h.orig 2009-08-26 16:18:55.000000000 +0000
-+++ ./src/pwman.h 2010-09-14 02:40:40.029593205 +0000
+--- src/pwman.h.orig 2017-05-01 16:59:03 UTC
++++ src/pwman.h
@@ -26,6 +26,7 @@
#include <string.h>
#include <config.h>
@@ -8,3 +8,22 @@
#include <stdarg.h>
#define CONF_FILE ".pwmanrc"
+@@ -112,12 +113,12 @@ typedef struct {
+ int sign_db;
+ } Options;
+
+-Options *options;
+-int write_options;
+-PWList *pwlist;
+-PWList *current_pw_sublist;
+-PWSearchResult *search_results;
+-time_t time_base;
++extern Options *options;
++extern int write_options;
++extern PWList *pwlist;
++extern PWList *current_pw_sublist;
++extern PWSearchResult *search_results;
++extern time_t time_base;
+
+ char *trim_ws(char*);
+ void debug(char*, ...);
diff --git a/security/pwman/files/patch-src_actions.c b/security/pwman/files/patch-src_actions.c
new file mode 100644
index 000000000000..d0a967b3eb51
--- /dev/null
+++ b/security/pwman/files/patch-src_actions.c
@@ -0,0 +1,16 @@
+--- src/actions.c.orig 2017-05-01 16:59:03 UTC
++++ src/actions.c
+@@ -23,6 +23,13 @@
+ #include <pwman.h>
+ #include <gnupg.h>
+
++Options *options;
++int write_options;
++PWList *pwlist;
++PWList *current_pw_sublist;
++PWSearchResult *search_results;
++time_t time_base;
++
+ extern Pw * uilist_get_highlighted_item();
+ extern PWList * uilist_get_highlighted_sublist();
+ extern PWList * pwlist_new(char*);