aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-04-02 10:22:39 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-04-02 10:22:39 +0000
commit230d79dbbce8cab1c5b6dda3199fb6f94f1a4fb7 (patch)
tree745d4f492daafd52ea15ba52526a61885cd7d5af /security
parent963f9cd89f5488cb04792395db95e0fb8a6b9a94 (diff)
downloadports-230d79dbbce8cab1c5b6dda3199fb6f94f1a4fb7.tar.gz
ports-230d79dbbce8cab1c5b6dda3199fb6f94f1a4fb7.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/amap/Makefile32
-rw-r--r--security/amap/distinfo1
-rw-r--r--security/amap/files/patch-Makefile.am16
-rw-r--r--security/amap/files/patch-amap.c12
-rw-r--r--security/amap/pkg-descr5
-rw-r--r--security/amap/pkg-plist5
7 files changed, 72 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index f16e53acecfa..d3138246f853 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -6,6 +6,7 @@
SUBDIR += aescrypt
SUBDIR += aide
SUBDIR += altivore
+ SUBDIR += amap
SUBDIR += amavis-perl
SUBDIR += amavisd
SUBDIR += amavisd-new
diff --git a/security/amap/Makefile b/security/amap/Makefile
new file mode 100644
index 000000000000..d6f3684bdc1f
--- /dev/null
+++ b/security/amap/Makefile
@@ -0,0 +1,32 @@
+# Ports collection makefile for: amap
+# Date created: 23 Mar 2003
+# Whom: Yonatan <Yonatan@xpert.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= amap
+PORTVERSION= 1.2.1
+CATEGORIES= security
+MASTER_SITES= http://www.thehackerschoice.com/releases/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= Yonatan@xpert.com
+COMMENT= Application mapper
+
+HAS_CONFIGURE= yes
+USE_REINPLACE= yes
+ALL_TARGET= all
+MAN1= amap.1
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|PREFIX|${PREFIX}|' ${WRKSRC}/amap.c
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/amap ${PREFIX}/bin/
+ ${MKDIR} ${PREFIX}/share/amap
+ ${INSTALL_DATA} ${WRKSRC}/appdefs.resp ${PREFIX}/share/amap/
+ ${INSTALL_DATA} ${WRKSRC}/appdefs.trig ${PREFIX}/share/amap/
+ ${INSTALL_MAN} ${WRKSRC}/amap.1 ${MANPREFIX}/man/man1/
+
+.include <bsd.port.mk>
diff --git a/security/amap/distinfo b/security/amap/distinfo
new file mode 100644
index 000000000000..e2b5f5eae7df
--- /dev/null
+++ b/security/amap/distinfo
@@ -0,0 +1 @@
+MD5 (amap-1.2.1.tgz) = c84cdd211628573fc516575829629896
diff --git a/security/amap/files/patch-Makefile.am b/security/amap/files/patch-Makefile.am
new file mode 100644
index 000000000000..05b2a6405b42
--- /dev/null
+++ b/security/amap/files/patch-Makefile.am
@@ -0,0 +1,16 @@
+--- Makefile.am.orig Sun Mar 23 14:32:41 2003
++++ Makefile.am Sun Mar 23 14:40:52 2003
+@@ -1,10 +1,9 @@
+-CC=gcc
+-OPT=-O2
++OPT=-O
+ OPT_DEBUG=-ggdb -Wall
+ BIN=amap
+-DIR=/usr/local/bin
++DIR=${PREFIX}/bin
+ SCRIPTS=appdefs.trig appdefs.resp
+-MANDIR=/usr/local/man/man1
++MANDIR=${MANPREFIX}
+ MANPAGE=amap.1
+ all: strip
+
diff --git a/security/amap/files/patch-amap.c b/security/amap/files/patch-amap.c
new file mode 100644
index 000000000000..06968d259e7e
--- /dev/null
+++ b/security/amap/files/patch-amap.c
@@ -0,0 +1,12 @@
+--- amap.c.orig Sun Mar 23 15:42:07 2003
++++ amap.c Sun Mar 23 16:01:36 2003
+@@ -64,7 +64,8 @@
+ char banner_string[256];
+
+ // where are my appdefs files?
+-char *searchpath[12] = { "./", "/etc/", "/usr/etc", "/usr/local/etc/",
++char *searchpath[13] = { "./", "PREFIX/share/amap/", "/etc/", "/usr/etc",
++ "/usr/local/etc/",
+ "/opt/etc/", "/usr/local/amap/", "/opt/amap/",
+ "/usr/local/lib/", "/usr/local/lib/amap/",
+ "/usr/lib/amap/", "/usr/local/bin/", NULL };
diff --git a/security/amap/pkg-descr b/security/amap/pkg-descr
new file mode 100644
index 000000000000..aea2fbfdb8a5
--- /dev/null
+++ b/security/amap/pkg-descr
@@ -0,0 +1,5 @@
+Amap is a next-generation scanning tool, it identifies applications
+and services even if they are not listening to the default port
+by creating a bogus-communication.
+
+WWW: http://www.thehackerschoice.com/releases.php
diff --git a/security/amap/pkg-plist b/security/amap/pkg-plist
new file mode 100644
index 000000000000..4e4273e88b9f
--- /dev/null
+++ b/security/amap/pkg-plist
@@ -0,0 +1,5 @@
+@comment $FreeBSD$
+bin/amap
+share/amap/appdefs.resp
+share/amap/appdefs.trig
+@dirrm share/amap