aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2007-02-06 11:49:15 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2007-02-06 11:49:15 +0000
commit2886fac158d2d230b6f8ef854547c8d1e2e8852a (patch)
tree5e2fb5014a4b58b5b21e9fd3b21361df76a6dee4 /security
parent704618017c53d3fc53a25fed1fe92dd5c5486939 (diff)
downloadports-2886fac158d2d230b6f8ef854547c8d1e2e8852a.tar.gz
ports-2886fac158d2d230b6f8ef854547c8d1e2e8852a.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/keepassx/Makefile29
-rw-r--r--security/keepassx/distinfo3
-rw-r--r--security/keepassx/pkg-descr9
-rw-r--r--security/keepassx/pkg-plist43
5 files changed, 85 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index bd1a627dad6e..bc76d445a85f 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -200,6 +200,7 @@
SUBDIR += jce_policy14
SUBDIR += john
SUBDIR += kedpm
+ SUBDIR += keepassx
SUBDIR += keychain
SUBDIR += keynote
SUBDIR += keyprint
diff --git a/security/keepassx/Makefile b/security/keepassx/Makefile
new file mode 100644
index 000000000000..1b5c4664f490
--- /dev/null
+++ b/security/keepassx/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: keepassx
+# Date created: 18 September 2006
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= KeePassX
+PORTVERSION= 0.2.2
+CATEGORIES= security
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME:L}
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= Cross Platform Password Manager
+
+WRKSRC= ${WRKDIR}/${PORTNAME:L}-${PORTVERSION}
+
+USE_QT_VER= 4
+QT_COMPONENTS= qmake gui moc uic qt3support
+HAS_CONFIGURE= yes
+
+do-configure:
+ @cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
+ ${QMAKE} -unix PREFIX=${PREFIX} \
+ INCLUDEPATH+=${X11BASE}/include LIBS+=-L${X11BASE}/lib \
+ keepass.pro
+
+.include <bsd.port.mk>
diff --git a/security/keepassx/distinfo b/security/keepassx/distinfo
new file mode 100644
index 000000000000..482d0ee36514
--- /dev/null
+++ b/security/keepassx/distinfo
@@ -0,0 +1,3 @@
+MD5 (KeePassX-0.2.2.tar.gz) = 5ee945ab12c2667ef5c4013a0636c26f
+SHA256 (KeePassX-0.2.2.tar.gz) = ee588bd744195e394e7b618b8e0aeb25cbf37ca5b619b1c7e2176fd412b29cbd
+SIZE (KeePassX-0.2.2.tar.gz) = 302656
diff --git a/security/keepassx/pkg-descr b/security/keepassx/pkg-descr
new file mode 100644
index 000000000000..fd415e613b89
--- /dev/null
+++ b/security/keepassx/pkg-descr
@@ -0,0 +1,9 @@
+KeePassX is a free/open-source password manager or safe which helps you
+to manage your passwords in a secure way. You can put all your
+passwords in one database, which is locked with one master key or a
+key-disk. So you only have to remember one single master password or
+insert the key-disk to unlock the whole database. The databases are
+encrypted using the best and most secure encryption algorithms currently
+known (AES and Twofish).
+
+WWW: http://keepassx.sourceforge.net/
diff --git a/security/keepassx/pkg-plist b/security/keepassx/pkg-plist
new file mode 100644
index 000000000000..de75fc5dfd7d
--- /dev/null
+++ b/security/keepassx/pkg-plist
@@ -0,0 +1,43 @@
+bin/keepass
+share/keepass/license.html
+share/keepass/i18n/keepass-de_DE.qm
+share/keepass/i18n/keepass-fr_FR.qm
+share/keepass/icons/clientic.png
+share/keepass/icons/i18n.png
+share/keepass/icons/keepassx.png
+share/keepass/icons/key.png
+share/keepass/icons/ok.png
+share/keepass/icons/search.png
+share/keepass/icons/settings.png
+share/keepass/icons/nuvola/32x32/actions/configure.png
+share/keepass/icons/nuvola/32x32/actions/edit.png
+share/keepass/icons/nuvola/32x32/actions/edit_add.png
+share/keepass/icons/nuvola/32x32/actions/editcopy.png
+share/keepass/icons/nuvola/32x32/actions/editdelete.png
+share/keepass/icons/nuvola/32x32/actions/exit.png
+share/keepass/icons/nuvola/32x32/actions/fileclose.png
+share/keepass/icons/nuvola/32x32/actions/fileexport.png
+share/keepass/icons/nuvola/32x32/actions/filenew.png
+share/keepass/icons/nuvola/32x32/actions/fileopen.png
+share/keepass/icons/nuvola/32x32/actions/filesave.png
+share/keepass/icons/nuvola/32x32/actions/filesaveas.png
+share/keepass/icons/nuvola/32x32/actions/find.png
+share/keepass/icons/nuvola/32x32/actions/help.png
+share/keepass/icons/nuvola/32x32/actions/identity.png
+share/keepass/icons/nuvola/32x32/actions/klipper_dock.png
+share/keepass/icons/nuvola/32x32/actions/reload.png
+share/keepass/icons/nuvola/32x32/actions/run.png
+share/keepass/icons/nuvola/32x32/apps/ktouch.png
+share/keepass/icons/nuvola/32x32/filesystems/desktop.png
+share/keepass/icons/nuvola/32x32/filesystems/folder.png
+share/keepass/icons/nuvola/32x32/filesystems/folder_home.png
+share/keepass/icons/nuvola/32x32/filesystems/network_local.png
+share/keepass/icons/nuvola/32x32/filesystems/trashcan_full.png
+@dirrm share/keepass/icons/nuvola/32x32/filesystems
+@dirrm share/keepass/icons/nuvola/32x32/apps
+@dirrm share/keepass/icons/nuvola/32x32/actions
+@dirrm share/keepass/icons/nuvola/32x32
+@dirrm share/keepass/icons/nuvola
+@dirrm share/keepass/icons
+@dirrm share/keepass/i18n
+@dirrm share/keepass