aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-03-19 10:40:22 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-03-19 10:40:22 +0000
commit2a3357182d8cb640f374f8c60b71b6c99ec43843 (patch)
tree7a5f4c1c91d14d9fcab2b30589db732cde4a3725 /security
parent92fdeef4740a0893f904a81b5150a5e3f5604b10 (diff)
downloadports-2a3357182d8cb640f374f8c60b71b6c99ec43843.tar.gz
ports-2a3357182d8cb640f374f8c60b71b6c99ec43843.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/seahorse-plugins/Makefile49
-rw-r--r--security/seahorse/Makefile43
2 files changed, 36 insertions, 56 deletions
diff --git a/security/seahorse-plugins/Makefile b/security/seahorse-plugins/Makefile
index fd7c9b7df078..bbfa3f5e99da 100644
--- a/security/seahorse-plugins/Makefile
+++ b/security/seahorse-plugins/Makefile
@@ -1,10 +1,6 @@
-# New ports collection makefile for: seahorse-plugins
-# Date created: 06 August 2008
-# Whom: Dave McKay <dave@mu.org>
-#
+# Created by: Dave McKay <dave@mu.org>
# $FreeBSD$
# $MCom: ports/security/seahorse-plugins/Makefile,v 1.28 2011/07/03 11:57:45 kwm Exp $
-#
PORTNAME= seahorse-plugins
PORTVERSION= 2.30.1
@@ -16,38 +12,31 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= Plug-ins for the Seahorse key and password management application
-LIB_DEPENDS= cryptui.0:${PORTSDIR}/security/seahorse \
- gcrypt.18:${PORTSDIR}/security/libgcrypt
+LIB_DEPENDS= cryptui:${PORTSDIR}/security/seahorse \
+ gcrypt:${PORTSDIR}/security/libgcrypt
USE_BZIP2= yes
USE_GETTEXT= yes
USE_GMAKE= yes
-#USE_GECKO= libxul19
-USE_GNOME= gnomehack intlhack gnomeprefix gconf2 gnomedocutils
+USES= pathfix
+USE_GNOME= intlhack gnomeprefix gconf2 gnomedocutils
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
INSTALLS_OMF= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-OPTIONS= NAUTILUS "Enable the Nautilus component" on \
- GEDIT "Enable GEdit plug-in support" on \
- APPLET "Enable clipboard encryption applet" on \
- NOTIFY "Enable libnotify support" on
-#EPIPHANY "Enable Epiphany plug-in support" on
+OPTIONS_DEFINE= NAUTILUS GEDIT APPLET NOTIFY
+NAUTILUS_DESC= Nautilus component
+GEDIT_DESC= GEdit plug-in support
+APPLET_DESC= Clipboard encryption applet
GCONF_SCHEMAS= seahorse-plugins.schemas
MAN1= seahorse-agent.1 seahorse-tool.1
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-#.if ${GECKO}=="libxul"
-#CONFIGURE_ARGS+=--with-gecko=libxul-unstable
-#.else
-#CONFIGURE_ARGS+=--with-gecko=${GECKO:S/19//}
-#.endif
-
-.if !defined(WITHOUT_GEDIT)
+.if ${PORT_OPTIONS:MGEDIT}
BUILD_DEPENDS+= gedit:${PORTSDIR}/editors/gedit
RUN_DEPENDS+= gedit:${PORTSDIR}/editors/gedit
PLIST_SUB+= GEDIT=""
@@ -57,7 +46,7 @@ PLIST_SUB+= GEDIT="@comment "
CONFIGURE_ARGS+=--disable-gedit
.endif
-.if !defined(WITHOUT_NAUTILUS)
+.if ${PORT_OPTIONS:MNAUTILUS}
USE_GNOME+= nautilus2
PLIST_SUB+= NAUTILUS=""
.else
@@ -65,16 +54,10 @@ PLIST_SUB+= NAUTILUS="@comment "
CONFIGURE_ARGS+=--disable-nautilus
.endif
-#.if !defined(WITHOUT_EPIPHANY)
-#BUILD_DEPENDS+= epiphany:${PORTSDIR}/www/epiphany
-#RUN_DEPENDS+= epiphany:${PORTSDIR}/www/epiphany
-#PLIST_SUB+= EPIPHANY="" EPHY_VERSION="2.26"
-#.else
CONFIGURE_ARGS+=--disable-epiphany
PLIST_SUB+= EPHY="@comment "
-#.endif
-.if !defined(WITHOUT_APPLET)
+.if ${PORT_OPTIONS:MAPPLET}
USE_GNOME+= gnomepanel
PLIST_SUB+= APPLET=""
.else
@@ -82,8 +65,8 @@ CONFIGURE_ARGS+=--disable-applet
PLIST_SUB+= APPLET="@comment "
.endif
-.if !defined(WITHOUT_NOTIFY)
-LIB_DEPENDS+= notify.4:${PORTSDIR}/devel/libnotify
+.if ${PORT_OPTIONS:MNOTIFY}
+LIB_DEPENDS+= notify:${PORTSDIR}/devel/libnotify
.else
CONFIGURE_ARGS+=--disable-libnotify
.endif
@@ -98,4 +81,4 @@ post-install:
@-update-desktop-database
@-update-mime-database ${PREFIX}/share/mime
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/seahorse/Makefile b/security/seahorse/Makefile
index 631a0e0cbd45..2d08cce6acab 100644
--- a/security/seahorse/Makefile
+++ b/security/seahorse/Makefile
@@ -1,14 +1,10 @@
-# New ports collection makefile for: Seahorse
-# Date created: 08 March 2000
-# Whom: Dave McKay <dave@mu.org>
-#
+# Created by: Dave McKay <dave@mu.org>
# $FreeBSD$
-# $MCom: ports/security/seahorse/Makefile,v 1.104 2011/07/03 11:57:45 kwm Exp $
-#
+# $MCom: ports/security/seahorse/Makefile,v 1.109 2012/09/01 23:02:12 mezz Exp $
PORTNAME= seahorse
PORTVERSION= 2.32.0
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= security gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -18,20 +14,21 @@ COMMENT= GNOME application for managing encryption keys (PGP, SSH)
BUILD_DEPENDS= gpg:${PORTSDIR}/security/gnupg
RUN_DEPENDS= gpg:${PORTSDIR}/security/gnupg
-LIB_DEPENDS= gpgme.19:${PORTSDIR}/security/gpgme \
- dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
- gcr.0:${PORTSDIR}/security/gnome-keyring \
- gcrypt.18:${PORTSDIR}/security/libgcrypt \
- soup-2.4.1:${PORTSDIR}/devel/libsoup
+LIB_DEPENDS= gpgme:${PORTSDIR}/security/gpgme \
+ dbus-glib-1:${PORTSDIR}/devel/dbus-glib \
+ gcr:${PORTSDIR}/security/gnome-keyring \
+ gcrypt:${PORTSDIR}/security/libgcrypt \
+ soup-2.4:${PORTSDIR}/devel/libsoup
-CONFLICTS= seahorse-3.[0-9]*
+CONFLICTS= libcryptui-3.[0-9]* seahorse-3.[0-9]*
USE_XORG= sm
USE_LDCONFIG= yes
USE_BZIP2= yes
USE_GETTEXT= yes
USE_GMAKE= yes
-USE_GNOME= gnomehack intlhack gnomeprefix gconf2 gnomedocutils
+USES= pathfix
+USE_GNOME= intlhack gnomeprefix gconf2 gnomedocutils
GNU_CONFIGURE= yes
INSTALLS_OMF= yes
INSTALLS_ICONS= yes
@@ -42,25 +39,25 @@ CONFIGURE_ARGS= --enable-introspection=no
GCONF_SCHEMAS= seahorse.schemas
MAN1= seahorse.1 seahorse-daemon.1
-OPTIONS= LDAP "Enable LDAP support" on \
- NOTIFY "Enable libnotify support" on \
- MDNS "Enable mDNS key sharing" on
+OPTIONS_DEFINE= LDAP NOTIFY MDNS
+OPTIONS_DEFAULT=LDAP NOTIFY MDNS
+MDNS_DESC= mDNS key sharing
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_LDAP)
+.if ${PORT_OPTIONS:MLDAP}
USE_OPENLDAP= yes
.else
CONFIGURE_ARGS+=--disable-ldap
.endif
-.if !defined(WITHOUT_NOTIFY)
-LIB_DEPENDS+= notify.4:${PORTSDIR}/devel/libnotify
+.if ${PORT_OPTIONS:MNOTIFY}
+LIB_DEPENDS+= notify:${PORTSDIR}/devel/libnotify
.else
CONFIGURE_ARGS+=--disable-libnotify
.endif
-.if !defined(WITHOUT_MDNS)
+.if ${PORT_OPTIONS:MMDNS}
LIB_DEPENDS+= avahi-client:${PORTSDIR}/net/avahi-app
.else
CONFIGURE_ARGS+=--disable-sharing
@@ -70,4 +67,4 @@ post-patch:
@${REINPLACE_CMD} -e 's|" == "|" = "|g' \
${WRKSRC}/configure
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>