aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorGreg Larkin <glarkin@FreeBSD.org>2011-11-23 19:37:24 +0000
committerGreg Larkin <glarkin@FreeBSD.org>2011-11-23 19:37:24 +0000
commit5381a161b0d75ba37dc9bc824e38163027b665f5 (patch)
treeaf8ef1c37548e66ec274bdd51bffab96a52236d2 /security
parenta32837d5acbd732c9935b7a68e4284401d7ab032 (diff)
downloadports-5381a161b0d75ba37dc9bc824e38163027b665f5.tar.gz
ports-5381a161b0d75ba37dc9bc824e38163027b665f5.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/logcheck/Makefile4
-rw-r--r--security/logcheck/files/patch-rulefiles__linux__ignore.d.server__ssh13
2 files changed, 17 insertions, 0 deletions
diff --git a/security/logcheck/Makefile b/security/logcheck/Makefile
index 60c3cf8170ba..fc1b87963cd4 100644
--- a/security/logcheck/Makefile
+++ b/security/logcheck/Makefile
@@ -7,6 +7,7 @@
PORTNAME= logcheck
PORTVERSION= 1.3.13
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_DEBIAN_POOL}
DISTNAME= ${PORTNAME}_${PORTVERSION}
@@ -55,6 +56,9 @@ pre-patch:
@${SED} ${_SUB_LIST_TEMP} ${FILESDIR}/${patch}.in > ${WRKDIR}/${patch}
.endfor
+post-patch:
+ @${FIND} ${WRKSRC}/rulefiles -type f -name \*.orig -delete
+
do-build:
@${REINPLACE_CMD} -e 's!/var/log/syslog!/var/log/messages!' \
${WRKSRC}/etc/logcheck.logfiles
diff --git a/security/logcheck/files/patch-rulefiles__linux__ignore.d.server__ssh b/security/logcheck/files/patch-rulefiles__linux__ignore.d.server__ssh
new file mode 100644
index 000000000000..c482cb8536ac
--- /dev/null
+++ b/security/logcheck/files/patch-rulefiles__linux__ignore.d.server__ssh
@@ -0,0 +1,13 @@
+--- ./rulefiles/linux/ignore.d.server/ssh.orig 2010-09-03 04:24:30.000000000 -0400
++++ ./rulefiles/linux/ignore.d.server/ssh 2011-11-23 14:25:31.000000000 -0500
+@@ -21,8 +21,8 @@
+ ^\w{3} [ :[:digit:]]{11} [._[:alnum:]-]+ sshd\[[[:digit:]]+\]: \(pam_unix\) check pass; user unknown$
+ ^\w{3} [ :[:digit:]]{11} [._[:alnum:]-]+ sshd\[[[:digit:]]+\]: \(pam_unix\) bad username \[[^]]+\]$
+ ^\w{3} [ :[:digit:]]{11} [._[:alnum:]-]+ sshd\[[[:digit:]]+\]: error: Could not get shadow information for NOUSER$
+-^\w{3} [ :[:digit:]]{11} [._[:alnum:]-]+ sshd\[[[:digit:]]+\]: error: PAM: Authentication failure for( illegal user)? [^[:space:]]+ from ([:.[:xdigit:]]+|UNKNOWN|[-_.[:alnum:]]+)$
+-^\w{3} [ :[:digit:]]{11} [._[:alnum:]-]+ sshd\[[[:digit:]]+\]: error: PAM: User not known to the underlying authentication module for i(llegal|nvalid) user [^[:space:]]+ from ([:.[:xdigit:]]+|UNKNOWN|[-_.[:alnum:]]+)$
++^\w{3} [ :[:digit:]]{11} [._[:alnum:]-]+ sshd\[[[:digit:]]+\]: error: PAM: authentication error for( illegal user)? [^[:space:]]+ from ([:.[:xdigit:]]+|UNKNOWN|[-_.[:alnum:]]+)$
++^\w{3} [ :[:digit:]]{11} [._[:alnum:]-]+ sshd\[[[:digit:]]+\]: error: PAM: unknown user for i(llegal|nvalid) user [^[:space:]]+ from ([:.[:xdigit:]]+|UNKNOWN|[-_.[:alnum:]]+)$
+ ^\w{3} [ :[:digit:]]{11} [._[:alnum:]-]+ sshd\[[[:digit:]]+\]: error: ssh_msg_send: write$
+ ^\w{3} [ :[:digit:]]{11} [._[:alnum:]-]+ sshd\[[[:digit:]]+\]: fatal: Timeout before authentication for [:[:alnum:].]+$
+ ^\w{3} [ :[:digit:]]{11} [._[:alnum:]-]+ sshd\[[[:digit:]]+\]: fatal: Write failed: (Connection (timed out|reset by peer)|Broken pipe)$