aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2020-09-24 18:14:52 +0000
committerSteve Wills <swills@FreeBSD.org>2020-09-24 18:14:52 +0000
commit59a4c814227869c1882dc7ab2f12ea40173b4b9b (patch)
tree4728397d2df0b4bf3f0c1f5896870aef4b0f825f /security
parent190e4337c95ea05ddf0a27c9f43350948e909080 (diff)
downloadports-59a4c814227869c1882dc7ab2f12ea40173b4b9b.tar.gz
ports-59a4c814227869c1882dc7ab2f12ea40173b4b9b.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/cracklib/Makefile22
1 files changed, 0 insertions, 22 deletions
diff --git a/security/cracklib/Makefile b/security/cracklib/Makefile
index dc4c3e984c5c..f4af648b735b 100644
--- a/security/cracklib/Makefile
+++ b/security/cracklib/Makefile
@@ -6,11 +6,6 @@ PORTVERSION= 2.9.7
CATEGORIES= security
MASTER_SITES= https://github.com/cracklib/cracklib/releases/download/v${PORTVERSION}/ \
LOCAL/cy
-.if !defined(PYTHON_SLAVEPORT)
-DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX} \
- ${WORDS_DISTFILE}
-EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
-.endif
MAINTAINER= cy@FreeBSD.org
COMMENT?= Password-checking library
@@ -24,22 +19,6 @@ CONFIGURE_ARGS= --with-default-dict=${DICTFILE}
INSTALL_TARGET= install-strip
USES= libtool tar:bz2
-.if defined(PYTHON_SLAVEPORT)
-CATEGORIES+= python
-
-USES+= python:2.7 localbase
-USE_PYTHON= flavors
-
-CONFIGURE_ARGS+=--disable-nls --with-python
-
-pre-build:
- cd ${WRKSRC}/lib && ${MAKE_CMD} libcrack.la
-
-do-test:
- @(cd ${BUILD_WKRSRC} && ${SETENV} PYTHONPATH=${STAGEDIR}${PYTHONPREFIX_SITELIBDIR} \
- ${PYTHON_CMD} -c \
- "from test_${PORTNAME} import run; run(use_dictpath=\"${DICTFILE:S|^${PREFIX}/|${LOCALBASE}/|}\")")
-.else
WORDS_DISTFILE= ${PORTNAME}-words-${PORTVERSION}.bz2
USE_LDCONFIG= yes
@@ -57,6 +36,5 @@ post-install:
${LN} -s ${PORTNAME}.3 ${STAGEDIR}${MAN3PREFIX}/man/man3/FascistCheck.3
@${MKDIR} ${STAGEDIR}${DICTPATH}
@PATH=$${PATH}:${STAGEDIR}${PREFIX}/sbin LD_LIBRARY_PATH=/lib:/usr/lib:${STAGEDIR}${PREFIX}/lib ${STAGEDIR}${PREFIX}/sbin/create-cracklib-dict -o ${STAGEDIR}${DICTPATH}/cracklib-words ${_DISTDIR}/${WORDS_DISTFILE}
-.endif
.include <bsd.port.mk>