aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2002-07-07 04:51:26 +0000
committerCy Schubert <cy@FreeBSD.org>2002-07-07 04:51:26 +0000
commita457a0b5e74ebf7791795eed32c8f8ed6c511f0a (patch)
tree193031fa95e9eb5436482ebfbed2bd1e770c929e /security
parent43356963b46dfd1c2150669ec31357a8c34ba5fc (diff)
downloadports-a457a0b5e74ebf7791795eed32c8f8ed6c511f0a.tar.gz
ports-a457a0b5e74ebf7791795eed32c8f8ed6c511f0a.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/l5/Makefile25
-rw-r--r--security/l5/distinfo1
-rw-r--r--security/l5/pkg-comment1
-rw-r--r--security/l5/pkg-descr15
-rw-r--r--security/l5/pkg-plist3
6 files changed, 46 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index bc3b103c8dcc..f6b10a6f7165 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -88,6 +88,7 @@
SUBDIR += kssh
SUBDIR += l0pht-watch
SUBDIR += l0phtcrack
+ SUBDIR += l5
SUBDIR += labrea
SUBDIR += lcrzo
SUBDIR += lcrzoex
diff --git a/security/l5/Makefile b/security/l5/Makefile
new file mode 100644
index 000000000000..fd5014ed0929
--- /dev/null
+++ b/security/l5/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: l6
+# Date created: Sat, 23 Jun 2002
+# Whom: andrew@scoop.co.nz
+#
+# $FreeBSD$
+#
+
+PORTNAME= l5
+PORTVERSION= 1.2
+CATEGORIES= security sysutils
+MASTER_SITES= http://ftp.cerias.purdue.edu/pub/tools/unix/sysutils/l5/
+DISTNAME= L5
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= andrew@scoop.co.nz
+
+NO_WRKSUBDIR= true
+ALL_TARGET= freebsd
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${MKDIR} ${PREFIX}/share/doc/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/security/l5/distinfo b/security/l5/distinfo
new file mode 100644
index 000000000000..aa13b0e7a596
--- /dev/null
+++ b/security/l5/distinfo
@@ -0,0 +1 @@
+MD5 (L5.tgz) = 750fddb8835098f8326a0b8b601bfcde
diff --git a/security/l5/pkg-comment b/security/l5/pkg-comment
new file mode 100644
index 000000000000..e44783c75b2f
--- /dev/null
+++ b/security/l5/pkg-comment
@@ -0,0 +1 @@
+File Integrity Assessment Tool
diff --git a/security/l5/pkg-descr b/security/l5/pkg-descr
new file mode 100644
index 000000000000..378883f324b3
--- /dev/null
+++ b/security/l5/pkg-descr
@@ -0,0 +1,15 @@
+After examining Tripwire and deciding that it was *way* overkill for my
+own purposes...
+
+...L5 simply walks down Unix or DOS filesystems, sort of like "ls -R" or
+"find" would, generating listings of anything it finds there. It tells
+you everything it can about a file's status, and adds on an MD5 hash of
+it. Its output is rather "numeric", but it is a very simple format and
+is designed to be post-treated by scripts that call L5...
+
+...Unlike Tripwire itself, this is NOT a complete toolkit -- one is
+expected to use it as a small, reliable part of a larger system...
+
+_H*
+
+Andrew McNaughton <andrew@scoop.co.nz>
diff --git a/security/l5/pkg-plist b/security/l5/pkg-plist
new file mode 100644
index 000000000000..9d5b9675f9d7
--- /dev/null
+++ b/security/l5/pkg-plist
@@ -0,0 +1,3 @@
+bin/l5
+share/doc/l5/README
+@dirrm share/doc/l5