aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2006-05-01 04:04:11 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2006-05-01 04:04:11 +0000
commita8137202c28ec64b62a403e05d548d0509712a8b (patch)
tree9578db5767f075c2b0d1592550a552a4429ebe90 /security
parentbbf54beefca557e77c02d6507cf3a15a52245d88 (diff)
downloadports-a8137202c28ec64b62a403e05d548d0509712a8b.tar.gz
ports-a8137202c28ec64b62a403e05d548d0509712a8b.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-Authen-TypeKey/Makefile35
-rw-r--r--security/p5-Authen-TypeKey/distinfo3
-rw-r--r--security/p5-Authen-TypeKey/pkg-descr8
-rw-r--r--security/p5-Authen-TypeKey/pkg-plist5
5 files changed, 52 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index c656c3a3868f..d0a3edc5fe51 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -290,6 +290,7 @@
SUBDIR += p5-Authen-Smb
SUBDIR += p5-Authen-TacacsPlus
SUBDIR += p5-Authen-Ticket
+ SUBDIR += p5-Authen-TypeKey
SUBDIR += p5-Business-PayPal-EWP
SUBDIR += p5-CSP
SUBDIR += p5-Crypt-Anubis
diff --git a/security/p5-Authen-TypeKey/Makefile b/security/p5-Authen-TypeKey/Makefile
new file mode 100644
index 000000000000..032c4012d040
--- /dev/null
+++ b/security/p5-Authen-TypeKey/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: p5-Authen-TypeKey
+# Date created: 2006-03-19
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Authen-TypeKey
+PORTVERSION= 0.05
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Authen
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= TypeKey authentication verification
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1 \
+ ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64 \
+ ${SITE_PERL}/Class/ErrorHandler.pm:${PORTSDIR}/devel/p5-Class-ErrorHandler \
+ ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/Math/BigInt.pm:${PORTSDIR}/math/p5-Math-BigInt
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Authen::TypeKey.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+IGNORE= requires perl 5.6.x or later. Install lang/perl5 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/security/p5-Authen-TypeKey/distinfo b/security/p5-Authen-TypeKey/distinfo
new file mode 100644
index 000000000000..c151fc83a554
--- /dev/null
+++ b/security/p5-Authen-TypeKey/distinfo
@@ -0,0 +1,3 @@
+MD5 (Authen-TypeKey-0.05.tar.gz) = 1a938b0d4e2d0ee6e6e09fd8c046edd2
+SHA256 (Authen-TypeKey-0.05.tar.gz) = 412f00ba42442efc20a9f23e106efe0aa1930c2835d134edd11418fcc8a382e5
+SIZE (Authen-TypeKey-0.05.tar.gz) = 17944
diff --git a/security/p5-Authen-TypeKey/pkg-descr b/security/p5-Authen-TypeKey/pkg-descr
new file mode 100644
index 000000000000..e0fc87b0eb4a
--- /dev/null
+++ b/security/p5-Authen-TypeKey/pkg-descr
@@ -0,0 +1,8 @@
+Authen::TypeKey is an implementation of verification for signatures
+generated by TypeKey authentication.
+
+For information on the TypeKey protocol and using TypeKey in other
+applications, see http://www.sixapart.com/typekey/api.
+
+Author: Six Apart Ltd, cpan@sixapart.com
+WWW: http://search.cpan.org/dist/Authen-TypeKey/
diff --git a/security/p5-Authen-TypeKey/pkg-plist b/security/p5-Authen-TypeKey/pkg-plist
new file mode 100644
index 000000000000..ae649af1468f
--- /dev/null
+++ b/security/p5-Authen-TypeKey/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Authen/TypeKey.pm
+@dirrmtry %%SITE_PERL%%/Authen
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Authen/TypeKey/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Authen/TypeKey
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Authen