aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorTAKATSU Tomonari <tota@FreeBSD.org>2016-01-29 06:54:50 +0000
committerTAKATSU Tomonari <tota@FreeBSD.org>2016-01-29 06:54:50 +0000
commitbabe15d122a4583859c6edbdbc807b04abdc5164 (patch)
tree09eeca1e20c98f6a0da9a4201c92ab1b72b3e37f /security
parent407486ba8a5475ea4bab731456503ad89b0f5d94 (diff)
downloadports-babe15d122a4583859c6edbdbc807b04abdc5164.tar.gz
ports-babe15d122a4583859c6edbdbc807b04abdc5164.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/R-cran-openssl/Makefile19
-rw-r--r--security/R-cran-openssl/distinfo2
-rw-r--r--security/R-cran-openssl/files/patch-src_ssl.c10
-rw-r--r--security/R-cran-openssl/pkg-descr12
5 files changed, 44 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index ddc094d16c05..5732ba9b93f9 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -7,6 +7,7 @@
SUBDIR += ADMsnmp
SUBDIR += R-cran-ROAuth
SUBDIR += R-cran-digest
+ SUBDIR += R-cran-openssl
SUBDIR += aescrypt
SUBDIR += aespipe
SUBDIR += afl
diff --git a/security/R-cran-openssl/Makefile b/security/R-cran-openssl/Makefile
new file mode 100644
index 000000000000..77ed4554b4cf
--- /dev/null
+++ b/security/R-cran-openssl/Makefile
@@ -0,0 +1,19 @@
+# Created by: TAKATSU Tomonari <tota@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= openssl
+PORTVERSION= 0.9.1
+CATEGORIES= security
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= tota@FreeBSD.org
+COMMENT= Toolkit for Encryption, Signatures and Certificates Based on OpenSSL
+
+LICENSE= MIT
+
+USES= cran:auto-plist
+
+post-patch:
+ @${REINPLACE_CMD} -e '/bin\//s|bash|sh|' ${WRKSRC}/configure
+
+.include <bsd.port.mk>
diff --git a/security/R-cran-openssl/distinfo b/security/R-cran-openssl/distinfo
new file mode 100644
index 000000000000..8c0cca59bc78
--- /dev/null
+++ b/security/R-cran-openssl/distinfo
@@ -0,0 +1,2 @@
+SHA256 (openssl_0.9.1.tar.gz) = 940feb0c3e9eb918bcdc58948e5c7807e0c9da49daae30eee7c3963c489ced02
+SIZE (openssl_0.9.1.tar.gz) = 882942
diff --git a/security/R-cran-openssl/files/patch-src_ssl.c b/security/R-cran-openssl/files/patch-src_ssl.c
new file mode 100644
index 000000000000..7bc05a053b44
--- /dev/null
+++ b/security/R-cran-openssl/files/patch-src_ssl.c
@@ -0,0 +1,10 @@
+--- src/ssl.c.orig 2016-01-18 12:03:01 UTC
++++ src/ssl.c
+@@ -11,6 +11,7 @@
+ const char *inet_ntop(int af, const void *src, char *dst, socklen_t size);
+ #else
+ #include <sys/socket.h>
++#include <netinet/in.h>
+ #include <resolv.h>
+ #include <netdb.h>
+ #include <arpa/inet.h>
diff --git a/security/R-cran-openssl/pkg-descr b/security/R-cran-openssl/pkg-descr
new file mode 100644
index 000000000000..72f6b0dee037
--- /dev/null
+++ b/security/R-cran-openssl/pkg-descr
@@ -0,0 +1,12 @@
+Bindings to OpenSSL libssl and libcrypto, plus custom SSH pubkey
+parsers. Supports RSA, DSA and NIST curves P-256, P-384 and P-521.
+Cryptographic signatures can either be created and verified manually
+or via x509 certificates. AES block cipher is used in CBC mode for
+symmetric encryption; RSA for asymmetric (public key) encryption.
+High-level envelope functions combine RSA and AES for encrypting
+arbitrary sized data. Other utilities include key generators, hash
+functions (md5, sha1, sha256, etc), base64 encoder, a secure random
+number generator, and 'bignum' math methods for manually performing
+crypto calculations on large multibyte integers.
+
+WWW: https://cran.r-project.org/web/packages/openssl/