aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2004-02-23 01:45:55 +0000
committerMark Linimon <linimon@FreeBSD.org>2004-02-23 01:45:55 +0000
commitc2430908d446d35c08f1c81c4e3e4892b64759af (patch)
tree80477c6b852ca641370cb4ec58bb15a747c65755 /security
parent115dfbb7056bb00bad957e0a2a8570ed6d4468c0 (diff)
downloadports-c2430908d446d35c08f1c81c4e3e4892b64759af.tar.gz
ports-c2430908d446d35c08f1c81c4e3e4892b64759af.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/f-prot-sig/Makefile41
-rw-r--r--security/f-prot-sig/pkg-descr14
-rw-r--r--security/f-prot-sig/pkg-message19
-rw-r--r--security/f-prot-sig/pkg-plist7
-rw-r--r--security/f-prot/Makefile16
-rw-r--r--security/f-prot/pkg-plist61
7 files changed, 123 insertions, 36 deletions
diff --git a/security/Makefile b/security/Makefile
index 3c6664d6718d..b73ab2daae4f 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -72,6 +72,7 @@
SUBDIR += drwebd
SUBDIR += dsniff
SUBDIR += f-prot
+ SUBDIR += f-prot-sig
SUBDIR += fakebo
SUBDIR += fakeident
SUBDIR += find-zlib
diff --git a/security/f-prot-sig/Makefile b/security/f-prot-sig/Makefile
new file mode 100644
index 000000000000..94a827ba62cc
--- /dev/null
+++ b/security/f-prot-sig/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: f-prot-sig
+# Date created: 11 Feb 2004
+# Whom: Tom McLaughlin <tmclaugh@sdf.lonestar.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= f-prot-sig
+PORTVERSION= 20040216
+CATEGORIES= security
+MASTER_SITES= ftp://ftp.f-prot.com/pub/
+
+DISTFILES= fp-def.zip \
+ macrdef2.zip
+
+MAINTAINER= tim@bishnet.net
+COMMENT= F-Prot Antivirus Signatures
+
+# F-Prot does not version their .DEF files so the port always pulls the latest.
+NO_CHECKSUM= yes
+
+NO_PACKAGE= Free for personal use only
+NO_CDROM= Free for personal use only
+RESTRICTED= Free for personal use only
+
+NO_BUILD= YES
+NO_WRKSUBDIR= YES
+USE_ZIP= YES
+
+post-extract:
+.for fetched in ${DISTFILES}
+ ${MV} ${DISTDIR}/${fetched} ${DISTDIR}/${fetched}-${PORTVERSION}.zip
+.endfor
+
+do-install:
+ ${MKDIR} ${PREFIX}/f-prot
+ ${INSTALL_DATA} ${WRKSRC}/* ${PREFIX}/f-prot
+
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/security/f-prot-sig/pkg-descr b/security/f-prot-sig/pkg-descr
new file mode 100644
index 000000000000..207bded05cf3
--- /dev/null
+++ b/security/f-prot-sig/pkg-descr
@@ -0,0 +1,14 @@
+F-Prot Antivirus for BSD Workstations utilizes the renowned F-Prot
+Antivirus scanning engine for primary scan but has in addition to
+that a system of internal heuristics devised to search for unknown
+viruses.
+
+This port contains the virus signature files for use with F-Prot
+Antivirus which can be found in ports under security/f-prot .
+
+Please note that the license explicitly permits that F-Prot Antivirus
+for BSD Workstations is free for personal users on personal
+workstations. For any other use please consult their website for
+licensing information.
+
+WWW: http://www.f-prot.com/
diff --git a/security/f-prot-sig/pkg-message b/security/f-prot-sig/pkg-message
new file mode 100644
index 000000000000..1db0dd808cf9
--- /dev/null
+++ b/security/f-prot-sig/pkg-message
@@ -0,0 +1,19 @@
+***************************************************************************
+
+This is a port of the virus signature files for F-Prot Antivirus.
+You will need to install the port security/f-prot to make use of them.
+
+The port disables verifying the checksum of the distfiles due to their
+frequency of change. If you wish to verify the files yourself you may use
+the PGP signature files that have been installed in:
+
+${PREFIX}/f-prot/
+
+The F-RISK public PGP key is located at:
+
+http://www.f-prot.com/company/KEY.ASC
+
+NOTE: The script check-updates.pl is all ready included with the f-prot
+port and can be used as a secondary means of updating virus signature files.
+
+***************************************************************************
diff --git a/security/f-prot-sig/pkg-plist b/security/f-prot-sig/pkg-plist
new file mode 100644
index 000000000000..0da4dc90885a
--- /dev/null
+++ b/security/f-prot-sig/pkg-plist
@@ -0,0 +1,7 @@
+f-prot/SIGN.ASC
+f-prot/SIGN.DEF
+f-prot/SIGN2.ASC
+f-prot/SIGN2.DEF
+f-prot/MACRO.DEF
+f-prot/MACRO.ASC
+@unexec rmdir f-prot 2> /dev/null || true
diff --git a/security/f-prot/Makefile b/security/f-prot/Makefile
index 452b29cba405..05d918cb1ab2 100644
--- a/security/f-prot/Makefile
+++ b/security/f-prot/Makefile
@@ -15,7 +15,8 @@ DISTNAME= fp-freebsd-ws-${PORTVERSION}
MAINTAINER= tim@bishnet.net
COMMENT= F-Prot Antivirus for BSD Workstations
-RUN_DEPENDS= ${SITE_PERL}/HTTP/Request.pm:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS= ${SITE_PERL}/HTTP/Request.pm:${PORTSDIR}/www/p5-libwww \
+ ${PREFIX}/f-prot/SIGN.DEF:${PORTSDIR}/security/f-prot-sig
NO_PACKAGE= Free for personal use only
NO_CDROM= Free for personal use only
@@ -29,8 +30,19 @@ MAN1= f-prot.1
ONLY_FOR_ARCHS= i386
do-install:
- cd ${WRKDIR} && ${TAR} -cf - f-prot | ${TAR} -xf - -C ${PREFIX}
+ cd ${WRKDIR} && ${TAR} --exclude man_pages \
+ --exclude doc_ws \
+ --exclude f-prot.sh \
+ --exclude *.DEF \
+ -cf - f-prot | ${TAR} -xf - -C ${PREFIX}
+
${INSTALL_SCRIPT} ${WRKSRC}/f-prot.sh ${PREFIX}/bin/f-prot
${INSTALL_MAN} ${WRKSRC}/man_pages/f-prot.1 ${MANPREFIX}/man/man1/
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${CP} -Rp ${WRKSRC}/doc_ws/* ${DOCSDIR}
+.endif
+
.include <bsd.port.mk>
diff --git a/security/f-prot/pkg-plist b/security/f-prot/pkg-plist
index 8658c12cf6c3..9ea9e0b58667 100644
--- a/security/f-prot/pkg-plist
+++ b/security/f-prot/pkg-plist
@@ -3,42 +3,35 @@ f-prot/CHANGES
f-prot/ENGLISH.TX0
f-prot/INSTALL.bsd_ws
f-prot/LICENSE
-f-prot/MACRO.DEF
f-prot/README
-f-prot/SIGN.DEF
-f-prot/SIGN2.DEF
-f-prot/doc_ws/add_info.html
-f-prot/doc_ws/auto_updt.html
-f-prot/doc_ws/comm_scan.html
-f-prot/doc_ws/index.html
-f-prot/doc_ws/inf_eicar.gif
-f-prot/doc_ws/info_options.html
-f-prot/doc_ws/inst_pro.html
-f-prot/doc_ws/license.html
-f-prot/doc_ws/loc_files.html
-f-prot/doc_ws/macro_scanning_options.html
-f-prot/doc_ws/main_feat.html
-f-prot/doc_ws/man_updt.html
-f-prot/doc_ws/norm_scan.gif
-f-prot/doc_ws/per_scan.html
-f-prot/doc_ws/reporting_options.html
-f-prot/doc_ws/scanning_options.html
-f-prot/doc_ws/screenshot.jpg
-f-prot/doc_ws/sys_req.html
-f-prot/doc_ws/test_eicar.html
-f-prot/doc_ws/test_inst.html
-f-prot/doc_ws/updater.html
-f-prot/doc_ws/updater_req.html
-f-prot/doc_ws/updt_macro.gif
-f-prot/doc_ws/updt_sign.gif
-f-prot/doc_ws/updt_signature.gif
f-prot/f-prot
-f-prot/f-prot.sh
f-prot/install-f-prot.pl
-f-prot/man_pages/check-updates.pl.8
-f-prot/man_pages/f-prot.1
f-prot/tools/check-updates.pl
-@dirrm f-prot/doc_ws
-@dirrm f-prot/man_pages
+%%PORTDOCS%%%%DOCSDIR%%/add_info.html
+%%PORTDOCS%%%%DOCSDIR%%/auto_updt.html
+%%PORTDOCS%%%%DOCSDIR%%/comm_scan.html
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/inf_eicar.gif
+%%PORTDOCS%%%%DOCSDIR%%/info_options.html
+%%PORTDOCS%%%%DOCSDIR%%/inst_pro.html
+%%PORTDOCS%%%%DOCSDIR%%/license.html
+%%PORTDOCS%%%%DOCSDIR%%/loc_files.html
+%%PORTDOCS%%%%DOCSDIR%%/macro_scanning_options.html
+%%PORTDOCS%%%%DOCSDIR%%/main_feat.html
+%%PORTDOCS%%%%DOCSDIR%%/man_updt.html
+%%PORTDOCS%%%%DOCSDIR%%/norm_scan.gif
+%%PORTDOCS%%%%DOCSDIR%%/per_scan.html
+%%PORTDOCS%%%%DOCSDIR%%/reporting_options.html
+%%PORTDOCS%%%%DOCSDIR%%/scanning_options.html
+%%PORTDOCS%%%%DOCSDIR%%/screenshot.jpg
+%%PORTDOCS%%%%DOCSDIR%%/sys_req.html
+%%PORTDOCS%%%%DOCSDIR%%/test_eicar.html
+%%PORTDOCS%%%%DOCSDIR%%/test_inst.html
+%%PORTDOCS%%%%DOCSDIR%%/updater.html
+%%PORTDOCS%%%%DOCSDIR%%/updater_req.html
+%%PORTDOCS%%%%DOCSDIR%%/updt_macro.gif
+%%PORTDOCS%%%%DOCSDIR%%/updt_sign.gif
+%%PORTDOCS%%%%DOCSDIR%%/updt_signature.gif
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm f-prot/tools
-@dirrm f-prot/
+@unexec rmdir f-prot 2> /dev/null || true