aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-09-19 15:57:53 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2019-09-19 15:57:53 +0000
commit22143e5ad205ff320b7bf418fdac3cc9627e8f74 (patch)
tree1531c120bc91676c84dbbac405350f14fca74996 /security
parent0807be7361c4d8b95381de6ce40b74c3f151a5b3 (diff)
downloadports-22143e5ad205ff320b7bf418fdac3cc9627e8f74.tar.gz
ports-22143e5ad205ff320b7bf418fdac3cc9627e8f74.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/samhain/Makefile34
1 files changed, 16 insertions, 18 deletions
diff --git a/security/samhain/Makefile b/security/samhain/Makefile
index 971192cf112e..c5abec58c0af 100644
--- a/security/samhain/Makefile
+++ b/security/samhain/Makefile
@@ -3,6 +3,7 @@
PORTNAME= samhain
PORTVERSION= 4.3.2
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://la-samhna.de/archive/
DISTNAME= samhain_signed-${PORTVERSION}
@@ -16,12 +17,16 @@ BROKEN_aarch64= fails to build: undefined reference to sbrk
BROKEN_mips= fails to configure: error: Could not find the libwrap library
BROKEN_mips64= fails to configure: error: Could not find the libwrap library
-OPTIONS_DEFINE= ASM DB_RELOAD DEBUG DNMALLOC DOCS ENCRYPT GNUPG IPV6 KCHECK \
- LIBWRAP LOGFILE_MONITOR LOGIN_WATCH MAIL MOUNTS_CHECK MYSQL \
- ODBC PGSQL PORT_CHECK PROCESS_CHECK POSIX_ACL PRELUDE PTRACE \
- SRP STATIC SUIDCHECK UDP USERFILES XML_LOGS
-OPTIONS_DEFAULT=ASM DNMALLOC ENCRYPT LIBWRAP MAIL SRP
+OPTIONS_DEFINE= ASM DB_RELOAD DEBUG DNMALLOC DOCS ENCRYPT GNUPG IPV6 \
+ KCHECK LIBWRAP LOGFILE_MONITOR LOGIN_WATCH MAIL \
+ MOUNTS_CHECK PORT_CHECK POSIX_ACL PRELUDE PROCESS_CHECK \
+ PTRACE SRP STATIC SUIDCHECK UDP USERFILES XML_LOGS
+OPTIONS_DEFAULT= ASM DNMALLOC ENCRYPT LIBWRAP MAIL SRP
+OPTIONS_RADIO= DB
+OPTIONS_RADIO_DB= MYSQL ODBC PGSQL
+OPTIONS_SUB= yes
+DB_DESC= Database support
DB_RELOAD_DESC= Enable database reload on SIGHUP
DNMALLOC_DESC= Enable dnmalloc
ENCRYPT_DESC= Enable client/server encryption
@@ -41,8 +46,6 @@ UDP_DESC= Enable UDP server
USERFILES_DESC= Enable check for users config files
XML_LOGS_DESC= Enable XML-formatted logs
-OPTIONS_SUB= yes
-
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
GNU_CONFIGURE= yes
@@ -82,14 +85,17 @@ MAIL_CONFIGURE_ENABLE= mail
MOUNTS_CHECK_CONFIGURE_ENABLE= mounts-check
+MYSQL_IMPLIES= XML_LOGS
MYSQL_USES= mysql
-MYSQL_CONFIGURE_ARGS= --with-database=mysql
+MYSQL_CONFIGURE_ON= --with-database=mysql
-ODBC_CONFIGURE_ARGS= --with-database=odbc
+ODBC_IMPLIES= XML_LOGS
ODBC_LIB_DEPENDS= libodbc.so:databases/unixODBC
+ODBC_CONFIGURE_ON= --with-database=odbc
+PGSQL_IMPLIES= XML_LOGS
PGSQL_USES= pgsql
-PGSQL_CONFIGURE_ARGS= --with-database=postgresql
+PGSQL_CONFIGURE_ON= --with-database=postgresql
PORT_CHECK_CONFIGURE_ENABLE= port-check
@@ -168,14 +174,6 @@ IGNORE= can't build client and server at once
@${ECHO_MSG}
.endif
-.if ${PORT_OPTIONS:MMYSQL} && ! ${PORT_OPTIONS:MXML_LOGS}
-IGNORE= xml logging is required to log to MySQL
-.endif
-
-.if ${PORT_OPTIONS:MPGSQL} && ! ${PORT_OPTIONS:MXML_LOGS}
-IGNORE= xml logging is required to log to Postgres
-.endif
-
post-extract:
@${TAR} -C ${WRKDIR} -xzf ${WRKSRC}.tar.gz
@${RM} ${WRKSRC}.tar.gz ${WRKSRC}.tar.gz.asc