aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-08-21 14:08:06 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-08-21 14:08:06 +0000
commitc9cf6c61132115ca4b6476190fe9576d06ee06db (patch)
treea29fe29c38d5df1895cfbe84019093fae61a6b42 /security
parentb100cd9f05b8e71f0cd2e142eafe47d54108a79c (diff)
downloadports-c9cf6c61132115ca4b6476190fe9576d06ee06db.tar.gz
ports-c9cf6c61132115ca4b6476190fe9576d06ee06db.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/p5-App-Genpass/Makefile3
-rw-r--r--security/p5-Authen-Simple-LDAP/Makefile3
-rw-r--r--security/p5-Authen-Simple/Makefile3
-rw-r--r--security/p5-CACertOrg-CA/Makefile3
-rw-r--r--security/p5-IO-Async-SSL/Makefile3
5 files changed, 10 insertions, 5 deletions
diff --git a/security/p5-App-Genpass/Makefile b/security/p5-App-Genpass/Makefile
index ce86061dbfcd..eb89bc57bad3 100644
--- a/security/p5-App-Genpass/Makefile
+++ b/security/p5-App-Genpass/Makefile
@@ -24,7 +24,8 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-List-MoreUtils>=0:${PORTSDIR}/lang/p5-List-MoreUtils \
p5-Test-Deep>=0:${PORTSDIR}/devel/p5-Test-Deep
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
REINPLACE_ARGS= -i ''
MAN1= genpass.1
diff --git a/security/p5-Authen-Simple-LDAP/Makefile b/security/p5-Authen-Simple-LDAP/Makefile
index 962cbc94ef99..87fc49c2d73e 100644
--- a/security/p5-Authen-Simple-LDAP/Makefile
+++ b/security/p5-Authen-Simple-LDAP/Makefile
@@ -18,7 +18,8 @@ BUILD_DEPENDS= p5-Authen-Simple>=0:${PORTSDIR}/security/p5-Authen-Simple \
p5-perl-ldap>=0:${PORTSDIR}/net/p5-perl-ldap
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN3= Authen::Simple::ActiveDirectory.3 \
Authen::Simple::LDAP.3
diff --git a/security/p5-Authen-Simple/Makefile b/security/p5-Authen-Simple/Makefile
index db42c914d5b2..eaedfabf75cf 100644
--- a/security/p5-Authen-Simple/Makefile
+++ b/security/p5-Authen-Simple/Makefile
@@ -19,7 +19,8 @@ BUILD_DEPENDS= p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor \
p5-Params-Validate>=0:${PORTSDIR}/devel/p5-Params-Validate
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN3= Authen::Simple.3 \
Authen::Simple::Adapter.3 \
diff --git a/security/p5-CACertOrg-CA/Makefile b/security/p5-CACertOrg-CA/Makefile
index 040da65db7ba..693bc891cedb 100644
--- a/security/p5-CACertOrg-CA/Makefile
+++ b/security/p5-CACertOrg-CA/Makefile
@@ -11,7 +11,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= CACert.org CA root certificate in PEM format
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN3= CACertOrg::CA.3
diff --git a/security/p5-IO-Async-SSL/Makefile b/security/p5-IO-Async-SSL/Makefile
index 5f236015a45a..4a94569e49d7 100644
--- a/security/p5-IO-Async-SSL/Makefile
+++ b/security/p5-IO-Async-SSL/Makefile
@@ -21,7 +21,8 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= ${LOCALBASE}/bin/socat:${PORTSDIR}/net/socat \
p5-Test-Pod>=1:${PORTSDIR}/devel/p5-Test-Pod
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN3= IO::Async::SSL.3 \
IO::Async::SSLStream.3