aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorDmitri Goutnik <dmgk@FreeBSD.org>2019-09-19 14:44:07 +0000
committerDmitri Goutnik <dmgk@FreeBSD.org>2019-09-19 14:44:07 +0000
commite73360392ca6e69b763798e1896c686a3375c9dd (patch)
tree13e11425b000932d51b849f1b897ea523b4f6e1a /security
parent08398c97bb34ef33ba08d3932e204a6ca42d7810 (diff)
downloadports-e73360392ca6e69b763798e1896c686a3375c9dd.tar.gz
ports-e73360392ca6e69b763798e1896c686a3375c9dd.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/botan2/Makefile41
-rw-r--r--security/botan2/distinfo6
-rw-r--r--security/botan2/files/patch-boost-1.7051
-rw-r--r--security/botan2/pkg-plist11
4 files changed, 36 insertions, 73 deletions
diff --git a/security/botan2/Makefile b/security/botan2/Makefile
index 434775748320..a223749ba406 100644
--- a/security/botan2/Makefile
+++ b/security/botan2/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= botan
-DISTVERSION= 2.10.0
-PORTREVISION= 4
+DISTVERSION= 2.11.0
CATEGORIES= security
MASTER_SITES= http://botan.randombit.net/releases/
PKGNAMESUFFIX= 2
@@ -14,26 +13,30 @@ COMMENT= Portable, easy to use and efficient C++ crypto library
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/license.txt
-BROKEN_armv6= include/arm_neon.h:28:2: error: "NEON support not enabled"
+BROKEN_armv6= include/arm_neon.h:28:2: error: "NEON support not enabled"
LIB_DEPENDS= libboost_filesystem.so:devel/boost-libs
-USES= compiler:c++11-lang gmake python:build shebangfix tar:tgz
-SHEBANG_FILES= configure.py src/scripts/install.py
-HAS_CONFIGURE= yes
+USES= compiler:c++11-lang gmake python:build shebangfix tar:xz
USE_LDCONFIG= yes
-CONFIGURE_SCRIPT= configure.py
-CONFIGURE_ARGS= --with-external-includedir=${PREFIX}/include \
- --with-external-libdir=${PREFIX}/lib \
- --with-boost --with-bzip2 --with-lzma --with-zlib \
- --cc=${COMPILER_TYPE}
-LDFLAGS+= -pthread
-
-SHLIBVER= ${DISTVERSION:S/./ /g:[2]}
-PLIST_SUB= SHLIBVER=${SHLIBVER}
+SHEBANG_FILES= configure.py src/scripts/install.py
-DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}-${PORTVERSION}
+HAS_CONFIGURE= yes
+CONFIGURE_SCRIPT= configure.py
+CONFIGURE_ARGS= --cc=${COMPILER_TYPE} \
+ --with-boost \
+ --with-bzip2 \
+ --with-external-includedir=${LOCALBASE}/include \
+ --with-external-libdir=${LOCALBASE}/lib \
+ --with-lzma \
+ --with-zlib
+LDFLAGS+= -pthread
+
+DOCSDIR= ${LOCALBASE}/share/doc/${PORTNAME}-${PORTVERSION}
+
+_SHLIBVER= ${DISTVERSION:S/./ /g:[2]}
+PLIST_SUB= SHLIBVER=${_SHLIBVER}
PORTDOCS= *
OPTIONS_DEFINE= DOCS SQLITE3 SSL
@@ -52,6 +55,10 @@ SSL_CONFIGURE_WITH= openssl
CONFIGURE_ARGS+= --cc-abi="-march=armv8-a+crypto"
.endif
+.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1200000
+CONFIGURE_ARGS+= --without-os-features=getentropy,elf_aux_info
+.endif
+
.if ${ARCH} == i386 || ${ARCH} == amd64
PLIST_SUB+= HAS_RDRAND_RNG=""
.else
@@ -63,6 +70,6 @@ post-patch:
${WRKSRC}/src/build-data/cc/clang.txt
post-install:
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/botan ${STAGEDIR}${PREFIX}/lib/libbotan-2.so.${SHLIBVER}.${SHLIBVER}.0
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/botan ${STAGEDIR}${PREFIX}/lib/libbotan-2.so.${_SHLIBVER}.${_SHLIBVER}.0
.include <bsd.port.mk>
diff --git a/security/botan2/distinfo b/security/botan2/distinfo
index 0ff1501b0937..4ea9cbd42bb0 100644
--- a/security/botan2/distinfo
+++ b/security/botan2/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1554050060
-SHA256 (Botan-2.10.0.tgz) = 88481997578c27924724fea76610d43d9f59c99edfe561d41803bbc98871ad31
-SIZE (Botan-2.10.0.tgz) = 7240021
+TIMESTAMP = 1568364010
+SHA256 (Botan-2.11.0.tar.xz) = f7874da2aeb8c018fd77df40b2137879bf90b66f5589490c991e83fb3e8094be
+SIZE (Botan-2.11.0.tar.xz) = 5765712
diff --git a/security/botan2/files/patch-boost-1.70 b/security/botan2/files/patch-boost-1.70
deleted file mode 100644
index 055854e2d931..000000000000
--- a/security/botan2/files/patch-boost-1.70
+++ /dev/null
@@ -1,51 +0,0 @@
-boost 1.70 compatibility (accepted upstream)
-https://github.com/randombit/botan/pull/1881
-
---- src/cli/tls_http_server.cpp.orig 2019-01-04 11:14:58 UTC
-+++ src/cli/tls_http_server.cpp
-@@ -41,6 +41,12 @@
-
- #include "credentials.h"
-
-+#if BOOST_VERSION >= 107000
-+#define GET_IO_SERVICE(s) ((boost::asio::io_context&)(s).get_executor().context())
-+#else
-+#define GET_IO_SERVICE(s) ((s).get_io_service())
-+#endif
-+
- namespace Botan_CLI {
-
- namespace {
-@@ -435,7 +441,7 @@ class TLS_Asio_HTTP_Server final
- session::pointer make_session()
- {
- return session::create(
-- m_acceptor.get_io_service(),
-+ GET_IO_SERVICE(m_acceptor),
- m_session_manager,
- m_creds,
- m_policy);
---- src/cli/tls_proxy.cpp.orig 2019-01-04 11:14:58 UTC
-+++ src/cli/tls_proxy.cpp
-@@ -33,6 +33,12 @@
-
- #include "credentials.h"
-
-+#if BOOST_VERSION >= 107000
-+#define GET_IO_SERVICE(s) ((boost::asio::io_context&)(s).get_executor().context())
-+#else
-+#define GET_IO_SERVICE(s) ((s).get_io_service())
-+#endif
-+
- namespace Botan_CLI {
-
- namespace {
-@@ -370,7 +376,7 @@ class tls_proxy_server final
- session::pointer make_session()
- {
- return session::create(
-- m_acceptor.get_io_service(),
-+ GET_IO_SERVICE(m_acceptor),
- m_session_manager,
- m_creds,
- m_policy,
diff --git a/security/botan2/pkg-plist b/security/botan2/pkg-plist
index 8f6e9454e9e9..586142c92221 100644
--- a/security/botan2/pkg-plist
+++ b/security/botan2/pkg-plist
@@ -3,7 +3,12 @@ include/botan-2/botan/adler32.h
include/botan-2/botan/aead.h
include/botan-2/botan/aes.h
include/botan-2/botan/alg_id.h
+include/botan-2/botan/argon2.h
include/botan-2/botan/aria.h
+include/botan-2/botan/asio_async_ops.h
+include/botan-2/botan/asio_context.h
+include/botan-2/botan/asio_error.h
+include/botan-2/botan/asio_stream.h
include/botan-2/botan/asn1_alt_name.h
include/botan-2/botan/asn1_attribute.h
include/botan-2/botan/asn1_obj.h
@@ -14,12 +19,12 @@ include/botan-2/botan/asn1_time.h
include/botan-2/botan/assert.h
include/botan-2/botan/atomic.h
include/botan-2/botan/auto_rng.h
-include/botan-2/botan/b64_filt.h
include/botan-2/botan/base32.h
include/botan-2/botan/base58.h
include/botan-2/botan/base64.h
include/botan-2/botan/basefilt.h
include/botan-2/botan/bcrypt.h
+include/botan-2/botan/bcrypt_pbkdf.h
include/botan-2/botan/ber_dec.h
include/botan-2/botan/bigint.h
include/botan-2/botan/blake2b.h
@@ -43,6 +48,8 @@ include/botan-2/botan/ccm.h
include/botan-2/botan/cecpq1.h
include/botan-2/botan/cert_status.h
include/botan-2/botan/certstor.h
+include/botan-2/botan/certstor_flatfile.h
+include/botan-2/botan/certstor_system.h
include/botan-2/botan/certstor_sql.h
%%SQLITE3%%include/botan-2/botan/certstor_sqlite.h
include/botan-2/botan/cfb.h
@@ -116,7 +123,6 @@ include/botan-2/botan/gost_3411.h
include/botan-2/botan/hash.h
include/botan-2/botan/hash_id.h
include/botan-2/botan/hex.h
-include/botan-2/botan/hex_filt.h
include/botan-2/botan/hkdf.h
include/botan-2/botan/hmac.h
include/botan-2/botan/hmac_drbg.h
@@ -236,6 +242,7 @@ include/botan-2/botan/sm2.h
include/botan-2/botan/sm2_enc.h
include/botan-2/botan/sm3.h
include/botan-2/botan/sm4.h
+include/botan-2/botan/sodium.h
include/botan-2/botan/sp800_108.h
include/botan-2/botan/sp800_56a.h
include/botan-2/botan/sp800_56c.h