aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2010-03-23 21:01:52 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2010-03-23 21:01:52 +0000
commit16804915d9759807719673ea93121edbd3e62e50 (patch)
tree7758418122195f753397a0147d0f5762f0de8ace /security
parent656511a3efb1fa43a8894195a452a9ac36a748fe (diff)
downloadports-16804915d9759807719673ea93121edbd3e62e50.tar.gz
ports-16804915d9759807719673ea93121edbd3e62e50.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/polarssl/Makefile19
-rw-r--r--security/polarssl/distinfo6
2 files changed, 21 insertions, 4 deletions
diff --git a/security/polarssl/Makefile b/security/polarssl/Makefile
index b7a111fb756a..da062668f70e 100644
--- a/security/polarssl/Makefile
+++ b/security/polarssl/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= polarssl
-PORTVERSION= 0.12.1
+PORTVERSION= 0.13.0
DISTVERSIONSUFFIX= -gpl
CATEGORIES= security devel
MASTER_SITES= http://polarssl.org/code/download/
@@ -15,9 +15,26 @@ EXTRACT_SUFX= .tgz
MAINTAINER= dinoex@FreeBSD.org
COMMENT= Open Source embedded SSL/TLS cryptographic library
+USE_CMAKE= yes
+USE_PERL5_BUILD= yes
+
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+CMAKE_BUILD_TYPE= release
PORTDOCS= ChangeLog LICENSE README
+BINFILES= aescrypt2 benchmark dh_client dh_genprime dh_server hello \
+ md5sum mpi_demo rsa_genkey rsa_sign rsa_verify selftest \
+ sha1sum sha2sum ssl_cert_test ssl_client1 ssl_client2 \
+ ssl_server ssl_test
+
+# cmake install is broken, so we do it by hand
+do-install:
+ @${TAR} -C ${WRKSRC}/include -cf - polarssl | ${TAR} -C ${PREFIX}/include -xf -
+ ${INSTALL_DATA} ${WRKSRC}/library/libpolarssl.a ${PREFIX}/lib/
+.for i in ${BINFILES}
+ ${INSTALL_DATA} ${WRKSRC}/programs/*/${i} ${PREFIX}/bin/polarssl_${i}
+.endfor
+
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
diff --git a/security/polarssl/distinfo b/security/polarssl/distinfo
index 7e3063cf9c99..6c004fe37ca9 100644
--- a/security/polarssl/distinfo
+++ b/security/polarssl/distinfo
@@ -1,3 +1,3 @@
-MD5 (polarssl-0.12.1-gpl.tgz) = 08bc85a19bbe65493076b9968b421e80
-SHA256 (polarssl-0.12.1-gpl.tgz) = 4bd79758b22e04b653e3e825847e3c72b4aab51685fa2acdb6fe00431c8bb8f3
-SIZE (polarssl-0.12.1-gpl.tgz) = 335160
+MD5 (polarssl-0.13.0-gpl.tgz) = 4d21060523c8e25b4464b9b01ed031e1
+SHA256 (polarssl-0.13.0-gpl.tgz) = f45d92b6d2b4f1a8b1e85ac2d7c4597a255b87e38c6ef53d0f6cc000b9755087
+SIZE (polarssl-0.13.0-gpl.tgz) = 342686