aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-05-21 23:55:39 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-05-21 23:55:39 +0000
commit48870e228aaa878922672948be3b01c14c0adf8a (patch)
tree8b2209ecf909c418939c6cf6d9546f37c5cf71b3 /security
parentb1415e4ab8517d3e136485c48f18e7db255e2a11 (diff)
downloadports-48870e228aaa878922672948be3b01c14c0adf8a.tar.gz
ports-48870e228aaa878922672948be3b01c14c0adf8a.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/hydra/Makefile8
-rw-r--r--security/hydra/distinfo4
-rw-r--r--security/hydra/files/patch-Makefile.am11
-rw-r--r--security/hydra/files/patch-hydra-gtk-make_xhydra.sh11
-rw-r--r--security/hydra/files/patch-hydra-gtk-src-callbacks.c84
-rw-r--r--security/hydra/files/patch-hydra-teamspeak.c26
6 files changed, 139 insertions, 5 deletions
diff --git a/security/hydra/Makefile b/security/hydra/Makefile
index f133823e1520..dbd3c929162e 100644
--- a/security/hydra/Makefile
+++ b/security/hydra/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= hydra
-PORTVERSION= 4.5
+PORTVERSION= 4.6
CATEGORIES= security
MASTER_SITES= http://www.thc.org/releases/ \
${MASTER_SITE_PACKETSTORM}
@@ -18,9 +18,11 @@ MAINTAINER= llevier@argosnet.com
COMMENT= Brute force attack utility working on multiple network services
NO_LATEST_LINK= yes
-PLIST_FILES= bin/hydra
+PLIST_FILES= bin/hydra bin/xhydra
USE_REINPLACE= yes
GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_GNOME= gtk20
USE_OPENSSL= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-src
@@ -30,6 +32,6 @@ post-patch:
${WRKSRC}/Makefile.am
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/hydra ${PREFIX}/bin
+ @${INSTALL_PROGRAM} ${WRKSRC}/hydra ${WRKSRC}/hydra-gtk/src/xhydra ${PREFIX}/bin
.include <bsd.port.mk>
diff --git a/security/hydra/distinfo b/security/hydra/distinfo
index 72e8c4a52781..8c64579ba615 100644
--- a/security/hydra/distinfo
+++ b/security/hydra/distinfo
@@ -1,2 +1,2 @@
-MD5 (hydra-4.5-src.tar.gz) = 04c45be0ded184d0f7e92c7a4a936f82
-SIZE (hydra-4.5-src.tar.gz) = 166724
+MD5 (hydra-4.6-src.tar.gz) = e41a6653cb0b75c0ab2033c84ebb92cc
+SIZE (hydra-4.6-src.tar.gz) = 171063
diff --git a/security/hydra/files/patch-Makefile.am b/security/hydra/files/patch-Makefile.am
new file mode 100644
index 000000000000..e53e0c72fec0
--- /dev/null
+++ b/security/hydra/files/patch-Makefile.am
@@ -0,0 +1,11 @@
+--- Makefile.am.orig Fri May 20 16:54:16 2005
++++ Makefile.am Fri May 20 16:54:24 2005
+@@ -36,7 +36,7 @@
+ @echo
+
+ xhydra:
+- -cd hydra-gtk && ./make_xhydra.sh
++ -cd hydra-gtk && sh make_xhydra.sh
+
+ pw-inspector: pw-inspector.c
+ -$(CC) $(OPTS) -o pw-inspector pw-inspector.c
diff --git a/security/hydra/files/patch-hydra-gtk-make_xhydra.sh b/security/hydra/files/patch-hydra-gtk-make_xhydra.sh
new file mode 100644
index 000000000000..6a1dd92c9b7c
--- /dev/null
+++ b/security/hydra/files/patch-hydra-gtk-make_xhydra.sh
@@ -0,0 +1,11 @@
+--- hydra-gtk/make_xhydra.sh.orig Fri May 20 17:03:45 2005
++++ hydra-gtk/make_xhydra.sh Fri May 20 17:04:06 2005
+@@ -8,7 +8,7 @@
+ cat errors
+ exit 1
+ }
+-make > /dev/null 2> errors
++gmake > /dev/null 2> errors
+ test -e src/xhydra || {
+ echo "Error: could not compile. Analyse this:"
+ cat errors
diff --git a/security/hydra/files/patch-hydra-gtk-src-callbacks.c b/security/hydra/files/patch-hydra-gtk-src-callbacks.c
new file mode 100644
index 000000000000..b3810d78bd71
--- /dev/null
+++ b/security/hydra/files/patch-hydra-gtk-src-callbacks.c
@@ -0,0 +1,84 @@
+--- hydra-gtk/src/callbacks.c.realorig Tue Jun 8 00:33:18 2004
++++ hydra-gtk/src/callbacks.c Sat May 21 14:20:53 2005
+@@ -69,21 +69,6 @@
+
+ options[0] = HYDRA_BIN;
+
+- /* get the target, or target list */
+- widget = lookup_widget(GTK_WIDGET(wndMain), "radioTarget1");
+- if ( gtk_toggle_button_get_active((GtkToggleButton *) widget) ){
+- widget = lookup_widget(GTK_WIDGET(wndMain), "entTarget");
+- options[i++] = (char *) gtk_entry_get_text((GtkEntry *) widget);
+- } else {
+- options[i++] = "-M";
+- widget = lookup_widget(GTK_WIDGET(wndMain), "entTargetFile");
+- options[i++] = (char *) gtk_entry_get_text((GtkEntry *) widget);
+- }
+-
+- /* get the service */
+- widget = lookup_widget(GTK_WIDGET(wndMain), "entProtocol");
+- options[i++] = (char *) gtk_entry_get_text((GtkEntry *) widget);
+-
+ /* get the port */
+ widget = lookup_widget(GTK_WIDGET(wndMain), "spnPort");
+ j = gtk_spin_button_get_value_as_int((GtkSpinButton *) widget);
+@@ -307,6 +292,21 @@
+ }
+ }
+
++ /* get the target, or target list */
++ widget = lookup_widget(GTK_WIDGET(wndMain), "radioTarget1");
++ if ( gtk_toggle_button_get_active((GtkToggleButton *) widget) ){
++ widget = lookup_widget(GTK_WIDGET(wndMain), "entTarget");
++ options[i++] = (char *) gtk_entry_get_text((GtkEntry *) widget);
++ } else {
++ options[i++] = "-M";
++ widget = lookup_widget(GTK_WIDGET(wndMain), "entTargetFile");
++ options[i++] = (char *) gtk_entry_get_text((GtkEntry *) widget);
++ }
++
++ /* get the service */
++ widget = lookup_widget(GTK_WIDGET(wndMain), "entProtocol");
++ options[i++] = (char *) gtk_entry_get_text((GtkEntry *) widget);
++
+ options[i] = NULL;
+ return i;
+ }
+@@ -472,8 +472,8 @@
+ int *popen_re_unbuffered(char *command) {
+ static int p_r[2] = {-1, -1}, p_e[2] = {-1, -1};
+ static int *pfd = NULL;
+- hydra_pid = 0;
+ char *options[128];
++ hydra_pid = 0;
+
+ update_statusbar();
+
+@@ -494,6 +494,7 @@
+ g_warning("popen_rw_unbuffered: Error forking!");
+ return NULL;
+ } else if (hydra_pid == 0) { /* child */
++ int k;
+ if (setpgid(getpid(), getpid()) < 0)
+ g_warning("popen_rw_unbuffered: setpgid() failed");
+ if (close(p_r[0]) < 0)
+@@ -517,7 +518,6 @@
+ execv(HYDRA_BIN, options);
+
+ g_warning("%s %i: popen_rw_unbuffered: execv() returned", __FILE__, __LINE__);
+- int k;
+ for ( k = 0; options[k] != NULL; k++ ){
+ g_warning(options[k]);
+ }
+@@ -669,8 +669,9 @@
+ on_chkColon_toggled (GtkToggleButton *togglebutton,
+ gpointer user_data)
+ {
+- GtkWidget *user = lookup_widget(GTK_WIDGET(wndMain), "frmUsername");;
+- GtkWidget *pass = lookup_widget(GTK_WIDGET(wndMain), "frmPass");
++ GtkWidget *user, *pass;
++ user = lookup_widget(GTK_WIDGET(wndMain), "frmUsername");;
++ pass = lookup_widget(GTK_WIDGET(wndMain), "frmPass");
+
+ if (gtk_toggle_button_get_active(togglebutton)){
+ gtk_widget_set_sensitive(user, FALSE);
diff --git a/security/hydra/files/patch-hydra-teamspeak.c b/security/hydra/files/patch-hydra-teamspeak.c
new file mode 100644
index 000000000000..57a4692504a2
--- /dev/null
+++ b/security/hydra/files/patch-hydra-teamspeak.c
@@ -0,0 +1,26 @@
+--- hydra-teamspeak.c.orig Thu Jan 6 16:39:55 2005
++++ hydra-teamspeak.c Sat May 21 20:00:40 2005
+@@ -14,11 +14,6 @@
+ char *login, *pass;
+ char buf[100];
+
+- if (strlen(login = hydra_get_next_login()) == 0)
+- login = empty;
+- if (strlen(pass = hydra_get_next_password()) == 0)
+- pass = empty;
+-
+ struct team_speak {
+ char header[16];
+ unsigned long crc;
+@@ -35,6 +30,11 @@
+ char login[29];
+ };
+ struct team_speak teamspeak;
++
++ if (strlen(login = hydra_get_next_login()) == 0)
++ login = empty;
++ if (strlen(pass = hydra_get_next_password()) == 0)
++ pass = empty;
+
+ memset(&teamspeak, 0, sizeof(struct team_speak));
+