aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2008-06-08 13:20:15 +0000
committerPav Lucistnik <pav@FreeBSD.org>2008-06-08 13:20:15 +0000
commit528cf594311828ff2e9bebfc935cd38d4d881cd0 (patch)
tree1a827dc7e6851758f111a7480b408393f983fe21 /security
parent256e9c60bceea67e6f877eeae713a05be10accad (diff)
downloadports-528cf594311828ff2e9bebfc935cd38d4d881cd0.tar.gz
ports-528cf594311828ff2e9bebfc935cd38d4d881cd0.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/openvas-client/Makefile2
-rw-r--r--security/openvas-libnasl/Makefile2
-rw-r--r--security/openvas-libnasl/files/patch-configure12
-rw-r--r--security/openvas-libraries/Makefile3
-rw-r--r--security/openvas-libraries/Makefile.common4
-rw-r--r--security/openvas-libraries/files/patch-configure20
-rw-r--r--security/openvas-libraries/files/patch-libopenvas-Makefile105
-rw-r--r--security/openvas-libraries/files/patch-openvas-libraries.tmpl.in23
-rw-r--r--security/openvas-plugins/Makefile9
-rw-r--r--security/openvas-server/Makefile5
-rw-r--r--security/openvas-server/Makefile.common4
-rw-r--r--security/openvas-server/files/patch-openvas.tmpl.in20
-rw-r--r--security/openvas-server/files/patch-openvasd-Makefile141
13 files changed, 314 insertions, 36 deletions
diff --git a/security/openvas-client/Makefile b/security/openvas-client/Makefile
index 2919c99bbe9e..945aa7d09395 100644
--- a/security/openvas-client/Makefile
+++ b/security/openvas-client/Makefile
@@ -20,6 +20,6 @@ GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_GNOME= gtk20
-.include "${.CURDIR}/../../security/openvas-server/Makefile.common"
+.include "${.CURDIR}/../../security/openvas-libraries/Makefile.common"
.include <bsd.port.mk>
diff --git a/security/openvas-libnasl/Makefile b/security/openvas-libnasl/Makefile
index a081a3d336d1..ea70c641c542 100644
--- a/security/openvas-libnasl/Makefile
+++ b/security/openvas-libnasl/Makefile
@@ -29,6 +29,6 @@ USE_BISON= build
MAN1= openvas-libnasl-config.1 openvas-nasl.1
-.include "${.CURDIR}/../../security/openvas-server/Makefile.common"
+.include "${.CURDIR}/../../security/openvas-libraries/Makefile.common"
.include <bsd.port.mk>
diff --git a/security/openvas-libnasl/files/patch-configure b/security/openvas-libnasl/files/patch-configure
new file mode 100644
index 000000000000..cbf67bba1ca7
--- /dev/null
+++ b/security/openvas-libnasl/files/patch-configure
@@ -0,0 +1,12 @@
+remove obsolete objformat
+--- configure.orig 2008-06-06 11:23:51.000000000 +0900
++++ configure 2008-06-06 11:24:15.000000000 +0900
+@@ -6339,7 +6339,7 @@
+
+ freebsd*)
+ objformat=`test -x /usr/bin/objformat && /usr/bin/objformat || echo aout`
+- version_type=freebsd-$objformat
++ version_type=freebsd-elf
+ case $version_type in
+ freebsd-elf*)
+ library_names_spec='${libname}${release}.so$versuffix ${libname}${release}.so $libname.so'
diff --git a/security/openvas-libraries/Makefile b/security/openvas-libraries/Makefile
index cdc82967464e..6b57f07fa34a 100644
--- a/security/openvas-libraries/Makefile
+++ b/security/openvas-libraries/Makefile
@@ -17,12 +17,13 @@ COMMENT= Libraries for OpenVAS
LIB_DEPENDS= gnutls.26:${PORTSDIR}/security/gnutls
LDFLAGS+= -L${LOCALBASE}/lib
+CPPFLAGS+= -I${LOCALBASE}/include
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
MAN1= libopenvas-config.1
-.include "${.CURDIR}/../../security/openvas-server/Makefile.common"
+.include "${.CURDIR}/Makefile.common"
.include <bsd.port.mk>
diff --git a/security/openvas-libraries/Makefile.common b/security/openvas-libraries/Makefile.common
new file mode 100644
index 000000000000..5ce24ac6ba7f
--- /dev/null
+++ b/security/openvas-libraries/Makefile.common
@@ -0,0 +1,4 @@
+CONFIGURE_ARGS+= --includedir=${PREFIX}/include \
+ --localstatedir=${PREFIX}/openvas \
+ --sharedstatedir=${PREFIX}/openvas/com \
+ --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
diff --git a/security/openvas-libraries/files/patch-configure b/security/openvas-libraries/files/patch-configure
index 48f5768c9321..79b71384e91b 100644
--- a/security/openvas-libraries/files/patch-configure
+++ b/security/openvas-libraries/files/patch-configure
@@ -1,6 +1,16 @@
--- configure.orig 2008-03-27 03:57:28.000000000 +0900
-+++ configure 2008-04-26 22:00:22.000000000 +0900
-@@ -8136,7 +8136,7 @@
++++ configure 2008-06-06 09:42:17.000000000 +0900
+@@ -6343,7 +6343,8 @@
+
+ freebsd*)
+ objformat=`test -x /usr/bin/objformat && /usr/bin/objformat || echo aout`
+- version_type=freebsd-$objformat
++ # recent FreeBSD only supports elf. objformat was removed from FreeBSD 7
++ version_type=freebsd-elf
+ case $version_type in
+ freebsd-elf*)
+ library_names_spec='${libname}${release}.so$versuffix ${libname}${release}.so $libname.so'
+@@ -8136,7 +8137,7 @@
echo $ECHO_N "(cached) $ECHO_C" >&6
else
ac_check_lib_save_LIBS=$LIBS
@@ -9,7 +19,7 @@
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
_ACEOF
-@@ -8192,7 +8192,7 @@
+@@ -8192,7 +8193,7 @@
{ echo "$as_me:$LINENO: result: $ac_cv_lib_resolv___dn_expand" >&5
echo "${ECHO_T}$ac_cv_lib_resolv___dn_expand" >&6; }
if test $ac_cv_lib_resolv___dn_expand = yes; then
@@ -18,7 +28,7 @@
else
{ { echo "$as_me:$LINENO: error: you need to install resolve library with development files" >&5
echo "$as_me: error: you need to install resolve library with development files" >&2;}
-@@ -8290,11 +8290,11 @@
+@@ -8290,11 +8291,11 @@
#ifdef __cplusplus
extern "C"
#endif
@@ -32,7 +42,7 @@
;
return 0;
}
-@@ -12909,7 +12909,7 @@
+@@ -12909,7 +12910,7 @@
echo $ECHO_N "(cached) $ECHO_C" >&6
else
ac_check_lib_save_LIBS=$LIBS
diff --git a/security/openvas-libraries/files/patch-libopenvas-Makefile b/security/openvas-libraries/files/patch-libopenvas-Makefile
new file mode 100644
index 000000000000..de0a529417c6
--- /dev/null
+++ b/security/openvas-libraries/files/patch-libopenvas-Makefile
@@ -0,0 +1,105 @@
+honor CPPFLAGS and CFLAGS
+
+--- libopenvas/Makefile.orig 2008-04-27 17:29:09.000000000 +0900
++++ libopenvas/Makefile 2008-04-27 17:29:32.000000000 +0900
+@@ -46,76 +46,76 @@
+
+
+ getopt.o : getopt.c
+- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c getopt.c
++ $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CPPFLAGS) $(CFLAGS) -c getopt.c
+
+ getopt1.o : getopt1.c
+- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c getopt1.c
++ $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CPPFLAGS) $(CFLAGS) -c getopt1.c
+
+ plugutils.o : plugutils.c
+- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c plugutils.c
++ $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CPPFLAGS) $(CFLAGS) -c plugutils.c
+
+ resolve.o : resolve.c resolve.h
+- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c resolve.c
++ $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CPPFLAGS) $(CFLAGS) -c resolve.c
+
+ share_fd.o : share_fd.c
+- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c share_fd.c
++ $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CPPFLAGS) $(CFLAGS) -c share_fd.c
+
+ system.o : system.c system_internal.h
+- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c system.c
++ $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CPPFLAGS) $(CFLAGS) -c system.c
+
+ arglists.o : arglists.c
+- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c arglists.c
++ $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CPPFLAGS) $(CFLAGS) -c arglists.c
+
+ network.o : network.c
+- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c network.c
++ $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CPPFLAGS) $(CFLAGS) -c network.c
+
+ scanners_utils.o : scanners_utils.c scanners_utils.h
+- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c scanners_utils.c
++ $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CPPFLAGS) $(CFLAGS) -c scanners_utils.c
+
+ ftp_funcs.o : ftp_funcs.c ftp_funcs.h
+- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c ftp_funcs.c
++ $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CPPFLAGS) $(CFLAGS) -c ftp_funcs.c
+ www_funcs.o : www_funcs.c
+- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c www_funcs.c
++ $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CPPFLAGS) $(CFLAGS) -c www_funcs.c
+
+ pcap.o : pcap.c
+- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c pcap.c
++ $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CPPFLAGS) $(CFLAGS) -c pcap.c
+
+ hlst.o : hlst.c hlst.h
+- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c hlst.c
++ $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CPPFLAGS) $(CFLAGS) -c hlst.c
+
+ ptycall.o : ptycall.c
+- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c ptycall.c
++ $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CPPFLAGS) $(CFLAGS) -c ptycall.c
+
+ harglists.o : harglists.c
+- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c harglists.c
++ $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CPPFLAGS) $(CFLAGS) -c harglists.c
+
+ ids_send.o : ids_send.c
+- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c ids_send.c
++ $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CPPFLAGS) $(CFLAGS) -c ids_send.c
+
+ bpf_share.o: bpf_share.c
+- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c bpf_share.c
++ $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CPPFLAGS) $(CFLAGS) -c bpf_share.c
+
+ rand.o: rand.c
+- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c rand.c
++ $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CPPFLAGS) $(CFLAGS) -c rand.c
+
+ popen.o: popen.c
+- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c popen.c
++ $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CPPFLAGS) $(CFLAGS) -c popen.c
+
+ services.o: services.c
+- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -DNESSUS_STATE_DIR=\"$(localstatedir)\" -c services.c
++ $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CPPFLAGS) $(CFLAGS) -DNESSUS_STATE_DIR=\"$(localstatedir)\" -c services.c
+
+ services1.o: services1.c
+- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -DNESSUS_STATE_DIR=\"$(localstatedir)\" -DCONF_DIR=\"$(sysconfdir)\" -c services1.c
++ $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CPPFLAGS) $(CFLAGS) -DNESSUS_STATE_DIR=\"$(localstatedir)\" -DCONF_DIR=\"$(sysconfdir)\" -c services1.c
+
+ proctitle.o: proctitle.c
+- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c proctitle.c
++ $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CPPFLAGS) $(CFLAGS) -c proctitle.c
+
+ store.o: store.c
+- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -DNESSUS_STATE_DIR=\"$(localstatedir)\" -c store.c
++ $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CPPFLAGS) $(CFLAGS) -DNESSUS_STATE_DIR=\"$(localstatedir)\" -c store.c
+
+
+ kb.o: kb.c
+- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c kb.c
++ $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CPPFLAGS) $(CFLAGS) -c kb.c
+
+
+ libopenvas.la: $(OBJS)
diff --git a/security/openvas-libraries/files/patch-openvas-libraries.tmpl.in b/security/openvas-libraries/files/patch-openvas-libraries.tmpl.in
index 232183bd4c46..bae7561c6aa4 100644
--- a/security/openvas-libraries/files/patch-openvas-libraries.tmpl.in
+++ b/security/openvas-libraries/files/patch-openvas-libraries.tmpl.in
@@ -1,11 +1,14 @@
---- openvas-libraries.tmpl.in.orig 2008-04-26 22:46:43.000000000 +0900
-+++ openvas-libraries.tmpl.in 2008-04-26 22:47:03.000000000 +0900
-@@ -45,7 +45,7 @@
+honor CPPFLAGS and LDFLAGS
+--- openvas-libraries.tmpl.in.orig 2008-03-21 06:00:30.000000000 +0900
++++ openvas-libraries.tmpl.in 2008-04-27 17:27:45.000000000 +0900
+@@ -62,8 +62,9 @@
+ DEBUG_SSL = @debug_ssl@
- libsdir=${rootdir}/libs
- top_builddir = @PWDD@
--include= -I. -I$(rootdir)/include
-+include= -I. -I$(rootdir)/include -I$(includedir)
- lib_dir=@libdir@
- USE_CIPHER=@cipher_cflags@
- INSTALL=@INSTALL@
+ # Some defines you may want to modify
++CPPFLAGS=@CPPFLAGS@
+ DEFS=@DEFS@ $(DEBUG_SSL) $(USE_CIPHER) $(DEBUG)
+-LDFLAGS=
++LDFLAGS=@LDFLAGS@
+
+ # Your C compiler
+ CC=@CC@
diff --git a/security/openvas-plugins/Makefile b/security/openvas-plugins/Makefile
index 052efd7d944b..fb4d0ad86af2 100644
--- a/security/openvas-plugins/Makefile
+++ b/security/openvas-plugins/Makefile
@@ -27,7 +27,12 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include `${LIBNET_CONFIG} --cflags`" \
LDFLAGS="-L${LOCALBASE}/lib"
MAN1= openvas-build.1
-.include "${.CURDIR}/../../security/openvas-server/Makefile.common"
+.include "${.CURDIR}/../../security/openvas-libraries/Makefile.common"
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != "i386"
+BROKEN= does not compile
+.endif
post-patch:
@${REINPLACE_CMD} -e 's|-lnet|`${LIBNET_CONFIG} --libs`|' \
@@ -35,4 +40,4 @@ post-patch:
@${REINPLACE_CMD} -e 's|libnet-config|${LIBNET_CONFIG}|' \
${WRKSRC}/plugins/3com_hub/Makefile
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/security/openvas-server/Makefile b/security/openvas-server/Makefile
index f0e4bc0082f1..e2f41e942730 100644
--- a/security/openvas-server/Makefile
+++ b/security/openvas-server/Makefile
@@ -17,6 +17,9 @@ COMMENT= A security scanner: a fork of Nessus
LIB_DEPENDS= openvas.1:${PORTSDIR}/security/openvas-libraries \
openvasnasl.1:${PORTSDIR}/security/openvas-libnasl
+LDFLAGS+= -L${LOCALBASE}/lib
+CPPFLAGS+= -I${LOCALBASE}/include
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
GNU_CONFIGURE= yes
# XXX openvas-mkcert uses gettext
USE_GETTEXT= yes
@@ -25,6 +28,6 @@ USE_RC_SUBR= openvasd
MAN1= openvas-check-signature.1 openvas-mkrand.1
MAN8= openvasd.8 openvas-adduser.8 openvas-rmuser.8 openvas-mkcert.8
-.include "${.CURDIR}/../../security/openvas-server/Makefile.common"
+.include "${.CURDIR}/../../security/openvas-libraries/Makefile.common"
.include <bsd.port.mk>
diff --git a/security/openvas-server/Makefile.common b/security/openvas-server/Makefile.common
deleted file mode 100644
index f3e23716c281..000000000000
--- a/security/openvas-server/Makefile.common
+++ /dev/null
@@ -1,4 +0,0 @@
-CONFIGURE_ARGS+= --includedir=${LOCALBASE}/include \
- --localstatedir=${PREFIX}/openvas \
- --sharedstatedir=${PREFIX}/openvas/com \
- --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
diff --git a/security/openvas-server/files/patch-openvas.tmpl.in b/security/openvas-server/files/patch-openvas.tmpl.in
index 6836a333dd90..6549a391e990 100644
--- a/security/openvas-server/files/patch-openvas.tmpl.in
+++ b/security/openvas-server/files/patch-openvas.tmpl.in
@@ -1,11 +1,9 @@
---- openvas.tmpl.in.orig 2008-04-27 00:54:18.000000000 +0900
-+++ openvas.tmpl.in 2008-04-27 00:54:45.000000000 +0900
-@@ -36,7 +36,7 @@
- srcdir=${rootdir}/src
- libsdir=${rootdir}/libs
- top_builddir = @PWDD@
--include= -I. -I$(rootdir)/include
-+include= -I. -I$(rootdir)/include -I$(includedir)
- INSTALL=@INSTALL@
- INSTALL_DIR=@INSTALL_DIR@
- installuser=@installuser@
+--- openvas.tmpl.in.orig 2007-10-18 04:25:43.000000000 +0900
++++ openvas.tmpl.in 2008-04-27 17:52:51.000000000 +0900
+@@ -128,5 +128,6 @@
+ NASLCFLAGS=@NASLCFLAGS@
+ OPENVAS_CFLAGS=$(CWARN) $(include) $(OVSCFLAGS) $(NASLCFLAGS) $(OPENVAS_DIRECTORIES)
+ CFLAGS=@CFLAGS@
++CPPFLAGS=@CPPFLAGS@
+
+ LIBS=@LIBS@
diff --git a/security/openvas-server/files/patch-openvasd-Makefile b/security/openvas-server/files/patch-openvasd-Makefile
new file mode 100644
index 000000000000..16266997267f
--- /dev/null
+++ b/security/openvas-server/files/patch-openvasd-Makefile
@@ -0,0 +1,141 @@
+--- openvasd/Makefile.orig 2008-04-27 17:49:28.000000000 +0900
++++ openvasd/Makefile 2008-04-27 17:50:41.000000000 +0900
+@@ -46,105 +46,105 @@
+ @chmod +x cflags
+
+ openvasd : cflags $(OBJS)
+- $(CC) $(LDFLAGS) $(OPENVAS_INCLUDE) $(OBJS) -o openvasd $(LIBS)
++ $(CC) $(LDFLAGS) $(OPENVAS_INCLUDE) $(CPPFLAGS) $(OBJS) -o openvasd $(LIBS)
+
+ openvas-check-signature : cflags openvas-check-signature.o
+- $(CC) $(LDFLAGS) $(OPENVAS_INCLUDE) openvas-check-signature.o -o openvas-check-signature $(LIBS)
++ $(CC) $(LDFLAGS) $(OPENVAS_INCLUDE) $(CPPFLAGS) openvas-check-signature.o -o openvas-check-signature $(LIBS)
+
+ openvas-check-signature.o: openvas-check-signature.c
+- $(CC) $(CFLAGS) $(OPENVAS_INCLUDE) -c openvas-check-signature.c
++ $(CC) $(CFLAGS) $(OPENVAS_INCLUDE) $(CPPFLAGS) -c openvas-check-signature.c
+
+ users.o : cflags users.c users.h
+- $(CC) $(CFLAGS) $(OPENVAS_INCLUDE) -c users.c
++ $(CC) $(CFLAGS) $(OPENVAS_INCLUDE) $(CPPFLAGS) -c users.c
+
+ processes.o : cflags processes.c processes.h
+- $(CC) $(CFLAGS) $(OPENVAS_INCLUDE) -c processes.c
++ $(CC) $(CFLAGS) $(OPENVAS_INCLUDE) $(CPPFLAGS) -c processes.c
+
+ rules.o : cflags rules.c rules.h
+- $(CC) $(CFLAGS) $(OPENVAS_INCLUDE) -c rules.c
++ $(CC) $(CFLAGS) $(OPENVAS_INCLUDE) $(CPPFLAGS) -c rules.c
+
+ preferences.o : cflags preferences.c preferences.h
+- $(CC) $(CFLAGS) $(OPENVAS_INCLUDE) -c preferences.c
++ $(CC) $(CFLAGS) $(OPENVAS_INCLUDE) $(CPPFLAGS) -c preferences.c
+
+ pluginload.o : cflags pluginload.h pluginload.c
+- $(CC) $(CFLAGS) $(OPENVAS_INCLUDE) -c pluginload.c
++ $(CC) $(CFLAGS) $(OPENVAS_INCLUDE) $(CPPFLAGS) -c pluginload.c
+
+ openvasd.o : cflags openvasd.c
+- $(CC) $(CFLAGS) $(OPENVAS_INCLUDE) -c openvasd.c
++ $(CC) $(CFLAGS) $(OPENVAS_INCLUDE) $(CPPFLAGS) -c openvasd.c
+
+ auth.o : cflags auth.c auth.h
+- $(CC) $(CFLAGS) $(OPENVAS_INCLUDE) -c auth.c
++ $(CC) $(CFLAGS) $(OPENVAS_INCLUDE) $(CPPFLAGS) -c auth.c
+
+ attack.o : cflags attack.c attack.h
+- $(CC) $(CFLAGS) $(OPENVAS_INCLUDE) -c attack.c
++ $(CC) $(CFLAGS) $(OPENVAS_INCLUDE) $(CPPFLAGS) -c attack.c
+
+ comm.o : cflags comm.c comm.h
+- $(CC) $(CFLAGS) $(OPENVAS_INCLUDE) -c comm.c
++ $(CC) $(CFLAGS) $(OPENVAS_INCLUDE) $(CPPFLAGS) -c comm.c
+
+ utils.o : cflags utils.c utils.h
+- $(CC) $(CFLAGS) $(OPENVAS_INCLUDE) -c utils.c
++ $(CC) $(CFLAGS) $(OPENVAS_INCLUDE) $(CPPFLAGS) -c utils.c
+
+ log.o : cflags log.c log.h
+- $(CC) $(CFLAGS) $(OPENVAS_INCLUDE) -c log.c
++ $(CC) $(CFLAGS) $(OPENVAS_INCLUDE) $(CPPFLAGS) -c log.c
+
+ sighand.o : cflags sighand.c sighand.h
+- $(CC) $(CFLAGS) $(OPENVAS_INCLUDE) -c sighand.c
++ $(CC) $(CFLAGS) $(OPENVAS_INCLUDE) $(CPPFLAGS) -c sighand.c
+
+ ntp_10.o : cflags ntp_10.c ntp_10.h
+- $(CC) $(CFLAGS) $(OPENVAS_INCLUDE) -c ntp_10.c
++ $(CC) $(CFLAGS) $(OPENVAS_INCLUDE) $(CPPFLAGS) -c ntp_10.c
+
+ ntp_11.o : cflags ntp_11.c ntp_11.h
+- $(CC) $(CFLAGS) $(OPENVAS_INCLUDE) -c ntp_11.c
++ $(CC) $(CFLAGS) $(OPENVAS_INCLUDE) $(CPPFLAGS) -c ntp_11.c
+
+ parser.o : cflags parser.c parser.h
+- $(CC) $(CFLAGS) $(OPENVAS_INCLUDE) -c parser.c
++ $(CC) $(CFLAGS) $(OPENVAS_INCLUDE) $(CPPFLAGS) -c parser.c
+
+ piic.o : cflags piic.c piic.h
+- $(CC) $(CFLAGS) $(OPENVAS_INCLUDE) -c piic.c
++ $(CC) $(CFLAGS) $(OPENVAS_INCLUDE) $(CPPFLAGS) -c piic.c
+
+ nasl_plugins.o : cflags nasl_plugins.c
+- $(CC) $(CFLAGS) $(OPENVAS_INCLUDE) -c nasl_plugins.c
++ $(CC) $(CFLAGS) $(OPENVAS_INCLUDE) $(CPPFLAGS) -c nasl_plugins.c
+
+ nes_plugins.o : cflags nes_plugins.c
+- $(CC) $(CFLAGS) $(OPENVAS_INCLUDE) -c nes_plugins.c
++ $(CC) $(CFLAGS) $(OPENVAS_INCLUDE) $(CPPFLAGS) -c nes_plugins.c
+
+ plugs_req.o : cflags plugs_req.c
+- $(CC) $(CFLAGS) $(OPENVAS_INCLUDE) -c plugs_req.c
++ $(CC) $(CFLAGS) $(OPENVAS_INCLUDE) $(CPPFLAGS) -c plugs_req.c
+
+ save_tests.o : cflags save_tests.c save_tests.h
+- $(CC) $(CFLAGS) $(OPENVAS_INCLUDE) -c save_tests.c
++ $(CC) $(CFLAGS) $(OPENVAS_INCLUDE) $(CPPFLAGS) -c save_tests.c
+
+ save_kb.o : cflags save_kb.c save_kb.h
+- $(CC) $(CFLAGS) $(OPENVAS_INCLUDE) -c save_kb.c
++ $(CC) $(CFLAGS) $(OPENVAS_INCLUDE) $(CPPFLAGS) -c save_kb.c
+
+ detached.o : cflags detached.c detached.h
+- $(CC) $(CFLAGS) $(OPENVAS_INCLUDE) -c detached.c
++ $(CC) $(CFLAGS) $(OPENVAS_INCLUDE) $(CPPFLAGS) -c detached.c
+
+ pluginlaunch.o : cflags pluginlaunch.c
+- $(CC) $(CFLAGS) $(OPENVAS_INCLUDE) -c pluginlaunch.c
++ $(CC) $(CFLAGS) $(OPENVAS_INCLUDE) $(CPPFLAGS) -c pluginlaunch.c
+
+ locks.o : cflags locks.c
+- $(CC) $(CFLAGS) $(OPENVAS_INCLUDE) -c locks.c
++ $(CC) $(CFLAGS) $(OPENVAS_INCLUDE) $(CPPFLAGS) -c locks.c
+
+
+ dirutils.o : cflags dirutils.c
+- $(CC) $(CFLAGS) $(OPENVAS_INCLUDE) -c dirutils.c
++ $(CC) $(CFLAGS) $(OPENVAS_INCLUDE) $(CPPFLAGS) -c dirutils.c
+
+
+ plugs_hash.o : cflags plugs_hash.c
+- $(CC) $(CFLAGS) $(OPENVAS_INCLUDE) -c plugs_hash.c
++ $(CC) $(CFLAGS) $(OPENVAS_INCLUDE) $(CPPFLAGS) -c plugs_hash.c
+
+ pluginupload.o : cflags pluginupload.c
+- $(CC) $(CFLAGS) $(OPENVAS_INCLUDE) -c pluginupload.c
++ $(CC) $(CFLAGS) $(OPENVAS_INCLUDE) $(CPPFLAGS) -c pluginupload.c
+
+ pluginscheduler.o : cflags pluginscheduler.c
+- $(CC) $(CFLAGS) $(OPENVAS_INCLUDE) -c pluginscheduler.c
++ $(CC) $(CFLAGS) $(OPENVAS_INCLUDE) $(CPPFLAGS) -c pluginscheduler.c
+
+ hosts.o : cflags hosts.c
+- $(CC) $(CFLAGS) $(OPENVAS_INCLUDE) -c hosts.c
++ $(CC) $(CFLAGS) $(OPENVAS_INCLUDE) $(CPPFLAGS) -c hosts.c
+
+ shared_socket.o : cflags shared_socket.c
+- $(CC) $(CFLAGS) $(OPENVAS_INCLUDE) -c shared_socket.c
++ $(CC) $(CFLAGS) $(OPENVAS_INCLUDE) $(CPPFLAGS) -c shared_socket.c
+ clean :
+ rm -f *.o openvasd openvas-check-signature *~ cflags
+