aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-09-23 08:07:57 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-09-23 08:07:57 +0000
commit5837bf2776069bab1ad100c0ca6c9ca47c1c7522 (patch)
tree5f292df2291135c60867a4dc0faf696f557f934f /security
parenteb61a3cda1392ced669b4f9f42d9d7c7f2b6dd4f (diff)
Notes
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/pear-Crypt_MicroID/Makefile23
-rw-r--r--security/pear-Crypt_MicroID/distinfo3
-rw-r--r--security/pear-Crypt_MicroID/pkg-descr3
4 files changed, 30 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index d45b68dc1085..8ba0b28f3c95 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -559,6 +559,7 @@
SUBDIR += pear-Crypt_DiffieHellman
SUBDIR += pear-Crypt_GPG
SUBDIR += pear-Crypt_HMAC
+ SUBDIR += pear-Crypt_MicroID
SUBDIR += pear-Crypt_RC4
SUBDIR += pear-Crypt_RSA
SUBDIR += pear-File_HtAccess
diff --git a/security/pear-Crypt_MicroID/Makefile b/security/pear-Crypt_MicroID/Makefile
new file mode 100644
index 000000000000..94519b39ceb6
--- /dev/null
+++ b/security/pear-Crypt_MicroID/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: pear-Crypt_MicroID
+# Date created: 2008-09-22
+# Whom: Martin Wilke <miwi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Crypt_MicroID
+PORTVERSION= 0.1.0
+CATEGORIES= security www pear
+
+MAINTAINER= miwi@FreeBSD.org
+COMMENT= PHP MicroID library.
+
+BUILD_DEPENDS+= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+RUN_DEPENDS+= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+
+FILES= Crypt/MicroID.php Crypt/MicroID/AlgorithmNotFoundException.php
+TESTS= 001-generate.phpt 002-verify.phpt tests-config.php
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
+.include <bsd.port.post.mk>
diff --git a/security/pear-Crypt_MicroID/distinfo b/security/pear-Crypt_MicroID/distinfo
new file mode 100644
index 000000000000..97bc95c0feaf
--- /dev/null
+++ b/security/pear-Crypt_MicroID/distinfo
@@ -0,0 +1,3 @@
+MD5 (PEAR/Crypt_MicroID-0.1.0.tgz) = d3516f2e05926c7184dbb530a90c18f7
+SHA256 (PEAR/Crypt_MicroID-0.1.0.tgz) = 8e9196cc686b367a571ba76ac7f065ff339a939586fce816d957ae263b707064
+SIZE (PEAR/Crypt_MicroID-0.1.0.tgz) = 2954
diff --git a/security/pear-Crypt_MicroID/pkg-descr b/security/pear-Crypt_MicroID/pkg-descr
new file mode 100644
index 000000000000..4a1fbb520d8a
--- /dev/null
+++ b/security/pear-Crypt_MicroID/pkg-descr
@@ -0,0 +1,3 @@
+Provides methods needed to generate and verify MicroIDs.
+
+WWW: http://pear.php.net/package/Crypt_MicroID/