aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-28 12:58:54 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-28 12:58:54 +0000
commit5c308e91fbec2684b771dc5abf51d9fc3e4712de (patch)
treed00161006c21b702e0b4101b9368c48356b8d794 /security
parentf737d0f044cec61036d97d71f02c943288de8665 (diff)
Notes
Diffstat (limited to 'security')
-rw-r--r--security/isnprober/Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/security/isnprober/Makefile b/security/isnprober/Makefile
index 2d8b96b06d15..0def7f90812f 100644
--- a/security/isnprober/Makefile
+++ b/security/isnprober/Makefile
@@ -17,16 +17,17 @@ RUN_DEPENDS= p5-Net-RawIP>=0:${PORTSDIR}/net/p5-Net-RawIP
PLIST_FILES= bin/${PORTNAME}
PORTDOCS= README
-USES= perl5
+USES= perl5 shebangfix
USE_PERL5= run
NO_BUILD= yes
-NO_STAGE= yes
+SHEBANG_FILES= isnprober
+
+OPTIONS_DEFINE= DOCS
+
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
-.ifndef NOPORTDOCS
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}/
-.endif
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>