aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2007-06-01 08:20:31 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2007-06-01 08:20:31 +0000
commit9274ab617e6c47e79f0167e3601ac4bd5a23f004 (patch)
tree9db338736e02452f64611789ff6dfb6787e20fa1 /security
parent1c7f69533096ec924c3b875a43e9689fa8019d71 (diff)
downloadports-9274ab617e6c47e79f0167e3601ac4bd5a23f004.tar.gz
ports-9274ab617e6c47e79f0167e3601ac4bd5a23f004.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/gsasl/Makefile6
-rw-r--r--security/gsasl/Makefile.man2
-rw-r--r--security/gsasl/distinfo6
-rw-r--r--security/gsasl/files/patch-lib::lt-main.sh15
-rw-r--r--security/gsasl/files/patch-ltmain.sh15
-rw-r--r--security/gsasl/pkg-plist7
6 files changed, 15 insertions, 36 deletions
diff --git a/security/gsasl/Makefile b/security/gsasl/Makefile
index 47578e9ff62b..3c123cf1a739 100644
--- a/security/gsasl/Makefile
+++ b/security/gsasl/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= gsasl
-PORTVERSION= 0.2.12
+PORTVERSION= 0.2.16
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_GNU_ALPHA} \
http://josefsson.org/${PORTNAME}/releases/
@@ -24,8 +24,10 @@ USE_GNOME= gnomehack gnometarget pkgconfig
USE_GETOPT_LONG= yes
USE_PERL5_BUILD= yes
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --mandir=${PREFIX}/man \
+ --infodir=${PREFIX}/info
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
INFO= gsasl
diff --git a/security/gsasl/Makefile.man b/security/gsasl/Makefile.man
index 54b9bd6ab2eb..a9bda8e485a5 100644
--- a/security/gsasl/Makefile.man
+++ b/security/gsasl/Makefile.man
@@ -100,6 +100,8 @@ MAN3+= gsasl_server_step.3
MAN3+= gsasl_server_step_base64.3
MAN3+= gsasl_server_suggest_mechanism.3
MAN3+= gsasl_server_support_p.3
+MAN3+= gsasl_session_hook_get.3
+MAN3+= gsasl_session_hook_set.3
MAN3+= gsasl_simple_getpass.3
MAN3+= gsasl_step.3
MAN3+= gsasl_step64.3
diff --git a/security/gsasl/distinfo b/security/gsasl/distinfo
index 0f7dce0acbae..6b2c77d5efa2 100644
--- a/security/gsasl/distinfo
+++ b/security/gsasl/distinfo
@@ -1,3 +1,3 @@
-MD5 (gsasl-0.2.12.tar.gz) = a3d8188f373579a31c26b2bd1a75f194
-SHA256 (gsasl-0.2.12.tar.gz) = 303901144da2964b4f397d3a51218df076c227b010993240e683f43df4e56381
-SIZE (gsasl-0.2.12.tar.gz) = 2725477
+MD5 (gsasl-0.2.16.tar.gz) = eb23cc53c7a176fa39c1c9ec7257b018
+SHA256 (gsasl-0.2.16.tar.gz) = 47dc89ff255055fae7b212c7f568126ab456bce2ad6e4ce02db71b40ab6c626a
+SIZE (gsasl-0.2.16.tar.gz) = 3139739
diff --git a/security/gsasl/files/patch-lib::lt-main.sh b/security/gsasl/files/patch-lib::lt-main.sh
deleted file mode 100644
index 9c7ffd7cfbcc..000000000000
--- a/security/gsasl/files/patch-lib::lt-main.sh
+++ /dev/null
@@ -1,15 +0,0 @@
---- lib/ltmain.sh.orig Sat Apr 17 08:15:31 2004
-+++ lib/ltmain.sh Sat Apr 17 08:16:16 2004
-@@ -5528,10 +5528,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false ; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/security/gsasl/files/patch-ltmain.sh b/security/gsasl/files/patch-ltmain.sh
deleted file mode 100644
index 8869ae9e49a2..000000000000
--- a/security/gsasl/files/patch-ltmain.sh
+++ /dev/null
@@ -1,15 +0,0 @@
---- ltmain.sh.orig Thu Oct 30 16:27:10 2003
-+++ ltmain.sh Thu Oct 30 16:27:24 2003
-@@ -5457,10 +5457,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false ; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/security/gsasl/pkg-plist b/security/gsasl/pkg-plist
index e85fc7e2c39d..1df6d7650385 100644
--- a/security/gsasl/pkg-plist
+++ b/security/gsasl/pkg-plist
@@ -3,14 +3,17 @@ include/gsasl-compat.h
include/gsasl-mech.h
include/gsasl.h
lib/libgsasl.a
+lib/libgsasl.la
lib/libgsasl.so
-lib/libgsasl.so.9
+lib/libgsasl.so.10
libdata/pkgconfig/libgsasl.pc
%%PORTDOCS%%%%DOCSDIR%%/gsasl.html
%%PORTDOCS%%%%DOCSDIR%%/reference/abstraction.png
%%PORTDOCS%%%%DOCSDIR%%/reference/ch01.html
%%PORTDOCS%%%%DOCSDIR%%/reference/controlflow.png
%%PORTDOCS%%%%DOCSDIR%%/reference/controlflow2.png
+%%PORTDOCS%%%%DOCSDIR%%/reference/gsasl-gsasl.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/gsasl-gsasl-compat.html
%%PORTDOCS%%%%DOCSDIR%%/reference/gsasl-gsasl-mech.html
%%PORTDOCS%%%%DOCSDIR%%/reference/gsasl.devhelp
%%PORTDOCS%%%%DOCSDIR%%/reference/gsasl.devhelp2
@@ -30,6 +33,7 @@ libdata/pkgconfig/libgsasl.pc
%%NLS%%share/locale/fr/LC_MESSAGES/libgsasl.mo
%%NLS%%share/locale/ga/LC_MESSAGES/gsasl.mo
%%NLS%%share/locale/ga/LC_MESSAGES/libgsasl.mo
+%%NLS%%share/locale/id/LC_MESSAGES/gsasl.mo
%%NLS%%share/locale/nl/LC_MESSAGES/gsasl.mo
%%NLS%%share/locale/nl/LC_MESSAGES/libgsasl.mo
%%NLS%%share/locale/pl/LC_MESSAGES/gsasl.mo
@@ -44,5 +48,6 @@ libdata/pkgconfig/libgsasl.pc
%%NLS%%share/locale/vi/LC_MESSAGES/gsasl.mo
%%NLS%%share/locale/vi/LC_MESSAGES/libgsasl.mo
%%NLS%%share/locale/zh_CN/LC_MESSAGES/gsasl.mo
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/gsasl.mo
%%PORTDOCS%%@dirrm %%DOCSDIR%%/reference
%%PORTDOCS%%@dirrm %%DOCSDIR%%