aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorMark Felder <feld@FreeBSD.org>2014-12-04 14:42:07 +0000
committerMark Felder <feld@FreeBSD.org>2014-12-04 14:42:07 +0000
commita9be4132d485b45025c8354e10e2cf39f500b1be (patch)
treed1f5159165c3a8662722d51c70be41ae7f644ba6 /security
parent95d26daf40fd0209c4cead32ceadeba2669fe77a (diff)
downloadports-a9be4132d485b45025c8354e10e2cf39f500b1be.tar.gz
ports-a9be4132d485b45025c8354e10e2cf39f500b1be.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/polarssl13/Makefile60
-rw-r--r--security/polarssl13/distinfo2
-rw-r--r--security/polarssl13/files/patch-include-polarssl-config_h11
-rw-r--r--security/polarssl13/files/patch-library-Makefile25
-rw-r--r--security/polarssl13/pkg-descr21
-rw-r--r--security/polarssl13/pkg-plist90
7 files changed, 210 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 3300e00797a2..49022beacc92 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -734,6 +734,7 @@
SUBDIR += pktsuckers
SUBDIR += please
SUBDIR += polarssl
+ SUBDIR += polarssl13
SUBDIR += poly1305aes
SUBDIR += pond
SUBDIR += portsentry
diff --git a/security/polarssl13/Makefile b/security/polarssl13/Makefile
new file mode 100644
index 000000000000..3ae7fc4c2af9
--- /dev/null
+++ b/security/polarssl13/Makefile
@@ -0,0 +1,60 @@
+# $FreeBSD$
+
+PORTNAME= polarssl
+PORTVERSION= 1.3.9
+DISTVERSIONSUFFIX= -gpl
+CATEGORIES= security devel
+MASTER_SITES= http://polarssl.org/download/
+
+MAINTAINER= chris@bsdjunk.com
+COMMENT= Open Source embedded SSL/TLS cryptographic library
+
+LICENSE= GPLv2
+
+ALL_TARGET= no_test
+
+USES= gmake tar:tgz
+USE_LDCONFIG= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+# PolarSSL 1.3 branch introduces API changes that would best be served at this
+# time by a new/seperate polarssl13 port. Therefore, limit Portscout to the
+# 1.2 branch for this port.
+#Why ?
+#PORTSCOUT= limit:^1\.2\.
+
+DOCFILES= ChangeLog README.rst LICENSE
+BINFILES= aescrypt2 benchmark dh_client dh_genprime dh_server hello \
+ md5sum mpi_demo rsa_genkey rsa_sign rsa_verify selftest \
+ sha1sum sha2sum ssl_cert_test ssl_client1 ssl_client2 \
+ ssl_server ssl_test
+
+# cmake install is broken, so we do it by hand
+do-install:
+ @cd ${WRKSRC}/include && ${COPYTREE_SHARE} ${PORTNAME} ${STAGEDIR}${PREFIX}/include "! -name *.orig"
+ ${INSTALL_DATA} ${WRKSRC}/library/libpolarssl.a ${STAGEDIR}${PREFIX}/lib/
+ ${INSTALL_DATA} ${WRKSRC}/library/libpolarssl.so ${STAGEDIR}${PREFIX}/lib/libpolarssl.so.7
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libpolarssl.so.7
+ cd ${STAGEDIR}${PREFIX}/lib/ && ${LN} -sf libpolarssl.so.7 libpolarssl.so
+.for i in ${BINFILES}
+ ${INSTALL_PROGRAM} ${WRKSRC}/programs/*/${i} ${STAGEDIR}${PREFIX}/bin/polarssl_${i}
+.endfor
+
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
+post-install:
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+.for i in ${DOCFILES}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${STAGEDIR}${DOCSDIR}
+.endfor
+.endif
+
+.if ${ARCH} == "powerpc"
+BROKEN= Does not compile on powerpc
+.endif
+
+.include <bsd.port.mk>
diff --git a/security/polarssl13/distinfo b/security/polarssl13/distinfo
new file mode 100644
index 000000000000..3abc9d6362f2
--- /dev/null
+++ b/security/polarssl13/distinfo
@@ -0,0 +1,2 @@
+SHA256 (polarssl-1.3.9-gpl.tgz) = d3605afc28ed4b7d1d9e3142d72e42855e4a23c07c951bbb0299556b02d36755
+SIZE (polarssl-1.3.9-gpl.tgz) = 1741396
diff --git a/security/polarssl13/files/patch-include-polarssl-config_h b/security/polarssl13/files/patch-include-polarssl-config_h
new file mode 100644
index 000000000000..17dd114141b3
--- /dev/null
+++ b/security/polarssl13/files/patch-include-polarssl-config_h
@@ -0,0 +1,11 @@
+--- include/polarssl/config.h.old 2014-11-28 15:57:37.000000000 +0000
++++ include/polarssl/config.h 2014-11-28 16:00:32.000000000 +0000
+@@ -1518,7 +1518,7 @@
+ *
+ * Uncomment to enable the HAVEGE random generator.
+ */
+-//#define POLARSSL_HAVEGE_C
++#define POLARSSL_HAVEGE_C
+
+ /**
+ * \def POLARSSL_HMAC_DRBG_C
diff --git a/security/polarssl13/files/patch-library-Makefile b/security/polarssl13/files/patch-library-Makefile
new file mode 100644
index 000000000000..88c39895a047
--- /dev/null
+++ b/security/polarssl13/files/patch-library-Makefile
@@ -0,0 +1,25 @@
+--- library/Makefile.old 2014-11-28 16:02:22.000000000 +0000
++++ library/Makefile 2014-11-28 16:03:01.000000000 +0000
+@@ -18,9 +18,7 @@
+ # CFLAGS += -D_BSD_EXTENSION
+
+ # To compile as a shared library:
+-ifdef SHARED
+ CFLAGS += -fPIC
+-endif
+
+ SONAME=libpolarssl.so.7
+
+@@ -65,11 +63,7 @@
+
+ .SILENT:
+
+-ifndef SHARED
+-all: static
+-else
+-all: shared
+-endif
++all: shared static
+
+ static: libpolarssl.a
+
diff --git a/security/polarssl13/pkg-descr b/security/polarssl13/pkg-descr
new file mode 100644
index 000000000000..5016535825c7
--- /dev/null
+++ b/security/polarssl13/pkg-descr
@@ -0,0 +1,21 @@
+PolarSSL is a light-weight open source cryptographic and SSL/TLS library
+written in C. PolarSSL is written with embedded systems in mind and has
+been ported on a number of architectures, including ARM, PowerPC, MIPS
+and Motorola 68000.
+
+Features include:
+ * Small memory footprint
+ * Clean and simple API for integration
+ * Loose coupling of cryptographic code.
+ * Symmetric encryption algorithms: AES, Triple-DES, DES, ARC4, Camellia, XTEA
+ * Hash algorithms: MD2, MD4, MD5, SHA-1, SHA-224, SHA-256, SHA-384, SHA-512
+ * HAVEGE random number generator
+ * RSA with PKCS#1 v1.5 padding
+ * SSL version 3 and TLS version 1 client support
+ * X.509 certificate and CRL reading from memory or disk in PEM and DER formats
+ * Over 900 regression and code coverage tests
+ * Example applications
+
+LICENSE: GPL2
+
+WWW: http://polarssl.org/
diff --git a/security/polarssl13/pkg-plist b/security/polarssl13/pkg-plist
new file mode 100644
index 000000000000..31f8ba1db1dd
--- /dev/null
+++ b/security/polarssl13/pkg-plist
@@ -0,0 +1,90 @@
+bin/polarssl_aescrypt2
+bin/polarssl_benchmark
+bin/polarssl_dh_client
+bin/polarssl_dh_genprime
+bin/polarssl_dh_server
+bin/polarssl_hello
+bin/polarssl_md5sum
+bin/polarssl_mpi_demo
+bin/polarssl_rsa_genkey
+bin/polarssl_rsa_sign
+bin/polarssl_rsa_verify
+bin/polarssl_selftest
+bin/polarssl_sha1sum
+bin/polarssl_sha2sum
+bin/polarssl_ssl_cert_test
+bin/polarssl_ssl_client1
+bin/polarssl_ssl_client2
+bin/polarssl_ssl_server
+bin/polarssl_ssl_test
+include/polarssl/aesni.h
+include/polarssl/ccm.h
+include/polarssl/check_config.h
+include/polarssl/compat-1.2.h
+include/polarssl/ecdh.h
+include/polarssl/ecdsa.h
+include/polarssl/ecp.h
+include/polarssl/hmac_drbg.h
+include/polarssl/memory.h
+include/polarssl/memory_buffer_alloc.h
+include/polarssl/oid.h
+include/polarssl/pk.h
+include/polarssl/pk_wrap.h
+include/polarssl/platform.h
+include/polarssl/ripemd160.h
+include/polarssl/sha256.h
+include/polarssl/sha512.h
+include/polarssl/ssl_ciphersuites.h
+include/polarssl/threading.h
+include/polarssl/x509_crl.h
+include/polarssl/x509_crt.h
+include/polarssl/x509_csr.h
+lib/libpolarssl.so.7
+include/polarssl/aes.h
+include/polarssl/arc4.h
+include/polarssl/asn1.h
+include/polarssl/asn1write.h
+include/polarssl/base64.h
+include/polarssl/bignum.h
+include/polarssl/blowfish.h
+include/polarssl/bn_mul.h
+include/polarssl/camellia.h
+include/polarssl/certs.h
+include/polarssl/cipher.h
+include/polarssl/cipher_wrap.h
+include/polarssl/config.h
+include/polarssl/ctr_drbg.h
+include/polarssl/debug.h
+include/polarssl/des.h
+include/polarssl/dhm.h
+include/polarssl/entropy.h
+include/polarssl/entropy_poll.h
+include/polarssl/error.h
+include/polarssl/gcm.h
+include/polarssl/havege.h
+include/polarssl/md.h
+include/polarssl/md2.h
+include/polarssl/md4.h
+include/polarssl/md5.h
+include/polarssl/md_wrap.h
+include/polarssl/net.h
+include/polarssl/openssl.h
+include/polarssl/padlock.h
+include/polarssl/pem.h
+include/polarssl/pbkdf2.h
+include/polarssl/pkcs11.h
+include/polarssl/pkcs12.h
+include/polarssl/pkcs5.h
+include/polarssl/rsa.h
+include/polarssl/sha1.h
+include/polarssl/ssl.h
+include/polarssl/ssl_cache.h
+include/polarssl/timing.h
+include/polarssl/version.h
+include/polarssl/x509.h
+include/polarssl/xtea.h
+lib/libpolarssl.a
+lib/libpolarssl.so
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/README.rst
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE