aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2009-01-06 17:59:31 +0000
committerPav Lucistnik <pav@FreeBSD.org>2009-01-06 17:59:31 +0000
commitb2a96c6df1c8809216eced623ec37a8372b3216e (patch)
tree0c994bc87e8a2f221a7e2be76b9aafc16eab32bb /security
parent87b685f5d4325ba771e96b0ef49c71f903fb3ae0 (diff)
downloadports-b2a96c6df1c8809216eced623ec37a8372b3216e.tar.gz
ports-b2a96c6df1c8809216eced623ec37a8372b3216e.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/bdc/Makefile13
-rw-r--r--security/bioapi/Makefile8
-rw-r--r--security/bruteforceblocker/Makefile8
-rw-r--r--security/cyrus-sasl2-saslauthd/Makefile11
-rw-r--r--security/cyrus-sasl2/Makefile12
-rw-r--r--security/expiretable/Makefile8
-rw-r--r--security/freebsd-update/Makefile4
-rw-r--r--security/gnupg1/Makefile5
-rw-r--r--security/gnupg1/pkg-message5
-rw-r--r--security/gnutls/Makefile5
-rw-r--r--security/gpgme/Makefile2
-rw-r--r--security/ike/Makefile5
-rw-r--r--security/libfprint/Makefile8
-rw-r--r--security/libfprint/files/extra-patch-FreeBSD531
-rw-r--r--security/ncrypt/Makefile8
-rw-r--r--security/nss/Makefile4
-rw-r--r--security/openbsm/Makefile14
-rw-r--r--security/openbsm/pkg-plist2
-rw-r--r--security/openssl/Makefile8
-rw-r--r--security/snort/Makefile4
-rw-r--r--security/snort/files/extra-patch-src-sf_snort_plugin_api.h12
-rw-r--r--security/stunnel/Makefile3
-rw-r--r--security/trans-proxy-tor/Makefile4
-rw-r--r--security/unicornscan/Makefile15
-rw-r--r--security/vscan/Makefile5
-rw-r--r--security/vxquery/Makefile9
-rw-r--r--security/wipe/Makefile6
27 files changed, 22 insertions, 197 deletions
diff --git a/security/bdc/Makefile b/security/bdc/Makefile
index 9d07b1f1255f..55406aac4942 100644
--- a/security/bdc/Makefile
+++ b/security/bdc/Makefile
@@ -15,6 +15,8 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}.2-fbsd${BDREL}
MAINTAINER= itetcu@FreeBSD.org
COMMENT= BitDefender Console Antivirus for FreeBSD
+LIB_DEPENDS= c.5:${PORTSDIR}/misc/compat5x
+
WRKSRC= ${WRKDIR}/${PORTNAME}
NO_BUILD= yes
@@ -23,16 +25,9 @@ PKGMESSAGE= ${WRKDIR}/pkg-message
ONLY_FOR_ARCHS= i386
RESTRICTED= License prohibits redistribution
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 600000
-LIB_DEPENDS+= c.5:${PORTSDIR}/misc/compat5x
-.endif
-.if ${OSVERSION} < 502001
-IGNORE= requires FreeBSD 5.2.1 or later
-.else
BDREL= 5
-.endif
+
+.include <bsd.port.pre.mk>
.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}) && !defined(PACKAGE_BUILDING)
ECHO_MSG= /usr/bin/printf
diff --git a/security/bioapi/Makefile b/security/bioapi/Makefile
index a46d1e439f8b..b8d592856532 100644
--- a/security/bioapi/Makefile
+++ b/security/bioapi/Makefile
@@ -24,10 +24,4 @@ CONFIGURE_ARGS= --localstatedir=/var/db/ --with-Qt-dir=no
USE_LDCONFIG= yes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 600000
-IGNORE= needs at least FreeBSD 6.0-RELEASE
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/bruteforceblocker/Makefile b/security/bruteforceblocker/Makefile
index a20fbfb9a5a1..295f23ff9154 100644
--- a/security/bruteforceblocker/Makefile
+++ b/security/bruteforceblocker/Makefile
@@ -27,12 +27,6 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
PKGMESSAGE= ${WRKDIR}/pkg-message
SUB_FILES= pkg-message
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 502106
-IGNORE= requires at least FreeBSD 5.2
-.endif
-
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.pl ${PREFIX}/sbin/${PORTNAME}
${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.conf ${PREFIX}/etc/${PORTNAME}.conf-dist
@@ -51,4 +45,4 @@ post-install:
@${CAT} ${PKGMESSAGE}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/cyrus-sasl2-saslauthd/Makefile b/security/cyrus-sasl2-saslauthd/Makefile
index 54e2f52300d9..2b9c70f3ac20 100644
--- a/security/cyrus-sasl2-saslauthd/Makefile
+++ b/security/cyrus-sasl2-saslauthd/Makefile
@@ -77,28 +77,19 @@ CONFIGURE_ARGS+=--enable-httpform
CONFIGURE_ARGS+=--enable-gssapi=${KRB5_HOME} --with-gss_impl=mit
.elif !defined(WITHOUT_GSSAPI) && defined(HEIMDAL_HOME) && exists(${HEIMDAL_HOME}/lib/libgssapi.a)
CONFIGURE_ARGS+=--enable-gssapi=${HEIMDAL_HOME} --with-gss_impl=heimdal
-.elif !defined(WITHOUT_GSSAPI) && ( defined(MAKE_KERBEROS5) || ${OSVERSION} > 500105 ) && exists(/usr/lib/libkrb5.a)
+.elif !defined(WITHOUT_GSSAPI) && exists(/usr/lib/libkrb5.a)
CONFIGURE_ARGS+=--enable-gssapi
.else
CONFIGURE_ARGS+=--disable-gssapi
.endif
# KERBEROS 4 was removed in FreeBSD 5.0-CURRENT
-.if ${OSVERSION} > 500105
.if defined(WITH_KERBEROS4)
LIB_DEPENDS+= krb.2:${PORTSDIR}/security/krb4
CONFIGURE_ARGS+=--enable-krb4=${LOCALBASE}/krb4
.else
CONFIGURE_ARGS+=--disable-krb4
.endif
-.elif exists(/usr/lib/libkrb.a) && defined(MAKE_KERBEROS4) && !defined(WITHOUT_KERBEROS4)
-CONFIGURE_ARGS+=--enable-krb4
-.elif !exists(/usr/lib/libkrb.a) && defined(WITH_KERBEROS4)
-LIB_DEPENDS+= krb.2:${PORTSDIR}/security/krb4
-CONFIGURE_ARGS+=--enable-krb4=${LOCALBASE}/krb4
-.else
-CONFIGURE_ARGS+=--disable-krb4
-.endif
.if ${OPENSSLBASE} == /usr
CONFIGURE_ARGS+=--with-openssl=yes
diff --git a/security/cyrus-sasl2/Makefile b/security/cyrus-sasl2/Makefile
index 1c568d31fe79..83d4ee954577 100644
--- a/security/cyrus-sasl2/Makefile
+++ b/security/cyrus-sasl2/Makefile
@@ -170,7 +170,7 @@ CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}"
CONFIGURE_ARGS+=--enable-gssapi=${KRB5_HOME} --with-gss_impl=mit
.elif !defined(WITHOUT_GSSAPI) && defined(HEIMDAL_HOME) && exists(${HEIMDAL_HOME}/lib/libgssapi.a)
CONFIGURE_ARGS+=--enable-gssapi=${HEIMDAL_HOME} --with-gss_impl=heimdal
-.elif !defined(WITHOUT_GSSAPI) && ( defined(MAKE_KERBEROS5) || ${OSVERSION} > 500105 ) && exists(/usr/lib/libkrb5.a)
+.elif !defined(WITHOUT_GSSAPI) && exists(/usr/lib/libkrb5.a)
CONFIGURE_ARGS+=--enable-gssapi
.else
CONFIGURE_ARGS+=--disable-gssapi
@@ -178,7 +178,6 @@ GSSAPI= "@comment "
.endif
# KERBEROS 4 was removed in FreeBSD 5.0-CURRENT
-.if ${OSVERSION} > 500105
.if defined(WITH_KERBEROS4)
LIB_DEPENDS+= krb.2:${PORTSDIR}/security/krb4
CONFIGURE_ARGS+=--enable-krb4=${LOCALBASE}/krb4
@@ -186,15 +185,6 @@ CONFIGURE_ARGS+=--enable-krb4=${LOCALBASE}/krb4
CONFIGURE_ARGS+=--disable-krb4
EBONES= "@comment "
.endif
-.elif exists(/usr/lib/libkrb.a) && defined(MAKE_KERBEROS4) && !defined(WITHOUT_KERBEROS4)
-CONFIGURE_ARGS+=--enable-krb4
-.elif !exists(/usr/lib/libkrb.a) && defined(WITH_KERBEROS4)
-LIB_DEPENDS+= krb.2:${PORTSDIR}/security/krb4
-CONFIGURE_ARGS+=--enable-krb4=${LOCALBASE}/krb4
-.else
-CONFIGURE_ARGS+=--disable-krb4
-EBONES= "@comment "
-.endif
.if ${OPENSSLBASE} == /usr
CONFIGURE_ARGS+=--with-openssl=yes
diff --git a/security/expiretable/Makefile b/security/expiretable/Makefile
index f145123da220..67ac06be9bce 100644
--- a/security/expiretable/Makefile
+++ b/security/expiretable/Makefile
@@ -16,10 +16,4 @@ COMMENT= Utility to remove entries from the pf(4) table based on their age
USE_RC_SUBR= expiretable
MAN1= expiretable.1
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 502106
-IGNORE= is only for 5.3 and above (requires pf library)
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/freebsd-update/Makefile b/security/freebsd-update/Makefile
index 892447283507..84d77361244f 100644
--- a/security/freebsd-update/Makefile
+++ b/security/freebsd-update/Makefile
@@ -16,10 +16,6 @@ COMMENT= Fetches and installs binary updates to FreeBSD
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 600034 && ( ${OSVERSION} < 504104 || ${OSVERSION} > 599999 )
-RUN_DEPENDS= bspatch:${PORTSDIR}/misc/bsdiff
-.endif
-
.if ${OSVERSION} > 700019 || ( ${OSVERSION} > 601104 && ${OSVERSION} < 700000 )
IGNORE= is now contained in the base system
.endif
diff --git a/security/gnupg1/Makefile b/security/gnupg1/Makefile
index 560aa4bfb662..b8f853c5def7 100644
--- a/security/gnupg1/Makefile
+++ b/security/gnupg1/Makefile
@@ -95,11 +95,6 @@ post-install:
.if defined(WITH_SUID_GPG)
${CHMOD} u+s ${PREFIX}/bin/gpg
.endif
-.if ${OSVERSION} < 500019
- @${CAT} ${PKGMESSAGE}
-.else
-PKGMESSAGE= /nonexistent
-.endif
check:
(cd ${WRKSRC}; ${MAKE} check)
diff --git a/security/gnupg1/pkg-message b/security/gnupg1/pkg-message
deleted file mode 100644
index 6123fa32f234..000000000000
--- a/security/gnupg1/pkg-message
+++ /dev/null
@@ -1,5 +0,0 @@
-************************************************************
-TIPS:
- o Use rndcontrol(8) if you want more entropy.
- See http://people.freebsd.org/~dougb/randomness.html for more details.
-************************************************************
diff --git a/security/gnutls/Makefile b/security/gnutls/Makefile
index 677773fe6f7c..79ba7b5e63ca 100644
--- a/security/gnutls/Makefile
+++ b/security/gnutls/Makefile
@@ -50,11 +50,6 @@ CONFIGURE_ARGS+= --with-lzo
CONFIGURE_ARGS+= --with-lzo=no
.endif
-.if ${OSVERSION} < 600000
-BUILD_DEPENDS+= ${LOCALBASE}/bin/makeinfo:${PORTSDIR}/print/texinfo
-CONFIGURE_ENV+= MAKEINFO="${LOCALBASE}/bin/makeinfo"
-.endif
-
.if defined(WITHOUT_CXX)
CONFIGURE_ARGS+= --disable-cxx
PLIST_SUB+= CXX="@comment "
diff --git a/security/gpgme/Makefile b/security/gpgme/Makefile
index 99d4a2f54947..a2b1ea6d6a97 100644
--- a/security/gpgme/Makefile
+++ b/security/gpgme/Makefile
@@ -49,7 +49,7 @@ post-patch:
@${REINPLACE_CMD} -e 's|^clfilesdir.*|clfilesdir=$$\(libdir\)/common-lisp/gpgme|g' \
${WRKSRC}/lang/cl/Makefile.in
.if defined(WITH_PTH)
-.if ${OSVERSION} < 503100 || defined(PTHREAD_LIBS) && ${PTHREAD_LIBS} != "-pthread"
+.if defined(PTHREAD_LIBS) && ${PTHREAD_LIBS} != "-pthread"
@${REINPLACE_CMD} -e 's|t_thread1_LDADD = ../../gpgme/libgpgme-pthread.la|t_thread1_LDADD = ../../gpgme/libgpgme-pthread.la -lpthread|g' \
${WRKSRC}/tests/gpg/Makefile.in
.endif
diff --git a/security/ike/Makefile b/security/ike/Makefile
index 35da834062ed..1a9d03c6b9d8 100644
--- a/security/ike/Makefile
+++ b/security/ike/Makefile
@@ -57,10 +57,7 @@ post-patch:
.ifdef(WITH_NATT)
@${ECHO_MSG} "===> -------------------------------------------------------------------------"
@${ECHO_MSG} "===> ATTENTION: You need a kernel patch to enable NAT-Traversal functionality!"
-. if ${OSVERSION} < 600000
- @${ECHO_MSG} "===> There is no known NAT-T patch for FreeBSD 1 - 5!!!"
-. endif
-. if ${OSVERSION} > 600000 && ${OSVERSION} < 699999
+. if ${OSVERSION} < 699999
@${ECHO_MSG} "===> http://ipsec-tools.sf.net/freebsd6-natt.diff"
. endif
. if ${OSVERSION} > 700000 && ${OSVERSION} < 799999
diff --git a/security/libfprint/Makefile b/security/libfprint/Makefile
index cb4afe40aaca..ae0cbee54b81 100644
--- a/security/libfprint/Makefile
+++ b/security/libfprint/Makefile
@@ -24,14 +24,8 @@ USE_LDCONFIG= yes
USE_OPENSSL= yes
USE_GNOME= glib20 pkgconfig
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 600000
-EXTRA_PATCHES= ${FILESDIR}/extra-patch-FreeBSD5
-.endif
-
CONFIGURE_ENV+= CRYPTO_CFLAGS=-I${OPENSSLINC} \
CRYPTO_LIBS=-lcrypto \
CFLAGS="${CFLAGS} -DHAVE_MEMMEM"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/libfprint/files/extra-patch-FreeBSD5 b/security/libfprint/files/extra-patch-FreeBSD5
deleted file mode 100644
index f804d8d4643d..000000000000
--- a/security/libfprint/files/extra-patch-FreeBSD5
+++ /dev/null
@@ -1,31 +0,0 @@
---- libfprint/drivers/upekts.c.orig 2008-04-29 22:04:53.000000000 +0200
-+++ libfprint/drivers/upekts.c 2008-04-29 22:11:18.000000000 +0200
-@@ -35,6 +35,8 @@
-
- #include <fp_internal.h>
-
-+#include "libfprint/errno_compat.h"
-+
- #define EP_IN (1 | USB_ENDPOINT_IN)
- #define EP_OUT (2 | USB_ENDPOINT_OUT)
- #define TIMEOUT 5000
---- libfprint/drivers/uru4000.c.orig 2008-04-29 22:04:44.000000000 +0200
-+++ libfprint/drivers/uru4000.c 2008-04-29 22:11:33.000000000 +0200
-@@ -28,6 +28,8 @@
-
- #include <fp_internal.h>
-
-+#include "libfprint/errno_compat.h"
-+
- #define EP_INTR (1 | USB_ENDPOINT_IN)
- #define EP_DATA (2 | USB_ENDPOINT_IN)
- #define USB_RQ 0x04
---- libfprint/errno_compat.h.orig 2008-04-29 22:30:31.550769000 +0200
-+++ libfprint/errno_compat.h 2008-04-29 22:30:31.550769000 +0200
-@@ -0,0 +1,6 @@
-+#ifndef _ERRNO_COMPAT_H_
-+#define _ERRNO_COMPAT_H_
-+
-+#define EPROTO 92
-+
-+#endif /* _ERRNO_COMPAT_H_ */
diff --git a/security/ncrypt/Makefile b/security/ncrypt/Makefile
index 31294adc8168..31c3f415991b 100644
--- a/security/ncrypt/Makefile
+++ b/security/ncrypt/Makefile
@@ -21,14 +21,8 @@ USE_AUTOTOOLS= automake:19 aclocal:19 autoconf:262
PLIST_FILES= bin/ncrypt bin/nrm
-.include <bsd.port.pre.mk>
-
post-configure:
@${REINPLACE_CMD} -E 's,^(CC|CFLAGS) =,\1 \?=,g' \
${WRKSRC}/Makefile
-.if (${OSVERSION} < 501000)
- @${REINPLACE_CMD} -e 's,ifndef WIN32,if (!defined(__FreeBSD__)),g' \
- ${WRKSRC}/ncrypt.c
-.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/nss/Makefile b/security/nss/Makefile
index 87da42a716b4..54fb86dd4599 100644
--- a/security/nss/Makefile
+++ b/security/nss/Makefile
@@ -36,10 +36,6 @@ DIST= ${WRKSRC:H:H}/dist
.include <bsd.port.pre.mk>
-.if ${ARCH} == "alpha" && ${OSVERSION} < 500035
-IGNORE= core dumps on alpha during build
-.endif
-
EXTERNALS= CVS dbm security/nss/cmd/zlib nsprpub security/dbm
EXTRACT_AFTER_ARGS=| ${TAR} -xf - \
${EXTERNALS:C,^,--exclude ${DISTNAME}/mozilla/,}
diff --git a/security/openbsm/Makefile b/security/openbsm/Makefile
index ba243665ad06..286a3f399a92 100644
--- a/security/openbsm/Makefile
+++ b/security/openbsm/Makefile
@@ -42,16 +42,8 @@ MAN5= audit.log.5 \
audit_event.5 \
audit_user.5 \
audit_warn.5
-MAN8= auditfilterd.8
-
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 600000
-MAN8+= audit.8 \
+MAN8= auditfilterd.8 \
+ audit.8 \
auditd.8
-PLIST_FILES+= sbin/audit \
- sbin/auditd
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/openbsm/pkg-plist b/security/openbsm/pkg-plist
index 5c695bdf3b43..74884033d0e7 100644
--- a/security/openbsm/pkg-plist
+++ b/security/openbsm/pkg-plist
@@ -13,6 +13,8 @@ lib/auditfilter_noop.so.0
lib/auditfilter_noop.so
lib/auditfilter_noop.la
lib/auditfilter_noop.a
+sbin/audit
+sbin/auditd
sbin/auditfilterd
sbin/auditreduce
sbin/praudit
diff --git a/security/openssl/Makefile b/security/openssl/Makefile
index 27a6b0a6b070..96bc0fad608b 100644
--- a/security/openssl/Makefile
+++ b/security/openssl/Makefile
@@ -879,17 +879,9 @@ OPENSSL_BASE_SOPATH= ${OPENSSL_BASE_SONAME:H}
.if ( ${OSVERSION} >= 700019 )
IGNORE= Conflicts with version in the base
.endif
-.if ( ${OSVERSION} >= 600100 )
OPENSSL_SHLIBVER?= 4
.else
-OPENSSL_SHLIBVER?= 3
-.endif
-.else
-.if ( ${OSVERSION} >= 600100 )
OPENSSL_SHLIBVER?= 5
-.else
-OPENSSL_SHLIBVER?= 4
-.endif
.endif
# disable runtime SSE2 detection
diff --git a/security/snort/Makefile b/security/snort/Makefile
index 39aa954ecbe8..e59f13bea5e4 100644
--- a/security/snort/Makefile
+++ b/security/snort/Makefile
@@ -45,10 +45,6 @@ DOCS= RELEASE.NOTES doc/AUTHORS doc/BUGS doc/CREDITS \
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500036
-EXTRA_PATCHES+= ${FILESDIR}/extra-patch-src-sf_snort_plugin_api.h
-.endif
-
.if defined(WITH_FLEXRESP)
LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet10-config
.elif defined(WITH_FLEXRESP2)
diff --git a/security/snort/files/extra-patch-src-sf_snort_plugin_api.h b/security/snort/files/extra-patch-src-sf_snort_plugin_api.h
deleted file mode 100644
index 1d0940f70374..000000000000
--- a/security/snort/files/extra-patch-src-sf_snort_plugin_api.h
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/dynamic-plugins/sf_engine/sf_snort_plugin_api.h.orig Fri Feb 3 01:49:10 2006
-+++ src/dynamic-plugins/sf_engine/sf_snort_plugin_api.h Wed Sep 6 13:53:28 2006
-@@ -36,8 +36,8 @@
- #include "stdio.h"
-
- #ifndef WIN32
--#include <netinet/in.h>
- #include <sys/types.h>
-+#include <netinet/in.h>
- #else
- typedef unsigned char u_int8_t;
- typedef unsigned short u_int16_t;
diff --git a/security/stunnel/Makefile b/security/stunnel/Makefile
index 37cadc71f488..2b421336cc2b 100644
--- a/security/stunnel/Makefile
+++ b/security/stunnel/Makefile
@@ -46,9 +46,6 @@ BROKEN= 'The WITH_UCONTEXT, WITH_FORK and WITH_PTHREAD options are mutually excl
.endif
.if defined(WITH_UCONTEXT)
-.if ${OSVERSION} < 500112
-BROKEN= 'The ucontext model is only supported on FreeBSD 5.x and 6.x'
-.endif
CONFIGURE_ARGS+=--with-threads=ucontext
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} ${PTHREAD_CFLAGS}" LDFLAGS="${LDFLAGS} ${PTHREAD_LIBS}"
.elif defined(WITH_FORK)
diff --git a/security/trans-proxy-tor/Makefile b/security/trans-proxy-tor/Makefile
index 8d5aeb7f2755..0309da2fee78 100644
--- a/security/trans-proxy-tor/Makefile
+++ b/security/trans-proxy-tor/Makefile
@@ -66,10 +66,6 @@ RUN_DEPENDS+= ${LOCALBASE}/bin/tor:${PORTSDIR}/security/tor
IGNORE= requires PF
.endif
-.if (${OSVERSION} < 502106)
-IGNORE= requires PF which is not available on FreeBSD versions below 5.3
-.endif
-
pre-install:
PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
do-install:
diff --git a/security/unicornscan/Makefile b/security/unicornscan/Makefile
index bca38f85c124..f15e3ab92614 100644
--- a/security/unicornscan/Makefile
+++ b/security/unicornscan/Makefile
@@ -18,6 +18,7 @@ BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet
USE_GMAKE= yes
MAKE_ENV= LIBNET_CONFIG="${LIBNET_CONFIG}"
+CFLAGS+= -DWITH_LONGOPTS
MAN1= unicornscan.1
@@ -27,20 +28,6 @@ LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet11-config
.include <bsd.port.pre.mk>
-# Check if where building on a 5.3 or older system. Older
-# system require libpcap 0.8.x to be installed.
-
-.if ${OSVERSION} < 503000
-BUILD_DEPENDS+= ${PREFIX}/lib/libpcap.a:${PORTSDIR}/net/libpcap
-.endif
-
-# Systems newer then 502103 include the getopt_long
-# function
-
-.if ${OSVERSION} > 502103
-CFLAGS+= -DWITH_LONGOPTS
-.endif
-
post-patch:
.for text in pkg-message
@${SED} -e 's,%%PREFIX%%,${PREFIX},g' \
diff --git a/security/vscan/Makefile b/security/vscan/Makefile
index ee4b3afbb37a..c8cd7c4223e5 100644
--- a/security/vscan/Makefile
+++ b/security/vscan/Makefile
@@ -33,9 +33,6 @@ USE_LDCONFIG= YES
.endif
.if defined(WITHOUT_COMPAT3)
-.if ${OSVERSION} < 501000
-IGNORE= requires FreeBSD 5.1 or later
-.endif
.else
LIB_DEPENDS+= c.3:${PORTSDIR}/misc/compat3x
.endif
@@ -86,7 +83,7 @@ do-install:
post-install:
${LN} -sf ${PREFIX}/lib${UVSCAN_LIB32}/libbsdfv.so.4 ${PREFIX}/lib${UVSCAN_LIB32}/libbsdfv.so
-.if defined(WITHOUT_COMPAT3) && ${OSVERSION} >= 501000
+.if defined(WITHOUT_COMPAT3)
@${ECHO_CMD} ""
@${ECHO_CMD} "This may affect the system security. Use at your own risk."
@${ECHO_CMD} "You need to add the following two lines to your libmap${UVSCAN_LIB32}.conf(5):"
diff --git a/security/vxquery/Makefile b/security/vxquery/Makefile
index 3d9a3c6fd99e..e632f076d688 100644
--- a/security/vxquery/Makefile
+++ b/security/vxquery/Makefile
@@ -16,14 +16,7 @@ COMMENT= VuXML Query Tool
USE_BZIP2= YES
GNU_CONFIGURE= YES
-# FreeBSD 5.x systems have expat in the base system.
-.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 501111
-CONFIGURE_ENV+= LIBS="-L${LOCALBASE}/lib" CPPFLAGS="-I${LOCALBASE}/include"
-LIB_DEPENDS= expat:${PORTSDIR}/textproc/expat2
-.endif
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/object/vxquery ${PREFIX}/bin/vxquery
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/wipe/Makefile b/security/wipe/Makefile
index e4d70c83621a..52961e56ca59 100644
--- a/security/wipe/Makefile
+++ b/security/wipe/Makefile
@@ -20,11 +20,7 @@ GNU_CONFIGURE= yes
MAN1= wipe.1
PORTDOCS= CHANGES INSTALL LICENSE README TESTING TODO copyright
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} > 500039
EXTRA_PATCHES= ${PATCHDIR}/500040-patch-blkdev.c
-.endif
post-install:
${INSTALL_MAN} ${WRKSRC}/wipe.1 ${PREFIX}/man/man1
@@ -35,4 +31,4 @@ post-install:
done
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>