aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorJeremy Lea <reg@FreeBSD.org>2000-04-17 00:19:02 +0000
committerJeremy Lea <reg@FreeBSD.org>2000-04-17 00:19:02 +0000
commitb4455771cced2fe9f134e751fe88dbba7226e694 (patch)
tree39733bef5e1d466d30938b5a47f0b46a7b6890b4 /security
parent877b8a533b44bb6324ebbaf65cd80a60d1572003 (diff)
downloadports-b4455771cced2fe9f134e751fe88dbba7226e694.tar.gz
ports-b4455771cced2fe9f134e751fe88dbba7226e694.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/crack/Makefile4
-rw-r--r--security/fwtk/Makefile2
-rw-r--r--security/fwtk/files/patch-az2
-rw-r--r--security/heimdal/Makefile15
-rw-r--r--security/p5-PGP-Sign/Makefile16
-rw-r--r--security/pidentd/Makefile6
-rw-r--r--security/ssh/Makefile30
-rw-r--r--security/ssh2/Makefile30
8 files changed, 47 insertions, 58 deletions
diff --git a/security/crack/Makefile b/security/crack/Makefile
index f2d3d169fe54..6181d5a2400e 100644
--- a/security/crack/Makefile
+++ b/security/crack/Makefile
@@ -22,7 +22,7 @@ RESTRICTED= "contains crypto (libdes)"
WRKSRC= ${WRKDIR}/c50a
pre-configure:
-.if !defined(USE_DES)
+.if !defined(WITH_DES)
@${MV} -f ${WRKSRC}/src/libdes ${WRKSRC}/src/libdes.notused
@${MV} -f ${WRKSRC}/src/util/elcid.c ${WRKSRC}/src/util/elcid.c.orig
@${CP} -p ${WRKSRC}/src/util/elcid.c,bsd ${WRKSRC}/src/util/elcid.c
@@ -38,7 +38,7 @@ pre-build:
do-build:
cd ${WRKSRC} ; ./Crack -makeonly
cd ${WRKSRC} ; ./Crack -makedict
-.if !defined(USE_DES)
+.if !defined(WITH_DES)
@#(cd ${WRKSRC} ; ./Crack -fgnd -fmt bsd ${FILESDIR}/pw-md5.test)
.endif
diff --git a/security/fwtk/Makefile b/security/fwtk/Makefile
index d0384b21e89a..5cda928d70f9 100644
--- a/security/fwtk/Makefile
+++ b/security/fwtk/Makefile
@@ -31,7 +31,7 @@ SBIN_BINS= authdump authload authmgr
LIBEXEC_BINS= authsrv ftp-gw http-gw netacl plug-gw rlogin-gw smap smapd \
tn-gw
-.if !defined(NO_X11)
+.if !defined(WITHOUT_X11)
LIBEXEC_BINS+= x-gw
MAN8+= x-gw.8
.endif
diff --git a/security/fwtk/files/patch-az b/security/fwtk/files/patch-az
index 300906fb48ac..c2ff156b76cb 100644
--- a/security/fwtk/files/patch-az
+++ b/security/fwtk/files/patch-az
@@ -7,7 +7,7 @@
-DIRS= smap smapd netacl plug-gw ftp-gw tn-gw rlogin-gw http-gw x-gw
+DIRS= smap smapd netacl plug-gw ftp-gw tn-gw rlogin-gw http-gw
+
-+.if !defined(NO_X11)
++.if !defined(WITHOUT_X11)
+DIRS+= x-gw
+.endif
diff --git a/security/heimdal/Makefile b/security/heimdal/Makefile
index 9dc19c2b30f2..99c50d56a4fa 100644
--- a/security/heimdal/Makefile
+++ b/security/heimdal/Makefile
@@ -35,11 +35,8 @@ CONFIGURE_ARGS= --prefix=${PREFIX} --enable-shared
PREFIX= ${HEIMDAL_HOME}
.endif
-.if exists(${X11BASE}/lib/libX11.a) && !defined(NO_X11)
+.if exists(${X11BASE}/lib/libX11.a) && !defined(WITHOUT_X11)
USE_XLIB= yes
-.endif
-
-.if defined(USE_XLIB)
MAN1+= kx.1 rxtelnet.1 rxterm.1 tenletxr.1
MAN8+= kxd.8
CONFIGURE_ARGS+= --with-x
@@ -47,13 +44,9 @@ CONFIGURE_ARGS+= --with-x
CONFIGURE_ARGS+= --without-x
.endif
-.if exists(/usr/lib/libkrb.a) && !defined(NO_KRB4)
-WITH_KRB4= yes
-.endif
-
-.if defined(WITH_KRB4)
+.if exists(/usr/lib/libkrb.a) && !defined(WITHOUT_KRB4)
CONFIGURE_ARGS+= --with-krb4
-.elif !defined(KRB5_KRB4_COMPAT) || ${KRB5_KRB4_COMPAT} == "NO"
+.elif !defined(KRB5_KRB4_COMPAT)
CONFIGURE_ARGS+= --without-krb4
.endif
@@ -61,7 +54,7 @@ PLIST:= ${WRKDIR}/PLIST
pre-install:
@${CP} ${PKGDIR}/PLIST ${PLIST}
-.if defined(WITH_KRB4)
+.if exists(/usr/lib/libkrb.a) && !defined(WITHOUT_KRB4)
@${CAT} ${PKGDIR}/PLIST.KRB4 >> ${PLIST}
.endif
.if defined(USE_XLIB)
diff --git a/security/p5-PGP-Sign/Makefile b/security/p5-PGP-Sign/Makefile
index a633181f45f0..3c2c1e5ab61d 100644
--- a/security/p5-PGP-Sign/Makefile
+++ b/security/p5-PGP-Sign/Makefile
@@ -20,22 +20,22 @@ MAN3= PGP::Sign.3
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
# You can either define one of these on the command line or accept the
-# default (USE_PGP2). You can also predefine the values for PGP (or
+# default (WITH_PGP2). You can also predefine the values for PGP (or
# PGPS and PGPV) and PGPSTYLE if you don't like what this makefile
# would assign.
-# USE_PGP2 - use PGP 2.6.* or a reasonable facsimile thereof
-# USE_PGP5 - use PGP 5 or a work-alike
-# USE_GPG - use Gnu Privacy Guard
+# WITH_PGP2 - use PGP 2.6.* or a reasonable facsimile thereof
+# WITH_PGP5 - use PGP 5 or a work-alike
+# WITH_GPG - use Gnu Privacy Guard
-.if !defined(USE_PGP5) && !defined(USE_GPG)
-USE_PGP2?= yes
+.if !defined(WITH_PGP5) && !defined(WITH_GPG)
+WITH_PGP2?= yes
RUN_DEPENDS= pgp:${PORTSDIR}/security/pgp
.ifndef PGP
PGP!= which pgp || ${ECHO} ${PREFIX}/bin/pgp
.endif
PGPSTYLE?= PGP2
.else
-.ifdef USE_PGP5
+.ifdef WITH_PGP5
RUN_DEPENDS= pgps:${PORTSDIR}/security/pgp5
.ifndef PGPS
PGPS!= which pgps || ${ECHO} ${PREFIX}/bin/pgps
@@ -45,7 +45,7 @@ PGPV!= which pgpv || ${ECHO} ${PREFIX}/bin/pgpv
.endif
PGPSTYLE?= PGP5
.endif
-.ifdef USE_GPG
+.ifdef WITH_GPG
RUN_DEPENDS= gpg:${PORTSDIR}/security/gnupg
.ifndef PGP
PGP!= which gpg || ${ECHO} ${PREFIX}/bin/gpg
diff --git a/security/pidentd/Makefile b/security/pidentd/Makefile
index 712fe03d07bd..23f3da8ddadc 100644
--- a/security/pidentd/Makefile
+++ b/security/pidentd/Makefile
@@ -30,13 +30,13 @@ ADD_GDEFS+= -DINET6 -D__ss_family=ss_family -D__ss_len=ss_len
# Uncomment to activate the use of verifiable "cookies". The idea is to be
# able to detect fake "logs" intended to get your innocent users in trouble.
# Naturally, since it uses libdes, you must have the "secure" dist installed.
-# USE_DES= true
+#WITH_DES= yes
-.if defined(USE_DES)
+.if defined(WITH_DES)
ADD_GDEFS+= -DINCLUDE_CRYPT
ADD_GLIBS= -ldes
.endif
-.if defined(USE_DES) || ${OSVERSION} >= 400014
+.if defined(WITH_DES) || ${OSVERSION} >= 400014
MAKE_ENV+= ADD_GDEFS="${ADD_GDEFS}" ADD_GLIBS="${ADD_GLIBS}"
.endif
diff --git a/security/ssh/Makefile b/security/ssh/Makefile
index e49d4ddb39df..efc3a4e0d1df 100644
--- a/security/ssh/Makefile
+++ b/security/ssh/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
#
# Maximal ssh package requires YES values for
-# USE_PERL, USE_TCPWRAP
+# WITH_PERL, WITH_TCPWRAP
#
PORTNAME= ssh
@@ -56,21 +56,17 @@ CONFIGURE_ARGS+=--with-kerberos5=${KRB5_HOME} --enable-kerberos-tgt-passing \
# Include support for the SecureID card
# Warning: untested !
-.if defined(USE_SECUREID) && ${USE_SECUREID} == YES
+.if defined(WITH_SECUREID)
CONFIGURE_ARGS+= --with-secureid
.endif
# Don't use IDEA. IDEA can be freely used for non-commercial use. However,
# commercial use may require a licence in a number of countries
# Warning: untested !
-.if defined(DONT_USE_IDEA) && ${DONT_USE_IDEA} == YES
+.if defined(WITHOUT_IDEA)
CONFIGURE_ARGS+= --without-idea
.endif
-.if !exists(${X11BASE}/bin/xauth)
-CONFIGURE_ARGS+= --without-x
-.endif
-
MAN1= scp1.1 ssh-add1.1 ssh-agent1.1 ssh-keygen1.1 ssh1.1 \
make-ssh-known-hosts1.1
MAN8= sshd1.8
@@ -115,8 +111,7 @@ post-install:
.include <bsd.port.pre.mk>
-.if defined(USE_PERL) && ${USE_PERL} == YES || \
- exists(${PERL5}) && (!defined(USE_PERL) || ${USE_PERL} != NO)
+.if defined(WITH_PERL) || (exists(${PERL5}) && (!defined(WITHOUT_PERL))
USE_PERL5= yes
CONFIGURE_ENV+= PERL=${PERL5}
.else
@@ -127,9 +122,8 @@ CONFIGURE_ENV+= PERL=/replace_it_with_PERL_path
.if exists(/usr/include/tcpd.h)
CONFIGURE_ARGS+= --with-libwrap
.else
-.if defined(USE_TCPWRAP) && ${USE_TCPWRAP} == YES || \
- exists(${PREFIX}/lib/libwrap.a) && \
- (!defined(USE_TCPWRAP) || ${USE_TCPWRAP} != NO)
+.if defined(WITH_TCPWRAP) || (exists(${PREFIX}/lib/libwrap.a) \
+ && !defined(WITHOUT_TCPWRAP))
CONFIGURE_ENV+= LDFLAGS=-L${PREFIX}/lib CFLAGS="${CFLAGS} -I${PREFIX}/include"
CONFIGURE_ARGS+= --with-libwrap
LIB_DEPENDS+= wrap.7:${PORTSDIR}/security/tcp_wrapper
@@ -138,25 +132,29 @@ LIB_DEPENDS+= wrap.7:${PORTSDIR}/security/tcp_wrapper
# Original IPv6 patches were obtained from ftp://ftp.kyoto.wide.ad.jp/IPv6/ssh/
# ssh-1.2.27-IPv6-1.5-patch.gz
-# We still use USE_INET6 here and try to support pre 4.0 machines with kame
+# We still use WITH_INET6 here and try to support pre 4.0 machines with kame
# IPv6 stack
-.if ${OSVERSION} >= 400014 || ( ${OSVERSION} < 400014 && defined(USE_INET6) )
+.if ${OSVERSION} >= 400014 || ( ${OSVERSION} < 400014 && defined(WITH_INET6) )
CONFIGURE_ARGS+= --enable-ipv6
.else
CONFIGURE_ARGS+= --disable-ipv6
.endif
# Include SOCKS firewall support
-.if defined(USE_SOCKS) && ${USE_SOCKS} == YES
+.if defined(WITH_SOCKS)
CONFIGURE_ARGS+= --with-socks="-L${PREFIX}/lib -lsocks5" --with-socks5
.endif
# Include extra files if X11 is installed
-.if exists(${X11BASE}/lib/libX11.a)
+.if defined(WITH_X11) || (exists(${X11BASE}/lib/libX11.a) \
+ && !defined(WITHOUT_X11))
+USE_XLIB= yes
PLIST:= ${WRKDIR}/PLIST
pre-install:
@${CAT} ${PKGDIR}/PLIST.X11 > ${PLIST}
@${CAT} ${PKGDIR}/PLIST >> ${PLIST}
+.else
+CONFIGURE_ARGS+= --without-x
.endif
.include <bsd.port.post.mk>
diff --git a/security/ssh2/Makefile b/security/ssh2/Makefile
index 8d447d6c6f2c..7c8a9b6e7865 100644
--- a/security/ssh2/Makefile
+++ b/security/ssh2/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
#
# Maximal ssh2 package requires YES values for
-# USE_SSH1, USE_TCPWRAP
+# WITH_SSH1, WITH_TCPWRAP
PORTNAME= ssh2
PORTVERSION= 2.0.13
@@ -32,35 +32,33 @@ CONFIGURE_ARGS= --with-etcdir=${PREFIX}/etc --enable-debug
.include <bsd.port.pre.mk>
-# Include support for ssh1 client backward compatibility
-USE_SSH1?= YES
+# Don't support for ssh1 client backward compatibility
+#WITHOUT_SSH1= yes
# Include tcp_wrappers support (automaticlly YES if /usr/include/tcpd.h exists)
-USE_TCPWRAP?= NO
-# Warning: untested !
+#WITH_TCPWRAP= yes
+# Warning: untested!
# Include support for the TIS authentication server
-USE_TIS?= NO
+#WITH_TIS= yes
# Include support for the SecureID card
-USE_SECUREID?= NO
+#WITH_SECUREID= yes
-.if ${OSVERSION} < 400016 && defined(USE_SSH1) && ${USE_SSH1} == YES
+.if ${OSVERSION} < 400016 && !defined(WITHOUT_SSH1)
BUILD_DEPENDS+= ssh1:${PORTSDIR}/security/ssh
RUN_DEPENDS+= ssh1:${PORTSDIR}/security/ssh
.endif
-.if defined(USE_SECUREID) && ${USE_SECUREID} == YES
+.if defined(WITH_SECUREID)
CONFIGURE_ARGS+= --with-secureid
.endif
-.if defined(USE_TIS) && ${USE_TIS} == YES
+.if defined(WITH_TIS)
CONFIGURE_ARGS+= --with-tis
.endif
-.if exists(/usr/include/tcpd.h)
+.if exists(/usr/include/tcpd.h) && !defined(WITHOUT_TCPWRAP)
CONFIGURE_ARGS+= --with-libwrap
-.else
-.if defined(USE_TCPWRAP) && ${USE_TCPWRAP} == YES
+.elif defined(WITH_TCPWRAP)
CONFIGURE_ARGS+= --with-libwrap="-L ${PREFIX}/lib -lwrap"
LIB_DEPENDS+= wrap.7:${PORTSDIR}/security/tcp_wrapper
.endif
-.endif
MAN1= ssh2.1 ssh-keygen2.1 ssh-add2.1 ssh-agent2.1 \
scp2.1 sftp2.1
@@ -75,7 +73,7 @@ MLINKS= ssh2.1 ssh.1 \
sshd2.8 sshd.8
PORTDOCS= CHANGES LICENSING README
-.if !defined(USE_SSH1) || (defined(USE_SSH1) && ${USE_SSH1} != YES)
+.if defined(WITHOUT_SSH1)
PLIST= ${PKGDIR}/PLIST.ssh2_only
.endif
@@ -85,7 +83,7 @@ post-patch:
.endif
post-install:
-.if defined(USE_SSH1) && ${USE_SSH1} == YES
+.if !defined(WITHOUT_SSH1)
.for i in ssh ssh-keygen ssh-add ssh-agent scp
${MV} -f ${PREFIX}/man/man1/${i}.1${MAN_SUFX} ${PREFIX}/man/man1/${i}.old.1${MAN_SUFX}
.endfor