aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorTorsten Blum <torstenb@FreeBSD.org>1996-07-18 11:33:47 +0000
committerTorsten Blum <torstenb@FreeBSD.org>1996-07-18 11:33:47 +0000
commite1b1692d10b17c57230bcf2456aa863e214b07ba (patch)
treee49b4e665cb6afe6d33025a1d47bcc37c8135060 /security
parentdd89dbec592bc5da7f53dba5d94cc6107783308a (diff)
downloadports-e1b1692d10b17c57230bcf2456aa863e214b07ba.tar.gz
ports-e1b1692d10b17c57230bcf2456aa863e214b07ba.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/ssh/Makefile27
-rw-r--r--security/ssh/distinfo2
-rw-r--r--security/ssh/files/patch-ac24
-rw-r--r--security/ssh/files/patch-af108
-rw-r--r--security/ssh/pkg-plist3
-rw-r--r--security/ssh2/Makefile27
-rw-r--r--security/ssh2/distinfo2
-rw-r--r--security/ssh2/files/patch-ac24
-rw-r--r--security/ssh2/files/patch-af108
-rw-r--r--security/ssh2/pkg-plist3
10 files changed, 154 insertions, 174 deletions
diff --git a/security/ssh/Makefile b/security/ssh/Makefile
index be5100f79727..18eca9e6015c 100644
--- a/security/ssh/Makefile
+++ b/security/ssh/Makefile
@@ -1,31 +1,26 @@
# New ports collection makefile for: ssh
-# Version required: 1.2.14.1
+# Version required: 1.2.14
# Date created: 30 Jul 1995
# Whom: torstenb@FreeBSD.ORG
#
-# $Id: Makefile,v 1.28 1996/07/16 00:33:10 ache Exp $
+# $Id: Makefile,v 1.27 1996/06/20 14:11:17 ache Exp $
#
# Maximal ssh package requires YES values for
# USE_PERL, USE_TCPWRAP
#
-DISTNAME= ssh-1.2.14.1
+DISTNAME= ssh-1.2.14
CATEGORIES= security net
-MASTER_SITES= http://ssh.fi/ \
- ftp://ftp.relcom.ru/unix/crypto/
-#MASTER_SITES= ftp://ftp.cs.hut.fi/pub/ssh/
+MASTER_SITES= ftp://ftp.cs.hut.fi/pub/ssh/
MAINTAINER= torstenb@FreeBSD.ORG
-# WARNING: you need libz 1.0.3 or above, previous versions have a bug
-
-LIB_DEPENDS= z\\.1\\.0:${PORTSDIR}/devel/libz
-
# You can set USA_RESIDENT appropriately in /etc/make.conf if this bugs you..
.if defined(USA_RESIDENT) && ${USA_RESIDENT} == YES
DISTFILES= ${DISTNAME}.tar.gz rsaref2.tar.gz
-MASTER_SITES+= \
+MASTER_SITES= \
+ ftp://ftp.cs.hut.fi/pub/ssh/ \
ftp://nic.funet.fi/pub/crypt/mirrors/ftp.dsi.unimi.it/applied-crypto/ \
ftp://rzsun2.informatik.uni-hamburg.de/pub/virus/crypt/ripem/ \
ftp://ftp.dsi.unimi.it/pub/security/crypt/math/ \
@@ -38,7 +33,7 @@ IS_INTERACTIVE= YES
GNU_CONFIGURE= YES
-CONFIGURE_ARGS+= --with-etcdir=${PREFIX}/etc --no-recursion
+CONFIGURE_ARGS= --prefix=${PREFIX} --with-etcdir=${PREFIX}/etc
.if defined(USA_RESIDENT) && ${USA_RESIDENT} == YES
CONFIGURE_ARGS+= --with-rsaref
@@ -90,8 +85,6 @@ post-install:
${PREFIX}/man/man1/ssh-agent.1 ${PREFIX}/man/man1/ssh-keygen.1 \
${PREFIX}/man/man1/ssh.1 ${PREFIX}/man/man8/sshd.8 \
${PREFIX}/man/man1/make-ssh-known-hosts.1
- rm ${PREFIX}/man/man1/slogin.1
- ln -fs ${PREFIX}/man/man1/ssh.1.gz ${PREFIX}/man/man1/slogin.1.gz
@if [ ! -f ${PREFIX}/etc/rc.d/sshd.sh ]; then \
echo "Installing ${PREFIX}/etc/rc.d/sshd.sh startup file."; \
echo "#!/bin/sh" > ${PREFIX}/etc/rc.d/sshd.sh; \
@@ -104,10 +97,10 @@ post-install:
# Following stuff must be after <bsd.port.mk> to expand exists() properly
.if defined(USE_PERL) && ${USE_PERL} == YES || \
- exists(${PREFIX}/bin/perl5.003) && \
+ exists(${PREFIX}/bin/perl5.002) && \
(!defined(USE_PERL) || ${USE_PERL} != NO)
-BUILD_DEPENDS+= perl5.003:${PORTSDIR}/lang/perl5
-CONFIGURE_ENV+= PERL=${PREFIX}/bin/perl5.003
+BUILD_DEPENDS+= perl5.002:${PORTSDIR}/lang/perl5
+CONFIGURE_ENV+= PERL=${PREFIX}/bin/perl5.002
.else
CONFIGURE_ENV+= PERL=/replace_it_with_PERL_path
.endif
diff --git a/security/ssh/distinfo b/security/ssh/distinfo
index fdd7625ca42a..c6c50f32a33e 100644
--- a/security/ssh/distinfo
+++ b/security/ssh/distinfo
@@ -1,2 +1,2 @@
-MD5 (ssh-1.2.14.1.tar.gz) = 8f9576aecd09cc7448a3f87cdb5b54ad
+MD5 (ssh-1.2.14.tar.gz) = 4c23661228a7946f9fb7aa40d6c7dad4
MD5 (rsaref2.tar.gz) = 0b474c97bf1f1c0d27e5a95f1239c08d
diff --git a/security/ssh/files/patch-ac b/security/ssh/files/patch-ac
new file mode 100644
index 000000000000..7701a515af29
--- /dev/null
+++ b/security/ssh/files/patch-ac
@@ -0,0 +1,24 @@
+*** login.c.bak Thu Jun 6 15:39:34 1996
+--- login.c Mon Jun 17 19:56:43 1996
+***************
+*** 236,241 ****
+--- 236,254 ----
+ strncpy(u.ut_user, user, sizeof(u.ut_user));
+ #endif /* HAVE_NAME_IN_UTMP */
+ #ifdef HAVE_HOST_IN_UTMP
++ #ifdef __FreeBSD__
++ if (strlen(host) > UT_HOSTSIZE) {
++ struct hostent *hp = gethostbyname(host);
++
++ if (hp != NULL) {
++ struct in_addr in;
++
++ memmove(&in, hp->h_addr, sizeof(in));
++ host = inet_ntoa(in);
++ } else
++ host = "invalid hostname";
++ }
++ #endif
+ strncpy(u.ut_host, host, sizeof(u.ut_host));
+ #endif /* HAVE_HOST_IN_UTMP */
+ #ifdef HAVE_ADDR_IN_UTMP
diff --git a/security/ssh/files/patch-af b/security/ssh/files/patch-af
index 6ac8a839817d..a100f6ddf50a 100644
--- a/security/ssh/files/patch-af
+++ b/security/ssh/files/patch-af
@@ -1,67 +1,41 @@
-*** Makefile.in.orig Fri Jul 12 13:13:34 1996
---- Makefile.in Tue Jul 16 02:45:04 1996
-***************
-*** 144,155 ****
- SHELL = /bin/sh
-
- GMPDIR = gmp-1.3.2
-! GMPLIBS = -L$(GMPDIR) -lgmp
-! GMPDEP = $(GMPDIR)/gmp.h $(GMPDIR)/libgmp.a
-
- ZLIBDIR = zlib-1.0.3
-! ZLIBDEP = $(ZLIBDIR)/libz.a
-! ZLIBLIBS = -L$(ZLIBDIR) -lz
-
- RSAREFDIR = rsaref2
- RSAREFSRCDIR = $(RSAREFDIR)/source
---- 144,159 ----
- SHELL = /bin/sh
-
- GMPDIR = gmp-1.3.2
-! GMPINCDIR = $(GMPDIR)
-! GMPLIBDIR = $(GMPDIR)
-! GMPLIBS = -L$(GMPLIBDIR) -lgmp
-! GMPDEP = $(GMPINCDIR)/gmp.h $(GMPLIBDIR)/libgmp.a
-
- ZLIBDIR = zlib-1.0.3
-! ZLIBINCDIR = $(ZLIBDIR)
-! ZLIBLIBDIR = $(ZLIBDIR)
-! ZLIBDEP = $(ZLIBINCDIR)/zlib.h $(ZLIBLIBDIR)/libz.a
-! ZLIBLIBS = -L$(ZLIBLIBDIR) -lz
-
- RSAREFDIR = rsaref2
- RSAREFSRCDIR = $(RSAREFDIR)/source
-***************
-*** 232,238 ****
- $(CC) -o rfc-pg rfc-pg.c
-
- .c.o:
-! $(CC) -c -I. -I$(srcdir)/$(GMPDIR) -I$(srcdir)/$(ZLIBDIR) $(DEFS) -DHOST_KEY_FILE=\"$(HOST_KEY_FILE)\" -DHOST_CONFIG_FILE=\"$(HOST_CONFIG_FILE)\" -DSERVER_CONFIG_FILE=\"$(SERVER_CONFIG_FILE)\" -DSSH_PROGRAM=\"$(SSH_PROGRAM)\" -DETCDIR=\"$(etcdir)\" -DPIDDIR=\"$(piddir)\" -DBINDIR=\"$(bindir)\" $(CFLAGS) $(X_CFLAGS) $<
-
- sshd: $(SSHD_OBJS) $(GMPDEP) $(RSAREFDEP) $(ZLIBDEP)
- -rm -f sshd
---- 236,242 ----
- $(CC) -o rfc-pg rfc-pg.c
-
- .c.o:
-! $(CC) -c -I. -I$(GMPINCDIR) -I$(ZLIBINCDIR) $(DEFS) -DHOST_KEY_FILE=\"$(HOST_KEY_FILE)\" -DHOST_CONFIG_FILE=\"$(HOST_CONFIG_FILE)\" -DSERVER_CONFIG_FILE=\"$(SERVER_CONFIG_FILE)\" -DSSH_PROGRAM=\"$(SSH_PROGRAM)\" -DETCDIR=\"$(etcdir)\" -DPIDDIR=\"$(piddir)\" -DBINDIR=\"$(bindir)\" $(CFLAGS) $(X_CFLAGS) $<
-
- sshd: $(SSHD_OBJS) $(GMPDEP) $(RSAREFDEP) $(ZLIBDEP)
- -rm -f sshd
-***************
-*** 291,297 ****
- CC="$(CC)" CFLAGS="$(CFLAGS) -I. -I$(srcdir)/$(GMPDIR) \
- -I../$(srcdir)/$(GMPDIR)" RANLIB="$(RANLIB)"
-
-! $(ZLIBDEP):
- -if test '!' -d $(ZLIBDIR); then \
- mkdir $(ZLIBDIR); \
- cp $(srcdir)/$(ZLIBDIR)/Makefile $(ZLIBDIR); \
---- 295,301 ----
- CC="$(CC)" CFLAGS="$(CFLAGS) -I. -I$(srcdir)/$(GMPDIR) \
- -I../$(srcdir)/$(GMPDIR)" RANLIB="$(RANLIB)"
-
-! $(ZLIBDIR)/libz.a:
- -if test '!' -d $(ZLIBDIR); then \
- mkdir $(ZLIBDIR); \
- cp $(srcdir)/$(ZLIBDIR)/Makefile $(ZLIBDIR); \
+--- Makefile.in.orig Thu Jun 6 19:39:35 1996
++++ Makefile.in Fri Jun 7 11:58:02 1996
+@@ -137,12 +137,16 @@
+ SHELL = /bin/sh
+
+ GMPDIR = gmp-1.3.2
+-GMPLIBS = -L$(GMPDIR) -lgmp
+-GMPDEP = $(GMPDIR)/gmp.h $(GMPDIR)/libgmp.a
++GMPINCDIR = $(GMPDIR)
++GMPLIBDIR = $(GMPDIR)
++GMPDEP = $(GMPINCDIR)/gmp.h $(GMPLIBDIR)/libgmp.a
++GMPLIBS = -L$(GMPLIBDIR) -lgmp
+
+ ZLIBDIR = zlib095
+-ZLIBDEP = $(ZLIBDIR)/libz.a
+-ZLIBLIBS = -L$(ZLIBDIR) -lz
++ZLIBINCDIR = $(ZLIBDIR)
++ZLIBLIBDIR = $(ZLIBDIR)
++ZLIBDEP = $(ZLIBINCDIR)/zlib.h $(ZLIBLIBDIR)/libz.a
++ZLIBLIBS = -L$(ZLIBLIBDIR) -lz
+
+ RSAREFDIR = rsaref2
+ RSAREFSRCDIR = $(RSAREFDIR)/source
+@@ -223,7 +227,7 @@
+ $(CC) -o rfc-pg rfc-pg.c
+
+ .c.o:
+- $(CC) -c -I. -I$(srcdir)/$(GMPDIR) -I$(srcdir)/$(ZLIBDIR) $(DEFS) -DHOST_KEY_FILE=\"$(HOST_KEY_FILE)\" -DHOST_CONFIG_FILE=\"$(HOST_CONFIG_FILE)\" -DSERVER_CONFIG_FILE=\"$(SERVER_CONFIG_FILE)\" -DSSH_PROGRAM=\"$(SSH_PROGRAM)\" -DETCDIR=\"$(etcdir)\" -DPIDDIR=\"$(piddir)\" -DBINDIR=\"$(bindir)\" $(CFLAGS) $(X_CFLAGS) $<
++ $(CC) -c -I. -I$(GMPINCDIR) -I$(ZLIBINCDIR) $(DEFS) -DHOST_KEY_FILE=\"$(HOST_KEY_FILE)\" -DHOST_CONFIG_FILE=\"$(HOST_CONFIG_FILE)\" -DSERVER_CONFIG_FILE=\"$(SERVER_CONFIG_FILE)\" -DSSH_PROGRAM=\"$(SSH_PROGRAM)\" -DETCDIR=\"$(etcdir)\" -DPIDDIR=\"$(piddir)\" -DBINDIR=\"$(bindir)\" $(CFLAGS) $(X_CFLAGS) $<
+
+ sshd: $(SSHD_OBJS) $(GMPDEP) $(RSAREFDEP) $(ZLIBDEP)
+ -rm -f sshd
+@@ -282,7 +286,7 @@
+ CC="$(CC)" CFLAGS="$(CFLAGS) -I. -I$(srcdir)/$(GMPDIR) \
+ -I../$(srcdir)/$(GMPDIR)" RANLIB="$(RANLIB)"
+
+-$(ZLIBDEP):
++$(ZLIBDIR)/libz.a:
+ -if test '!' -d $(ZLIBDIR); then \
+ mkdir $(ZLIBDIR); \
+ cp $(srcdir)/$(ZLIBDIR)/Makefile $(ZLIBDIR); \
diff --git a/security/ssh/pkg-plist b/security/ssh/pkg-plist
index c207d58536ff..5cf40f2c48f4 100644
--- a/security/ssh/pkg-plist
+++ b/security/ssh/pkg-plist
@@ -1,8 +1,8 @@
etc/rc.d/sshd.sh
@unexec rm %D/etc/rc.d/sshd.sh
bin/scp
+bin/slogin
bin/ssh
-@exec ln -fs %D/%F %B/slogin
bin/ssh-add
bin/ssh-agent
bin/ssh-askpass
@@ -16,6 +16,5 @@ man/man1/ssh-add.1.gz
man/man1/ssh-agent.1.gz
man/man1/ssh-keygen.1.gz
man/man1/ssh.1.gz
-@exec ln -fs %D/%F %B/slogin.1.gz
man/man8/sshd.8.gz
sbin/sshd
diff --git a/security/ssh2/Makefile b/security/ssh2/Makefile
index be5100f79727..18eca9e6015c 100644
--- a/security/ssh2/Makefile
+++ b/security/ssh2/Makefile
@@ -1,31 +1,26 @@
# New ports collection makefile for: ssh
-# Version required: 1.2.14.1
+# Version required: 1.2.14
# Date created: 30 Jul 1995
# Whom: torstenb@FreeBSD.ORG
#
-# $Id: Makefile,v 1.28 1996/07/16 00:33:10 ache Exp $
+# $Id: Makefile,v 1.27 1996/06/20 14:11:17 ache Exp $
#
# Maximal ssh package requires YES values for
# USE_PERL, USE_TCPWRAP
#
-DISTNAME= ssh-1.2.14.1
+DISTNAME= ssh-1.2.14
CATEGORIES= security net
-MASTER_SITES= http://ssh.fi/ \
- ftp://ftp.relcom.ru/unix/crypto/
-#MASTER_SITES= ftp://ftp.cs.hut.fi/pub/ssh/
+MASTER_SITES= ftp://ftp.cs.hut.fi/pub/ssh/
MAINTAINER= torstenb@FreeBSD.ORG
-# WARNING: you need libz 1.0.3 or above, previous versions have a bug
-
-LIB_DEPENDS= z\\.1\\.0:${PORTSDIR}/devel/libz
-
# You can set USA_RESIDENT appropriately in /etc/make.conf if this bugs you..
.if defined(USA_RESIDENT) && ${USA_RESIDENT} == YES
DISTFILES= ${DISTNAME}.tar.gz rsaref2.tar.gz
-MASTER_SITES+= \
+MASTER_SITES= \
+ ftp://ftp.cs.hut.fi/pub/ssh/ \
ftp://nic.funet.fi/pub/crypt/mirrors/ftp.dsi.unimi.it/applied-crypto/ \
ftp://rzsun2.informatik.uni-hamburg.de/pub/virus/crypt/ripem/ \
ftp://ftp.dsi.unimi.it/pub/security/crypt/math/ \
@@ -38,7 +33,7 @@ IS_INTERACTIVE= YES
GNU_CONFIGURE= YES
-CONFIGURE_ARGS+= --with-etcdir=${PREFIX}/etc --no-recursion
+CONFIGURE_ARGS= --prefix=${PREFIX} --with-etcdir=${PREFIX}/etc
.if defined(USA_RESIDENT) && ${USA_RESIDENT} == YES
CONFIGURE_ARGS+= --with-rsaref
@@ -90,8 +85,6 @@ post-install:
${PREFIX}/man/man1/ssh-agent.1 ${PREFIX}/man/man1/ssh-keygen.1 \
${PREFIX}/man/man1/ssh.1 ${PREFIX}/man/man8/sshd.8 \
${PREFIX}/man/man1/make-ssh-known-hosts.1
- rm ${PREFIX}/man/man1/slogin.1
- ln -fs ${PREFIX}/man/man1/ssh.1.gz ${PREFIX}/man/man1/slogin.1.gz
@if [ ! -f ${PREFIX}/etc/rc.d/sshd.sh ]; then \
echo "Installing ${PREFIX}/etc/rc.d/sshd.sh startup file."; \
echo "#!/bin/sh" > ${PREFIX}/etc/rc.d/sshd.sh; \
@@ -104,10 +97,10 @@ post-install:
# Following stuff must be after <bsd.port.mk> to expand exists() properly
.if defined(USE_PERL) && ${USE_PERL} == YES || \
- exists(${PREFIX}/bin/perl5.003) && \
+ exists(${PREFIX}/bin/perl5.002) && \
(!defined(USE_PERL) || ${USE_PERL} != NO)
-BUILD_DEPENDS+= perl5.003:${PORTSDIR}/lang/perl5
-CONFIGURE_ENV+= PERL=${PREFIX}/bin/perl5.003
+BUILD_DEPENDS+= perl5.002:${PORTSDIR}/lang/perl5
+CONFIGURE_ENV+= PERL=${PREFIX}/bin/perl5.002
.else
CONFIGURE_ENV+= PERL=/replace_it_with_PERL_path
.endif
diff --git a/security/ssh2/distinfo b/security/ssh2/distinfo
index fdd7625ca42a..c6c50f32a33e 100644
--- a/security/ssh2/distinfo
+++ b/security/ssh2/distinfo
@@ -1,2 +1,2 @@
-MD5 (ssh-1.2.14.1.tar.gz) = 8f9576aecd09cc7448a3f87cdb5b54ad
+MD5 (ssh-1.2.14.tar.gz) = 4c23661228a7946f9fb7aa40d6c7dad4
MD5 (rsaref2.tar.gz) = 0b474c97bf1f1c0d27e5a95f1239c08d
diff --git a/security/ssh2/files/patch-ac b/security/ssh2/files/patch-ac
new file mode 100644
index 000000000000..7701a515af29
--- /dev/null
+++ b/security/ssh2/files/patch-ac
@@ -0,0 +1,24 @@
+*** login.c.bak Thu Jun 6 15:39:34 1996
+--- login.c Mon Jun 17 19:56:43 1996
+***************
+*** 236,241 ****
+--- 236,254 ----
+ strncpy(u.ut_user, user, sizeof(u.ut_user));
+ #endif /* HAVE_NAME_IN_UTMP */
+ #ifdef HAVE_HOST_IN_UTMP
++ #ifdef __FreeBSD__
++ if (strlen(host) > UT_HOSTSIZE) {
++ struct hostent *hp = gethostbyname(host);
++
++ if (hp != NULL) {
++ struct in_addr in;
++
++ memmove(&in, hp->h_addr, sizeof(in));
++ host = inet_ntoa(in);
++ } else
++ host = "invalid hostname";
++ }
++ #endif
+ strncpy(u.ut_host, host, sizeof(u.ut_host));
+ #endif /* HAVE_HOST_IN_UTMP */
+ #ifdef HAVE_ADDR_IN_UTMP
diff --git a/security/ssh2/files/patch-af b/security/ssh2/files/patch-af
index 6ac8a839817d..a100f6ddf50a 100644
--- a/security/ssh2/files/patch-af
+++ b/security/ssh2/files/patch-af
@@ -1,67 +1,41 @@
-*** Makefile.in.orig Fri Jul 12 13:13:34 1996
---- Makefile.in Tue Jul 16 02:45:04 1996
-***************
-*** 144,155 ****
- SHELL = /bin/sh
-
- GMPDIR = gmp-1.3.2
-! GMPLIBS = -L$(GMPDIR) -lgmp
-! GMPDEP = $(GMPDIR)/gmp.h $(GMPDIR)/libgmp.a
-
- ZLIBDIR = zlib-1.0.3
-! ZLIBDEP = $(ZLIBDIR)/libz.a
-! ZLIBLIBS = -L$(ZLIBDIR) -lz
-
- RSAREFDIR = rsaref2
- RSAREFSRCDIR = $(RSAREFDIR)/source
---- 144,159 ----
- SHELL = /bin/sh
-
- GMPDIR = gmp-1.3.2
-! GMPINCDIR = $(GMPDIR)
-! GMPLIBDIR = $(GMPDIR)
-! GMPLIBS = -L$(GMPLIBDIR) -lgmp
-! GMPDEP = $(GMPINCDIR)/gmp.h $(GMPLIBDIR)/libgmp.a
-
- ZLIBDIR = zlib-1.0.3
-! ZLIBINCDIR = $(ZLIBDIR)
-! ZLIBLIBDIR = $(ZLIBDIR)
-! ZLIBDEP = $(ZLIBINCDIR)/zlib.h $(ZLIBLIBDIR)/libz.a
-! ZLIBLIBS = -L$(ZLIBLIBDIR) -lz
-
- RSAREFDIR = rsaref2
- RSAREFSRCDIR = $(RSAREFDIR)/source
-***************
-*** 232,238 ****
- $(CC) -o rfc-pg rfc-pg.c
-
- .c.o:
-! $(CC) -c -I. -I$(srcdir)/$(GMPDIR) -I$(srcdir)/$(ZLIBDIR) $(DEFS) -DHOST_KEY_FILE=\"$(HOST_KEY_FILE)\" -DHOST_CONFIG_FILE=\"$(HOST_CONFIG_FILE)\" -DSERVER_CONFIG_FILE=\"$(SERVER_CONFIG_FILE)\" -DSSH_PROGRAM=\"$(SSH_PROGRAM)\" -DETCDIR=\"$(etcdir)\" -DPIDDIR=\"$(piddir)\" -DBINDIR=\"$(bindir)\" $(CFLAGS) $(X_CFLAGS) $<
-
- sshd: $(SSHD_OBJS) $(GMPDEP) $(RSAREFDEP) $(ZLIBDEP)
- -rm -f sshd
---- 236,242 ----
- $(CC) -o rfc-pg rfc-pg.c
-
- .c.o:
-! $(CC) -c -I. -I$(GMPINCDIR) -I$(ZLIBINCDIR) $(DEFS) -DHOST_KEY_FILE=\"$(HOST_KEY_FILE)\" -DHOST_CONFIG_FILE=\"$(HOST_CONFIG_FILE)\" -DSERVER_CONFIG_FILE=\"$(SERVER_CONFIG_FILE)\" -DSSH_PROGRAM=\"$(SSH_PROGRAM)\" -DETCDIR=\"$(etcdir)\" -DPIDDIR=\"$(piddir)\" -DBINDIR=\"$(bindir)\" $(CFLAGS) $(X_CFLAGS) $<
-
- sshd: $(SSHD_OBJS) $(GMPDEP) $(RSAREFDEP) $(ZLIBDEP)
- -rm -f sshd
-***************
-*** 291,297 ****
- CC="$(CC)" CFLAGS="$(CFLAGS) -I. -I$(srcdir)/$(GMPDIR) \
- -I../$(srcdir)/$(GMPDIR)" RANLIB="$(RANLIB)"
-
-! $(ZLIBDEP):
- -if test '!' -d $(ZLIBDIR); then \
- mkdir $(ZLIBDIR); \
- cp $(srcdir)/$(ZLIBDIR)/Makefile $(ZLIBDIR); \
---- 295,301 ----
- CC="$(CC)" CFLAGS="$(CFLAGS) -I. -I$(srcdir)/$(GMPDIR) \
- -I../$(srcdir)/$(GMPDIR)" RANLIB="$(RANLIB)"
-
-! $(ZLIBDIR)/libz.a:
- -if test '!' -d $(ZLIBDIR); then \
- mkdir $(ZLIBDIR); \
- cp $(srcdir)/$(ZLIBDIR)/Makefile $(ZLIBDIR); \
+--- Makefile.in.orig Thu Jun 6 19:39:35 1996
++++ Makefile.in Fri Jun 7 11:58:02 1996
+@@ -137,12 +137,16 @@
+ SHELL = /bin/sh
+
+ GMPDIR = gmp-1.3.2
+-GMPLIBS = -L$(GMPDIR) -lgmp
+-GMPDEP = $(GMPDIR)/gmp.h $(GMPDIR)/libgmp.a
++GMPINCDIR = $(GMPDIR)
++GMPLIBDIR = $(GMPDIR)
++GMPDEP = $(GMPINCDIR)/gmp.h $(GMPLIBDIR)/libgmp.a
++GMPLIBS = -L$(GMPLIBDIR) -lgmp
+
+ ZLIBDIR = zlib095
+-ZLIBDEP = $(ZLIBDIR)/libz.a
+-ZLIBLIBS = -L$(ZLIBDIR) -lz
++ZLIBINCDIR = $(ZLIBDIR)
++ZLIBLIBDIR = $(ZLIBDIR)
++ZLIBDEP = $(ZLIBINCDIR)/zlib.h $(ZLIBLIBDIR)/libz.a
++ZLIBLIBS = -L$(ZLIBLIBDIR) -lz
+
+ RSAREFDIR = rsaref2
+ RSAREFSRCDIR = $(RSAREFDIR)/source
+@@ -223,7 +227,7 @@
+ $(CC) -o rfc-pg rfc-pg.c
+
+ .c.o:
+- $(CC) -c -I. -I$(srcdir)/$(GMPDIR) -I$(srcdir)/$(ZLIBDIR) $(DEFS) -DHOST_KEY_FILE=\"$(HOST_KEY_FILE)\" -DHOST_CONFIG_FILE=\"$(HOST_CONFIG_FILE)\" -DSERVER_CONFIG_FILE=\"$(SERVER_CONFIG_FILE)\" -DSSH_PROGRAM=\"$(SSH_PROGRAM)\" -DETCDIR=\"$(etcdir)\" -DPIDDIR=\"$(piddir)\" -DBINDIR=\"$(bindir)\" $(CFLAGS) $(X_CFLAGS) $<
++ $(CC) -c -I. -I$(GMPINCDIR) -I$(ZLIBINCDIR) $(DEFS) -DHOST_KEY_FILE=\"$(HOST_KEY_FILE)\" -DHOST_CONFIG_FILE=\"$(HOST_CONFIG_FILE)\" -DSERVER_CONFIG_FILE=\"$(SERVER_CONFIG_FILE)\" -DSSH_PROGRAM=\"$(SSH_PROGRAM)\" -DETCDIR=\"$(etcdir)\" -DPIDDIR=\"$(piddir)\" -DBINDIR=\"$(bindir)\" $(CFLAGS) $(X_CFLAGS) $<
+
+ sshd: $(SSHD_OBJS) $(GMPDEP) $(RSAREFDEP) $(ZLIBDEP)
+ -rm -f sshd
+@@ -282,7 +286,7 @@
+ CC="$(CC)" CFLAGS="$(CFLAGS) -I. -I$(srcdir)/$(GMPDIR) \
+ -I../$(srcdir)/$(GMPDIR)" RANLIB="$(RANLIB)"
+
+-$(ZLIBDEP):
++$(ZLIBDIR)/libz.a:
+ -if test '!' -d $(ZLIBDIR); then \
+ mkdir $(ZLIBDIR); \
+ cp $(srcdir)/$(ZLIBDIR)/Makefile $(ZLIBDIR); \
diff --git a/security/ssh2/pkg-plist b/security/ssh2/pkg-plist
index c207d58536ff..5cf40f2c48f4 100644
--- a/security/ssh2/pkg-plist
+++ b/security/ssh2/pkg-plist
@@ -1,8 +1,8 @@
etc/rc.d/sshd.sh
@unexec rm %D/etc/rc.d/sshd.sh
bin/scp
+bin/slogin
bin/ssh
-@exec ln -fs %D/%F %B/slogin
bin/ssh-add
bin/ssh-agent
bin/ssh-askpass
@@ -16,6 +16,5 @@ man/man1/ssh-add.1.gz
man/man1/ssh-agent.1.gz
man/man1/ssh-keygen.1.gz
man/man1/ssh.1.gz
-@exec ln -fs %D/%F %B/slogin.1.gz
man/man8/sshd.8.gz
sbin/sshd