aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-05-25 20:05:50 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-05-25 20:05:50 +0000
commite82e60987a5e00137f41d03dcdb5ce0cccca9825 (patch)
tree4876bef72db56f83f05cdef798095e963786df4e /security
parent1e666cdba22098ed0cb4590c6006290340d9afa3 (diff)
downloadports-e82e60987a5e00137f41d03dcdb5ce0cccca9825.tar.gz
ports-e82e60987a5e00137f41d03dcdb5ce0cccca9825.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-Crypt-Dining/Makefile32
-rw-r--r--security/p5-Crypt-Dining/distinfo3
-rw-r--r--security/p5-Crypt-Dining/pkg-descr20
-rw-r--r--security/p5-Crypt-Dining/pkg-plist5
5 files changed, 61 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 256920673e05..70117130e5fd 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -326,6 +326,7 @@
SUBDIR += p5-Crypt-DES_PP
SUBDIR += p5-Crypt-DH
SUBDIR += p5-Crypt-DSA
+ SUBDIR += p5-Crypt-Dining
SUBDIR += p5-Crypt-ECB
SUBDIR += p5-Crypt-Enigma
SUBDIR += p5-Crypt-GOST
diff --git a/security/p5-Crypt-Dining/Makefile b/security/p5-Crypt-Dining/Makefile
new file mode 100644
index 000000000000..6cadeba5770b
--- /dev/null
+++ b/security/p5-Crypt-Dining/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-Crypt-Dining
+# Date created: 25 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Crypt-Dining
+PORTVERSION= 1.01
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Crypt
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= The Dining Cryptographers' Protocol
+
+BUILD_DEPENDS= ${SITE_PERL}/Crypt/Random.pm:${PORTSDIR}/security/p5-Crypt-Random \
+ ${SITE_PERL}/Net/Address/IPv4/Local.pm:${PORTSDIR}/net/p5-Net-Address-IPv4-Local
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= Crypt::Dining.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl 5.6.0 due to dependencies. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/security/p5-Crypt-Dining/distinfo b/security/p5-Crypt-Dining/distinfo
new file mode 100644
index 000000000000..6d0a05cebdee
--- /dev/null
+++ b/security/p5-Crypt-Dining/distinfo
@@ -0,0 +1,3 @@
+MD5 (Crypt-Dining-1.01.tar.gz) = 054242c8fffcfaa127d9e91cd86e5905
+SHA256 (Crypt-Dining-1.01.tar.gz) = 8bd751c90746fb9f95663f2c323ba3cd7d9513726d7d11cd576689a12feaf453
+SIZE (Crypt-Dining-1.01.tar.gz) = 4833
diff --git a/security/p5-Crypt-Dining/pkg-descr b/security/p5-Crypt-Dining/pkg-descr
new file mode 100644
index 000000000000..861dc7c97726
--- /dev/null
+++ b/security/p5-Crypt-Dining/pkg-descr
@@ -0,0 +1,20 @@
+The dining cryptographers' protocol is documented in Bruce Schneier's book
+as a kind of "cryptographic ouija board". It works as follows:
+
+A number of cryptographers are dining at a circular table. At the end of
+the meal, the waiter is summoned and asked for the bill. He replies,
+"Thank you, sir. The bill has been paid." The cryptographers now have the
+problem of working out whether someone at the table paid the bill, or
+whether the NSA has paid it as some sort of veiled threat. The protocol
+proceeds.
+
+Each cryptographer flips a coin, and shows the result ONLY to the
+participant on his RIGHT. Each cryptographer then compares his coin with
+that on his LEFT, and raises his hand if they show different faces. If any
+participant paid the bill, he "cheats" and does the opposite, that is, he
+raises his hand if the coins show the same face. Now, the hands are
+counted. An odd number means that someone at the table paid the bill. An
+even number means that the NSA paid.
+
+WWW: http://search.cpan.org/dist/Crypt-Dining
+Author: Shevek <shevek@cpan.org>
diff --git a/security/p5-Crypt-Dining/pkg-plist b/security/p5-Crypt-Dining/pkg-plist
new file mode 100644
index 000000000000..48edf496ad5b
--- /dev/null
+++ b/security/p5-Crypt-Dining/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Crypt/Dining.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/Dining/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/Dining
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt
+@dirrmtry %%SITE_PERL%%/Crypt