aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2016-02-05 07:05:11 +0000
committerCy Schubert <cy@FreeBSD.org>2016-02-05 07:05:11 +0000
commit098a06a07351e354695888648cace577c064687d (patch)
tree0b475653dfa69085d840ad47070aae0a04086787 /security
parent59b5b989bc085af6ff3514950960d169a2bef2bf (diff)
Notes
Diffstat (limited to 'security')
-rw-r--r--security/cracklib/Makefile18
-rw-r--r--security/cracklib/distinfo6
-rw-r--r--security/cracklib/files/patch-util__cracklib-format10
-rw-r--r--security/cracklib/files/pw_dict.hwmbin1024 -> 0 bytes
-rw-r--r--security/cracklib/files/pw_dict.pwdbin1842838 -> 0 bytes
-rw-r--r--security/cracklib/files/pw_dict.pwibin77624 -> 0 bytes
6 files changed, 25 insertions, 9 deletions
diff --git a/security/cracklib/Makefile b/security/cracklib/Makefile
index 9e3237dbbd34..d827dc99e3f5 100644
--- a/security/cracklib/Makefile
+++ b/security/cracklib/Makefile
@@ -2,13 +2,17 @@
# $FreeBSD$
PORTNAME= cracklib
-PORTVERSION= 2.9.4
+PORTVERSION= 2.9.6
CATEGORIES= security
.if defined(PYTHON_SLAVEPORT)
CATEGORIES+= python
.endif
-MASTER_SITES= SF \
+MASTER_SITES= https://github.com/cracklib/cracklib/releases/download/cracklib-2.9.6/ \
LOCAL/cy
+DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX} \
+ ${PORTNAME}-words-${PORTVERSION}.gz
+EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
+WORDS_DISTFILE= ${PORTNAME}-words-${PORTVERSION}.gz
MAINTAINER= cy@FreeBSD.org
COMMENT?= Password-checking library
@@ -16,7 +20,7 @@ COMMENT?= Password-checking library
LICENSE= LGPL21
DICTPATH= ${PREFIX}/libdata/${PORTNAME}
-DICTFILE= ${DICTPATH}/pw_dict
+DICTFILE= ${DICTPATH}/cracklib-words
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-default-dict=${DICTFILE}
INSTALL_TARGET= install-strip
@@ -43,9 +47,9 @@ PLIST_FILES= include/crack.h \
lib/libcrack.so \
lib/libcrack.so.2 \
lib/libcrack.so.2.9.0 \
- libdata/cracklib/pw_dict.hwm \
- libdata/cracklib/pw_dict.pwd \
- libdata/cracklib/pw_dict.pwi \
+ libdata/cracklib/cracklib-words.hwm \
+ libdata/cracklib/cracklib-words.pwd \
+ libdata/cracklib/cracklib-words.pwi \
man/man3/FascistCheck.3.gz \
man/man3/cracklib.3.gz \
sbin/cracklib-check \
@@ -105,7 +109,7 @@ post-install:
${INSTALL_MAN} ${FILESDIR}/${PORTNAME}.3 ${STAGEDIR}${MAN3PREFIX}/man/man3/
${LN} -s ${PORTNAME}.3 ${STAGEDIR}${MAN3PREFIX}/man/man3/FascistCheck.3
@${MKDIR} ${STAGEDIR}${DICTPATH}
- ${INSTALL_DATA} ${FILESDIR}/pw_dict* ${STAGEDIR}${DICTPATH}/
+ @PATH=$${PATH}:${STAGEDIR}${PREFIX}/sbin ${STAGEDIR}${PREFIX}/sbin/create-cracklib-dict -o ${STAGEDIR}${DICTPATH}/cracklib-words ${_DISTDIR}/${WORDS_DISTFILE}
.endif
.include <bsd.port.mk>
diff --git a/security/cracklib/distinfo b/security/cracklib/distinfo
index 94785d43c078..d4ca7cf61c79 100644
--- a/security/cracklib/distinfo
+++ b/security/cracklib/distinfo
@@ -1,2 +1,4 @@
-SHA256 (cracklib-2.9.4.tar.gz) = f2a866b4b9808344228ea6d68b69e3ba9a8a99210e23dfd718d4b95c60be8958
-SIZE (cracklib-2.9.4.tar.gz) = 622478
+SHA256 (cracklib-2.9.6.tar.gz) = 17cf76943de272fd579ed831a1fd85339b393f8d00bf9e0d17c91e972f583343
+SIZE (cracklib-2.9.6.tar.gz) = 642402
+SHA256 (cracklib-words-2.9.6.gz) = 27973245225eeb9d0090e97f3dea4197dec99b64d9d3a791a60298f3b021824c
+SIZE (cracklib-words-2.9.6.gz) = 5536645
diff --git a/security/cracklib/files/patch-util__cracklib-format b/security/cracklib/files/patch-util__cracklib-format
new file mode 100644
index 000000000000..573a22c4072a
--- /dev/null
+++ b/security/cracklib/files/patch-util__cracklib-format
@@ -0,0 +1,10 @@
+--- util/cracklib-format.orig 2015-08-18 11:41:16.000000000 -0700
++++ util/cracklib-format 2016-02-04 21:05:17.397847600 -0800
+@@ -3,6 +3,7 @@
+ # This preprocesses a set of word lists into a suitable form for input
+ # into cracklib-packer
+ #
++unset LANG
+ gzip -cdf "$@" |
+ grep -v '^\(#\|$\)' |
+ tr '[A-Z]' '[a-z]' |
diff --git a/security/cracklib/files/pw_dict.hwm b/security/cracklib/files/pw_dict.hwm
deleted file mode 100644
index 3604faffabf7..000000000000
--- a/security/cracklib/files/pw_dict.hwm
+++ /dev/null
Binary files differ
diff --git a/security/cracklib/files/pw_dict.pwd b/security/cracklib/files/pw_dict.pwd
deleted file mode 100644
index e36b6099e9d5..000000000000
--- a/security/cracklib/files/pw_dict.pwd
+++ /dev/null
Binary files differ
diff --git a/security/cracklib/files/pw_dict.pwi b/security/cracklib/files/pw_dict.pwi
deleted file mode 100644
index acfac8857f18..000000000000
--- a/security/cracklib/files/pw_dict.pwi
+++ /dev/null
Binary files differ