aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorGoran Mekic <meka@tilda.center>2021-10-04 17:07:25 +0000
committerAshish SHUKLA <ashish@FreeBSD.org>2021-11-24 11:20:18 +0000
commit127e49fb45063a84e3f57540ef05b842d116a041 (patch)
treef7ec88de7b0117eee4a804f393498d0208580f51 /security
parent18a47d7c81c82c753c8f43fe1ab0c2384f0c63d7 (diff)
downloadports-127e49fb45063a84e3f57540ef05b842d116a041.tar.gz
ports-127e49fb45063a84e3f57540ef05b842d116a041.zip
www/py-pyjwt: Rename to www/py-pyjwt1
To make it possible to easily import py-pyjwt v2.x move the current port to a versioned directory. Bump consumers after rename of the dependency. PR: 254038 (cherry picked from commit e6ec12f6646f71fe84268d21f3a6901191ebf60e)
Diffstat (limited to 'security')
-rw-r--r--security/py-oauthlib/Makefile5
-rw-r--r--security/py-social-auth-core/Makefile3
2 files changed, 5 insertions, 3 deletions
diff --git a/security/py-oauthlib/Makefile b/security/py-oauthlib/Makefile
index 278e49fd533e..7ee64dd9b898 100644
--- a/security/py-oauthlib/Makefile
+++ b/security/py-oauthlib/Makefile
@@ -2,6 +2,7 @@
PORTNAME= oauthlib
PORTVERSION= 1.1.2
+PORTREVISION= 1
CATEGORIES= security net python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -14,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>0:devel/py-nose@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}cryptography>0:security/py-cryptography@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pyjwt>=1.0.0:www/py-pyjwt@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pyjwt1>=1.0.0:www/py-pyjwt1@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}blinker>0:devel/py-blinker@${PY_FLAVOR}
OPTIONS_DEFINE= RSA SIGNALS SIGNEDTOKEN
@@ -27,7 +28,7 @@ SIGNEDTOKEN_DESC= Support for Signed Token
RSA_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cryptography>0:security/py-cryptography@${PY_FLAVOR}
SIGNALS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}blinker>0:devel/py-blinker@${PY_FLAVOR}
SIGNEDTOKEN_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cryptography>0:security/py-cryptography@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pyjwt>=1.0.0:www/py-pyjwt@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}pyjwt1>=1.0.0:www/py-pyjwt1@${PY_FLAVOR}
USES= python:3.6+
USE_PYTHON= autoplist distutils
diff --git a/security/py-social-auth-core/Makefile b/security/py-social-auth-core/Makefile
index 42f31a36cd76..01c868c4ef75 100644
--- a/security/py-social-auth-core/Makefile
+++ b/security/py-social-auth-core/Makefile
@@ -1,5 +1,6 @@
PORTNAME= social-auth-core
DISTVERSION= 4.0.2
+PORTREVISION= 1
CATEGORIES= security www python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -13,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cryptography>=2.1.1:security/py-cryptography@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}defusedxml>=0.5.0:devel/py-defusedxml@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}python3-openid>=3.0.10:security/py-python3-openid@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pyjwt>=1.7.1:www/py-pyjwt@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pyjwt1>=1.7.1:www/py-pyjwt1@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}oauthlib>=1.0.3:security/py-oauthlib@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}requests>=2.9.1:www/py-requests@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}requests-oauthlib>=0.6.1:www/py-requests-oauthlib@${PY_FLAVOR} \