aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorJochen Neumeister <joneum@FreeBSD.org>2018-07-05 15:16:33 +0000
committerJochen Neumeister <joneum@FreeBSD.org>2018-07-05 15:16:33 +0000
commit6b34d5f65840d9d051bf7b374abb9e1848ca2205 (patch)
treefb62175c3c93cb04fc327f97ff12f9abe9c3fee6 /security
parent9f682b4085bae1f1e08e5e7c5f7c6601d6a1b80c (diff)
downloadports-6b34d5f65840d9d051bf7b374abb9e1848ca2205.tar.gz
ports-6b34d5f65840d9d051bf7b374abb9e1848ca2205.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/i2p/Makefile10
-rw-r--r--security/i2p/distinfo6
-rw-r--r--security/i2p/files/patch-apps_streaming_java_src_net_i2p_client_streaming_impl_I2PServerSocketFull.java19
-rw-r--r--security/i2p/files/patch-apps_streaming_java_src_net_i2p_client_streaming_impl_I2PSocketManagerFull.java19
4 files changed, 47 insertions, 7 deletions
diff --git a/security/i2p/Makefile b/security/i2p/Makefile
index 550564789f57..6df3b10d8540 100644
--- a/security/i2p/Makefile
+++ b/security/i2p/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= i2p
-DISTVERSION= 0.9.33
+DISTVERSION= 0.9.35
CATEGORIES= security java net-p2p
MASTER_SITES= SF/${PORTNAME:tl}/${PORTVERSION} \
http://download.i2p2.no/releases/${PORTVERSION}/ \
@@ -11,7 +11,7 @@ MASTER_SITES= SF/${PORTNAME:tl}/${PORTVERSION} \
http://download.i2p2.de/releases/${PORTVERSION}/ \
https://launchpad.net/i2p/trunk/${PORTVERSION}/+download/ \
https://googledrive.com/host/0B4jHEq5G7_EPWV9UeERwdGplZXc/${PORTVERSION}/
-DISTFILES= i2psource_${PORTVERSION}${EXTRACT_SUFX}
+DISTNAME= i2psource_${PORTVERSION}
MAINTAINER= neel@neelc.org
COMMENT= Anonymizing network
@@ -22,11 +22,13 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.txt
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
LICENSE_DISTFILES= i2psource_${PORTVERSION}${EXTRACT_SUFX}
+ONLY_FOR_ARCHS= amd64 i386
+ONLY_FOR_ARCHS_REASON= i2p libwrapper.so library binary only available for i386 and amd64
+
BUILD_DEPENDS= ${LOCALBASE}/lib/libgmp.a:math/gmp
LIB_DEPENDS= libiconv.so:converters/libiconv
-ONLY_FOR_ARCHS= i386 amd64
-ONLY_FOR_ARCHS_REASON= i2p libwrapper.so library binary only available for i386 and amd64
+WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION}
USES= gettext tar:bzip2
USE_RC_SUBR= i2p
diff --git a/security/i2p/distinfo b/security/i2p/distinfo
index 4c05803299b9..d69c66eafdc0 100644
--- a/security/i2p/distinfo
+++ b/security/i2p/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1518416518
-SHA256 (i2psource_0.9.33.tar.bz2) = 843345a85e021408e4cbeff8ee94b3842e9c4b5295bef374d5f2026872dae114
-SIZE (i2psource_0.9.33.tar.bz2) = 28985659
+TIMESTAMP = 1530364987
+SHA256 (i2psource_0.9.35.tar.bz2) = 8bb88d3db355ebfa5be65d48089db60919875ac298b7217b7f8150048ea5079e
+SIZE (i2psource_0.9.35.tar.bz2) = 29313321
diff --git a/security/i2p/files/patch-apps_streaming_java_src_net_i2p_client_streaming_impl_I2PServerSocketFull.java b/security/i2p/files/patch-apps_streaming_java_src_net_i2p_client_streaming_impl_I2PServerSocketFull.java
new file mode 100644
index 000000000000..5276b6f2ce44
--- /dev/null
+++ b/security/i2p/files/patch-apps_streaming_java_src_net_i2p_client_streaming_impl_I2PServerSocketFull.java
@@ -0,0 +1,19 @@
+--- apps/streaming/java/src/net/i2p/client/streaming/impl/I2PServerSocketFull.java.orig 2018-06-26 11:12:11 UTC
++++ apps/streaming/java/src/net/i2p/client/streaming/impl/I2PServerSocketFull.java
+@@ -8,6 +8,7 @@ import net.i2p.client.streaming.AcceptingChannel;
+ import net.i2p.client.streaming.I2PServerSocket;
+ import net.i2p.client.streaming.I2PSocket;
+ import net.i2p.client.streaming.I2PSocketManager;
++import net.i2p.client.streaming.RouterRestartException;
+
+ /**
+ * Bridge to allow accepting new connections
+@@ -35,7 +36,7 @@ class I2PServerSocketFull implements I2PServerSocket {
+ * Not actually thrown through 0.9.16; thrown as of 0.9.17
+ * @throws SocketTimeoutException if a timeout was previously set with setSoTimeout and the timeout has been reached.
+ */
+- public I2PSocket accept() throws I2PException, ConnectException, SocketTimeoutException {
++ public I2PSocket accept() throws I2PException, RouterRestartException, ConnectException, SocketTimeoutException {
+ return _socketManager.receiveSocket();
+ }
+
diff --git a/security/i2p/files/patch-apps_streaming_java_src_net_i2p_client_streaming_impl_I2PSocketManagerFull.java b/security/i2p/files/patch-apps_streaming_java_src_net_i2p_client_streaming_impl_I2PSocketManagerFull.java
new file mode 100644
index 000000000000..38fa1aee08a4
--- /dev/null
+++ b/security/i2p/files/patch-apps_streaming_java_src_net_i2p_client_streaming_impl_I2PSocketManagerFull.java
@@ -0,0 +1,19 @@
+--- apps/streaming/java/src/net/i2p/client/streaming/impl/I2PSocketManagerFull.java.orig 2018-06-26 11:12:11 UTC
++++ apps/streaming/java/src/net/i2p/client/streaming/impl/I2PSocketManagerFull.java
+@@ -28,6 +28,7 @@ import net.i2p.client.streaming.I2PServerSocket;
+ import net.i2p.client.streaming.I2PSocket;
+ import net.i2p.client.streaming.I2PSocketManager;
+ import net.i2p.client.streaming.I2PSocketOptions;
++import net.i2p.client.streaming.RouterRestartException;
+ import net.i2p.crypto.SigAlgo;
+ import net.i2p.crypto.SigType;
+ import net.i2p.data.Certificate;
+@@ -354,7 +355,7 @@ public class I2PSocketManagerFull implements I2PSocket
+ * @throws ConnectException (since 0.9.17; I2PServerSocket interface always declared it)
+ * @throws SocketTimeoutException if a timeout was previously set with setSoTimeout and the timeout has been reached.
+ */
+- public I2PSocket receiveSocket() throws I2PException, ConnectException, SocketTimeoutException {
++ public I2PSocket receiveSocket() throws I2PException, RouterRestartException, ConnectException, SocketTimeoutException {
+ verifySession();
+ Connection con = _connectionManager.getConnectionHandler().accept(_connectionManager.getSoTimeout());
+ I2PSocketFull sock = new I2PSocketFull(con, _context);