aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2014-08-17 11:18:54 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2014-08-17 11:18:54 +0000
commit70794437bb5bc2ae6f0846b5a26ad538a4b7dc78 (patch)
tree8c12bf472542347953713c918aa61adf93481cad /security
parent0d0dabfb6435a36ff45398c66a15d0f27b9f166c (diff)
Notes
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/py-cpe/Makefile19
-rw-r--r--security/py-cpe/distinfo2
-rw-r--r--security/py-cpe/pkg-descr15
4 files changed, 37 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index ed98d18b5d85..84a24a55373d 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -754,6 +754,7 @@
SUBDIR += py-cerealizer
SUBDIR += py-certify
SUBDIR += py-clamav
+ SUBDIR += py-cpe
SUBDIR += py-cracklib
SUBDIR += py-cryptkit
SUBDIR += py-cryptography
diff --git a/security/py-cpe/Makefile b/security/py-cpe/Makefile
new file mode 100644
index 000000000000..29dd05871eee
--- /dev/null
+++ b/security/py-cpe/Makefile
@@ -0,0 +1,19 @@
+# Created by: Kubilay Kocak <koobs@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= cpe
+PORTVERSION= 1.1.0
+CATEGORIES= security python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= koobs@FreeBSD.org
+COMMENT= Common Platform Enumeration (CPE) for Python
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= python:-2.7
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/security/py-cpe/distinfo b/security/py-cpe/distinfo
new file mode 100644
index 000000000000..2a9241bf5982
--- /dev/null
+++ b/security/py-cpe/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cpe-1.1.0.tar.gz) = 3e7d18460a9921ab6668d3cc2ffec59b6bd99922f30714446bcf982c022c4836
+SIZE (cpe-1.1.0.tar.gz) = 69155
diff --git a/security/py-cpe/pkg-descr b/security/py-cpe/pkg-descr
new file mode 100644
index 000000000000..04e56fa3954e
--- /dev/null
+++ b/security/py-cpe/pkg-descr
@@ -0,0 +1,15 @@
+Common Platform Enumeration (CPE) is a standardized method of describing
+and identifying classes of applications, operating systems, and hardware
+devices present among an enterprise's computing assets.
+
+For more information, please visit the official website of CPE, developed
+by MITRE and maintained by NIST.
+
+Features:
+
+ * Versions: 1.1, 2.2, 2.3
+ * Formats: WFN, URI, FS.
+ * Cross-version conversion.
+ * Language parsing and evaluation.
+
+WWW: https://github.com/nilp0inter/cpe