aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorEitan Adler <eadler@FreeBSD.org>2011-10-20 12:22:03 +0000
committerEitan Adler <eadler@FreeBSD.org>2011-10-20 12:22:03 +0000
commit901babd7fdfc91d927ebe0aacf7ca151a6ca31e4 (patch)
treec7e1dddde786c793f36125338240fef3c1928297 /security
parent5ee29dca8a1c44cf180dbe683daf242fa5cd6f6e (diff)
Notes
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/py-htpasswd/Makefile28
-rw-r--r--security/py-htpasswd/distinfo2
-rw-r--r--security/py-htpasswd/pkg-descr6
4 files changed, 37 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 0e1bc9d71503..9eb597f77f04 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -693,6 +693,7 @@
SUBDIR += py-fchksum
SUBDIR += py-gnupg
SUBDIR += py-gnutls
+ SUBDIR += py-htpasswd
SUBDIR += py-kerberos
SUBDIR += py-keyring
SUBDIR += py-m2crypto
diff --git a/security/py-htpasswd/Makefile b/security/py-htpasswd/Makefile
new file mode 100644
index 000000000000..b40f89bafc38
--- /dev/null
+++ b/security/py-htpasswd/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: py-htpasswd
+# Date created: 2011-08-26
+# Whom: Aldis Berjoza <aldis@bsdroot.lv>
+#
+# $FreeBSD$
+#
+
+PORTNAME= htpasswd
+PORTVERSION= 2008.03.05
+CATEGORIES= security python
+MASTER_SITES= http://files.bsdroot.lv/my/FreeBSD/distfiles/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= aldis@bsdroot.lv
+COMMENT= Replacement for htpasswd
+
+USE_PYTHON= YES
+USE_XZ= YES
+
+PLIST_FILES= bin/${PORTNAME}.py
+
+NO_BUILD= YES
+NO_WRKSUBDIR= YES
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}.py ${PREFIX}/bin/
+
+.include <bsd.port.mk>
diff --git a/security/py-htpasswd/distinfo b/security/py-htpasswd/distinfo
new file mode 100644
index 000000000000..54aaded2d2cf
--- /dev/null
+++ b/security/py-htpasswd/distinfo
@@ -0,0 +1,2 @@
+SHA256 (htpasswd-2008.03.05.tar.xz) = 179941e30f8e2b9ff8f4e88e4300ca6e9dcaa761066c4d5444383ecfe3963a13
+SIZE (htpasswd-2008.03.05.tar.xz) = 1640
diff --git a/security/py-htpasswd/pkg-descr b/security/py-htpasswd/pkg-descr
new file mode 100644
index 000000000000..45616b259277
--- /dev/null
+++ b/security/py-htpasswd/pkg-descr
@@ -0,0 +1,6 @@
+Replacement for htpasswd.
+
+This port will install htpasswd.py that can be found in trac trac contrib
+directory.
+
+WWW: http://trac.edgewall.org/browser/trunk/contrib/htpasswd.py