aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2014-05-08 10:47:26 +0000
committerRenato Botelho <garga@FreeBSD.org>2014-05-08 10:47:26 +0000
commit9c60da33fc7546e3341a64daf1149b9950a819e7 (patch)
tree9ccfcc07630015b4363c5da234ecbe8271f6945c /security
parentd89554cc6c9a169420a93a74f60ea9be7c90da5b (diff)
Notes
Diffstat (limited to 'security')
-rw-r--r--security/clamav/Makefile6
-rw-r--r--security/clamav/distinfo4
-rw-r--r--security/clamav/files/patch-libclamav-c++-llvm72
-rw-r--r--security/clamav/pkg-plist14
4 files changed, 11 insertions, 85 deletions
diff --git a/security/clamav/Makefile b/security/clamav/Makefile
index 7396319a81a3..123c8e6bf44d 100644
--- a/security/clamav/Makefile
+++ b/security/clamav/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= clamav
-PORTVERSION= 0.98.1
-PORTREVISION= 3
+PORTVERSION= 0.98.3
CATEGORIES= security
MASTER_SITES= SF
@@ -12,6 +11,8 @@ COMMENT= Command line virus scanner written entirely in C
LICENSE= GPLv2
+LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl
+
OPTIONS_DEFINE= ARC ARJ LHA UNZOO UNRAR LLVM TESTS MILTER LDAP ICONV STDERR \
EXPERIMENTAL DOCS IPV6 DMG_XAR
@@ -48,6 +49,7 @@ DMG_XAR_USE= GNOME=libxml2
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
USES= gmake
+INSTALL_TARGET= install-strip
USE_RC_SUBR= clamav-clamd clamav-freshclam
PORTDOCS= *
diff --git a/security/clamav/distinfo b/security/clamav/distinfo
index 75a77da505a8..e0d9126dc943 100644
--- a/security/clamav/distinfo
+++ b/security/clamav/distinfo
@@ -1,2 +1,2 @@
-SHA256 (clamav-0.98.1.tar.gz) = 35f5e84d734cdd4532c1cc6c92560c5b31d1c24f2e1e203bef0ca1351eb223dc
-SIZE (clamav-0.98.1.tar.gz) = 15431484
+SHA256 (clamav-0.98.3.tar.gz) = 2792a9e8706a516d2e81339846fc38f94fa8dd3f604b2fde9d0b07593727f62b
+SIZE (clamav-0.98.3.tar.gz) = 15543335
diff --git a/security/clamav/files/patch-libclamav-c++-llvm b/security/clamav/files/patch-libclamav-c++-llvm
deleted file mode 100644
index 91c436b65f8b..000000000000
--- a/security/clamav/files/patch-libclamav-c++-llvm
+++ /dev/null
@@ -1,72 +0,0 @@
---- libclamav/c++/llvm/lib/Target/SubtargetFeature.cpp.orig
-+++ libclamav/c++/llvm/lib/Target/SubtargetFeature.cpp
-@@ -18,6 +18,7 @@
- #include <algorithm>
- #include <cassert>
- #include <cctype>
-+#include <cstdlib>
- using namespace llvm;
-
- //===----------------------------------------------------------------------===//
---- libclamav/c++/llvm/include/llvm/Support/CFG.h.orig
-+++ libclamav/c++/llvm/include/llvm/Support/CFG.h
-@@ -27,8 +27,9 @@
-
- template <class Ptr, class USE_iterator> // Predecessor Iterator
- class PredIterator : public std::iterator<std::forward_iterator_tag,
-- Ptr, ptrdiff_t> {
-- typedef std::iterator<std::forward_iterator_tag, Ptr, ptrdiff_t> super;
-+ Ptr, ptrdiff_t, Ptr*, Ptr*> {
-+ typedef std::iterator<std::forward_iterator_tag, Ptr, ptrdiff_t, Ptr*,
-+ Ptr*> super;
- typedef PredIterator<Ptr, USE_iterator> Self;
- USE_iterator It;
-
-@@ -40,6 +41,7 @@
-
- public:
- typedef typename super::pointer pointer;
-+ typedef typename super::reference reference;
-
- PredIterator() {}
- explicit inline PredIterator(Ptr *bb) : It(bb->use_begin()) {
-@@ -50,7 +52,7 @@
- inline bool operator==(const Self& x) const { return It == x.It; }
- inline bool operator!=(const Self& x) const { return !operator==(x); }
-
-- inline pointer operator*() const {
-+ inline reference operator*() const {
- assert(!It.atEnd() && "pred_iterator out of range!");
- return cast<TerminatorInst>(*It)->getParent();
- }
-@@ -100,10 +102,11 @@
-
- template <class Term_, class BB_> // Successor Iterator
- class SuccIterator : public std::iterator<std::bidirectional_iterator_tag,
-- BB_, ptrdiff_t> {
-+ BB_, ptrdiff_t, BB_*, BB_*> {
- const Term_ Term;
- unsigned idx;
-- typedef std::iterator<std::bidirectional_iterator_tag, BB_, ptrdiff_t> super;
-+ typedef std::iterator<std::bidirectional_iterator_tag, BB_, ptrdiff_t, BB_*,
-+ BB_*> super;
- typedef SuccIterator<Term_, BB_> Self;
-
- inline bool index_is_valid(int idx) {
-@@ -112,6 +115,7 @@
-
- public:
- typedef typename super::pointer pointer;
-+ typedef typename super::reference reference;
- // TODO: This can be random access iterator, only operator[] missing.
-
- explicit inline SuccIterator(Term_ T) : Term(T), idx(0) {// begin iterator
-@@ -142,7 +146,7 @@
- inline bool operator==(const Self& x) const { return idx == x.idx; }
- inline bool operator!=(const Self& x) const { return !operator==(x); }
-
-- inline pointer operator*() const { return Term->getSuccessor(idx); }
-+ inline reference operator*() const { return Term->getSuccessor(idx); }
- inline pointer operator->() const { return operator*(); }
-
- inline Self& operator++() { ++idx; return *this; } // Preincrement
diff --git a/security/clamav/pkg-plist b/security/clamav/pkg-plist
index 6c3582d83c47..bed6b66ed12e 100644
--- a/security/clamav/pkg-plist
+++ b/security/clamav/pkg-plist
@@ -3,6 +3,7 @@ bin/clambc
bin/clamconf
bin/clamdtop
bin/clamscan
+bin/clamsubmit
bin/clamdscan
bin/freshclam
bin/sigtool
@@ -25,6 +26,7 @@ man/man1/clamconf.1.gz
man/man1/clamdscan.1.gz
man/man1/clamdtop.1.gz
man/man1/clamscan.1.gz
+man/man1/clamsubmit.1.gz
man/man1/freshclam.1.gz
man/man1/sigtool.1.gz
man/man5/clamav-milter.conf.5.gz
@@ -32,12 +34,6 @@ man/man5/clamd.conf.5.gz
man/man5/freshclam.conf.5.gz
man/man8/clamav-milter.8.gz
man/man8/clamd.8.gz
-@unexec if cmp -s %D/etc/clamd.conf %D/etc/clamd.conf.sample; then rm -f %D/etc/clamd.conf; fi
-etc/clamd.conf.sample
-@exec [ -f %B/clamd.conf ] || cp %B/%f %B/clamd.conf
-@unexec if cmp -s %D/etc/freshclam.conf %D/etc/freshclam.conf.sample; then rm -f %D/etc/freshclam.conf; fi
-etc/freshclam.conf.sample
-@exec [ -f %B/freshclam.conf ] || cp %B/%f %B/freshclam.conf
-%%MILTER%%@unexec if cmp -s %D/etc/clamav-milter.conf %D/etc/clamav-milter.conf.sample; then rm -f %D/etc/clamav-milter.conf; fi
-%%MILTER%%etc/clamav-milter.conf.sample
-%%MILTER%%@exec [ -f %B/clamav-milter.conf ] || cp %B/%f %B/clamav-milter.conf
+@sample etc/clamd.conf.sample
+@sample etc/freshclam.conf.sample
+%%MILTER%%@sample etc/clamav-milter.conf.sample