aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2015-02-07 07:25:22 +0000
committerKurt Jaeger <pi@FreeBSD.org>2015-02-07 07:25:22 +0000
commitb4bb164508d2874288be084ebafff792b19712ab (patch)
tree0196806c1c0b2ec0bd7ad16d597dabc336b90d85 /security
parentb4ea8bc6867f104a19b5a9dace56d3388f012ccc (diff)
downloadports-b4bb164508d2874288be084ebafff792b19712ab.tar.gz
ports-b4bb164508d2874288be084ebafff792b19712ab.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/libgcrypt/Makefile11
-rw-r--r--security/libgcrypt/files/patch-cipher-Makefile.in15
2 files changed, 24 insertions, 2 deletions
diff --git a/security/libgcrypt/Makefile b/security/libgcrypt/Makefile
index c292fc8cd1bb..c36243d0561b 100644
--- a/security/libgcrypt/Makefile
+++ b/security/libgcrypt/Makefile
@@ -2,6 +2,7 @@
PORTNAME= libgcrypt
PORTVERSION= 1.6.2
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_GNUPG}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -21,7 +22,6 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-drng-support
CONFIGURE_ENV= MAKEINFO="makeinfo --no-split"
CONFIGURE_TARGET=${ARCH:S/amd64/x86_64/}-portbld-${OPSYS:tl}${OSREL}
-INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
DOCS= AUTHORS ChangeLog ChangeLog-2011 INSTALL NEWS README \
@@ -53,8 +53,15 @@ USE_GCC= any
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-configure
.endif
-.if ${PORT_OPTIONS:MDOCS}
+# Fix crash at cipher/salsa20.c module on amd64
+.if ${ARCH} == "amd64" && exists(/usr/bin/clang)
+CFLAGS:= ${CFLAGS:N-O*} -O2
+.endif
+
post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/${PORTNAME}.so.20.0.2
+
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${STAGEDIR}${DOCSDIR}
.endif
diff --git a/security/libgcrypt/files/patch-cipher-Makefile.in b/security/libgcrypt/files/patch-cipher-Makefile.in
new file mode 100644
index 000000000000..852a9548e535
--- /dev/null
+++ b/security/libgcrypt/files/patch-cipher-Makefile.in
@@ -0,0 +1,15 @@
+--- cipher/Makefile.in.orig 2015-01-21 19:09:47.000000000 +0100
++++ cipher/Makefile.in 2015-01-21 19:13:35.000000000 +0100
+@@ -766,6 +766,12 @@
+ tiger.lo: $(srcdir)/tiger.c
+ `echo $(LTCOMPILE) -c $(srcdir)/tiger.c | $(o_flag_munging) `
+
++salsa20.o: $(srcdir)/salsa20.c
++ `echo $(COMPILE) -c $(srcdir)/salsa20.c | $(o_flag_munging) `
++
++salsa20.lo: $(srcdir)/salsa20.c
++ `echo $(LTCOMPILE) -c $(srcdir)/salsa20.c | $(o_flag_munging) `
++
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
+ .NOEXPORT: