aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2014-08-09 15:03:49 +0000
committerKurt Jaeger <pi@FreeBSD.org>2014-08-09 15:03:49 +0000
commitc9c0fba3555ebe2bc14b5a4b9a85b7922a1c5083 (patch)
tree4506c7cfc28676878e446067f401bdad4b7eee58 /security
parent60c7153b80b5a1a6f4449f0b95fe77af086781d8 (diff)
Notes
Diffstat (limited to 'security')
-rw-r--r--security/pwman/Makefile18
-rw-r--r--security/pwman/distinfo4
-rw-r--r--security/pwman/pkg-descr4
3 files changed, 14 insertions, 12 deletions
diff --git a/security/pwman/Makefile b/security/pwman/Makefile
index 55e7a8136a73..9449ecdc544c 100644
--- a/security/pwman/Makefile
+++ b/security/pwman/Makefile
@@ -2,31 +2,33 @@
# $FreeBSD$
PORTNAME= pwman
-PORTVERSION= 0.4.0
-PORTREVISION= 1
+PORTVERSION= 0.4.4
CATEGORIES= security
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Console password management application based on gpg(me)
-LIB_DEPENDS= libxml2.so:${PORTSDIR}/textproc/libxml2
+LICENSE= GPLv2 # (or later)
+
RUN_DEPENDS= gpgv:${PORTSDIR}/security/gnupg1
+USE_GNOME= libxml2
GNU_CONFIGURE= yes
-CFLAGS+= -Wno-return-type
-
+PORTDOCS= AUTHORS ChangeLog README TODO
PLIST_FILES= bin/convert_pwdb bin/pwdb2csv bin/pwman man/man1/pwman.1.gz
-PORTDOCS= AUTHORS COPYING ChangeLog README TODO
+
+CFLAGS+= -Wno-error=return-type
OPTIONS_DEFINE= DOCS
post-patch:
- @${REINPLACE_CMD} -e 's|/usr/bin/gpg|${LOCALBASE}/bin/gpg|g' ${WRKSRC}/src/options.c
+ @${REINPLACE_CMD} -e \
+ 's|/usr/bin|${LOCALBASE}/bin|' ${WRKSRC}/src/options.c
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR})
.include <bsd.port.mk>
diff --git a/security/pwman/distinfo b/security/pwman/distinfo
index 25a2307356b8..ef534ebdbc99 100644
--- a/security/pwman/distinfo
+++ b/security/pwman/distinfo
@@ -1,2 +1,2 @@
-SHA256 (pwman-0.4.0.tar.gz) = 8a3eaa5281c96dff1bf4c7a17c69c03b5471c4c21a44624d4def06a5c6dc223f
-SIZE (pwman-0.4.0.tar.gz) = 107105
+SHA256 (pwman-0.4.4.tar.gz) = 29027550ddef720ec447a3031063b10691e6139c9cd5bab18974a52dabdd69c5
+SIZE (pwman-0.4.4.tar.gz) = 114439
diff --git a/security/pwman/pkg-descr b/security/pwman/pkg-descr
index 969523bb62dd..084e3f990120 100644
--- a/security/pwman/pkg-descr
+++ b/security/pwman/pkg-descr
@@ -1,4 +1,4 @@
-PWman is a console application for managing passwords. It uses GPG (gpgme)
-for encryption and authentication.
+PWman is a console application for managing passwords. It uses
+GPG (gpgme) for encryption and authentication.
WWW: http://pwman.sourceforge.net/