aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorOlli Hauer <ohauer@FreeBSD.org>2012-01-04 16:47:52 +0000
committerOlli Hauer <ohauer@FreeBSD.org>2012-01-04 16:47:52 +0000
commitd4bf9fc462973957d11b2fd2b7522f857099d533 (patch)
tree0a16efa1ac7b476105567572727bd0310dab22c5 /security
parentf2895b183da3a210857bc1301d2e09a1981f47e2 (diff)
downloadports-d4bf9fc462973957d11b2fd2b7522f857099d533.tar.gz
ports-d4bf9fc462973957d11b2fd2b7522f857099d533.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/nmap/Makefile5
-rw-r--r--security/nmap/distinfo4
-rw-r--r--security/nmap/files/patch-nbase__configure22
-rw-r--r--security/nmap/pkg-plist60
4 files changed, 65 insertions, 26 deletions
diff --git a/security/nmap/Makefile b/security/nmap/Makefile
index 5cee734d6ae4..f69bb01ac469 100644
--- a/security/nmap/Makefile
+++ b/security/nmap/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= nmap
-DISTVERSION= 5.61TEST2
+DISTVERSION= 5.61TEST4
CATEGORIES= security ipv6
MASTER_SITES= http://nmap.org/dist/ \
LOCAL/ohauer
@@ -28,7 +28,8 @@ CONFIGURE_ARGS= --without-localdirs \
--without-zenmap \
--without-ndiff \
--with-libpcre=${LOCALBASE} \
- --with-liblua=${LOCALBASE}
+ --with-liblua=${LOCALBASE} \
+ --without-nmap-update
CONFIGURE_ENV= LUA_INCDIR="${LUA_INCDIR}" LUA_LIBDIR="${LUA_LIBDIR}"
# fix for gcc from ports
diff --git a/security/nmap/distinfo b/security/nmap/distinfo
index 50ebdfb2dfd9..65014e21f304 100644
--- a/security/nmap/distinfo
+++ b/security/nmap/distinfo
@@ -1,2 +1,2 @@
-SHA256 (nmap-5.61TEST2.tar.bz2) = 8b086eba391e306bcb99750a757abe016651b817b4fde046b0e1ea91c5455ee0
-SIZE (nmap-5.61TEST2.tar.bz2) = 21633731
+SHA256 (nmap-5.61TEST4.tar.bz2) = b914d42dd578ffd711e6e5a8ea136acbe367c356c03c967811e76bd24a1923ae
+SIZE (nmap-5.61TEST4.tar.bz2) = 21757047
diff --git a/security/nmap/files/patch-nbase__configure b/security/nmap/files/patch-nbase__configure
deleted file mode 100644
index a6a7d5e4f783..000000000000
--- a/security/nmap/files/patch-nbase__configure
+++ /dev/null
@@ -1,22 +0,0 @@
-This patch allows nmap to build with clang
-===============================================================
---- ./nbase/configure.orig 2011-06-29 00:19:31.000000000 +0200
-+++ ./nbase/configure 2011-07-31 23:17:57.000000000 +0200
-@@ -4515,7 +4515,7 @@
- #include <sys/socket.h>
- #endif
-
--void main(void) {
-+int main(void) {
- struct addrinfo hints, *ai;
- int error;
-
-@@ -4647,7 +4647,7 @@
- #include <netinet/in.h>
- #endif
-
--void main(void) {
-+int main(void) {
- struct sockaddr_in sa;
- char hbuf[256];
- int error;
diff --git a/security/nmap/pkg-plist b/security/nmap/pkg-plist
index 5b9e1964d0a5..5e8e1d51b313 100644
--- a/security/nmap/pkg-plist
+++ b/security/nmap/pkg-plist
@@ -13,8 +13,10 @@ bin/nping
%%DATADIR%%/nmap.xsl
%%DATADIR%%/nse_main.lua
%%DATADIR%%/nselib/afp.lua
+%%DATADIR%%/nselib/amqp.lua
%%DATADIR%%/nselib/asn1.lua
%%DATADIR%%/nselib/base64.lua
+%%DATADIR%%/nselib/bitcoin.lua
%%DATADIR%%/nselib/bittorrent.lua
%%DATADIR%%/nselib/brute.lua
%%DATADIR%%/nselib/citrixxml.lua
@@ -40,19 +42,23 @@ bin/nping
%%DATADIR%%/nselib/data/psexec/nmap_service.c
%%DATADIR%%/nselib/data/psexec/nmap_service.vcproj
%%DATADIR%%/nselib/data/psexec/pwdump.lua
+%%DATADIR%%/nselib/data/rtsp-urls.txt
%%DATADIR%%/nselib/data/snmpcommunities.lst
%%DATADIR%%/nselib/data/ssl-ciphers
%%DATADIR%%/nselib/data/ssl-fingerprints
+%%DATADIR%%/nselib/data/tftplist.txt
%%DATADIR%%/nselib/data/usernames.lst
%%DATADIR%%/nselib/data/wp-plugins.lst
%%DATADIR%%/nselib/datafiles.lua
%%DATADIR%%/nselib/dhcp.lua
%%DATADIR%%/nselib/dns.lua
+%%DATADIR%%/nselib/dnsbl.lua
%%DATADIR%%/nselib/dnssd.lua
%%DATADIR%%/nselib/drda.lua
%%DATADIR%%/nselib/ftp.lua
%%DATADIR%%/nselib/giop.lua
%%DATADIR%%/nselib/http.lua
+%%DATADIR%%/nselib/httpspider.lua
%%DATADIR%%/nselib/imap.lua
%%DATADIR%%/nselib/informix.lua
%%DATADIR%%/nselib/ipOps.lua
@@ -78,6 +84,7 @@ bin/nping
%%DATADIR%%/nselib/proxy.lua
%%DATADIR%%/nselib/rmi.lua
%%DATADIR%%/nselib/rpc.lua
+%%DATADIR%%/nselib/rtsp.lua
%%DATADIR%%/nselib/sasl.lua
%%DATADIR%%/nselib/shortport.lua
%%DATADIR%%/nselib/sip.lua
@@ -99,6 +106,8 @@ bin/nping
%%DATADIR%%/nselib/upnp.lua
%%DATADIR%%/nselib/url.lua
%%DATADIR%%/nselib/vnc.lua
+%%DATADIR%%/nselib/vulns.lua
+%%DATADIR%%/nselib/vuzedht.lua
%%DATADIR%%/nselib/wsdd.lua
%%DATADIR%%/nselib/xmpp.lua
%%DATADIR%%/scripts/address-info.nse
@@ -107,12 +116,16 @@ bin/nping
%%DATADIR%%/scripts/afp-path-vuln.nse
%%DATADIR%%/scripts/afp-serverinfo.nse
%%DATADIR%%/scripts/afp-showmount.nse
+%%DATADIR%%/scripts/amqp-info.nse
%%DATADIR%%/scripts/asn-query.nse
%%DATADIR%%/scripts/auth-owners.nse
%%DATADIR%%/scripts/auth-spoof.nse
%%DATADIR%%/scripts/backorifice-brute.nse
%%DATADIR%%/scripts/backorifice-info.nse
%%DATADIR%%/scripts/banner.nse
+%%DATADIR%%/scripts/bitcoin-getaddr.nse
+%%DATADIR%%/scripts/bitcoin-info.nse
+%%DATADIR%%/scripts/bitcoinrpc-info.nse
%%DATADIR%%/scripts/bittorrent-discovery.nse
%%DATADIR%%/scripts/broadcast-avahi-dos.nse
%%DATADIR%%/scripts/broadcast-db2-discover.nse
@@ -123,8 +136,14 @@ bin/nping
%%DATADIR%%/scripts/broadcast-ms-sql-discover.nse
%%DATADIR%%/scripts/broadcast-netbios-master-browser.nse
%%DATADIR%%/scripts/broadcast-novell-locate.nse
+%%DATADIR%%/scripts/broadcast-pc-anywhere.nse
+%%DATADIR%%/scripts/broadcast-pc-duo.nse
%%DATADIR%%/scripts/broadcast-ping.nse
+%%DATADIR%%/scripts/broadcast-rip-discover.nse
+%%DATADIR%%/scripts/broadcast-sybase-asa-discover.nse
%%DATADIR%%/scripts/broadcast-upnp-info.nse
+%%DATADIR%%/scripts/broadcast-wake-on-lan.nse
+%%DATADIR%%/scripts/broadcast-wpad-discover.nse
%%DATADIR%%/scripts/broadcast-wsdd-discover.nse
%%DATADIR%%/scripts/citrix-brute-xml.nse
%%DATADIR%%/scripts/citrix-enum-apps-xml.nse
@@ -141,6 +160,7 @@ bin/nping
%%DATADIR%%/scripts/db2-das-info.nse
%%DATADIR%%/scripts/db2-discover.nse
%%DATADIR%%/scripts/dhcp-discover.nse
+%%DATADIR%%/scripts/dns-blacklist.nse
%%DATADIR%%/scripts/dns-brute.nse
%%DATADIR%%/scripts/dns-cache-snoop.nse
%%DATADIR%%/scripts/dns-fuzz.nse
@@ -150,6 +170,7 @@ bin/nping
%%DATADIR%%/scripts/dns-recursion.nse
%%DATADIR%%/scripts/dns-service-discovery.nse
%%DATADIR%%/scripts/dns-update.nse
+%%DATADIR%%/scripts/dns-zeustracker.nse
%%DATADIR%%/scripts/dns-zone-transfer.nse
%%DATADIR%%/scripts/domcon-brute.nse
%%DATADIR%%/scripts/domcon-cmd.nse
@@ -167,41 +188,60 @@ bin/nping
%%DATADIR%%/scripts/ftp-proftpd-backdoor.nse
%%DATADIR%%/scripts/ftp-vsftpd-backdoor.nse
%%DATADIR%%/scripts/ftp-vuln-cve2010-4221.nse
+%%DATADIR%%/scripts/ganglia-info.nse
%%DATADIR%%/scripts/giop-info.nse
%%DATADIR%%/scripts/gopher-ls.nse
+%%DATADIR%%/scripts/hadoop-datanode-info.nse
+%%DATADIR%%/scripts/hadoop-jobtracker-info.nse
+%%DATADIR%%/scripts/hadoop-namenode-info.nse
+%%DATADIR%%/scripts/hadoop-secondary-namenode-info.nse
+%%DATADIR%%/scripts/hadoop-tasktracker-info.nse
+%%DATADIR%%/scripts/hbase-master-info.nse
+%%DATADIR%%/scripts/hbase-region-info.nse
%%DATADIR%%/scripts/hddtemp-info.nse
%%DATADIR%%/scripts/hostmap.nse
%%DATADIR%%/scripts/http-affiliate-id.nse
+%%DATADIR%%/scripts/http-apache-negotiation.nse
%%DATADIR%%/scripts/http-auth.nse
%%DATADIR%%/scripts/http-awstatstotals-exec.nse
%%DATADIR%%/scripts/http-axis2-dir-traversal.nse
+%%DATADIR%%/scripts/http-backup-finder.nse
%%DATADIR%%/scripts/http-barracuda-dir-traversal.nse
%%DATADIR%%/scripts/http-brute.nse
%%DATADIR%%/scripts/http-cakephp-version.nse
+%%DATADIR%%/scripts/http-cors.nse
%%DATADIR%%/scripts/http-date.nse
%%DATADIR%%/scripts/http-default-accounts.nse
%%DATADIR%%/scripts/http-domino-enum-passwords.nse
+%%DATADIR%%/scripts/http-email-harvest.nse
%%DATADIR%%/scripts/http-enum.nse
%%DATADIR%%/scripts/http-favicon.nse
%%DATADIR%%/scripts/http-form-brute.nse
%%DATADIR%%/scripts/http-google-malware.nse
+%%DATADIR%%/scripts/http-grep.nse
%%DATADIR%%/scripts/http-headers.nse
%%DATADIR%%/scripts/http-iis-webdav-vuln.nse
%%DATADIR%%/scripts/http-joomla-brute.nse
%%DATADIR%%/scripts/http-litespeed-sourcecode-download.nse
%%DATADIR%%/scripts/http-majordomo2-dir-traversal.nse
%%DATADIR%%/scripts/http-malware-host.nse
+%%DATADIR%%/scripts/http-method-tamper.nse
%%DATADIR%%/scripts/http-methods.nse
%%DATADIR%%/scripts/http-open-proxy.nse
+%%DATADIR%%/scripts/http-open-redirect.nse
%%DATADIR%%/scripts/http-passwd.nse
%%DATADIR%%/scripts/http-php-version.nse
+%%DATADIR%%/scripts/http-put.nse
%%DATADIR%%/scripts/http-robots.txt.nse
+%%DATADIR%%/scripts/http-robtex-reverse-ip.nse
%%DATADIR%%/scripts/http-title.nse
%%DATADIR%%/scripts/http-trace.nse
+%%DATADIR%%/scripts/http-unsafe-output-escaping.nse
%%DATADIR%%/scripts/http-userdir-enum.nse
%%DATADIR%%/scripts/http-vhosts.nse
%%DATADIR%%/scripts/http-vmware-path-vuln.nse
%%DATADIR%%/scripts/http-vuln-cve2011-3192.nse
+%%DATADIR%%/scripts/http-vuln-cve2011-3368.nse
%%DATADIR%%/scripts/http-waf-detect.nse
%%DATADIR%%/scripts/http-wordpress-brute.nse
%%DATADIR%%/scripts/http-wordpress-enum.nse
@@ -217,22 +257,29 @@ bin/nping
%%DATADIR%%/scripts/ip-geolocation-ipinfodb.nse
%%DATADIR%%/scripts/ip-geolocation-maxmind.nse
%%DATADIR%%/scripts/ipidseq.nse
+%%DATADIR%%/scripts/ipv6-node-info.nse
+%%DATADIR%%/scripts/irc-botnet-channels.nse
+%%DATADIR%%/scripts/irc-brute.nse
%%DATADIR%%/scripts/irc-info.nse
%%DATADIR%%/scripts/irc-unrealircd-backdoor.nse
%%DATADIR%%/scripts/iscsi-brute.nse
%%DATADIR%%/scripts/iscsi-info.nse
%%DATADIR%%/scripts/jdwp-version.nse
+%%DATADIR%%/scripts/krb5-enum-users.nse
%%DATADIR%%/scripts/ldap-brute.nse
%%DATADIR%%/scripts/ldap-novell-getpass.nse
%%DATADIR%%/scripts/ldap-rootdse.nse
%%DATADIR%%/scripts/ldap-search.nse
%%DATADIR%%/scripts/lexmark-config.nse
%%DATADIR%%/scripts/lltd-discovery.nse
+%%DATADIR%%/scripts/maxdb-info.nse
+%%DATADIR%%/scripts/metasploit-xmlrpc-brute.nse
%%DATADIR%%/scripts/modbus-discover.nse
%%DATADIR%%/scripts/mongodb-databases.nse
%%DATADIR%%/scripts/mongodb-info.nse
%%DATADIR%%/scripts/ms-sql-brute.nse
%%DATADIR%%/scripts/ms-sql-config.nse
+%%DATADIR%%/scripts/ms-sql-dump-hashes.nse
%%DATADIR%%/scripts/ms-sql-empty-password.nse
%%DATADIR%%/scripts/ms-sql-hasdbaccess.nse
%%DATADIR%%/scripts/ms-sql-info.nse
@@ -250,10 +297,12 @@ bin/nping
%%DATADIR%%/scripts/nbstat.nse
%%DATADIR%%/scripts/ncp-enum-users.nse
%%DATADIR%%/scripts/ncp-serverinfo.nse
+%%DATADIR%%/scripts/nessus-brute.nse
%%DATADIR%%/scripts/netbus-auth-bypass.nse
%%DATADIR%%/scripts/netbus-brute.nse
%%DATADIR%%/scripts/netbus-info.nse
%%DATADIR%%/scripts/netbus-version.nse
+%%DATADIR%%/scripts/nexpose-brute.nse
%%DATADIR%%/scripts/nfs-ls.nse
%%DATADIR%%/scripts/nfs-showmount.nse
%%DATADIR%%/scripts/nfs-statfs.nse
@@ -263,6 +312,8 @@ bin/nping
%%DATADIR%%/scripts/ntp-monlist.nse
%%DATADIR%%/scripts/omp2-brute.nse
%%DATADIR%%/scripts/omp2-enum-targets.nse
+%%DATADIR%%/scripts/openlookup-info.nse
+%%DATADIR%%/scripts/openvas-otp-brute.nse
%%DATADIR%%/scripts/oracle-brute.nse
%%DATADIR%%/scripts/oracle-enum-users.nse
%%DATADIR%%/scripts/oracle-sid-brute.nse
@@ -279,8 +330,13 @@ bin/nping
%%DATADIR%%/scripts/quake3-master-getservers.nse
%%DATADIR%%/scripts/realvnc-auth-bypass.nse
%%DATADIR%%/scripts/resolveall.nse
+%%DATADIR%%/scripts/reverse-index.nse
+%%DATADIR%%/scripts/rexec-brute.nse
+%%DATADIR%%/scripts/rlogin-brute.nse
%%DATADIR%%/scripts/rmi-dumpregistry.nse
%%DATADIR%%/scripts/rpcinfo.nse
+%%DATADIR%%/scripts/rtsp-methods.nse
+%%DATADIR%%/scripts/rtsp-url-brute.nse
%%DATADIR%%/scripts/script.db
%%DATADIR%%/scripts/servicetags.nse
%%DATADIR%%/scripts/sip-brute.nse
@@ -339,9 +395,13 @@ bin/nping
%%DATADIR%%/scripts/targets-sniffer.nse
%%DATADIR%%/scripts/targets-traceroute.nse
%%DATADIR%%/scripts/telnet-brute.nse
+%%DATADIR%%/scripts/telnet-encryption.nse
+%%DATADIR%%/scripts/tftp-enum.nse
+%%DATADIR%%/scripts/unusual-port.nse
%%DATADIR%%/scripts/upnp-info.nse
%%DATADIR%%/scripts/vnc-brute.nse
%%DATADIR%%/scripts/vnc-info.nse
+%%DATADIR%%/scripts/vuze-dht-info.nse
%%DATADIR%%/scripts/wdb-version.nse
%%DATADIR%%/scripts/whois.nse
%%DATADIR%%/scripts/wsdd-discover.nse