aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2013-03-04 10:55:23 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2013-03-04 10:55:23 +0000
commit5aa43c1aba1579d88f80fc6f75f5b1fcb3df4b66 (patch)
tree8252139e7b614c53058f1ef8f9b3f7ef729f31c0 /security
parent243c0ad4d0252af27fdabdff1c8e04581608e044 (diff)
downloadports-5aa43c1aba1579d88f80fc6f75f5b1fcb3df4b66.tar.gz
ports-5aa43c1aba1579d88f80fc6f75f5b1fcb3df4b66.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/hotssh/Makefile10
-rw-r--r--security/umit/Makefile10
-rw-r--r--security/w3af/Makefile4
3 files changed, 8 insertions, 16 deletions
diff --git a/security/hotssh/Makefile b/security/hotssh/Makefile
index 64ae460c1b4a..0a4804671b01 100644
--- a/security/hotssh/Makefile
+++ b/security/hotssh/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: hotssh
-# Date created: 2009-01-30
-# Whom: Ashish Shukla <wahjava@gmail.com>
-#
+# Created by: Ashish Shukla <wahjava@gmail.com>
# $FreeBSD$
-#
PORTNAME= hotssh
PORTVERSION= 0.2.7
@@ -18,11 +14,11 @@ COMMENT= HotSSH is an interface to Secure Shell, for GNOME and OpenSSH
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/dbus-python.pc:${PORTSDIR}/devel/py-dbus \
${LOCALBASE}/libdata/pkgconfig/pygobject-2.0.pc:${PORTSDIR}/devel/py-gobject \
${LOCALBASE}/libdata/pkgconfig/dbus-glib-1.pc:${PORTSDIR}/devel/dbus-glib \
- ${PYTHON_SITELIBDIR}/_sqlite3.so:${PORTSDIR}/databases/py-sqlite3 \
+ ${PYTHON_PKGNAMEPREFIX}sqlite3>0:${PORTSDIR}/databases/py-sqlite3 \
${PYTHON_SITELIBDIR}/gtk-2.0/vtemodule.so:${PORTSDIR}/x11-toolkits/py-vte
RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/dbus-python.pc:${PORTSDIR}/devel/py-dbus \
${LOCALBASE}/libdata/pkgconfig/pygobject-2.0.pc:${PORTSDIR}/devel/py-gobject \
- ${PYTHON_SITELIBDIR}/_sqlite3.so:${PORTSDIR}/databases/py-sqlite3 \
+ ${PYTHON_PKGNAMEPREFIX}sqlite3>0:${PORTSDIR}/databases/py-sqlite3 \
${PYTHON_SITELIBDIR}/gtk-2.0/vtemodule.so:${PORTSDIR}/x11-toolkits/py-vte
USE_GNOME= pygtk2 gnomedocutils libxslt glib20
diff --git a/security/umit/Makefile b/security/umit/Makefile
index 1873e5ae359b..1fd9f09b367a 100644
--- a/security/umit/Makefile
+++ b/security/umit/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: umit
-# Date created: 20 April 2007
-# Whom: Elisey Savateev <b3k@mail.ru>
-#
+# Created by: Elisey Savateev <b3k@mail.ru>
# $FreeBSD$
-#
PORTNAME= umit
PORTVERSION= 1.0
@@ -16,12 +12,12 @@ MAINTAINER= ayu@commun.jp
COMMENT= UMIT is the nmap frontend developed with Python and PyGTK
RUN_DEPENDS= ${LOCALBASE}/bin/nmap:${PORTSDIR}/security/nmap \
- ${PYTHON_SITELIBDIR}/_sqlite3.so:${PORTSDIR}/databases/py-sqlite3
+ ${PYTHON_PKGNAMEPREFIX}sqlite3>0:${PORTSDIR}/databases/py-sqlite3
INSTALLS_ICONS= yes
USE_BZIP2= yes
USE_GNOME= pygtk2
-USE_PYTHON= 2.5+
+USE_PYTHON= yes
USE_PYDISTUTILS= yes
.include <bsd.port.pre.mk>
diff --git a/security/w3af/Makefile b/security/w3af/Makefile
index 3dd3eedd080f..be3797fc9915 100644
--- a/security/w3af/Makefile
+++ b/security/w3af/Makefile
@@ -18,7 +18,7 @@ BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}lxml>=2.1:${PORTSDIR}/devel/py-lxml \
${PYTHON_PKGNAMEPREFIX}simplejson>=2.0:${PORTSDIR}/devel/py-simplejson \
${PYTHON_SITELIBDIR}/OpenSSL/SSL.so:${PORTSDIR}/security/py-openssl \
${PYTHON_SITELIBDIR}/SOAPpy:${PORTSDIR}/net/py-soappy \
- ${PYTHON_SITELIBDIR}/_sqlite3.so:${PORTSDIR}/databases/py-sqlite3 \
+ ${PYTHON_PKGNAMEPREFIX}sqlite3>0:${PORTSDIR}/databases/py-sqlite3 \
${PYTHON_SITELIBDIR}/fpconst.py:${PORTSDIR}/math/py-fpconst \
nltk>0:${PORTSDIR}/textproc/nltk \
${PYTHON_SITELIBDIR}/numpy/__init__.py:${PORTSDIR}/math/py-numpy \
@@ -35,7 +35,7 @@ MANCOMPRESSED= no
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_GETTEXT= yes
USE_BZIP2= yes
-USE_PYTHON= 2.5+
+USE_PYTHON= yes
OPTIONS_DEFINE= GUI